Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1582 connectés 

 



 Mot :   Pseudo :  
 
 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18
Auteur Sujet :

[TOPIC UNIQUE] MAO - tutoriaux. (NEW : VSTi supportés)

n°734731
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 26-09-2005 à 20:22:55  profilanswer
 

Reprise du message précédent :
Faudrait peut être que tu install lame ?

mood
Publicité
Posté le 26-09-2005 à 20:22:55  profilanswer
 

n°734733
Hermes le ​Messager
Breton Quiétiste
Posté le 26-09-2005 à 20:25:32  profilanswer
 

Joseph Desire a écrit :

Ah je sais pas je me suis pas penché sur le probleme, on peut lancer un VST sans Rosegarden ? Je suis plus du tout la :)


 
T'es sûr d'avoir fait ça :
 

Citation :

Build etc
---------
 
To build dssi-vst, you will need:
 
* The dssi.h header.
 
* A reasonably recent version of Wine (anything from the start of 2004
  onwards is probably OK) -- http://www.winehq.com/
 
* Steve Harris's liblo "Lite OSC" library -- http://liblo.sf.net/.
  You will need version 0.9 or newer.
 
* The VST SDK headers -- http://www.steinberg.net/steinberg/ygrabit/index.html
  These are free but not redistributable.
 
Once you have all of the above, edit Makefile.in to specify the VST
SDK location; then you should be able to build and install by running
autoconf ; ./configure ; make ; make install.
 
To use dssi-vst: make sure DSSI_PATH is set appropriately, set
VST_PATH to a colon-separated list of the directories containing VST
plugins, and start up your DSSI host.


 
 :whistle:  
 
Si tu l'as fait, alors tu télécharges un des VSTi que j'ai testé dans un de mes messages précédents, tu prends donc  la dll téléchargée que tu mets dans le dossier VST défini dans le VST_PATH.  :whistle:
 
Ensuite, tu démarres rosegarden et ton VSTi doit apparaitre avec les autres instruments DSSI.


Message édité par Hermes le Messager le 26-09-2005 à 20:26:18
n°734735
Hermes le ​Messager
Breton Quiétiste
Posté le 26-09-2005 à 20:27:26  profilanswer
 

M300A a écrit :

Faudrait peut être que tu install lame ?


 
Nope, avec Lame, ça marche pas. Je vais regarder d'où vient le problème... Rosegarden doit utiliser une autre lib peut-être... :/

n°735030
Joseph Des​ire
Posté le 27-09-2005 à 17:57:16  profilanswer
 

Euh honnetement je capte rien du tout, en plus j'ai utilisé des rpm. Donc le chemin vers dssi-vst est : /usr/lib/dssi/dssi-vst

n°735069
Hermes le ​Messager
Breton Quiétiste
Posté le 27-09-2005 à 19:59:01  profilanswer
 

Joseph Desire a écrit :

Euh honnetement je capte rien du tout, en plus j'ai utilisé des rpm. Donc le chemin vers dssi-vst est : /usr/lib/dssi/dssi-vst


 
Non. Si tu as utilisé des rpm, alors il faut que tu crées un répertoire VST où tu veux, et que tu indiques son chemin dans le path et settant VST_PATH.
 
Ensuite, tu places un VSTi dans ce dossier VST et il devrait apparaitre tout seul dans rosegarden dans les softsynth.  
 
Sinon, quelle version de wine ça t'a demandé quand tu as installé le rpm dssi-vst ?

n°735085
Joseph Des​ire
Posté le 27-09-2005 à 20:33:34  profilanswer
 

J'ai installé la version 20041308. J'ai lutté un peu pour trouver les bonnes librairies, le bon wine tools etc etc et ca a fini par s'installer....
 
Tu as vu la gueule de mon PATH ? J'ose plus rien toucher la, il est tout moisi.
 
Les softsynth ? Bah justement je me demandais ou était cette catégorie. J'ai pas installé de synthé virtuel en fait.

n°735093
Hermes le ​Messager
Breton Quiétiste
Posté le 27-09-2005 à 20:40:58  profilanswer
 

Joseph Desire a écrit :

J'ai installé la version 20041308. J'ai lutté un peu pour trouver les bonnes librairies, le bon wine tools etc etc et ca a fini par s'installer....
 
Tu as vu la gueule de mon PATH ? J'ose plus rien toucher la, il est tout moisi.
 
Les softsynth ? Bah justement je me demandais ou était cette catégorie. J'ai pas installé de synthé virtuel en fait.


 
Heu, si tu as réussi à installer dssi et dssi-vst, ça doit apparaitre. :o
 
Sauf évidemment si ta version de rosegarden ne le supporte pas.
 
Voilà, la démarche à suivre :
 
1) Tu démarres Rosegarden.
2) Tu ouvres un fichier midi.
3) Tu sélectionnes une piste et et tu fais un click droit à côté des deux petits leds de ta piste.
4) Tu sélectionnes synth plugins / synth plugin #1
5) A gauche tu as un panneau avec "Paramètres instrument" et là où ya marqué pas de synthétiseur, tu cliques une fois. Apparait alors un popup dans lequel tu peux choisir un plugin (donc un instrument dssi ou un VST si tu as installé vst-dssi et que tu as installé un VSTi dans ton dossier VST associé à ton PATH via VST_PATH).
 
:o
 

n°735104
Joseph Des​ire
Posté le 27-09-2005 à 21:02:41  profilanswer
 

Rosegarden 1.0.
 
Non j'ai rien de tous ça et surtout pas synth plugin.

n°735114
Hermes le ​Messager
Breton Quiétiste
Posté le 27-09-2005 à 21:57:35  profilanswer
 

Joseph Desire a écrit :

Rosegarden 1.0.
 
Non j'ai rien de tous ça et surtout pas synth plugin.


 
Ben donc ta version de rosegarden supporte pas les DSSI.
 
Conclusion, faut désinstaller rosegarden et soit trouver un rpm avec dssi enabled soit compiler rosegarden avec tout en "yes" au configure (je veux parler de la fin).

n°735121
Joseph Des​ire
Posté le 27-09-2005 à 22:14:14  profilanswer
 

okkkkkkkkk

mood
Publicité
Posté le 27-09-2005 à 22:14:14  profilanswer
 

n°735298
Joseph Des​ire
Posté le 28-09-2005 à 12:35:22  profilanswer
 

Citation :

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


 
Ceci est installé :
 

Citation :

Nom : libqt3
Version : 3.3.4-7.1.102mdk


 
Ce sont les bonnes librairies non ?

n°735305
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 12:56:13  profilanswer
 

Joseph Desire a écrit :

Citation :

checking for Qt... configure: error: Qt (>= Qt 3.1 (20021021)) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


 
Ceci est installé :
 

Citation :

Nom : libqt3
Version : 3.3.4-7.1.102mdk


 
Ce sont les bonnes librairies non ?


 
T'as installé les dev de QT ?  :??:  

n°735325
Joseph Des​ire
Posté le 28-09-2005 à 13:28:23  profilanswer
 

Tu me donnerais le nom exact du paquet ca m'aiderait bien. J'ai cherché les dev de QT et je vois rien qui correspond à cela.

n°735348
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 14:25:50  profilanswer
 

Joseph Desire a écrit :

Tu me donnerais le nom exact du paquet ca m'aiderait bien. J'ai cherché les dev de QT et je vois rien qui correspond à cela.


 
Effectivement ya pas. :o
 
fait une recherche sur où est QT3
 
locate (ou slocate) qt3
 
Ensuite tu l'indiques dans le configure :
 
./configure --with-qt-dir=/ou/est/QT3
 

n°735351
Joseph Des​ire
Posté le 28-09-2005 à 14:46:02  profilanswer
 

Citation :

./configure --with-qt-dir=/usr/lib/qt3/


 
Toujours la meme erreur.

n°735356
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 15:01:17  profilanswer
 

Joseph Desire a écrit :

Citation :

./configure --with-qt-dir=/usr/lib/qt3/


 
Toujours la meme erreur.


 
Que renvoie locate qt3 ?
 

n°735389
Joseph Des​ire
Posté le 28-09-2005 à 15:51:54  profilanswer
 

Citation :

[root@localhost kawada]# locate qt3
/usr/lib/qt3
/usr/lib/qt3/bin
/usr/lib/qt3/bin/qtconfig
/usr/lib/qt3/lib
/usr/lib/qt3/lib/libqt-mt.so.3
/usr/lib/qt3/lib/libeditor.prl
/usr/lib/qt3/lib/libdesignercore.a
/usr/lib/qt3/lib/libqassistantclient.prl
/usr/lib/qt3/lib/libqui.so.1
/usr/lib/qt3/lib/libqt-mt.prl
/usr/lib/qt3/lib/libqt-mt.la
/usr/lib/qt3/lib/libqui.so.1.0.0
/usr/lib/qt3/lib/libeditor.a
/usr/lib/qt3/lib/libqui.so.1.0
/usr/lib/qt3/lib/libqassistantclient.a
/usr/lib/qt3/lib/libqui.prl
/usr/lib/qt3/lib/libqt-mt.so.3.3.4
/usr/lib/qt3/lib/libqt-mt.so.3.3
/usr/lib/qt3/lib/libdesignercore.prl
/usr/lib/qt3/phrasebooks
/usr/lib/qt3/phrasebooks/norwegian.qph
/usr/lib/qt3/phrasebooks/german.qph
/usr/lib/qt3/phrasebooks/spanish.qph
/usr/lib/qt3/phrasebooks/swedish.qph
/usr/lib/qt3/phrasebooks/danish.qph
/usr/lib/qt3/phrasebooks/finnish.qph
/usr/lib/qt3/phrasebooks/dutch.qph
/usr/lib/qt3/phrasebooks/italian.qph
/usr/lib/qt3/phrasebooks/french.qph
/usr/lib/qt3/phrasebooks/russian.qph
/usr/lib/qt3/translations
/usr/lib/qt3/translations/qt_ar.qm
/usr/lib/qt3/translations/qt_de.qm
/usr/lib/qt3/translations/qt_cs.qm
/usr/lib/qt3/translations/qt_es.qm
/usr/lib/qt3/translations/qt_fr.qm
/usr/lib/qt3/translations/qt_he.qm
/usr/lib/qt3/translations/qt_ru.qm
/usr/lib/qt3/translations/qt_sk.qm
/usr/lib/qt3/translations/assistant_de.qm
/usr/lib/qt3/plugins
/usr/lib/qt3/plugins/lib
/usr/lib/qt3/plugins/lib/sqldrivers
/usr/lib/qt3/plugins/lib/styles
/usr/lib/qt3/plugins/lib/styles/libqcompactstyle.so
/usr/lib/qt3/plugins/lib/styles/libqmotifplusstyle.so
/usr/lib/qt3/plugins/lib/styles/libqplatinumstyle.so
/usr/lib/qt3/plugins/lib/styles/libqsgistyle.so
/usr/lib/qt3/plugins/lib/styles/libqcdestyle.so
/usr/lib/qt3/plugins/lib/styles/libqmotifstyle.so

n°735432
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 17:50:56  profilanswer
 

Joseph Desire a écrit :

Citation :

[root@localhost kawada]# locate qt3
/usr/lib/qt3
/usr/lib/qt3/bin
/usr/lib/qt3/bin/qtconfig
/usr/lib/qt3/lib
/usr/lib/qt3/lib/libqt-mt.so.3
/usr/lib/qt3/lib/libeditor.prl
/usr/lib/qt3/lib/libdesignercore.a
/usr/lib/qt3/lib/libqassistantclient.prl
/usr/lib/qt3/lib/libqui.so.1
/usr/lib/qt3/lib/libqt-mt.prl
/usr/lib/qt3/lib/libqt-mt.la
/usr/lib/qt3/lib/libqui.so.1.0.0
/usr/lib/qt3/lib/libeditor.a
/usr/lib/qt3/lib/libqui.so.1.0
/usr/lib/qt3/lib/libqassistantclient.a
/usr/lib/qt3/lib/libqui.prl
/usr/lib/qt3/lib/libqt-mt.so.3.3.4
/usr/lib/qt3/lib/libqt-mt.so.3.3
/usr/lib/qt3/lib/libdesignercore.prl
/usr/lib/qt3/phrasebooks
/usr/lib/qt3/phrasebooks/norwegian.qph
/usr/lib/qt3/phrasebooks/german.qph
/usr/lib/qt3/phrasebooks/spanish.qph
/usr/lib/qt3/phrasebooks/swedish.qph
/usr/lib/qt3/phrasebooks/danish.qph
/usr/lib/qt3/phrasebooks/finnish.qph
/usr/lib/qt3/phrasebooks/dutch.qph
/usr/lib/qt3/phrasebooks/italian.qph
/usr/lib/qt3/phrasebooks/french.qph
/usr/lib/qt3/phrasebooks/russian.qph
/usr/lib/qt3/translations
/usr/lib/qt3/translations/qt_ar.qm
/usr/lib/qt3/translations/qt_de.qm
/usr/lib/qt3/translations/qt_cs.qm
/usr/lib/qt3/translations/qt_es.qm
/usr/lib/qt3/translations/qt_fr.qm
/usr/lib/qt3/translations/qt_he.qm
/usr/lib/qt3/translations/qt_ru.qm
/usr/lib/qt3/translations/qt_sk.qm
/usr/lib/qt3/translations/assistant_de.qm
/usr/lib/qt3/plugins
/usr/lib/qt3/plugins/lib
/usr/lib/qt3/plugins/lib/sqldrivers
/usr/lib/qt3/plugins/lib/styles
/usr/lib/qt3/plugins/lib/styles/libqcompactstyle.so
/usr/lib/qt3/plugins/lib/styles/libqmotifplusstyle.so
/usr/lib/qt3/plugins/lib/styles/libqplatinumstyle.so
/usr/lib/qt3/plugins/lib/styles/libqsgistyle.so
/usr/lib/qt3/plugins/lib/styles/libqcdestyle.so
/usr/lib/qt3/plugins/lib/styles/libqmotifstyle.so



 
ya que ça ??  :heink:  
 
T'as rien dans /usr/share/ ??

n°735435
Joseph Des​ire
Posté le 28-09-2005 à 17:57:08  profilanswer
 

Non juste la liste que locate m'a sorti.

n°735444
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 18:04:46  profilanswer
 

essaye avec ./configure --with-qt-dir=/usr/lib/qt3/bin/

n°735465
Joseph Des​ire
Posté le 28-09-2005 à 18:55:15  profilanswer
 

Non toujours le meme message.

n°735486
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 19:48:16  profilanswer
 

Joseph Desire a écrit :

Non toujours le meme message.


 
C'est bizarre. Il te manque des trucs obligatoirement. Fait un thread sur ce forum à propos de ton problème. :/

n°735487
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 19:51:22  profilanswer
 

J'ai trouvé, tu dois installer ça : http://rpm.pbone.net/index.php3
 
libqt-devel

n°735498
Joseph Des​ire
Posté le 28-09-2005 à 20:35:54  profilanswer
 

En fait j'avais pas la bonne version de libqt3-devel dans urpmi. Trop vieille. Donc la c'est bon j'ai installé la bonne.
 
Maintenant j'ai ca :  
 

Citation :

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!


 
C'est ce paquet à installer ? :  
Nom : libkdebase4-devel
Version : 3.3.2-100mdk  
 
En tout cas je peux pas l'installer.....

n°735522
Hermes le ​Messager
Breton Quiétiste
Posté le 28-09-2005 à 21:31:15  profilanswer
 

Joseph Desire a écrit :

En fait j'avais pas la bonne version de libqt3-devel dans urpmi. Trop vieille. Donc la c'est bon j'ai installé la bonne.
 
Maintenant j'ai ca :  
 

Citation :

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!


 
C'est ce paquet à installer ? :  
Nom : libkdebase4-devel
Version : 3.3.2-100mdk  
 
En tout cas je peux pas l'installer.....


 
pourquoi ? Message d'erreur ?  :o  

n°735527
Joseph Des​ire
Posté le 28-09-2005 à 21:50:21  profilanswer
 

Bah juste : paquetage peuvent pas etre installés.
 
Ca me fait ca sur pas mal de trucs liés à KDE.

n°735574
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 08:40:34  profilanswer
 

Joseph Desire a écrit :

Bah juste : paquetage peuvent pas etre installés.
 
Ca me fait ca sur pas mal de trucs liés à KDE.


 
Faut trouver la version qui correspond à ta version actuelle de KDE
 
:o
 
Et puis, je t'ai demandé le message d'erreur EXACT.  :o


Message édité par Hermes le Messager le 29-09-2005 à 08:41:26
n°735608
Joseph Des​ire
Posté le 29-09-2005 à 12:12:38  profilanswer
 

Citation :

Désolé, les paquets suivants ne peuvent pas etre installées :libekdebase4-devel-3.3.2-100mdk


 
Par contre j'ai libekdebase4-3.3.2-100mdk d'installé.

n°735616
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 12:43:09  profilanswer
 

Joseph Desire a écrit :

Citation :

Désolé, les paquets suivants ne peuvent pas etre installées :libekdebase4-devel-3.3.2-100mdk


 
Par contre j'ai libekdebase4-3.3.2-100mdk d'installé.


 
Heu le message d'erreur n'est pas explicite. C'est un message d'erreur qui donne la CONCLUSION, pas l'erreur.
 
Utilise URPMI en console pour avoir le message d'erreur réelle. :o
 

n°735617
Joseph Des​ire
Posté le 29-09-2005 à 12:48:19  profilanswer
 

Citation :

[root@localhost kawada]# urpmi libkdebase4-devel
Les paquetages suivants ne peuvent pas être installés, car ils dépendent
de paquetages qui sont plus anciens que les versions installées:
libkdecore4-devel-3.3.2-123mdk
libkdebase4-devel-3.3.2-100mdk


 
Je me perd.....

n°735619
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 12:56:15  profilanswer
 

Joseph Desire a écrit :

Citation :

[root@localhost kawada]# urpmi libkdebase4-devel
Les paquetages suivants ne peuvent pas être installés, car ils dépendent
de paquetages qui sont plus anciens que les versions installées:
libkdecore4-devel-3.3.2-123mdk
libkdebase4-devel-3.3.2-100mdk


 
Je me perd.....


 
Quelle est la version de kdelib ? :o
 
Tout ce qui se rapporte à kde doit avoir le même numéro de version.
 
Sors moi tous tes paquets KDE qu'on voit ça.

n°735678
Joseph Des​ire
Posté le 29-09-2005 à 15:57:36  profilanswer
 

Hum j'utilise quoi comme commande pour lister avec les numéros de version ?

n°735691
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 16:19:00  profilanswer
 

Joseph Desire a écrit :

Hum j'utilise quoi comme commande pour lister avec les numéros de version ?


 
rien. Tu te contentes de regarder avec l'utilitaire de mandriva pour la sélection de paquet. :o
 
Tu dois avoir des paquets qui ne correspondent pas à 3.3.2-100mdk.
 

n°735721
Joseph Des​ire
Posté le 29-09-2005 à 17:50:33  profilanswer
 

Bon j'ai tout viré KE et j'ai tous réinstallé KDE proprement. Donc la c'est bon, le ./configure est bien passé.
 
Voila ce que ça me dit :  
 

Citation :

Installation Summary
--------------------
 
Install Directory             : /usr
 
Xft notation font support     : yes
ALSA MIDI support             : yes
JACK audio support            : yes
LADSPA plugin support         : yes
DSSI synth plugin support     : no
Custom OSC plugin GUI support : yes
LRDF plugin metadata support  : no


 
 
DSSI : je suppose qu'il manque les librairies de devel. Dois je compiler ?
LRDF : Toujours le meme probleme, et quand je regarde quelles sont ces dépendances y'en a un paquets, je fais comment pour trier ce merdier ????
 

Citation :

[root@localhost kawada]# urpmi liblrdf2-devel
Les paquetages suivants ne peuvent pas être installés, car ils dépendent
de paquetages qui sont plus anciens que les versions installées:
libopenssl0.9.7-devel-0.9.7e-5mdk
liblrdf2-devel-0.3.7-1mdk


n°735725
M300A
Sehr hopfen, vielen IBU, wow!
Posté le 29-09-2005 à 18:00:06  profilanswer
 

Installe une distribution avec un vrai système de paquetage... (j'ai entendu "debian" dans le fond ^^)

n°735729
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 18:04:55  profilanswer
 

Joseph Desire a écrit :

Bon j'ai tout viré KE et j'ai tous réinstallé KDE proprement. Donc la c'est bon, le ./configure est bien passé.
 
Voila ce que ça me dit :  
 

Citation :

Installation Summary
--------------------
 
Install Directory             : /usr
 
Xft notation font support     : yes
ALSA MIDI support             : yes
JACK audio support            : yes
LADSPA plugin support         : yes
DSSI synth plugin support     : no
Custom OSC plugin GUI support : yes
LRDF plugin metadata support  : no


 
 
DSSI : je suppose qu'il manque les librairies de devel. Dois je compiler ?
LRDF : Toujours le meme probleme, et quand je regarde quelles sont ces dépendances y'en a un paquets, je fais comment pour trier ce merdier ????
 

Citation :

[root@localhost kawada]# urpmi liblrdf2-devel
Les paquetages suivants ne peuvent pas être installés, car ils dépendent
de paquetages qui sont plus anciens que les versions installées:
libopenssl0.9.7-devel-0.9.7e-5mdk
liblrdf2-devel-0.3.7-1mdk



 
Pour librdf trouve un paquet plus récent, sinon compile carément lrdf. [:spamafote]
 
Pour DSSI, c'est normal, faut compiler dssi et dssi-vst, pas le choix. Et faut aussi compiler les instruments dssi dispos (fais une recherche).
 
Sinon, pour la distribution, c'est sûr que mandriva c'est pas le top pour la gestion des paquets, mais je te rassure, pour avoir un rosegarden avec dssi + vst, faut tout compiler quand même. [:petrus75]
 
Les deux meilleures distribs pour la mao (hormis agnula ou demudi bien sûr), c'est debian (ou ubuntu) ou gentoo (qui est la meilleure des distribs pour de la mao, vu que par définition, tout est compilé).
 

n°735731
Mjules
Modérateur
Parle dans le vide
Posté le 29-09-2005 à 18:11:54  profilanswer
 

notons que une fois les choses mises en place, c'est très simple de compiler/recompiler pour mandriva (~1/5 de ma distro est compilée par mes soins, tout en RPM)
 
http://qa.mandriva.com/twiki/bin/view/Main/RpmHowTo


Message édité par Mjules le 29-09-2005 à 18:12:36

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°735756
Joseph Des​ire
Posté le 29-09-2005 à 19:19:31  profilanswer
 

Commençons par DSSI 0.9 :  
 

Citation :


[kawada@localhost dssi-0.9]$ make
make[1]: Entering directory `/opt/dssi-0.9/jack-dssi-host'
make[1]: Rien à faire pour « all ».
make[1]: Leaving directory `/opt/dssi-0.9/jack-dssi-host'
make[1]: Entering directory `/opt/dssi-0.9/examples'
g++ -Wall -O2 -I../dssi -I/usr/include/lo   -I/usr/lib/qt3//include   -c -o trivial_sampler_qt_gui.o trivial_sampler_qt_gui.cpp
trivial_sampler_qt_gui.cpp: In member function `void SamplerGUI::generatePreview(QString)':
trivial_sampler_qt_gui.cpp:210: error: `fabs' undeclared (first use this function)
trivial_sampler_qt_gui.cpp:210: error: (Each undeclared identifier is reported only once for each function it appears in.)
make[1]: *** [trivial_sampler_qt_gui.o] Erreur 1
make[1]: Leaving directory `/opt/dssi-0.9/examples'
make: *** [all] Erreur 2


 
 
La je sèche. Kékil veut ?  :na:  On va y arriver. Y'a pas de raison, et comme le disait si justement JCVD : 'Tous a une raison'.

n°735763
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 19:28:42  profilanswer
 

Joseph Desire a écrit :

Commençons par DSSI 0.9 :  
 

Citation :


[kawada@localhost dssi-0.9]$ make
make[1]: Entering directory `/opt/dssi-0.9/jack-dssi-host'
make[1]: Rien à faire pour « all ».
make[1]: Leaving directory `/opt/dssi-0.9/jack-dssi-host'
make[1]: Entering directory `/opt/dssi-0.9/examples'
g++ -Wall -O2 -I../dssi -I/usr/include/lo   -I/usr/lib/qt3//include   -c -o trivial_sampler_qt_gui.o trivial_sampler_qt_gui.cpp
trivial_sampler_qt_gui.cpp: In member function `void SamplerGUI::generatePreview(QString)':
trivial_sampler_qt_gui.cpp:210: error: `fabs' undeclared (first use this function)
trivial_sampler_qt_gui.cpp:210: error: (Each undeclared identifier is reported only once for each function it appears in.)
make[1]: *** [trivial_sampler_qt_gui.o] Erreur 1
make[1]: Leaving directory `/opt/dssi-0.9/examples'
make: *** [all] Erreur 2


 
 
La je sèche. Kékil veut ?  :na:  On va y arriver. Y'a pas de raison, et comme le disait si justement JCVD : 'Tous a une raison'.


 
On t'as déjà dit qu'on ne "configure" pas ni ne "make" en root. Ya que pour le make install qu'on passe en root.
 
Ensuite, le ./configure s'est bien passé ?

n°735770
Joseph Des​ire
Posté le 29-09-2005 à 19:35:14  profilanswer
 

euh ou tu vois ROOT ? Je suis avec mon user normal.
 
Dans le README  : "Run "make" from the top-level directory.  There is no configure script."

n°735774
Hermes le ​Messager
Breton Quiétiste
Posté le 29-09-2005 à 19:36:52  profilanswer
 

Joseph Desire a écrit :

euh ou tu vois ROOT ? Je suis avec mon user normal.
 
Dans le README  : "Run "make" from the top-level directory.  There is no configure script."


 
heing ??  :??:  
 
Moi j'ai un configure dans DSSI.
 
C'est quoi que t'as téléchargé ? dssi 0.9 ? Ya un configure. :o
 

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16  17  18

Aller à :
Ajouter une réponse
 

Sujets relatifs
[Topic Unique] CrossOver[MDK 9.1] pb de reconnaissance carte son (fin du topic)
Nouvel OS 4.0 pour "New" Amiga...[UBUNTU] 19.10 'Eoan Ermine' - Topic dédié
encore un topic sur les températuresTopic Modifier les partitions sous Linux ("Partition Magic")
[Topic Unique] ROX-Filer[Topic unique] Rox (-Filer) + X Files Explorer
Plus de sujets relatifs à : [TOPIC UNIQUE] MAO - tutoriaux. (NEW : VSTi supportés)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR