Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1880 connectés 

 


 

 Mot :   Pseudo :  
 
 Page :   1  2  3  4
Auteur Sujet :

[Domotique] REX : Home Assistant (& Hass.io)

n°308843
Phenix21
Posté le 29-06-2020 à 20:54:01  profilanswer
 

Reprise du message précédent :
Ça se fait bien de rajouter les conteneurs qui t'intéressent en soit

 

De mon côté je suis plutôt partisan du principe qu'une bdd type influxdb n'a pas lieu d'être dans un conteneur domotique

mood
Publicité
Posté le 29-06-2020 à 20:54:01  profilanswer
 

n°308846
VisualC++
J'va y penser ...
Posté le 29-06-2020 à 21:02:31  profilanswer
 

MossieurPropre a écrit :

Si, on peut, cf. post 3 de ce topic


 
J'ai pas dit que ce n'était pas possible hein :) Cependant ce type d'installation est certainement vouée à disparaître (mm si devant la grogne cela a été pour le moment mi en standby).

n°308855
MossieurPr​opre
I d͟o̩n᷃'̵t͖ give a shit
Posté le 30-06-2020 à 07:30:08  profilanswer
 

wazany a écrit :

Yep mais le script n'est pas adapter a docker sur rpi d’après ce que j'ai l dans le script


 
Pour RPi tu as juste à utiliser l’image fournie par HA. Elle propose la version supervisée, et tourne dans Docker.
 
Mais clairement, HA sur Pi, c’est pas la panacée.
 

VisualC++ a écrit :


 
J'ai pas dit que ce n'était pas possible hein :) Cependant ce type d'installation est certainement vouée à disparaître (mm si devant la grogne cela a été pour le moment mi en standby).


 
En fait, je viens même de voir que c’est plus supporté par HA.
 
Dommage ... ils devraient proposer une image Debian ou Ubuntu Server x86 ... peut-être que l’image pour NUC peut faire l’affaire dans ce cas ?

n°308857
extenue1
Posté le 30-06-2020 à 08:09:10  profilanswer
 

HA dans Proxmox , c'est la panacée

n°308884
wazany
Posté le 30-06-2020 à 14:51:51  profilanswer
 

MossieurPropre a écrit :


 
Pour RPi tu as juste à utiliser l’image fournie par HA. Elle propose la version supervisée, et tourne dans Docker.
 
Mais clairement, HA sur Pi, c’est pas la panacée.
 


 
 
Ca serait vraiment limitant de n'utiliser que homeassistant et pas hassos  ?


---------------
L'annuaire des serveurs Discord Hardware.fr Aidez nous à le compléter ! | Mes ventes
n°308887
VisualC++
J'va y penser ...
Posté le 30-06-2020 à 15:10:54  profilanswer
 

extenue1 a écrit :

HA dans Proxmox , c'est la panacée


 
 :love:  :jap:

n°308902
MossieurPr​opre
I d͟o̩n᷃'̵t͖ give a shit
Posté le 30-06-2020 à 16:38:03  profilanswer
 

wazany a écrit :


 
 
Ca serait vraiment limitant de n'utiliser que homeassistant et pas hassos  ?


 
Ne pas avoir accès aux addons proposés, je trouve ça plutôt limitant, oui. Rien que pour Mosquitto ...

n°308903
wazany
Posté le 30-06-2020 à 16:39:30  profilanswer
 

Va falloir que je revois mon installation alors :/


---------------
L'annuaire des serveurs Discord Hardware.fr Aidez nous à le compléter ! | Mes ventes
n°308912
Phenix21
Posté le 30-06-2020 à 16:54:12  profilanswer
 

Mosquitto tu peux le faire tourner sur un conteneur docker à part, comme beaucoup des autres addons de hass.io

 

C'est ce que je fais

n°308917
VisualC++
J'va y penser ...
Posté le 30-06-2020 à 17:12:39  profilanswer
 

Pareil, je ne vois aucun intérêt à utiliser hassos, je préfère un docker avec des 10ène de docker pour les autres fonctions dont je souhaite profiter (que ce soit lié ou pas à home assistant / domotique).
Et puis mon os de base, je le maîtrise et applique / installe ce que je veux - pour moi toutes les solutions soft qui essaye de trop en faire, je part du principe que c'est une bêtise - pas les ressources / compétences à terme, sauf pour une boite pro.

Message cité 1 fois
Message édité par VisualC++ le 30-06-2020 à 17:12:47
mood
Publicité
Posté le 30-06-2020 à 17:12:39  profilanswer
 

n°308918
wazany
Posté le 30-06-2020 à 17:15:29  profilanswer
 

c'est la l’intérêt de docker. Faut que je m'y plonge plus sérieusement


---------------
L'annuaire des serveurs Discord Hardware.fr Aidez nous à le compléter ! | Mes ventes
n°308932
MossieurPr​opre
I d͟o̩n᷃'̵t͖ give a shit
Posté le 30-06-2020 à 19:27:32  profilanswer
 

VisualC++ a écrit :

Pareil, je ne vois aucun intérêt à utiliser hassos, je préfère un docker avec des 10ène de docker pour les autres fonctions dont je souhaite profiter (que ce soit lié ou pas à home assistant / domotique).
Et puis mon os de base, je le maîtrise et applique / installe ce que je veux - pour moi toutes les solutions soft qui essaye de trop en faire, je part du principe que c'est une bêtise - pas les ressources / compétences à terme, sauf pour une boite pro.


 
Perso je fais ça toute la journée au boulot, j’ai pas spécialement envie de me casser le cul le soir à la maison [:@ttil@:1]

n°317618
Groody
Utilisez MES smileys §
Posté le 26-10-2020 à 06:53:02  profilanswer
 

Salut !
Je n'ai pas compris l'utilité du reverse proxy?
Dans quel cas l'utiliser / en avoir besoin ?


---------------
Vidéo Concorde Air France | www.kiva.org
n°317620
VisualC++
J'va y penser ...
Posté le 26-10-2020 à 08:24:31  profilanswer
 

1 IP publique / N nom de domaine / N ip/port interne

 

Tu rediriges tous tes noms de domaine sur ton ip publique assignée à ta box (router avec ce qui faut).
Ton reverse proxy fera la redirection vers une ip/port interne en fonction du sous-domaine par exemple:
- toto.mondomaine.org > 192.168.0.10:8000
- tata.mondomaine.org > 192.168.0.10:8001
- titi.mondomaine.org > 192.168.0.20:8000

 

Et ca marche aussi en mixant sous-domaine/ port externe (du moment que ton router permette de nat/pat).


Message édité par VisualC++ le 26-10-2020 à 08:30:52
n°317622
VisualC++
J'va y penser ...
Posté le 26-10-2020 à 08:34:54  profilanswer
 

Un autre intérêt étant de pouvoir aussi faire du SSL offloading.
 
https://toto.mondomain.org > Router/ FW/ Reverse + offloading > http://192.168.0.1:45632
 
C'est ton reverse qui gère les certificats, tu n'as pas à maintenir ces derniers sur tes différents équipements backend.
 
HAProxy utilise très bien Lets encrypt par exemple (et la encore si tu gère complètement  ton router/fw/xx), tes certificats peuvent être auto renew et updaté sur le reverse.

n°317628
Groody
Utilisez MES smileys §
Posté le 26-10-2020 à 11:15:35  profilanswer
 

Merci ! :jap:
 
Ok, donc je n'en ai pas besoin.
:jap:


---------------
Vidéo Concorde Air France | www.kiva.org
n°324198
dboss77
Posté le 23-12-2020 à 23:05:48  profilanswer
 

:hello:  
 
vous conseillez quoi en prise connecter qui remonte la conso dans HA?


---------------

n°325356
Le_Clubber
Posté le 02-01-2021 à 09:56:52  profilanswer
 

Bonne année !!  :hello:  
 
Pour ça, j'ai deux prises Shelly Plug S.
J'en rependrais sans hésiter, car compactes et acceptent les fortes charges. On peut aussi désactiver les les si besoin.
 
Reconnues aussitôt dans HA, comme spécifié sur leur site.

n°325357
VisualC++
J'va y penser ...
Posté le 02-01-2021 à 10:22:05  profilanswer
 

Plutôt les Plug tout court chez Shelly, elles supportent les 16A règlementaire, le modèle S ce n'est "que" 10A.
Sinon les S26 chez Sonoff en pas cher aussi (mais 10A aussi).


Message édité par VisualC++ le 02-01-2021 à 10:26:45
n°327303
StefSamy
VC FTW
Posté le 12-01-2021 à 08:11:23  profilanswer
 

[:le multi de jayjay:4]  
 
J'hésite encore entre home assist et jeedom (ce que mon vendeur utilisait sur un syno et comme ça marchait.....) alors je vais lire la première page sagement, on a la même config (du zigbee, du somfy RTS, et du wifi classique).
 
Perso j'ai commandé un nuc J4005+8Go+SSD, une clef conbee, et je vais me faire un rflink pour les volets.


---------------
Inutile d'essayer de me faire passer pour un con. J'y arrive très bien tout seul. §§§ On ne fait pas boire un âne qui n'a pas soif.
n°332685
kiveu
Carlos Irwin Estevez
Posté le 22-02-2021 à 20:47:39  profilanswer
 

[:lardoncru:3]


---------------
I'm going to Disneyland !
n°332689
antioch_ar​row
Menace mineure
Posté le 22-02-2021 à 21:23:22  profilanswer
 

Drap :o

 

J'ai justement installé hier une VM avec Home Assistant (OS) en parallèle du Jeedom sur lequel je me fais la main depuis quelques semaines, histoire de comparer.

 

Ca tourne impec dans une VM sur un bon vieux Quadcore Q9650, 4go de RAM et SSD de 128go. :o

 

Pour l'instant j'aime bien, c'est complètement différent de Jeedom. Il y a un côté plus user-friendly (soyons honnêtes, Jeedom devient vite imbitable pour le commun des mortels :o ) même s'il semble y avoir moyen d'aller loin dessus aussi. Je ferai mon choix sous peu, quand j'aurai reçu le matos que j'attends (2 capteurs de température/humidité, capteur d'ouverture de porte, détecteur de mouvement et dongle Conbee2)


Message édité par antioch_arrow le 22-02-2021 à 21:30:53

---------------
Saremo il fatale prevalere dell'azione. Per sempre, tutto comincia ora.
n°332704
Flipper203
Posté le 22-02-2021 à 23:23:39  profilanswer
 

drap je veux tester ha par rapport a jeedom.

n°332770
antioch_ar​row
Menace mineure
Posté le 23-02-2021 à 14:21:31  profilanswer
 

De mon côté j'ai rapidement déchanté, ça se passait bien au début hier, j'avais commencé à mettre deux trois intégrations assez anodines (météo par exemple). Puis petit à petit, au fur et à mesure des redémarrages, j'avais des messages d'erreur divers, parfois ça ne démarrait pas du tout. Jusqu'au moment où je n'ai plus pu me connecter sur HA qu'à partir de la machine sur laquelle il était lancé.

 

J'ai pourtant rien fait de particulier, c'est comme s'il s'était mis à partir petit à petit en décrépitude. Autant de problèmes qui s'accumulent en si peu de temps, bon ben j'ai arrêté quoi :o

 

C'est dommage, il avait l'air assez sexy pourtant :/


Message édité par antioch_arrow le 23-02-2021 à 14:22:25

---------------
Saremo il fatale prevalere dell'azione. Per sempre, tutto comincia ora.
n°332780
cartemere
Posté le 23-02-2021 à 15:17:17  profilanswer
 

bizarre...
d'autant plus sur un problème de routing à l'intérieur de ta VM.
t'es sur que ça venait de HA et pas de la config/routing de ta VM ?

n°332784
antioch_ar​row
Menace mineure
Posté le 23-02-2021 à 15:31:54  profilanswer
 

cartemere a écrit :

bizarre...
d'autant plus sur un problème de routing à l'intérieur de ta VM.
t'es sur que ça venait de HA et pas de la config/routing de ta VM ?

 

Bah j'ai fait au plus simple et comme il était indiqué dans pas mal de tutos, comme l'accès par pont pour le réseau dans la config de la VM ( https://www.home-assistant.io/installation/windows )etc... Donc je ne sais pas trop ce qu'il s'est passé. [:spamafote]

 

J'ai pas eu le temps de faire de snapshots que ça merdait déjà. Néanmoins, si Jeedom finit par me gonfler, je retenterai peut-être, c'est l'avantage des VM, c'est moins "engageant" qu'un système installé en dur.

 

Edit : un exemple, je viens de tenter une install toute fraîche à partir à nouveau du VDI proposé sur le site et en suivant le tuto et au premier démarrage ça donne :

 

https://i.ibb.co/JvDSxBs/haerror.png

 

:D J'ai rien touché, je ne peux même pas me logger en root. C'est peut-être leur VDI qui est pourri ? :??:

 

Message cité 1 fois
Message édité par antioch_arrow le 23-02-2021 à 16:08:38

---------------
Saremo il fatale prevalere dell'azione. Per sempre, tutto comincia ora.
n°332805
snk4ever
Posté le 23-02-2021 à 18:13:42  profilanswer
 

pour lire, drap

n°332853
MossieurPr​opre
I d͟o̩n᷃'̵t͖ give a shit
Posté le 24-02-2021 à 09:03:14  profilanswer
 

Pour ma part, ça tourne toujours comme un charme dans Docker. Je fais une mise à jour tout les 6 mois - 1 an quand j’y pense, et ça passe toujours sans accroc :D

n°332885
cartemere
Posté le 24-02-2021 à 14:07:09  profilanswer
 

MossieurPropre a écrit :

Pour ma part, ça tourne toujours comme un charme dans Docker. Je fais une mise à jour tout les 6 mois - 1 an quand j’y pense, et ça passe toujours sans accroc :D


pareil pour moi avec mon install hass.io

 

10 mois après l'install, je fais le test de MAJ...
le test est OK...
je clique sur l'upgrade...
ça reboot après 10 min...
tout est OK...

 

ça se passe mieux que les MAJ Windows, rien à dire  [:michel_cymerde:7]


Message édité par cartemere le 24-02-2021 à 14:07:51
n°332892
Groody
Utilisez MES smileys §
Posté le 24-02-2021 à 15:10:51  profilanswer
 

test de maj ??  [:groody]


---------------
Vidéo Concorde Air France | www.kiva.org
n°332896
cartemere
Posté le 24-02-2021 à 15:31:07  profilanswer
 

Groody a écrit :

test de maj ??  [:groody]


validation que la configuration passera sur la prochaine version, pour pas se retrouver avec un HA qui ne boote pas après la MAJ à cause d'un fichier de config incompatible.
 
c'est un add-on que tu rajoute à Home Assistant :  
https://github.com/home-assistant/a [...] eck_config.
 
concrêtement, ce module déplie le core de la nouvelle version de HA. boote dessus avec ta config, et s'assure qu'il n'y a pas d'incompatibilité.
à la fin, il t'indique donc si ta config actuelle est compatible avec la version que tu souhaites installer
(pour éviter les mauvaises surprises et devoir se faire ch*** à remettre des backup)
 
ça donne ce genre de sortie dans les logs du module :  

Citation :

[cont-init.d] udev.sh: executing...  
starting version 3.2.9
[11:06:52] INFO: Update udev information
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:06:52] INFO: Setup udev devices
 
[11:06:53] INFO: Don't worry, this temporary installation is not overwriting your current one.
[11:06:53] INFO: Installing Home Assistant: latest...
[11:06:53] INFO: Please be patient, this might take a few minutes...
[11:07:43] INFO: Installed Home Assistant 2021.1.5
[11:07:43] INFO: Making a copy of your configuration for checking...
[11:07:43] INFO: Checking your configuration against this version...
[11:09:39] INFO: Configuration check finished - no error found! :)
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Message cité 2 fois
Message édité par cartemere le 24-02-2021 à 15:32:40
n°332986
struddel_
Savez-vous planter les choux ?
Posté le 25-02-2021 à 01:43:20  profilanswer
 

VisualC++ a écrit :

Un autre intérêt étant de pouvoir aussi faire du SSL offloading.
 
https://toto.mondomain.org > Router/ FW/ Reverse + offloading > http://192.168.0.1:45632
 
C'est ton reverse qui gère les certificats, tu n'as pas à maintenir ces derniers sur tes différents équipements backend.
 
HAProxy utilise très bien Lets encrypt par exemple (et la encore si tu gère complètement  ton router/fw/xx), tes certificats peuvent être auto renew et updaté sur le reverse.


 
J'ai à peu près rien compris car je maîtrise pas trop les certificats, que je sais pas ce qu'est un "offload", etc., mais du coup :
 
J'ai créé un nom de domaine avec les outils freebox, j'ai un certificat généré pour x temps, j'ai utilisé let's encrypt sur HA pour récupérer tout ça et je peux me co de l'extérieur, mais plus en interne.
 
Quelque part ça m'est égal (si j'ai un souci suffit de me co sur la VM et de mettre en quote les lignes http dans le configuration.yaml) mais :
 
- est-ce que c'est possible de me co en local via http ? (question de principe  :o  )
- est-ce qu'il y a moyen d'automatiser l'histoire du certificat ? (Et comment ?)


---------------
J'suis tombé sur un post il est comme-ci/comme-ça qu'est-ce que j'fais ?
n°332993
VisualC++
J'va y penser ...
Posté le 25-02-2021 à 09:01:12  profilanswer
 

Euh pas sur du tout de te comprendre (comme sur l'autre topic d'ailleurs).
 
Tu as un certificat généré pour X temps > par qui ?
Let's encrypt pour HA, cad ? normalement si tu as déjà un certificat, la seule chose est de remplir ssl_certificate et ssl_key dans la section http de la configuration.
 
Tu peux te co de l'extérieur et pas de l'intérieur, mais tu as redirigé comment sur ta freebox (perso jamais eu free, mais du NAT/PAT c'est toujours pareil) ?
La je dirais que tu devrais avoir qqchose comme: *:443 > ip_ha_:8123
 
Pour te co en interne, https://ip_ha:8123 donc. Après si tu as un serveur DNS (peut-être la freebox le fait aucune idée), tu lui renseignes ton_domaine = ip_ha et en interne tu pourras utiliser https://domaine:8123 (car la redirection 443 > 8123 est pas connue).
 
Si tu veux que ce soit plus seamless, tu changes la conf de HA pour écouter le port 443.
 
Je ne sais pas si HA une fois configuré pour du ssl écoute à la fois en http et https, je ne l'ai jamais fait (que du http pour ma part). Mais si c'est le cas, un simple http://ip_ha:8123 pour tester.
 
Pour le certificat, oui let's encrypt il y a un bot (ou via un cron ou via un docker) qui permet de renew auto les certificats.

n°332996
Shaad
Posté le 25-02-2021 à 10:03:18  profilanswer
 

cartemere a écrit :


validation que la configuration passera sur la prochaine version, pour pas se retrouver avec un HA qui ne boote pas après la MAJ à cause d'un fichier de config incompatible.
 
c'est un add-on que tu rajoute à Home Assistant :  
https://github.com/home-assistant/a [...] eck_config.
 
concrêtement, ce module déplie le core de la nouvelle version de HA. boote dessus avec ta config, et s'assure qu'il n'y a pas d'incompatibilité.
à la fin, il t'indique donc si ta config actuelle est compatible avec la version que tu souhaites installer
(pour éviter les mauvaises surprises et devoir se faire ch*** à remettre des backup)
 
ça donne ce genre de sortie dans les logs du module :  

Citation :

[cont-init.d] udev.sh: executing...  
starting version 3.2.9
[11:06:52] INFO: Update udev information
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:06:52] INFO: Setup udev devices
 
[11:06:53] INFO: Don't worry, this temporary installation is not overwriting your current one.
[11:06:53] INFO: Installing Home Assistant: latest...
[11:06:53] INFO: Please be patient, this might take a few minutes...
[11:07:43] INFO: Installed Home Assistant 2021.1.5
[11:07:43] INFO: Making a copy of your configuration for checking...
[11:07:43] INFO: Checking your configuration against this version...
[11:09:39] INFO: Configuration check finished - no error found! :)
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.



 
En théorie y'a plus vraiment besoin de ça, en tout cas je l'utilise plus depuis au moins 6 ou 8 mois, depuis qu'ils ont ajout le Safe Mode :
https://www.home-assistant.io/integrations/safe_mode/
 
En pratique je n'ai jamais eu de problème. Ca ne m'empêche pas de m'imposer un rythme de backup fréquent : un backup Home Assistant par jour, une réplication de la VM sur un second noeud Proxmox toutes les heures, et un backup complet de la VM chaque nuit.


Message édité par Shaad le 25-02-2021 à 10:04:51

---------------
Simulateur immobilier : Simu_Immo_v1.9. 3 outils: Investissement locatif, Achat Vs Location, Renégo/Rachat de Crédit
n°332997
Shaad
Posté le 25-02-2021 à 10:16:04  profilanswer
 

antioch_arrow a écrit :


 
Bah j'ai fait au plus simple et comme il était indiqué dans pas mal de tutos, comme l'accès par pont pour le réseau dans la config de la VM ( https://www.home-assistant.io/installation/windows )etc... Donc je ne sais pas trop ce qu'il s'est passé. [:spamafote]
 
J'ai pas eu le temps de faire de snapshots que ça merdait déjà. Néanmoins, si Jeedom finit par me gonfler, je retenterai peut-être, c'est l'avantage des VM, c'est moins "engageant" qu'un système installé en dur.
 
Edit : un exemple, je viens de tenter une install toute fraîche à partir à nouveau du VDI proposé sur le site et en suivant le tuto et au premier démarrage ça donne :
 
https://i.ibb.co/JvDSxBs/haerror.png
 
:D J'ai rien touché, je ne peux même pas me logger en root. C'est peut-être leur VDI qui est pourri ? :??:
 


 
Vouloir faire tourner des serveurs Linux dans des VM Windows, tu cherches un peu la merde aussi.  :D
Passe sur Proxmox comme tout le monde. C'est parfait.  :love:
 
Mon install Home Assistant doit avoir environ 18 mois. J'étais parti du .VMDK car je tournais sous ESXi à l'époque. Lors de ma migration vers Proxmox il y a un an environ, j'avais migré le .VMDK en image Proxmox et ça a démarré du premier coup et je n'ai jamais eu de soucis depuis.
Et j'ai changé de serveur il y a quelques mois : RAS. Ajout du nouveau noeud dans le cluster Proxmox, migration de la VM d'un noeud vers l'autre (juste un clic), et hop suppression de l'ancien serveur. Fini.


Message édité par Shaad le 25-02-2021 à 10:19:33

---------------
Simulateur immobilier : Simu_Immo_v1.9. 3 outils: Investissement locatif, Achat Vs Location, Renégo/Rachat de Crédit
n°333008
chevket
Posté le 25-02-2021 à 11:19:41  profilanswer
 

Est-ce que vous savez comment on fait pour avoir des graphs plus beaux dans le tableau de bord et surtout qui affichent plus de données dans le temps (genre les 3 derniers mois) ? Quand je dis d'afficher 48h, ça marche au moment mais ensuite plus tard, au rechargement de la page ça affiche un graph tronqué avec les infos sur 24h et rien avant.
 
Par ailleurs, quand un capteur Zigbee ne répond plus (pas un problème de batterie) il faut le supprimer de HA et le réintégrer ou il y a une autre manip pour forcer à ce qu'il retrouve le chemin pour accéder au contrôleur ?

Message cité 1 fois
Message édité par chevket le 25-02-2021 à 11:20:56
n°333016
Shaad
Posté le 25-02-2021 à 11:49:03  profilanswer
 

chevket a écrit :

Est-ce que vous savez comment on fait pour avoir des graphs plus beaux dans le tableau de bord et surtout qui affichent plus de données dans le temps (genre les 3 derniers mois) ? Quand je dis d'afficher 48h, ça marche au moment mais ensuite plus tard, au rechargement de la page ça affiche un graph tronqué avec les infos sur 24h et rien avant.


 
Pour les graphs, le standard c'est mini-graph-card :
https://github.com/kalkih/mini-graph-card
https://user-images.githubusercontent.com/457678/52977264-edf34980-33cc-11e9-903b-cee43b307ed8.png
 
Mais depuis quelques semaine y'a un nouveau challenger très prometteur et en développement actif : apexcharts-card
https://github.com/RomRider/apexcharts-card
https://github.com/RomRider/apexcharts-card/raw/master/docs/Header.png
 
 
Note : 3 mois d'historique dans HA c'est beaucoup.
Pour de l'historique long-terme on recommande plutôt d'avoir recours à une DB externe type InfluxDB.  
 

chevket a écrit :


Par ailleurs, quand un capteur Zigbee ne répond plus (pas un problème de batterie) il faut le supprimer de HA et le réintégrer ou il y a une autre manip pour forcer à ce qu'il retrouve le chemin pour accéder au contrôleur ?


 
Ce que tu décris là ne doit pas arriver.
 
Donc tu peux tenter de solutionner rapidement, soit en appuyant sur le bouton pour forcer le module à rechercher un routeur correct, et si ça marche vraiment pas tu devras sans doute le supprimer pour le réinclure.
 
Mais surtout tu dois faire en sorte que ce genre de problème n'arrive plus. J'ai 55 modules Zigbee et aucun ne 'disparaît'.
Un bon coordinateur, 1 ou 2 bons routeurs, et plus de soucis.

Message cité 1 fois
Message édité par Shaad le 25-02-2021 à 11:50:13

---------------
Simulateur immobilier : Simu_Immo_v1.9. 3 outils: Investissement locatif, Achat Vs Location, Renégo/Rachat de Crédit
n°333020
Groody
Utilisez MES smileys §
Posté le 25-02-2021 à 12:13:14  profilanswer
 

cartemere a écrit :


validation que la configuration passera sur la prochaine version, pour pas se retrouver avec un HA qui ne boote pas après la MAJ à cause d'un fichier de config incompatible.
 
c'est un add-on que tu rajoute à Home Assistant :  
https://github.com/home-assistant/a [...] eck_config.
 
concrêtement, ce module déplie le core de la nouvelle version de HA. boote dessus avec ta config, et s'assure qu'il n'y a pas d'incompatibilité.
à la fin, il t'indique donc si ta config actuelle est compatible avec la version que tu souhaites installer
(pour éviter les mauvaises surprises et devoir se faire ch*** à remettre des backup)
 
ça donne ce genre de sortie dans les logs du module :  

Citation :

[cont-init.d] udev.sh: executing...  
starting version 3.2.9
[11:06:52] INFO: Update udev information
[cont-init.d] udev.sh: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
[11:06:52] INFO: Setup udev devices
 
[11:06:53] INFO: Don't worry, this temporary installation is not overwriting your current one.
[11:06:53] INFO: Installing Home Assistant: latest...
[11:06:53] INFO: Please be patient, this might take a few minutes...
[11:07:43] INFO: Installed Home Assistant 2021.1.5
[11:07:43] INFO: Making a copy of your configuration for checking...
[11:07:43] INFO: Checking your configuration against this version...
[11:09:39] INFO: Configuration check finished - no error found! :)
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.



 
 
Je ne connaissais pas ! Merci ! :D


---------------
Vidéo Concorde Air France | www.kiva.org
n°333027
struddel_
Savez-vous planter les choux ?
Posté le 25-02-2021 à 13:12:10  profilanswer
 

VisualC++ a écrit :

Euh pas sur du tout de te comprendre (comme sur l'autre topic d'ailleurs).
 
Tu as un certificat généré pour X temps > par qui ?
Let's encrypt pour HA, cad ? normalement si tu as déjà un certificat, la seule chose est de remplir ssl_certificate et ssl_key dans la section http de la configuration.
 
Tu peux te co de l'extérieur et pas de l'intérieur, mais tu as redirigé comment sur ta freebox (perso jamais eu free, mais du NAT/PAT c'est toujours pareil) ?
La je dirais que tu devrais avoir qqchose comme: *:443 > ip_ha_:8123
 
Pour te co en interne, https://ip_ha:8123 donc. Après si tu as un serveur DNS (peut-être la freebox le fait aucune idée), tu lui renseignes ton_domaine = ip_ha et en interne tu pourras utiliser https://domaine:8123 (car la redirection 443 > 8123 est pas connue).
 
Si tu veux que ce soit plus seamless, tu changes la conf de HA pour écouter le port 443.
 
Je ne sais pas si HA une fois configuré pour du ssl écoute à la fois en http et https, je ne l'ai jamais fait (que du http pour ma part). Mais si c'est le cas, un simple http://ip_ha:8123 pour tester.
 
Pour le certificat, oui let's encrypt il y a un bot (ou via un cron ou via un docker) qui permet de renew auto les certificats.


 
Le problème c'est que j'y connais rien en certificat, ssl, etc., et que j'ai pas trop de connaissance en réseau (à part le très basique, je sais ce qu'est une IP, je connais les classes d'IP, comment ça marche, et les ports, mais ça s'arrête un peu là)
 
Du coup sans parler le même langage c'est compliqué de comprendre et se faire comprendre... "seamless" je sais pas ce que ça veut dire.
 
Quand j'ai installé HA, au tout début, j'y accédais via l'ip privée de ma VM :
 
http://192.168.0.100:8123  
 
Après je suis allé dans la config de ma freebox, j'ai demandé un nom de domaine. Au bout de 20 minute, ça m'a dit que le nom de domaine "xxxx.freeboxos.fr" était disponible et que j'avais un certificat valide pour X temps, je sais pas du tout comment ça fonctionne en interne chez free, je dis juste ce que ça m'a donné comme info.
 
Ensuite sur HA, j'ai renseigné mon nom de domaine dans let's encrypt car j'avais lu sur un tuto qu'il fallait le faire pour récupérer le certificat, mais ça se trouve j'ai rien compris, c'est parfaitement possible.
 
Dans la section http de HA j'ai ajouté ça :
 
http:
  base_url: XXXXX.freebox.fr:8123
  ssl_certificate: /ssl/fullchain.pem
  ssl_key: /ssl/privkey.pem
 
 
Dans les paramètres de la freebox j'ai mis ça :
 
DMZ vers l'IP de mon routeur TP-Link
 
Dans les paramètres de mon routeur TP-Link j'ai mis ça :
 
80 vers 8123 pour l'adresse 192.168.0.100
443 vers 8123 pour l'adresse 192.168.0.100
 
Maintenant, quand je vais sur :
http://192.168.0.100:8123 -> ça ne fonctionne plus
https://XXXXX.freeboxos.fr -> j'arrive sur HA
 
Et mes questions :
 
- Comment faire pour y accéder via http://192.168.0.100 ?
- comment ne pas me retrouver avec un certificat périmé un beau jour que je voudrai accéder à l'interface HA.
 
 


---------------
J'suis tombé sur un post il est comme-ci/comme-ça qu'est-ce que j'fais ?
n°333030
Shaad
Posté le 25-02-2021 à 13:28:29  profilanswer
 

Ajoute juste un "s" ;)
 
https://192.168.0.100:8123
 
Et tu devras surement accepter l'alerte de sécurité blabla...


---------------
Simulateur immobilier : Simu_Immo_v1.9. 3 outils: Investissement locatif, Achat Vs Location, Renégo/Rachat de Crédit
n°333037
struddel_
Savez-vous planter les choux ?
Posté le 25-02-2021 à 13:48:20  profilanswer
 

Ah oui, merci, le PIRE c'est que j'ai testé ça hier, mais voyant l'alerte je suis pas allé plus loin (mais il était 3h du matin, j'ai une excuse  [:nedurb] )


---------------
J'suis tombé sur un post il est comme-ci/comme-ça qu'est-ce que j'fais ?
mood
Publicité
Posté le   profilanswer
 

<

 Page :   1  2  3  4

Aller à :
Ajouter une réponse
 

Sujets relatifs
Besoin d'aide choix domotiqueIntérêt d'une box domotique ?
Serveur domotique et possibilité (delta dore & aldes)Débuter la domotique chez moi
[Topic Unique] Jeedom V4 - Domotique Open Source à la Française[Domotique] Docker : OpenHab + RfLink + Zigbee + MQTT
Aide visiophone domotiqueDomotique Raspberry - Vidéo surveillance
domotique yeelight +interrupteur aqara et hub xiaomi 
Plus de sujets relatifs à : [Domotique] REX : Home Assistant (& Hass.io)


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR