Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
830 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  428  429  430  431  432  433  434  435  436
Auteur Sujet :

[ Arch Linux ] Nouveauté, Stabilité, Simplicité [HAPPY BIRTHDAY !] \o/

n°1456989
Elbarto
Posté le 24-11-2020 à 11:50:08  profilanswer
 

Reprise du message précédent :
Pense à créer un fichier /etc/vconsole.conf, pour mettre ça dedans :
 

KEYMAP=fr-latin9


 
https://wiki.archlinux.org/index.ph [...] figuration
 
 


Message édité par Elbarto le 24-11-2020 à 11:50:51
mood
Publicité
Posté le 24-11-2020 à 11:50:08  profilanswer
 

n°1456990
minux
On Linux ...
Posté le 24-11-2020 à 11:52:57  profilanswer
 

Moi j'ai ça :

localectl status
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: us-acentos
      X11 Layout: us
       X11 Model: pc104
     X11 Options: grp:alt_shift_toggle


 
- Paramètres régionaux : format -> région -> France -français (fr_FR)
- Type de clavier : generic - PC générique 101 touches - Disposition Anglais (US international avec touches mortes)
 
J'utilise un clavier ANSI-US, mais je peux faire des ^ partout
 


---------------
Mes linux : 2002: Mandrake -> 2005: Ubuntu -> 2010: Arch | Roms MinuxBuild | Mes tutos pour root les Oneplus 5 et 6, et Xiaomi Mi9 série
n°1456991
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 12:12:16  profilanswer
 

Merci les gars, j'ai créé le fichier vconsole.conf (bizarre que je ne l'avais pas avant), redémarré, maintenant j'ai ça :
 
localectl status  
   System Locale: LANG=fr_FR.UTF-8
       VC Keymap: fr-latin9
      X11 Layout: fr-latin9
 
Mais toujours pas d'accent circonflexe...


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1456992
Elbarto
Posté le 24-11-2020 à 12:27:05  profilanswer
 

T'as testé avec un nouveau compte utilisateur ? (afin d'avoir un dossier plasma remis à zéro dans le home)
 
C'est ce que je fais quand j'ai un bug chelou, j'ai toujours un compte utilisateur de test pour comparer avec mon compte habituel.

n°1456995
Trit'
Posté le 24-11-2020 à 12:43:55  profilanswer
 

Moi, j’ai ça (mais je suis pas sous Plasma, ni Wayland) :
 

$ localectl status
   System Locale: LANG=fr_FR.UTF-8
                  LC_COLLATE=C
       VC Keymap: fr
      X11 Layout: fr


Et j’ai les accents circonflexes, donc le bug doit venir soit de Plasma, soit de Wayland (tu as essayé sous X.org ?), logiquement.

n°1457049
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 16:53:18  profilanswer
 

Le problème semble n'affecter que les applications KDE / QT, car dans Gedit ou Firefox, l'accent circonflexe fonctionne normalement.
 
J'ai essayé de créer un nouvel utilisateur, mais SDDM refuse de le logger... [:osweat]


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457053
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 17:19:12  profilanswer
 

Le problème n'est que sous Wayland ; sous la session X11, tout fonctionne.


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457054
Mobilis In​ Mobile
Posté le 24-11-2020 à 17:22:14  profilanswer
 

Wayland [:clooney16]

n°1457055
Trit'
Posté le 24-11-2020 à 17:23:16  profilanswer
 

tromzy a écrit :

Le problème n'est que sous Wayland ; sous la session X11, tout fonctionne.


J’allais justement dire que ce n’était pas dû à Qt non plus :
 
https://zupimages.net/up/20/48/wrt1.png

n°1457058
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 17:29:15  profilanswer
 

J'ai installé notepadqq pour tester, le problème y est présent.


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
mood
Publicité
Posté le 24-11-2020 à 17:29:15  profilanswer
 

n°1457059
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 17:44:28  profilanswer
 

J'ai trouvé ce bug report :
 
https://bugs.kde.org/show_bug.cgi?id=411729
 
Un workaround qui fonctionne (je viens de tester) est d'utiliser la variable d'environnement "QT_IM_MODULE=". J'ai lancé "QT_IM_MODULE= kate" dans la Konsole et je peux taper les accents circonflexes dans Kate.


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457060
tromzy
Arrêtez de m'appeler Sire.
Posté le 24-11-2020 à 17:50:46  profilanswer
 

Bon bah c'est bon, j'ai ajouté "QT_IM_MODULE=" dans /etc/environment (même pas besoin de mettre quoi que ce soit après le "=" ), et ça marche, j'ai mes circonflexes...


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457068
Trit'
Posté le 24-11-2020 à 18:48:44  profilanswer
 

tromzy a écrit :

J'ai installé notepadqq pour tester, le problème y est présent.


Ma capture avec Notepadqq, c’était juste pour te montrer ce que ça donnait chez moi avec un logiciel Qt, mais sous XFCE, qui ne tourne pas sous Wayland (et je doute que ma Radeon Mobility HD 4530 soit compatible Wayland, du reste). J’aurais pu en ouvrir un autre (mais j’en ai pas tant que ça, en fait ; et c’était de toute façon le plus indiqué pour voir si les accents circonflexes s’affichaient chez moi).

 
tromzy a écrit :

Bon bah c'est bon, j'ai ajouté "QT_IM_MODULE=" dans /etc/environment (même pas besoin de mettre quoi que ce soit après le "=" ), et ça marche, j'ai mes circonflexes...


C’est bon à savoir, et content de voir que t’as pu résoudre ton problème.


Message édité par Trit' le 24-11-2020 à 18:49:14
n°1457281
Trit'
Posté le 28-11-2020 à 12:20:13  profilanswer
 

Y a que moi qui ai des problèmes avec VidCutter, depuis le passage de MPV en version 0.33 ?
 
J’ai ça dans la console d’erreurs du logiciel :
https://zerobin.net/?a6aa4762afdbad [...] 1Yaj9sxYI= (lien valable une semaine)
 
Je sais que MPV 0.33 change beaucoup de choses en interne (il ne désactive plus l’écran de veille par défaut, par exemple ; et j’ai pas encore pu vérifier si passer le paramètre « stop-screensaver=yes » dans « ~/.config/mpv/mpv.conf » réparait ce que je considère comme une régression), mais j’ai rien vu dans le bugtracker d’Arch, ni dans les issue GitHub en amont.
 
Bon, je peux toujours contourner avec la ligne de commandes ffmpeg qui va bien, mais VidCutter avait l’avantage de faire ce que je demandais (extraire une partie de vidéo sans réencoder pour autant, pour virer les messages de sponsorisation de vidéos YouTube, notamment) en trois clics, littéralement.
 
Oh, bien sûr, tout fonctionnait très bien avec MPV 0.32.

n°1457284
gee
Bon ben hon
Posté le 28-11-2020 à 13:42:19  profilanswer
 

Je n'utilise pas VidCutter, mais au cas ou j'ai une extension chromium qui saute les pubs qui font partie des videos YouTube: SponsorBlock. Ca fonctionne bien, mais il faut en 1er que quelqu'un note ou est la pub...


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°1457300
Elbarto
Posté le 28-11-2020 à 20:27:17  profilanswer
 

Lors d'un pacman -Syu il y a eu ce message :
 

(116/269) mise à jour de cups                                                                                         [######################################################################] 100%
avertissement : /etc/cups/cupsd.conf installé sous le nom /etc/cups/cupsd.conf.pacnew
>>> Cups systemd socket and service files have been
>>> renamed by upstream decision. Please make sure
>>> to disable/reenable the services to your need.
>>> hint: "pacman -Ql cups | grep systemd" and
>>> "ls -lR /etc/systemd/ | grep cups"


 
Que faut-il faire ?
 
Avez-vous eu des soucis avec cups par rapport à votre imprimante ?

n°1457301
kajoux
Posté le 28-11-2020 à 20:31:55  profilanswer
 

Oui, l'autre jour, au moment d'imprimer mon attestation de sortie pour aller faire les courses, plus d'imprimante  [:kermodei:5]  
Mais sudo systemctl start cups.service et c'est reparti, puis sudo systemctl enable cups.service pour que ce soit permanent, c'est tout.

n°1457302
Trit'
Posté le 28-11-2020 à 20:54:41  profilanswer
 

Elbarto a écrit :

Lors d'un pacman -Syu il y a eu ce message :
 
[…]
 
Que faut-il faire ?


Ce qu’il faut faire ?
 

sudo systemctl disable --now org.cups.cupsd && sudo systemctl enable --now cups


Les explications sont ici : http://frederic.bezies.free.fr/blog/?p=20698
 
En fait, des gens ont forké CUPS en voyant qu’Apple, qui le maintenait jusque-là, l’a pratiquement abandonné. Du coup, ils ont dû changer le nom du service associé. Et Arch a donc repris cette version forkée dans ses dépôts.

n°1457303
Elbarto
Posté le 28-11-2020 à 22:52:28  profilanswer
 

Ce qui est bizarre c'est qu'aucune news sur cups ne figure sur le site d'archlinux, comme indiqué par un commentateur :
 

Citation :

Le vrai manque, c’est que, pour une fois, rien n’a été dit à ce sujet sur la page d’accueil et d’actus d’Arch Linux (quand il faut forcer l’écrasement d’un fichier avec pacman, là, ils savent prévenir ; mais ici : rien, nada, que dalle). Si on est du genre à fermer trop vite le Terminal ou se déconnecter aussi trop vite de sa session TTY, on se fait vite avoir (et je parle même pas de ceux passant par Pamac ou autre outil graphique qui va rien signaler non plus, vu que ce n’est pas quelque chose de bloquant pour le processus de mise à jour)…
Enfin, heureusement que ce genre de chose n’arrive pas tous les jours !

n°1457304
Trit'
Posté le 29-11-2020 à 00:29:52  profilanswer
 

Elbarto a écrit :

Ce qui est bizarre c'est qu'aucune news sur cups ne figure sur le site d'archlinux, comme indiqué par un commentateur


(Le commentateur en question, c’est moi :whistle: )
 
Oui, c’est très bizarre. Comme je le dis : ils sont si prompts à poster une news pour la moindre manip manuelle à effectuer, et là, non. Rien du tout. C’est devenu si marginal que ça, d’avoir une imprimante chez soi ? :??:
 
Ça me fait penser qu’il faudrait avertir nos amis manjariens : eux qui font généralement les MAJ en différé et via Pamac, ils auront absolument aucun message si les tauliers de leur distro ne préviennent pas de leur côté que la prochaine mise à jour de CUPS nécessite un petit geste supplémentaire pour être correctement effectuée (à moins qu’ils ne conçoivent leur paquet exprès pour faire ça automatiquement ?)…
 
EDIT : ouf, ça va ! Philm a justement posté hier un message pour prévenir ses utilisateurs :
https://forum.manjaro.org/t/stable- [...] qt/39962/2
 
Bon, je vais quand même laisser un message sur leur sujet ici, des fois que tous les manjariens ne lisent pas obligatoirement le forum de leur distribution…


Message édité par Trit' le 29-11-2020 à 00:35:14
n°1457306
kikiesttou​joursla
Bodyboard power !!!
Posté le 29-11-2020 à 08:18:27  profilanswer
 

Au moins je trouves ça arrangeant, le service cups je ne me rappellais jamais qu'il y avait org dedans ...

n°1457312
Trit'
Posté le 29-11-2020 à 10:06:51  profilanswer
 

kikiesttoujoursla a écrit :

Au moins je trouves ça arrangeant, le service cups je ne me rappellais jamais qu'il y avait org dedans ...


Ben, c’est arrivé vers 2015-2016, je crois (donc soit au moment de ma propre adoption d’Arch comme OS principal après plus de 20 ans de DOS et Windows, soit peu de temps après) : le nom du service est passé du jour au lendemain de « cups.service » à « org.cups.cupsd.service ». Là, il semble que ce soit le chemin inverse qui a été pris. :lol:

n°1457420
Trit'
Posté le 02-12-2020 à 11:04:39  profilanswer
 

Boum !
 
Le trio fatal noyau 5.9.x + GPU Nvidia + pilote Nouveau fait maintenant des victimes chez Fedora !
 
Peut-être que ça va pousser les devs du noyau à retrouver et corriger le commit qui, voulant réparer ce qui n’était pas cassé (vu que c’est très clairement un bug apparu lors d’un commit effectué durant la phase RC de la branche 5.9) et est maintenant en vrac, fait que lorsque le 5.10 prendra la place du 5.4 dans le paquet linux-lts, les Archiens utilisant Nouveau vont se retrouver très embêtés avec des PC qui vont subitement avoir un affichage qui cesse de répondre…

n°1457549
celp
Posté le 04-12-2020 à 13:24:32  profilanswer
 

Bonjour,
 
j'ai un soucis et personne sur le forum archlinux.fr ne semble s'intéresser à mon problème.
 
mon ordinateur sous gnome met plusieurs minutes avant de s'eteindre complément.
 
j'ai remarqué que le problème se produisait lorsque je me connecte à gnome.
 
avez vous une idée?
 

n°1457550
Andorria
Posté le 04-12-2020 à 13:34:57  profilanswer
 

je me demande bien pourquoi personne n'a voulu t'aider ... :whistle:

n°1457552
gee
Bon ben hon
Posté le 04-12-2020 à 13:35:17  profilanswer
 

Pareil avec un autre utilisateur?


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°1457563
Elbarto
Posté le 04-12-2020 à 14:30:13  profilanswer
 

Il faudrait configurer systemd et/ou gnome pour avoir un log dans une console, tu verrais alors en direct quel service-unit fait de la résistance quand tu éteins le PC, si tu utilises grub il faut enlever l'option "quiet" et "splash" dans le fichier de configuration /etc/default/grub :
 

GRUB_CMDLINE_LINUX_DEFAULT=""


 
https://bbs.archlinux.org/viewtopic.php?id=192647
 
https://www.system-linux.eu/public/images/systemd.jpg
 
Souvent les distributions (ainsi que windows) sont configurés par défaut pour masquer des infos à l'utilisateur lorsque tu démarres le PC et lorsque tu fermes la session, on voit un splash screen à la place, un logo animé, c'est beau mais ça n'aide pas le diagnostic,
 
l'autre option c'est de regarder dans le journal de systemd pour identifier le service qui pose problème à l'extinction (l'outil journalctl, pas évident à utiliser, il faut passer des options en ligne de commande pour filtrer la sortie, et parfois le faire avec un compte root pour être sûr de voir tous les messages).


Message édité par Elbarto le 04-12-2020 à 14:40:34
n°1457567
berlo
dubitatif
Posté le 04-12-2020 à 15:12:19  profilanswer
 

sous KDE il y a l'application Ksystemlog pour ne pas passer par la ligne de commande, doit bien y avoir l'équivalent sous gnome.

n°1457596
celp
Posté le 04-12-2020 à 21:04:12  profilanswer
 

merci de vos conseils.
 
je vais essayer la soluce du grub.
 

n°1457605
Trit'
Posté le 05-12-2020 à 00:15:57  profilanswer
 

celp a écrit :

merci de vos conseils.
 
je vais essayer la soluce du grub.


Note que si tu veux simplement faire un changement ponctuel de ce réglage, il suffit, à l’écran de choix de GRUB, d’appuyer sur E après avoir sélectionné l’OS de ton choix, puis de faire les changements voulus (note que ton clavier sera réglé en QWERTY), et enfin, faire Ctrl-X pour démarrer avec les réglages ainsi modifiés, qui seront valables jusqu’au prochain redémarrage.

n°1457607
celp
Posté le 05-12-2020 à 08:15:16  profilanswer
 

Merci de votre aide.
 
j'ai trouvé mon coupable mais pas la solution.
le coupable est le service gvfs :fou: . Il ne s'éteint pas.
 
et vu la tournure des choses, je pense que je vais partir sur kde car gnome change tout à chaque fois.
 
encore merci. :hello:


Message édité par celp le 05-12-2020 à 10:35:02
n°1457608
celp
Posté le 05-12-2020 à 08:15:56  profilanswer
 

Andorria a écrit :

je me demande bien pourquoi personne n'a voulu t'aider ... :whistle:


Oui sur le forums FR d'archlinux, aucune réponse.

n°1457621
Trit'
Posté le 05-12-2020 à 11:37:58  profilanswer
 

Aucun problème avec gvfs chez moi (qui, certes, suis sous XFCE et non Gnome).
 
Au pire, si c’est le service qui tarde trop à s’arrêter, tu peux forcer systemd à le tuer s’il ne répond plus après un délai donné : tu modifies le fichier /etc/systemd/system.conf et ajoutes cette ligne :
 

DefaultTimeoutStopSec=20s


(J’ai mis 20 secondes, comme sous Windows ; mais tu peux mettre la durée que tu veux, sachant que le délai par défaut est d’1 minute 30, soit 90 secondes)
 

celp a écrit :

Oui sur le forums FR d'archlinux, aucune réponse.


Si tu as donné aussi peu d’infos utiles que dans ton message initial qui n’en comporte aucune (« ça marche plus comme avant » n’est pas une info, même étalé sur 4 lignes), c’est pas étonnant…


Message édité par Trit' le 05-12-2020 à 11:38:41
n°1457784
tromzy
Arrêtez de m'appeler Sire.
Posté le 08-12-2020 à 10:17:44  profilanswer
 

Béni soit le site Arch Linux Archives !  [:shimay:1]

 

J'ai mis à jour le paquet texlive-core (et ses dépendances) hier et depuis, mes documentations professionnelles Latex ne compilaient plus... En passant par le site des archives de paquets (que je connaissais pas, béni soit aussi le Wiki d'Arch :o ), j'ai pu downgrader vers la version précédente de texlive-core et ça compile à nouveau... J'aurais été bien dans la merde sans ça !


Message édité par tromzy le 08-12-2020 à 10:18:10

---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457786
gee
Bon ben hon
Posté le 08-12-2020 à 10:54:08  profilanswer
 

Tu peux utiliser l'outil downgrade pour cela, il est sur AUR et fort pratique.


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°1457787
tromzy
Arrêtez de m'appeler Sire.
Posté le 08-12-2020 à 10:55:52  profilanswer
 

D'accord, merci. :jap: En général je réinstalle l'ancienne version depuis /var/cache/pacman/pkg, mais là je ne l'avais plus.


Message édité par tromzy le 08-12-2020 à 10:56:34

---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1457788
gee
Bon ben hon
Posté le 08-12-2020 à 10:56:19  profilanswer
 

:jap:

 

Au cas ou, dans ce cas-ci tu ferais:

Code :
  1. downgrade textlive-core
 


tu auras ensuite une version a choisir, et si oui ou non tu veux bloquer ce paquet dans pacman.conf.
C'est simple et bien fait.

Message cité 1 fois
Message édité par gee le 08-12-2020 à 10:57:32

---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°1457789
celp
Posté le 08-12-2020 à 11:09:31  profilanswer
 

gee a écrit :

:jap:
 
Au cas ou, dans ce cas-ci tu ferais:

Code :
  1. downgrade textlive-core


 
 
tu auras ensuite une version a choisir, et si oui ou non tu veux bloquer ce paquet dans pacman.conf.  
C'est simple et bien fait.


 
Jusqu' à que le bug soit résolu ?

n°1457791
gee
Bon ben hon
Posté le 08-12-2020 à 11:51:40  profilanswer
 

Par exemple.


---------------
"Phildar t'es vraiment une pute pas finie toi! Et Manu le gros porc arrete de t'marrer!"
n°1457806
tromzy
Arrêtez de m'appeler Sire.
Posté le 08-12-2020 à 16:23:53  profilanswer
 

Ha oui, pouvoir bloquer la mise à jour dans pacman c'est une bonne feature, en effet.


---------------
Keep It Simple, Stupid -- Emulation Porn -- Plutôt mourir que Pluto Mickey
n°1459483
Elbarto
Posté le 14-01-2021 à 15:23:42  profilanswer
 

Attention depuis fin décembre un utilisateur normal ne peut plus lancer dmesg,
 
il aura cette erreur :
 

$ dmesg
dmesg: échec de lecture du tampon de noyau: Opération non permise


 
rapport de bug :
https://bugs.archlinux.org/index.php?task_id=69168
https://bbs.archlinux.org/viewtopic.php?id=262222
 
il faut passer en mode root ou faire une modification particulière relative à la sécurité.

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  428  429  430  431  432  433  434  435  436

Aller à :
Ajouter une réponse
 

Sujets relatifs
linux + routeur/modem = casse teteDonnez moi des raisons pour me mettre a Linux
Conversation Video sous Linuxfree dégroupé en sagem sous linux et xp??
Linux 10.0 ^no bootInstaller Linux avec Windows XP
integration d'un drivers dans linux comment?FreeBSD vs Linux
[LINUX] comment faire marcher une clé usb?Linux oui mais...
Plus de sujets relatifs à : [ Arch Linux ] Nouveauté, Stabilité, Simplicité [HAPPY BIRTHDAY !] \o/


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR