Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1830 connectés 

 


 

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  46  47  48  ..  212  213  214  215  216  217
Auteur Sujet :

[Topic Unique] NAS et HTPC Homemade

n°7485220
christian ​bale
Posté le 02-07-2010 à 15:11:46  profilanswer
 

Reprise du message précédent :
 
 
 
OK  :jap: , je lui laisse la nuit. :) , si le scrub ne me provoque pas une panne....

mood
Publicité
Posté le 02-07-2010 à 15:11:46  profilanswer
 

n°7485221
Profil sup​primé
Posté le 02-07-2010 à 15:13:19  answer
 

christian bale a écrit :


 
 
OK  :jap: , je lui laisse la nuit. :) , si le scrub ne me provoque pas une panne....


Aucune raison. Tu vas juste voir un ralentissement des IO de ce pool.

n°7485704
christian ​bale
Posté le 03-07-2010 à 10:12:44  profilanswer
 


 
 
J'ai fait ma mauvaise langue, le scrub s'est déroulé avec 0 erreurs en 7H !
 

n°7485753
Profil sup​primé
Posté le 03-07-2010 à 11:38:26  answer
 

christian bale a écrit :


 
 
J'ai fait ma mauvaise langue, le scrub s'est déroulé avec 0 erreurs en 7H !
 


Bah parfait - donc regarde quel disque il faut changer et fait un remplacement (comme dit plus haut  ;) )

n°7485763
ITM
Avatar peint à la main
Posté le 03-07-2010 à 11:56:17  profilanswer
 

christian bale a écrit :


 
 
J'ai fait ma mauvaise langue, le scrub s'est déroulé avec 0 erreurs en 7H !
 


Moi aussi les premières minutes l'estime monte à 6000/8000 heures, mais au bout de quelques minutes elle descend en flèche pour se stabiliser vers les 4/6h ;)


---------------
iteme.free.fr | Mon feedback
n°7485943
neodam
c'est joli mais ça sert a rien
Posté le 03-07-2010 à 16:27:20  profilanswer
 

ça sert a quoi votre scrub ??


---------------
LastFm
n°7485948
Wo0chY
Posté le 03-07-2010 à 16:32:16  profilanswer
 

a vérifier l'intégrité des données


---------------
1 an en isolement
n°7485958
neodam
c'est joli mais ça sert a rien
Posté le 03-07-2010 à 16:47:23  profilanswer
 

c'est une fonction propre a zfs ?


---------------
LastFm
n°7485963
ITM
Avatar peint à la main
Posté le 03-07-2010 à 16:52:48  profilanswer
 

Je dirais que c'est un fonction propre aux systèmes de fichiers qui gèrent l'intégrité de données. Je pense que btrfs doit avoir l'équivalent.


---------------
iteme.free.fr | Mon feedback
n°7486450
loic_1715
Posté le 04-07-2010 à 10:52:25  profilanswer
 

loic_1715 a écrit :

Petite question (pour tous) : ça vaut quoi niveau rapidité un OS sur clef USB (par rapport à un HDD classique, par rapport à un SSD, je me doute que ça vaut pas grand chose) ?


up :)

mood
Publicité
Posté le 04-07-2010 à 10:52:25  profilanswer
 

n°7486531
turajo
Posté le 04-07-2010 à 12:16:58  profilanswer
 

ben ça dépend de la clé usb déjà, mais ça se débrouille pas trop mal, le chargement de l'OS est un peu plus long, mais une fois chargé t'as plus trop d'accès dessus donc ça va :)


---------------
MON FEED BACK
n°7486563
christian ​bale
Posté le 04-07-2010 à 12:57:04  profilanswer
 

 


Dis moi, je viens d'enlever 1 disque sur les 4 de 1TO.

 

Je l'ai enlevé à chaud sans aucune commande, je redémarre ubuntu il me met pour le status du Pool :

 

insufficient replicas
Corrupted data pour le Pool.

 

Bizarrement tout les disques sont online alors qu'il en manque un, ca veut dire quoi, si un disque crame, impossible d'accéder à mes données ?

 

Message cité 1 fois
Message édité par christian bale le 04-07-2010 à 13:04:54
n°7486578
christian ​bale
Posté le 04-07-2010 à 13:19:25  profilanswer
 

BOn ben génial, j'ai rebranché le disque sauf que je ne me souvient plus de l'order des cables SATA, maintenant j'ai mes 4 disques de reconnus, et mon Pool est corrompu....
 
 
Je sens que ca va mal se finir cette histoire

n°7486661
christian ​bale
Posté le 04-07-2010 à 14:46:18  profilanswer
 

Oh la la, je crois que c'est de pire en pire, maintenant après avoir remis tout mes disques , voila ce que j'ai.....
 
 
 
http://img180.imageshack.us/img180/2514/capturele.png


Message édité par christian bale le 04-07-2010 à 14:46:46
n°7486689
Profil sup​primé
Posté le 04-07-2010 à 15:19:45  answer
 

christian bale a écrit :


 
 
Dis moi, je viens d'enlever 1 disque sur les 4 de 1TO.
 
Je l'ai enlevé à chaud sans aucune commande, je redémarre ubuntu il me met pour le status du Pool :
 
insufficient replicas
Corrupted data pour le Pool.
 
Bizarrement tout les disques sont online alors qu'il en manque un, ca veut dire quoi, si un disque crame, impossible d'accéder à mes données ?
 


Avant de débrancher ton disque, il aurait fallut faire un débranchement correcte... Mais normalement ça passe.
Donc, tu as débranché un disque et direct après au zpool status il t'as mis ce que tu as posté?

n°7486712
christian ​bale
Posté le 04-07-2010 à 15:47:00  profilanswer
 


 
 
1)Arret du PC,  débranche le disque , Allumage >> Pool corompu
2)Arret du PC,  rebranche le disque , Allumage >> Pool ok
3) Mise offline du disque , Allumage >> Pool dégradé mais accessible
4) Arret du PC,  débranche le disque , Allumage >> Pool corompu
5) Arret du PC,  rebranche  le disque , Allumage >> Pool corompu, et le disque toujours en offline
 
La j'ai lancé un Zpool import, ca tourne depuis 20 minutes je vais voir si il arrive à retrouver la Pool, vu que les 4 disques sont branché et reconnu par Ubuntu.
 
Mais bon pas vraiment serein avec tout ça, j'hésite vraiment à repasser à autre chose concernant la gestion du systeme de fichiers, en plus j'ai fait aucun backup.....enfin bon travail de sauvage
 
 

n°7486777
turajo
Posté le 04-07-2010 à 17:09:12  profilanswer
 

Ben du mdadm ça changera rien si ton raid est corrompu, mais pour moi tu joues avec le feu à faire des tests de reconstruction etc alors que tu as des dd défectueux.


---------------
MON FEED BACK
n°7486789
christian ​bale
Posté le 04-07-2010 à 17:24:48  profilanswer
 

turajo a écrit :

Ben du mdadm ça changera rien si ton raid est corrompu, mais pour moi tu joues avec le feu à faire des tests de reconstruction etc alors que tu as des dd défectueux.


 
 
Ben le souci j'ai en gros que j'ai inverser les port sata, et maintenant ben j'arrive plus à revenir à ma config initiale

n°7486829
arkrom
so much fail
Posté le 04-07-2010 à 18:08:53  profilanswer
 

drap .. je doit recevoir un barebone d'occase pour faire ca .. je reviendrai voir


---------------
I sit, in my desolate room, no lights, no music, Just anger, I've killed everyone, I'm away forever, but I'm feeling better,How do I feel,What do I say,Fuck you, it all goes away,
n°7486834
christian ​bale
Posté le 04-07-2010 à 18:18:05  profilanswer
 

Please help, je viens de retrouver une photo avec l'order de mes disques sur un post...j'ai tout remis,
 
et je me retrouve avec le même message ?
 
Qu'est ce que je peut faire, il y a pas des fichiers de config à editer ?
 

n°7487373
Profil sup​primé
Posté le 05-07-2010 à 09:24:11  answer
 

christian bale a écrit :

Please help, je viens de retrouver une photo avec l'order de mes disques sur un post...j'ai tout remis,
 
et je me retrouve avec le même message ?
 
Qu'est ce que je peut faire, il y a pas des fichiers de config à editer ?
 


Quel message? (sois precis, c'est important  ;)  ) Tu peux poster l'output du message stp?
 

n°7487374
Profil sup​primé
Posté le 05-07-2010 à 09:29:02  answer
 

D'apres ce que je viens de voir, c'est ton metadata qui est out -> en gros c'est l'index de ton pool qui est abime, donc ton pool est perdu  :/
Par contre, je ne comprend pas ce que tu as essaye de faire avec toutes tes operations...
 
Quand tu dis etape 1) pool corrompu, c'etait le meme message d'erreur? Metadata errors?

n°7487377
christian ​bale
Posté le 05-07-2010 à 09:34:37  profilanswer
 


 
 
 :bounce:  :bounce:  
 
J'ai retrouvé mon Pool !!!!!
 
 
En gros j'ai remis les disques dans le même ordre. J'avais le message de la capture.
 
Ensuite je fais un Zpool export Mon_Pool,  
 
Et ensuite je fais un Zpool import -a ( ca le force à tous importer).
 
Et la il me retrouve mon Pool et le met en etat dégradé mais accessible !!! Je met online le disque et c'est bon, tout mon Pool de nouveau accessible !
 
 
Par contre deux question me vienne à l'esprit :
 
- Comment ca se fait que si on enleve un disque à chaud (imaginons une panne d'un disque c'est fait pour noramlement le raidz), ben ca soit autant le merdier.....
-Enfin pour garder un autre backup des données importantes qui soit pas en RAIDZ, vous voyez plutot quoi, un RAID miroir ou rien du tout.

n°7487380
Profil sup​primé
Posté le 05-07-2010 à 09:41:55  answer
 

christian bale a écrit :


 
 
 :bounce:  :bounce:  
 
J'ai retrouvé mon Pool !!!!!
 
 
En gros j'ai remis les disques dans le même ordre. J'avais le message de la capture.
 
Ensuite je fais un Zpool export Mon_Pool,  
 
Et ensuite je fais un Zpool import -a ( ca le force à tous importer).
 
Et la il me retrouve mon Pool et le met en etat dégradé mais accessible !!! Je met online le disque et c'est bon, tout mon Pool de nouveau accessible !
 
 
Par contre deux question me vienne à l'esprit :
 
- Comment ca se fait que si on enleve un disque à chaud (imaginons une panne d'un disque c'est fait pour noramlement le raidz), ben ca soit autant le merdier.....
-Enfin pour garder un autre backup des données importantes qui soit pas en RAIDZ, vous voyez plutot quoi, un RAID miroir ou rien du tout.


C'est bizarre ton truc. Ce que tu peux faire, c'est un test quivabien:
 
Cree des fichiers de 10mb, exemple: /tmp/disque1, /tmp/disque2, /tmp/disque3 et /tmp/disque4
Cree un pool raidz avec ces fichiers.
Met quelques data dessus, histoire d'avoir un truc dessus.
Efface un des /tmp/disquex et regarde le statut de ton pool.
 
S'il degrade mais accessible, c'est bien (logique)
S'il te le met directement en faulted c'est qu'il y a un bleme dans l'implementation zfs de ton OS...

n°7487381
Profil sup​primé
Posté le 05-07-2010 à 09:42:12  answer
 

Et sinon: fais un backup de ton pool!  [:thektulu]

n°7487388
loic_1715
Posté le 05-07-2010 à 09:52:11  profilanswer
 

turajo a écrit :

ben ça dépend de la clé usb déjà, mais ça se débrouille pas trop mal, le chargement de l'OS est un peu plus long, mais une fois chargé t'as plus trop d'accès dessus donc ça va :)


Merci pour ta réponse :jap:
"ça va", ça veut dire que le temps d'accès est correct (= qu'il est presque pareil que celui d'un HDD classique) ?
 

n°7487907
turajo
Posté le 05-07-2010 à 17:32:36  profilanswer
 

Ca veut dire que quand tu lances un truc c'est toujours un peu plus long parce que t'as des débits moindres, mais une fois tout lancé si t'as une utilisation en serveur de fichier tu verras plus trop la différence.
 
Le mieux c'est que tu fasses des tests, et que si ça n'est pas assez perf pour toi de passer sur un hdd (ou ssd ^^)


---------------
MON FEED BACK
n°7487938
turajo
Posté le 05-07-2010 à 17:44:58  profilanswer
 

Bon ce matin j'ai reçu ma Corsair CX 400 en remplacement de ma Antec Earthwatt 500, j'ai été étonné de la qualité de fabrication pour une alim de ce prix (câbles gainés, connecteurs apparemment solides)

 

Je rappelle la conf hardware :

 

Fractal Design R2 Black
Corsair CX400
Asus P5B-V
C2D E4400 (d'ailleurs je réfléchis à changer pour un C2D qui gère la virtualisation, quelqu'un sait si ça apporte beaucoup niveau perf?)
CoolerMaster GeminII
2x Noctua S12 + 2x Fractal Design 14cm + 2x Fractal Design 12 cm
2x1 Go GSkill PC5300 + 1 go Kingston PC5300
Carte raid Adaptec 1220SA
3x Samsung F2 1,5 To
2x Samsung F2 1 To + un 3ème dans le rack en backup
Hitachi 80 go pour l'OS

 

Software :

 

Ubuntu 10.04 32 bits
MDADM pour le RAID
Torrent : TorrentFlux passage à rutorrent bientôt je pense
Monitoring : Munin
Accès aux fichiers par le web : Webshare -> mieux (le projet est abandonné..) ?
Streaming mp3 : Ampache
Serveur web : Apache + PHP + MySQL + PGSQL
Partages réseaux : Samba (windows) + NFS (linux + xtreamer)

 

RAID 5 : 3x1,5To
 - Stockage : musiques, films, séries etc

 

RAID 1 : 2x1To
 - Documents
 - www
 - mysql
 - pgsql
 - svn
 - backup
   - docs
   - www
   - mysql
   - pgsql
   - svn
   - OS

 

Backup :
 - chaque nuit avec backup-manager je fais un backup incrémental des dossiers du RAID1 + OS sur le RAID1 -> Prévention de suppression par erreur etc
 - régulièrement (chaque semaine normalement  :sweat: ) avec rsync et cryptsetup (disque de backup crypté) backup entier du RAID 1 sur le 3ème HDD 1To dans le rack, puis stockage dans une autre pièce -> Prévention du RAID1 qui lâche (faut y aller mais on sait jamais) ou du PC qui crâme ^^

 

Je ne prévois rien dans le cas où l'appart brûle par contre  :lol:

 

Voici quelques photos :

 

http://img695.imageshack.us/img695/6740/dscn0893iz.th.jpg
http://img692.imageshack.us/img692/6628/dscn0894p.th.jpg
http://img717.imageshack.us/img717/8086/dscn0895g.th.jpg
http://img824.imageshack.us/img824/4616/dscn0896f.th.jpg


Message édité par turajo le 05-07-2010 à 18:19:44

---------------
MON FEED BACK
n°7487946
DrDooM
Posté le 05-07-2010 à 17:50:40  profilanswer
 

ouais prend un "vrai" CPU et ajoute de la RAM pour virtualiser ;)
tu comptes utiliser quoi? Xen? KVM?
je confirme, abandonne TorrentFlux et passe donc à rutorrent :)


Message édité par DrDooM le 05-07-2010 à 17:51:16

---------------
Désigné membre du camp du mal par sylphide pinklady :pt1cable:
n°7487972
turajo
Posté le 05-07-2010 à 18:02:40  profilanswer
 

Ben j'ai pas besoin d'un quad pour faire ce que je fais, mon cpu est jamais en full, c'est juste la virtualisation  qui me manque et je sais pas si ça va vraiment apporter quelque chose.
 
Ca serait sur VMWare, j'ai juste besoin une petite VM sous XP pour les trucs qui passent pas sous linux, mais j'avais essayé et ça ramait à mort.
 
Pour la RAM, je suis en 32 bits donc ça va me servir à rien d'en avoir plus ^^
 
rutorrent faut que je m'y mette, le support multi utilisateur a l'air bizarre à configurer


---------------
MON FEED BACK
n°7487976
DrDooM
Posté le 05-07-2010 à 18:04:02  profilanswer
 

bah passe en 64 bits, tu seras forcément amené par la suite à avoir besoin de plus de RAM. pour rutorrent j'ai mis les torrents en commun et le login c'est du htaccess, basta.


---------------
Désigné membre du camp du mal par sylphide pinklady :pt1cable:
n°7487982
ph75
Posté le 05-07-2010 à 18:08:10  profilanswer
 

turajo a écrit :

les trucs qui passent pas sous linux

Tu as essayé Wine ? pour les 3 applis que j'ai essayé ça marche nickel et aucune différence de perf n'est perceptible ...
Et je conseille aussi le 64 bits sous Linux, tout marche, y compris les applis Windows 32 bits sous Wine ...

Message cité 2 fois
Message édité par ph75 le 05-07-2010 à 18:11:35
n°7487987
DrDooM
Posté le 05-07-2010 à 18:11:03  profilanswer
 

ph75 a écrit :

Tu as essayé Wine ? pour les 3 applis que j'ai essayé ça marche nickel et aucune différence de perf n'est perceptible ...


 [:cerveau vomi]


---------------
Désigné membre du camp du mal par sylphide pinklady :pt1cable:
n°7487999
turajo
Posté le 05-07-2010 à 18:18:39  profilanswer
 

DrDooM a écrit :

bah passe en 64 bits, tu seras forcément amené par la suite à avoir besoin de plus de RAM. pour rutorrent j'ai mis les torrents en commun et le login c'est du htaccess, basta.


 
Le 64 bits j'y ai pensé, mais ça me fait franchement chier de tout réinstaller et de tout reconfigurer quand je vois le temps que j'ai passé depuis septembre à tout installer, donc pour l'instant ça restera comme ça surtout que j'ai pas vraiment le temps en ce moment ^^
 
Ouai j'ai déjà un htaccess, ce qui m'intéressait c'est justement la séparation des torrents.
 

ph75 a écrit :

Tu as essayé Wine ? pour les 3 applis que j'ai essayé ça marche nickel et aucune différence de perf n'est perceptible ...
Et je conseille aussi le 64 bits sous Linux, tout marche, y compris les applis Windows 32 bits sous Wine ...


 
En fait mon souci c'est que j'ai besoin une interface graphique pour JDownloader et que j'en ai pas sur ubuntu, donc XP me permettra d'en avoir une (je sais qu'on peut mettre JDownloader sous linux, c'est juste que je suis pas seul à l'utiliser et que ça doit rester simple à utiliser :)


---------------
MON FEED BACK
n°7488006
blanbec
Posté le 05-07-2010 à 18:26:42  profilanswer
 

turajo a écrit :


 
En fait mon souci c'est que j'ai besoin une interface graphique pour JDownloader et que j'en ai pas sur ubuntu, donc XP me permettra d'en avoir une (je sais qu'on peut mettre JDownloader sous linux, c'est juste que je suis pas seul à l'utiliser et que ça doit rester simple à utiliser :)


Tucan et plowshare marche en cli, pas besoin d'interface graphique et ça ira très bien pour ce que tu veux faire...


---------------
Mon feed-back | Topic unique: Seagate Dockstar
n°7488012
turajo
Posté le 05-07-2010 à 18:31:37  profilanswer
 

Merci pour les idées, mais ma copine saura jamais utiliser des progs en CLI :D
 
Puis ça m'a l'air moins évolué que JDownloader quand même.. le must ça serait de trouver un truc du genre qui fonctionne avec une webui, jdownloader le fait mais il faut quand même une gui pour le démarrer..


---------------
MON FEED BACK
n°7488040
loic_1715
Posté le 05-07-2010 à 18:52:20  profilanswer
 

turajo a écrit :

Ca veut dire que quand tu lances un truc c'est toujours un peu plus long parce que t'as des débits moindres, mais une fois tout lancé si t'as une utilisation en serveur de fichier tu verras plus trop la différence.
 
Le mieux c'est que tu fasses des tests, et que si ça n'est pas assez perf pour toi de passer sur un hdd (ou ssd ^^)


Je testerai si j'ai le temps (enfin surtout si j'ai pas trop la flemme). Je dois déjà tester pas mal de distributions pour trouver une (éventuelle) remplaçante à Ubuntu. Merci :jap:
 

n°7488109
ph75
Posté le 05-07-2010 à 19:49:14  profilanswer
 

turajo a écrit :

je sais qu'on peut mettre JDownloader sous linux, c'est juste que je suis pas seul à l'utiliser et que ça doit rester simple à utiliser :)

Détrompes toi avec Wine c'est totalement transparent, c'est une icône comme les autres sur le bureau pour le prg installé, quand tu lances le programme windows seuls les habitués détecteront visuellement que ce n'est pas du Linux natif (et encore), même les associations de fichiers fonctionnent parfaitement ...
Franchement monter une VM pour ça c'est faire du très compliqué et consommateur pour pas grand chose ...
Honnêtement il y a 1 mois j'étais un peu comme toi j'y croyais pas trop, je me suis dis ça ne coûte rien d'essayer et quand je vois le résultat je me dis finis les VM pour ce genre de petit programme ...

n°7488119
turajo
Posté le 05-07-2010 à 19:58:56  profilanswer
 

Vous comprenez pas le problème. Y a pas besoin de wine pour faire fonctionner JDownloader, c'est du java, ça tourne sans problème sous linux.
 
Le problème c'est que je n'ai pas d'interface graphique, et que JDownloader en a besoin d'une, d'où mon besoin de machine virtuelle.


---------------
MON FEED BACK
n°7488128
ph75
Posté le 05-07-2010 à 20:07:55  profilanswer
 

Dans ce cas la solution beaucoup plus simple que la VM, c'est VNC.

n°7488130
turajo
Posté le 05-07-2010 à 20:09:08  profilanswer
 

VNC c'est bien pour se connecter à un bureau à distance, donc à une interface graphique non ?


---------------
MON FEED BACK
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  46  47  48  ..  212  213  214  215  216  217

Aller à :
Ajouter une réponse
 

Sujets relatifs
Besoin d'1 coup de pouce pour finaliser HTPC/NAS[Topic Unique] Processeurs AMD Bulldozer FX-8100/6100/4100 (32nm)
[NAS]Buffalo Linkstation pro Duo : client bittorrent ?!! HTPC !! Noob inside....
[Topic unique] Crucial M225 (Version 64, 128, 256 Go)[Topic unique] Gigabyte GA-MA770T-UD3P
Conseil Config HTPC /Jeux 
Plus de sujets relatifs à : [Topic Unique] NAS et HTPC Homemade


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR