Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1493 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  166  167  168  169  170  171
Auteur Sujet :

[arduino] Topic Unique blabla @ Arduino

n°238954
_pollux_
パリ居住者
Posté le 18-12-2018 à 10:41:36  profilanswer
 

Reprise du message précédent :

_pollux_ a écrit :

Salut,  
 
Je reviens avec un MEGA suite à mon problème de mémoire sur l'UNO (utilisation de librairie graphique + carte SD + détecteur de poussière).
 
Plus de problème mémoire, mais un soucis avec le détecteur de poussière... il fonctionne bien avec l'UNO mais pas avec le MEGA (en gros, je ne détecte rien avec le MEGA alors que j'ai bien des retours sur l'UNO).
 
Le code est ici : https://github.com/AmphenolAdvanced [...] 1C_Int.ino
 
Je ne vois pas dans le programme ce qui pourrait faire que ça marche avec le UNO mais pas le MEGA... :(
 
J'ai viré toute la partie graphique parce que pas utile (i.e la librairie wire et arduino_gfx), ça fonctionne toujours sur le uno, mais pas sur le mega.
 
Si quelqu'un a une idée, je suis preneur :/


 
 
J'ai trouvé !
 
La blague, expliquée ici : http://rcarduino.blogspot.com/2013 [...] duino.html
 
En gros, les interruptions fonctionnent sur tous les ports digitaux de l'arduino uno, mais pas sur tous ceux du mega... en l’occurrence pas les ports 7 et 8 par défaut du programme que j'ai récupéré, ni évidemment les ports 2 et 3 que j'avais essayé pour test, mais uniquement les ports 10 à 15.


---------------
Le topic du sport électronique@hfr : watch the l33t !
mood
Publicité
Posté le 18-12-2018 à 10:41:36  profilanswer
 

n°239227
_Makaveli_
Make HFr Great Again
Posté le 20-12-2018 à 09:06:43  profilanswer
 

Hello :o

 

J'ai une question bête : je suis en train de regarder pour faire des sondes de température avec un arduino, pour l'instant j'ai regardé les uno, couplé avec une sonde de température.

 

Dans l'idéal, il me faudrait une alimentation par pile.

 

Est ce que quelqu'un a l'expérience de la consommation ? Genre c'est 1 pile par an ou 15 ? :o

 

J'ai vu ce type de cable : https://fr.aliexpress.com/item/6-pc [...] 06587.html

Message cité 1 fois
Message édité par _Makaveli_ le 20-12-2018 à 09:07:52

---------------
Humanity is overrated
n°239230
_pollux_
パリ居住者
Posté le 20-12-2018 à 09:22:22  profilanswer
 

Ça dépend de ce que tu fais avec ton arduino. Ou vont les donnés, comment, à quelle fréquence ? Afficheur ou pas ?


---------------
Le topic du sport électronique@hfr : watch the l33t !
n°239231
JPlnx
Posté le 20-12-2018 à 09:31:11  profilanswer
 

_Makaveli_ a écrit :

Hello :o
 
J'ai une question bête : je suis en train de regarder pour faire des sondes de température avec un arduino, pour l'instant j'ai regardé les uno, couplé avec une sonde de température.
 
Dans l'idéal, il me faudrait une alimentation par pile.
 
Est ce que quelqu'un a l'expérience de la consommation ? Genre c'est 1 pile par an ou 15 ? :o
 
J'ai vu ce type de cable : https://fr.aliexpress.com/item/6-pc [...] 06587.html


 
Je pense que tu devrais jeter un oeil à ce genre d'article : https://www.hackster.io/techmirtz/r [...] ion-9bcaf1
 
En gros pour optimiser la conso, il faut intervenir physiquement sur l'arduino pour :
supprimer le régulateur de tension
supprimer la led d'alimentation
et logiciellement pour faire en sorte qu'il passe un maximum de son temps en veille

n°239233
_Makaveli_
Make HFr Great Again
Posté le 20-12-2018 à 09:35:13  profilanswer
 

_pollux_ a écrit :

Ça dépend de ce que tu fais avec ton arduino. Ou vont les donnés, comment, à quelle fréquence ? Afficheur ou pas ?


 
Pas d'afficheur, remontée de température à un Jeedom pour faire de la régulation de chauffage. Donc en période de chauffe une remontée toutes les 5 minutes (voire 10) devrait suffire.
 

JPlnx a écrit :


 
Je pense que tu devrais jeter un oeil à ce genre d'article : https://www.hackster.io/techmirtz/r [...] ion-9bcaf1
 
En gros pour optimiser la conso, il faut intervenir physiquement sur l'arduino pour :
supprimer le régulateur de tension
supprimer la led d'alimentation
et logiciellement pour faire en sorte qu'il passe un maximum de son temps en veille


 
Je vais lire ça, merci :)


---------------
Humanity is overrated
n°239234
SuperSic
Posté le 20-12-2018 à 09:42:36  profilanswer
 

_Makaveli_ a écrit :

 

Pas d'afficheur, remontée de température à un Jeedom pour faire de la régulation de chauffage. Donc en période de chauffe une remontée toutes les 5 minutes (voire 10) devrait suffire.


Tu peux pas acheter une sonde domotique prévue pour ça ? Genre une sonde xiaomi qui communique en zigbee.


---------------
"Les soldats vivent. Et se demandent pourquoi." Toubib (La Compagnie noire) | [TU] Killing Floor 1&2
n°239235
_Makaveli_
Make HFr Great Again
Posté le 20-12-2018 à 09:45:31  profilanswer
 

SuperSic a écrit :


Tu peux pas acheter une sonde domotique prévue pour ça ? Genre une sonde xiaomi qui communique en zigbee.


 
J'en ai :d
 
Mais, le souci avec les sondes Xiaomi, même si elles sont très bien au demeurant, c'est la fréquence de mise à jour qui peut être insuffisante si on veut piloter le chauffage.
 
Et puis pour le fun de le faire, aussi :o


---------------
Humanity is overrated
n°239248
hyperboles​ke
Posté le 20-12-2018 à 11:23:09  profilanswer
 

Salut :o

 

J'ai toujours pas pris le temps de faire un compte rendu complet du montage de la serre (je veux encore modifier des trucs)
Mais en tous cas, ça pousse ! Du moins les citrouilles sont bien sorties, en 10 jours ! :D

 

https://reho.st/preview/self/1d6f7a0c8b735b2a7f01c1016edc5df2b2314cfe.jpg

n°239349
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 10:54:31  profilanswer
 

Vous utilisez beaucoup la communication par port série ? Et si oui, vous ne rencontrez jamais de problème ?
 
Parce que je trouve ça super relou les pertes d'informations dans les messages envoyés par port série quand la fréquence est assez élevée… Des caractères qui sont modifiés, voire carrément oubliés, et qui font que le message n'est pas valide :pfff: Et ceci quel que soit le baudrate.
Je pensais pas que niveau hardware c'était si inefficace comme technologie. C'est moi qui trippe ou bien ?


---------------
If you think it could look good, then I guess it should
n°239357
Natopsi
⫷⫸⫷⫸
Posté le 21-12-2018 à 11:51:51  profilanswer
 

Caractères modifiés : problèmes de perturbation du signal / parité ?
Caractères perdus : saturation du tampon de réception côté Arduino, qui peut arriver assez vite vu que le tampon est petit. Y'a toujours moyen de le gonfler si t'as de la mémoire libre:
https://github.com/arduino/ArduinoC [...] reSerial.h


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
mood
Publicité
Posté le 21-12-2018 à 11:51:51  profilanswer
 

n°239358
jemangedes​lolos
Posté le 21-12-2018 à 11:53:33  profilanswer
 

Tu as un problème.  
Après c'est une communication asynchrone donc il faut prendre des précautions.
Dans quelle circonstance tu rencontres des soucis ?
 
Si tu es en réception et que tu perds des caractères, c'est parce que tu n'utilises pas d’interruption et que ton micro est occupé à faire autre chose.
Tu ne vides donc pas la FIFO du micro assez vite et tu perds des caractères.
Si tu as des corruptions de caractères, tu as un problème d'oscillateur.
 
Si tu maitrises l'envoie et la réception, tu peux améliorer la robustesse de la communication en implémentant un CRC mais si tu es dans un environnement normal, tu dois pouvoir atteindre des baudate proche de 1Mbaud sans problème de perte ou de corruption de données.

n°239359
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 12:03:32  profilanswer
 

[:fabien27] Bon ben va falloir que je m'y penche plus sérieusement…
 
C'est une communication entre un ESP8266-12 et un Uno. Dès que je suis sous 300 ms entre chaque message j'ai du garbage.
Je vais regarder du côté de vos solutions, merci ! :hello:


---------------
If you think it could look good, then I guess it should
n°239393
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 14:29:11  profilanswer
 

Comme entre-temps je suis passé à autre chose (je reviendrai sur la comm' Serial plus tard), j'ai une petite question électricité :
 
Est-ce qu'on est d'accord que (du moment que l'alim est bien dimensionnée), je peux brancher autant de strips de LEDs que je veux sur le drain de Q1 sur ce schéma ?
https://cdn.sparkfun.com/r/600-600/assets/a/f/5/0/9/52433cdc757b7f6c7a8b456a.png
 
Question subsidiaire : si l'Arduino et chaque strip de LEDs possède chacun sa propre alimentation dédiée, ça fonctionne quand même du moment que tous les GND sont reliés ?
 
EDIT : ha oui, et aussi, si mes strips de LEDs sont un peu déportés (genre à 1 ou 2 mètres du transistor), c'est grave ou pas ?

Message cité 1 fois
Message édité par Turkleton le 21-12-2018 à 14:36:12

---------------
If you think it could look good, then I guess it should
n°239433
rat de com​bat
attention rongeur méchant!
Posté le 21-12-2018 à 17:26:50  profilanswer
 

Turkleton a écrit :

Est-ce qu'on est d'accord que (du moment que l'alim est bien dimensionnée), je peux brancher autant de strips de LEDs que je veux sur le drain de Q1 sur ce schéma ?

L'alim et le MOSFET (et les pistes du PCB). C'était toi avec les strips LED à 12A?

Citation :

Question subsidiaire : si l'Arduino et chaque strip de LEDs possède chacun sa propre alimentation dédiée, ça fonctionne quand même du moment que tous les GND sont reliés ?

Oui.

Citation :

EDIT : ha oui, et aussi, si mes strips de LEDs sont un peu déportés (genre à 1 ou 2 mètres du transistor), c'est grave ou pas ?

Pas du tout, tant que la section du câble est suffisante (pour limiter la chute de tension). Par contre si tu fais du PWM haute fréquence tu vas rayonner des cochonneries avec des fils longs.

n°239438
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 18:02:21  profilanswer
 

rat de combat a écrit :

L'alim et le MOSFET (et les pistes du PCB). C'était toi avec les strips LED à 12A?

J'ai pas compris ta 1ère phrase :D Et je ne crois pas avoir parlé de strips LED à 12A non, là ça sera moins que ça.

rat de combat a écrit :

Citation :

Question subsidiaire : si l'Arduino et chaque strip de LEDs possède chacun sa propre alimentation dédiée, ça fonctionne quand même du moment que tous les GND sont reliés ?

Oui.

:jap:  

rat de combat a écrit :

Citation :

EDIT : ha oui, et aussi, si mes strips de LEDs sont un peu déportés (genre à 1 ou 2 mètres du transistor), c'est grave ou pas ?

Pas du tout, tant que la section du câble est suffisante (pour limiter la chute de tension). Par contre si tu fais du PWM haute fréquence tu vas rayonner des cochonneries avec des fils longs.

Ok. J'avais pas pensé que la longueur des fils pouvait interférer avec le PWM, mais je vais tester (et garder l'écartement le plus petit possible).
 
Merci pour tes réponses !


---------------
If you think it could look good, then I guess it should
n°239439
rat de com​bat
attention rongeur méchant!
Posté le 21-12-2018 à 18:07:28  profilanswer
 

Turkleton a écrit :

J'ai pas compris ta 1ère phrase :D Et je ne crois pas avoir parlé de strips LED à 12A non, là ça sera moins que ça.

Oui pardon, c'était pas toi. Ma première phrase est simple pourtant. :o Q1 est un MOSFET, il doit supporter le courant de tes LED. Si c'est un "gros" boîtier genre TO-220 t'as de la marge, ces trucs encaissent des dizaines d'Ampères. Et PCB=circuit imprimé, les pistes doivent être assez larges pour ne pas trop chauffer avec le courant.

Turkleton a écrit :

Ok. J'avais pas pensé que la longueur des fils pouvait interférer avec le PWM, mais je vais tester (et garder l'écartement le plus petit possible).

Après reflexion, si tu restes à quelque centaines de Hz (largement suffisant) même avec les harmoniques ça ne doit pas monter très haut.
Ah oui, le résistance de 10k tu peux limiter la diminuer pour assurer la bonne commutation du MOSFET (moins de pertes). Contrairement à un BJT un MOSFET se commande en tension.

n°239446
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 18:47:25  profilanswer
 

Ta première phrase était peut-être simple, mais y'avait pas de verbe dedans :o  
Alors pour rentrer un peu plus dans les détails, le MOSFET c'est un IRLZ44N, la PCB c'est une plaque de prototypage où je soude dessus et le reste c'est des fils, et le contrôleur c'est un ESP12 (donc du 3,3V sur la sortie PWM). J'ai mis une résistance de 480 Ohms de mémoire.
 
En fait je pensais que la partie "puissance", on s'en foutait un peu vu qu'elle était derrière le MOSFET. Mais à te lire, j'ai trop des doutes maintenant (j'ai bien fait de poser la question :whistle: )


---------------
If you think it could look good, then I guess it should
n°239455
rat de com​bat
attention rongeur méchant!
Posté le 21-12-2018 à 19:49:25  profilanswer
 

Le IRLZ44 ça doit être bon et il supporte 50A, il y a de la marge...

n°239459
Turkleton
I don't quite understand you
Posté le 21-12-2018 à 20:12:38  profilanswer
 

Cool, merci encore ! :)  
 
Donc tu me confirmes que je peux contrôler plusieurs amps dans mes leds avec ce montage, du moment que mes alims le permettent ?


---------------
If you think it could look good, then I guess it should
n°239460
rat de com​bat
attention rongeur méchant!
Posté le 21-12-2018 à 20:16:43  profilanswer
 

oui

n°239576
Turkleton
I don't quite understand you
Posté le 22-12-2018 à 17:52:20  profilanswer
 

Merci, t'es un chef :jap:  
 
(Vu que c'est pour le boulot, je veux être sûr de pas trop faire n'importe quoi. Faudrait absolument que je trouve quelqu'un pour me faire une prestation de vérification de toutes mes installations électroniques…)


---------------
If you think it could look good, then I guess it should
n°240027
Nitescent
Posté le 28-12-2018 à 00:26:36  profilanswer
 

J'ai encore plein de problèmes niveau alimentation :/
Il faut que mes arduino soient contrôlables par le port USB, mais il faut aussi qu'ils soient utilisables quand l'ordinateur n'est pas en marche.

 

Donc je suis obligé de mettre des alimentations externes. En général je balance du 7,5V sur le pin Vin.
L'arduino est sensé sélectionner automatiquement l'alimentation et bloquer l'autre, mais quand je suis dans cette configuration, l'ordinateur plante à chaque fois que je le mets en marche et que je commence à m'en servir :/

 

De façon aléatoire, après 2 minutes ou 20 minutes j'ai un écran bleu, ou un freeze total. Après redémarrage parfois je n'ai plus aucun problème de toute la nuit quand je n'y touche pas trop.
Ou au contraire quand je fais des tests avec plusieurs reprogrammations ça peut me le faire planter 4 ou 5 fois de suite...

 

Ça le fait avec les arduino Nano, Uno, et maintenant avec un Méga Mini

 

Sur un montage j'avais essayé d'utiliser un hub USB avec alim externe.
C'est un truc basique ça, un hub.
Si je laisse le hub alimenté avec l'arduino branché sur une des prises USB, il devrait être alimenté en permanence et bien se passer :o

 

Mais parfois en alimentant le hub avant de mettre l'ordinateur en marche, l'ordi ne voulait pas démarrer. Quand il n'y a pas de problème de démarrage il plante quand même quelques minutes plus tard...

 

Sur un autre montage j'avais coupé la piste du 5V USB sur l'arduino Uno, je l'alimentais directement en 5V sur le pin 5V, et là je n'avais aucun problème au niveau de l'ordinateur.
Mais c'est pas du tout pratique cette solution, ça empêche la reprogrammation, et comme je m'en serts surtout à distance il me faut une autre solution.

 

Enfin bref, c'est bizarre, est ce que c'est mon ordi qui pourrait être trop sensible? Des protections de grillées?
Il y a longtemps quand j'avais commencé mes montages sur un vieil ordi portable il me semble que je n'avais pas autant de problèmes...
Mais en même temps, même si l'ordi est trop sensible, est ce que c'est normal que des courants soient mélangés comme ça entre les alimentations externes et l'usb à travers les arduinos ?

n°240030
_pollux_
パリ居住者
Posté le 28-12-2018 à 00:41:48  profilanswer
 

Quand tu dis contrôler l'Arduino par USB, tu parles de reprogrammation ? Parce que sinon, c'est peut être plus simple de passer par des liaisons série autres que celle de l'usb.


Message édité par _pollux_ le 28-12-2018 à 00:42:11

---------------
Le topic du sport électronique@hfr : watch the l33t !
n°240045
Nitescent
Posté le 28-12-2018 à 09:59:50  profilanswer
 

C'est envoyer des ordres, genre activer un relais.
Mais il faudrait que je puisse quand même le reprogrammer quand je veux faire des améliorations :/

n°240055
Turkleton
I don't quite understand you
Posté le 28-12-2018 à 10:40:41  profilanswer
 

C'est le genre de problèmes relous et super chiants à troubleshooter ça [:fabien27]  
 
Pareil que _pollux_, je pense qu'il vaut mieux contourner le problème et envoyer tes ordres par autre chose que l'USB (serial, ethernet, wifi, …).


---------------
If you think it could look good, then I guess it should
n°240062
Natopsi
⫷⫸⫷⫸
Posté le 28-12-2018 à 12:03:25  profilanswer
 

Marteau à écraser les mouches: https://www.aliexpress.com/item/New [...] 49159.html
 
Si retour de 5V peut être possible d'exploiter le merdier en coupant le fil +5V  
Si problèmes plutôt lié à la masse peut être voir pour les relier ensemble par un bonne section.


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°240547
Nitescent
Posté le 02-01-2019 à 14:30:21  profilanswer
 

Turkleton a écrit :

C'est le genre de problèmes relous et super chiants à troubleshooter ça [:fabien27]

 

Pareil que _pollux_, je pense qu'il vaut mieux contourner le problème et envoyer tes ordres par autre chose que l'USB (serial, ethernet, wifi, …).

 
Natopsi a écrit :

Marteau à écraser les mouches: https://www.aliexpress.com/item/New [...] 49159.html

 

Si retour de 5V peut être possible d'exploiter le merdier en coupant le fil +5V
Si problèmes plutôt lié à la masse peut être voir pour les relier ensemble par un bonne section.


Bon c'est bizarre, je me suis dit que mes montages étaient assez propres quand meme, que ça ne devrait pas déconner autant.
Donc j'ai fait plein de tests avec différentes configurations, et à un moment, même avec les deux arduinos débranchés de l'ordinateur j'ai eu un écran bleu en fait  [:tinostar]

 

Finalement ça ne viendrait peut être pas d'eux  [:transparency]
Alors j'ai essayé de virer les trucs sensibles pour trouver d'où ça pourrait venir :
- d'abord la carte USB 3 que j'avais ajouté il y a un an : plantage juste après le démarrage
- puis la ram, la troisième barrette était différente des deux premières, je l'ai virée, et apres ça je n'ai pas eu d'autres plantages  [:transparency]

 


J'ai essayé de rebrancher les deux arduinos avec leurs deux alimentations externes (deux step down 7,5V à partir du même 12V) et pas de problème après plusieurs heures d'utilisation.
C'est bizarre, je me rappelle très bien du moment où j'ai eu le premier plantage en branchant un arduino avec alim externe...

 

Donc maintenant je peux laisser les arduino tel quel et avoir le auto reset pour les reprogrammer à distance  :love:
Mais d'un autre côté c'est un peu chiant ces auto reset :o
L'arduino nano se reset sans arrêt, au démarrage de l'ordinateur, à la mise en marche de l'appareil photo, à la connexion à l'arduino méga, à la mise en marche de n'importe quel truc USB en général...

 

Je pense que je vais ajouter un relais qui fait contact avec un condensateur sur le pin reset, il se fermera automatiquement au premier démarrage et évitera tous les reset suivants. Et pour le reprogrammer il suffira d'ouvrir le relais manuellement...

 

L'arduino méga semble plus stable lui, je l'ai pas tous ces reboot. Et tant heureusement puisque c'est lui qui active les périphériques USB, sinon ça ferait des boucles infinies

 


Je pense que je vais prendre 2 ou 3 de ces isolateurs USB aussi, j'y crois pas du tout à ce que mon problème d'alimentation soit réglé :o

n°240684
_Makaveli_
Make HFr Great Again
Posté le 03-01-2019 à 16:11:05  profilanswer
 

J'ai commencé les tests sur mon NodeMcu v3.

 

Même en tentant le BareMinimum j'ai des :  serialport_receive_C0: 5A instead of C0

 

Même chose pour un sketch complet, avec la 1.6 ou la 1.8 de ArduinoIDE.

 

Quelqu'un a déjà eu l'erreur ?

 

La LED bleue de l'arduino s'allume mais ça ne reste pas....


Message édité par _Makaveli_ le 03-01-2019 à 16:12:26

---------------
Humanity is overrated
n°240710
_Makaveli_
Make HFr Great Again
Posté le 03-01-2019 à 18:16:54  profilanswer
 

Après recherche il vient avec un AT_based firmare, j'arrive à dialoguer avec via le ESPlorer.


---------------
Humanity is overrated
n°240712
Turkleton
I don't quite understand you
Posté le 03-01-2019 à 18:29:28  profilanswer
 

Moi les nodemcu, je les programme directement via l'IDE Arduino, ça flashe le firmware de base (trop simpliste pour ce que je veux faire) et je mets mon propre protocole de communication à la place ;)


---------------
If you think it could look good, then I guess it should
n°240719
_Makaveli_
Make HFr Great Again
Posté le 03-01-2019 à 18:51:46  profilanswer
 

C'est ce que j'essaye de faire aussi :d

 

Mais ça passe pas on dirait...

 

Tu appuies sur le bouton flash de la carte ? C'est une v3 que j'ai.


Message édité par _Makaveli_ le 03-01-2019 à 18:54:59

---------------
Humanity is overrated
n°240724
Turkleton
I don't quite understand you
Posté le 03-01-2019 à 19:03:37  profilanswer
 

Juste avec quelque chose comme ça, ça fonctionnait direct : https://www.instructables.com/id/Qu [...] duino-IDE/
 
Je regarderai demain quelle version j'ai mais je pense pas que ça ait un impact.
 
Et sinon je crois qu'il y a effectivement des trucs qui peuvent être faits avec les boutons pour forcer un état particulier (genre maintenir Flash appuyé en branchant la carte peut-être) mais j'ai jamais trop eu besoin.


---------------
If you think it could look good, then I guess it should
n°240749
_Makaveli_
Make HFr Great Again
Posté le 03-01-2019 à 21:01:07  profilanswer
 

J'ai réussi à connecter le Wifi via ESPlorer :o :d
 
J'ai regardé les infos et je suis tombé la dessus :
 

Citation :


AT version:1.1.0.0(May 11 2016 18:09:56)
SDK version:1.5.4(baaeaebb)
compile time:May 20 2016 15:08:19
OK


 
Maintenant j'arrive toujours pas à uploader depuis Arduino IDE.


---------------
Humanity is overrated
n°240806
_Makaveli_
Make HFr Great Again
Posté le 04-01-2019 à 08:54:40  profilanswer
 

J'ai eu une illumination hier : j'ai testé le 2eme que j'avais. Il est passé du 1er coup :o


Message édité par _Makaveli_ le 04-01-2019 à 09:22:13

---------------
Humanity is overrated
n°240809
Turkleton
I don't quite understand you
Posté le 04-01-2019 à 09:09:58  profilanswer
 

:)


---------------
If you think it could look good, then I guess it should
n°241762
Turkleton
I don't quite understand you
Posté le 10-01-2019 à 15:03:41  profilanswer
 

Je sais pas trop où poster ça donc…
 
Avez-vous essayé de faire joujou avec une montre connectée ? Je sais pas trop si c'est facile à hacker ou pas. Le but serait de pouvoir afficher du texte dessus depuis un serveur via le wifi, mais je sais pas trop où commencer vu que je sais même pas comment fonctionne une montre connectée (ni même à quoi c'est censé servir…).


---------------
If you think it could look good, then I guess it should
n°241763
rat de com​bat
attention rongeur méchant!
Posté le 10-01-2019 à 15:07:04  profilanswer
 

Turkleton a écrit :

Je sais pas trop si c'est facile à hacker ou pas.

Je dirai ça dépend du modèle. :o  
Tu as cherché genre "smartwatch hack"? A première vue ça sort pleins de trucs intéressants.

n°241796
Turkleton
I don't quite understand you
Posté le 10-01-2019 à 17:03:13  profilanswer
 

Ha plutin non, j'avais cherché "connected watch hack" comme un con… :pfff: Je trouvais pas grand chose.
 
Merci, du coup je vais regarder ça  ;)


---------------
If you think it could look good, then I guess it should
n°241800
SuperSic
Posté le 10-01-2019 à 17:30:11  profilanswer
 

Turkleton a écrit :

Ha plutin non, j'avais cherché "connected watch hack" comme un con… :pfff: Je trouvais pas grand chose.
 
Merci, du coup je vais regarder ça  ;)


Tu peux potentiellement la contrôler à distance suivant le modèle... et notamment activer son micro ou sa caméra. :D


---------------
"Les soldats vivent. Et se demandent pourquoi." Toubib (La Compagnie noire) | [TU] Killing Floor 1&2
n°243411
tomsoft
Posté le 22-01-2019 à 10:43:23  profilanswer
 

:hello:
 
J'utilise un Teensy 3.5, qui est tout en 3.3v (mais 5v tolerant).
 
J'aimerais lui faire lire un capteur de pression automobile,  
qui doit etre alimenté en 5v selon sa datasheet, et qui me ressort un signal entre 0 et 5v selon la pression lue.
 
3 pins :  
 
Power (+5v)
Ground (0v)
Output (0-5v)
 
Mon teensy étant 5v tolerant, je pourrais lui mettre, mais j'aimerais faire les choses bien.
 
L'ensemble sera alimenté par un 12-14v automobile, puis a travers un step-down pololu je regule tout à 5v,  
 
j'ai donc ma source de 5v pour le capteur, et le teensy s'occupe de réguler a 3.3v via son Vin.
 
Quelle est la méthode la plus simple pour convertir mon signal variable de 0 à 5v en signal variable de 0 à 3.3v ?  
 

n°243424
M4vrick
Mad user
Posté le 22-01-2019 à 11:53:34  profilanswer
 

tomsoft a écrit :

:hello:
 
J'utilise un Teensy 3.5, qui est tout en 3.3v (mais 5v tolerant).
 
J'aimerais lui faire lire un capteur de pression automobile,  
qui doit etre alimenté en 5v selon sa datasheet, et qui me ressort un signal entre 0 et 5v selon la pression lue.
 
3 pins :  
 
Power (+5v)
Ground (0v)
Output (0-5v)
 
Mon teensy étant 5v tolerant, je pourrais lui mettre, mais j'aimerais faire les choses bien.
 
L'ensemble sera alimenté par un 12-14v automobile, puis a travers un step-down pololu je regule tout à 5v,  
 
j'ai donc ma source de 5v pour le capteur, et le teensy s'occupe de réguler a 3.3v via son Vin.
 
Quelle est la méthode la plus simple pour convertir mon signal variable de 0 à 5v en signal variable de 0 à 3.3v ?  
 


 
J'ai eu exactement la même question il y a quelques mois pour la même application : pont diviseur de tension.


---------------
--== M4vr|ck ==--
mood
Publicité
Posté le   profilanswer
 

<

 Page :   1  2  3  4  5  ..  166  167  168  169  170  171

Aller à :
Ajouter une réponse
 

Sujets relatifs
* Réparations de vos appareils électroniques & electromenager * 
Plus de sujets relatifs à : [arduino] Topic Unique blabla @ Arduino


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR