Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1500 connectés 

 



Comment jugez-vous cette caméra IP made-in-china à 60€




Attention si vous cliquez sur "voir les résultats" vous ne pourrez plus voter

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  12  13  14  ..  26  27  28  29  30  31
Auteur Sujet :

[Topic Unique] H.264 IPCAM HD WIFI Pan & Tilt + IR-Cut + SDcard

n°732291
philou155
Posté le 16-04-2013 à 18:28:30  profilanswer
 

Reprise du message précédent :
Je confirme bonne camera, j'en ai plusieurs, interface web qui permet de voir autant que camera que possible sans logiciel.
 
Mais il manque toujours un systeme pour voir l'image en 16/9 sur zone minder ou ipsy connect depuis un PC.
 
Car a ce jour, la HD n'apporte rien pour l'enregistrement et la visu depuis ipsy connect et c'est bien dommage.
 
Le ON vif marche bien j'ai mise a jour une cam, peut etre va t'on avoir un logiciel performant pour la visu et l'enregistrement par la suite.

mood
Publicité
Posté le 16-04-2013 à 18:28:30  profilanswer
 

n°732374
azazel673
Posté le 17-04-2013 à 20:06:40  profilanswer
 

Bonjour philou155,  
 
sur Zoneminder arrivez-vous a controler la camera ?

n°732389
macmpi
Posté le 17-04-2013 à 23:32:42  profilanswer
 

Nouvelles version du firmware chez Maygion:
http://www.maygion.com/
Peu d'infos sur ce que ca apporte (estampillée 5.48 une fois installée, www ipcam(2013.04.12))
 
Après comparaison fine des www.bin, rien de majeur, en tout cas ayant des impacts coté interface.
 
Le app.bin 5.48 a l'air de mieux gérer les fuseaux horaires (mais toujours pas d'heure d'été).
Pour ma cam, il affiche maintenant un hardware version "H264": ce serait interessant de savoir ce que ca dit sur les modèles à P2P.
 
J'étais sur le point de faire un message de status sur l'architecture soft, hacks et possibilités d'extensions, etc...
Je pense que cette mise à jour (comme les prochaines) ne changent rien de ce point de vue, mais je vais vérifier de plus près, et donc communiquerai un peu plus tard...


Message édité par macmpi le 18-04-2013 à 00:47:15
n°732399
Aahem
Posté le 18-04-2013 à 01:11:25  profilanswer
 

Citation :

Nouvelles version du firmware chez Maygion


 
C'est quand même les plus rapides, chez Maygion.
Merci Macmpi  :)  

n°732400
macmpi
Posté le 18-04-2013 à 01:19:50  profilanswer
 

Aahem a écrit :

C'est quand même les plus rapides, chez Maygion.

Ben c'est eux qui font le soft pour tout le monde en fait! (et surement la plateforme hard avec).
Les manufacturiers/OEM ne font que du rebranding (parfois-même en ajoutant des bugs dans l'UI !).


Message édité par macmpi le 18-04-2013 à 01:20:57
n°732407
Mesfet
Posté le 18-04-2013 à 08:28:57  profilanswer
 

toujours pas les presets?

n°732544
macmpi
Posté le 19-04-2013 à 13:00:45  profilanswer
 

(pour une version à jour de ce message, voir: http://forum.hardware.fr/hfr/Hardw [...] tm#t705043)
 
Voilà un petit topo sur l'environnement logiciel de ces cam, après avoir poussé des analyses sur plusieurs modèles (merci au passage à tous ceux qui ont accepté de faire quelques tests qui m'ont été très précieux).
 
Paillassou, si tu veux déplacer ce post en début de topic, pour le rendre plus accessible en référence, pas de problème: je le mettrai à jour probablement, et ça évitera de répéter les mêmes choses à travers les post.
 
Donc, pour rappel, ces cam ont un firmware "core" (qui, pour le moment, n'est jamais mis à jour), et un firmware "applicatif" de gestion de la fonction principale de caméra.
 
Le firmware applicatif
Il est composé de 2 parties: l'application caméra (app.bin), et son interface de gestion (www.bin).
On les met à jour par l'interface de gestion: attention laisser la page web ouverte pendant toute la mise à jour, jusqu'au redemarrage (même si c'est long). En cas de pépins, on peut faire des mise à jour de secours par FTP, mais à éviter en fonctionnement normal (procédure différente).
En général on évite de faire les mise à jour en wifi, mais bon ça marche bien aussi... :)
 
Pour une version donnée du firmware, les app.bin sont les mêmes pour TOUTE cette famille de caméras. Certaines options/services sont activés (ou non) par des fichiers de config (voir plus loin).
 
Le www.bin contient les pages html/javascript de l'interface de commande, et le pluggin ocx.
L'html/javascript est facilement modifiable pour faire des petits hacks, ou customisations d'UI: il suffit de récupérer les fichiers par FTP, les modifier, les remettre.
(ex, permettre des URL non limitées à 64 caractères pour la fonction HTTP Alarm).
Tout comme pour le app.bin, on peut sans problème utiliser des www.bin d'autres manufacturiers, si on a des préférence sur la partie graphique, moins de bugs, etc.
Il faut juste veiller à ce qu'elle corresponde à un app.bin de la même version que celui que vous utilisez.
 
Un moyen simple pour vérifier que des fichiers sont exactement les mêmes, est de faire un calcul de MD5 et comparer les signatures résultantes (google est ton ami pour plus de précisions).
 
 
Fichiers de config
Vos config personnelles sont dans le fichiers cs.def.ini dans app/. On peut la sauvegarder sur le PC (et la restaurer) via l'interface de gestion.
Le firmware applicatif arrive avec un fichier de config de base: cs.ini. Il change à chaque version de app.bin.
 
Deux autres fichiers (plus ou moins bien cachés) très sensibles (à ne pas détruire!) se trouvent dans eye/ (pour ceux qui y ont accès):
ldr.ini et board.dat
Le premier contient une config d'usine propre à chaque caméra: il y a les infos de DDNS, addresses MAC, UID P2P qui sont sur les étiquettes de la cam.
Le board.dat est (très probablement) un fichier d'authentification crypté, qui contient ces mêmes infos, et qui avec le HID permet au logiciel de vérifier que ces paramètres n'ont pas été altérés.
Jusqu'ici cette vérification signale juste si l'HID est authentifié (valide et cohérent) ou non: ça n'a pas l'air de proscrire l'accès à un service si le HID n'est pas "authentifié": ça prévient juste qu'on utilise des paramètres qui ne sont pas ceux qu'on devrait...
Les infos de DDNS et UID correspondent à des comptes créés par le fabricant (ou Maygion?): on ne peut pas "inventer" des comptes.
 
 
Firmware "core" et fonctions diverses: FTP, Telnet, etc…
Le firmware core est un noyau Linux 2.6.36, uClibc 0.9.28, une busybox pour les fonctions shell de base, et quelques applications supplémentaires.
A ce jour, il n'y a pas de procédure pour mettre à jour (de manière permanente... :)) cette partie.
Cet environnent est donc la base immuable qui fait que la cam n'est jamais "briquée" de manière irrécupérable: le système redémarre toujours avec au moins le FTP, éventuellement le telnet qui permettent de remettre la cam d'aplomb (IP statique 192.168.1.111 sur ethernet dans les pire cas).
 
Ce socle est commun pour toutes les cam,…à quelques bricoles près si on veut pinailler… :)
En effet certaines cam "n'ont pas" telnet, ou ont un FTP "différent" (login Maygion ou login via les comptes de la cam, accès à toute la cam ou restreint à app/ et www/, …).
En fait les binaires sont présents, et ce ne sont que des différences de config, qui sont facilement contournables: on peut TOUJOURS activer le telnet et le FTP Maygion (le plus complet) sur toutes les cam!!
Il y a aussi de légère différence dans les busybox des diverses versions de cam: la liste des "applet" peuvent parfois être légèrement différente, mais rien de crucial.
 
J'ai noté un seul composant plus récent sur les dernières cam P2P (un petit utilitaire de démarrage): il doit surement faire des trucs mieux qu'avant, mais j'ai pu faire du P2P avec l'ancienne version aussi...
Pas de problèmes pour l'installer dynamiquement sur une "vieille" cam.
 
 
Hacking !... :pt1cable:  
En fait, on peut même aller beaucoup plus loin: on peut installer n'importe quel soft sur cette plateforme (pourvu qu'il ne soit pas trop gros et gourmand quand même): il suffit de se construire le bon environnement de développment/cross-compliation MIPS (little endian), et zou!.
J'ai pu par exemple recompiler une busybox plus étendue et la faire tourner sur la cam.
Les possibilités de hack sont donc énormes, et finalement assez simples à mettre en oeuvre, …tant que Maygion ne bouche pas les "trous".
 
Par exemple, ll semble qu'il y ait un "cadavre" de config d'un serveur iTunes (mt-daapd) dans le firmware core: bon ça ne fait pas trop de sens sur ce matériel sans gros espace de stockage, mais, conceptuellement, on pourrait effectivement installer ce genre de serveur.
 
Donc, il n'y a plus qu'à être créatif, et envisager quelle(s) application(s) (serveur, pilotable par interface web) on pourrait mettre là-dessus en parallèle de l'application caméra de base!...


Message édité par macmpi le 19-04-2013 à 17:27:37
n°732572
Marc
Super Administrateur
Chasseur de joce & sly
Posté le 19-04-2013 à 16:21:05  profilanswer
 

macmpi a écrit :

@ux ADMINS & MODOS SVP :
 
POST à attribuer au membre "macmpi"
 
MERCI ;)


Voilà :o

n°732580
macmpi
Posté le 19-04-2013 à 17:21:16  profilanswer
 

Merci à Paillassou et à toi.
Le post est donc désormais au début du topic, et sera mis à jour là-bas.
http://forum.hardware.fr/hfr/Hardw [...] tm#t705043  

n°732582
paillassou
Posté le 19-04-2013 à 17:26:00  profilanswer
 

;)

mood
Publicité
Posté le 19-04-2013 à 17:26:00  profilanswer
 

n°732638
Aahem
Posté le 20-04-2013 à 04:51:21  profilanswer
 

Nickel , le super récap soft de Macmpi, et bravo pour son emplacement.  
Avec le temps, la première page devient un must.

n°732639
Aahem
Posté le 20-04-2013 à 05:00:11  profilanswer
 

Citation :

Donc, il n'y a plus qu'à être créatif, et envisager quelle(s) application(s) (serveur, pilotable par interface web) on pourrait mettre là-dessus en parallèle de l'application caméra de base!...


Plutôt orienté alarme, domotique, contrôle d'entrées sorties etc.. ?  ...Hmmm..déclencher des scénarios sur une Vera lite ?
Dommage qu'il manque des entrées/sorties au niveau hard...surtout des entrées. On dirait qu'il y a un potentiel, mais cela ne doit pas être géré pour l'instant.
Par contre, un serveur Itune ..c'est la surprise !.


Message édité par Aahem le 20-04-2013 à 05:09:30
n°732656
Bocal83
Posté le 20-04-2013 à 13:00:41  profilanswer
 

Salut à tous !
 
Je viens de commander une CN-WIP604MW sur Aliexpress suite à vos avis sur ce topic ;-)
 
Ça à l'air d'être vraiment une bonne petite bête ! en plus d'être customisable (Linux inside, peut être y aurait-il moyen d'améliorer la qualité d'affichage en mouvement et de rajouter des fonctions en y installant des paquets ?)

n°732765
Aahem
Posté le 21-04-2013 à 23:24:25  profilanswer
 

Nos amis Polonais à BTI viennent de m'envoyer ce message:
"We sort out recording under Synology Surveilance Station
ONFIV doesn't works so far, but can record 640x480 MJPEG."

http://foscam.pl/p34,kamera-ip-wifi-b-g-n-model-bt-h08w-p2p-3-6mm.html  
Ca bouge :-)
 

n°732774
633216
Posté le 22-04-2013 à 07:29:40  profilanswer
 
n°732794
macmpi
Posté le 22-04-2013 à 12:16:43  profilanswer
 

Bocal83 a écrit :

(Linux inside, peut être y aurait-il moyen d'améliorer la qualité d'affichage en mouvement et de rajouter des fonctions en y installant des paquets ?)

Il n'y a pas de système de gestion de packets: ce n'est pas vraiment adapté à un environnement si contraint, et puis il faudrait que quelqu'un maintienne des versions de softs compilés, etc, etc...
Mais cela-dit, on peut tout à fait installer des trucs dessus, plus-ou-moins "à-la-mimine", oui :)
 
Quant-à améliorer l'application de caméra de surveillance elle-même, ça parait vraiment difficile, à moins que Maygion diffuse le code source (j'en doute), ou que quelqu'un s'amuse à "décompiler" l'application cs: surement pas une mince affaire.
Seule chance, tomber sur une appli du même genre, pas trop grosse, existant en open-source, et la recompiler: assez facile si ça existe.


Message édité par macmpi le 22-04-2013 à 12:17:33

---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°732821
Bubbah
Real Men Don't Do Backup
Posté le 22-04-2013 à 15:11:26  profilanswer
 

Encore une mise a jour sur www.maygion.com -> v05.53 !
pour moi ca marche maintenant bien en Onvif avec mon Syno (en fait depuis la v05.48 du 12 avril).  
Apparement il y a encore eu des ameliorations dans ce sens mais pas encore de controle Pan & Tilt.
En tout cas MayGion prone l'ouverture avec l'outil mkbin.exe inclus dans le package. Celui-ci est dispo depuis 09.07.2010 avec une note pour les DIY'ers (bidoulleurs), donc je ne pense pas qu'il ait l'intention de verouiller quoi que ce soit.
 
http://www.gadgetvictims.com/2013/ [...] ricam.html

Message cité 1 fois
Message édité par Bubbah le 22-04-2013 à 15:42:44

---------------
Bubbah - www.gadgetvictims.com
n°732846
philou155
Posté le 22-04-2013 à 17:34:35  profilanswer
 

azazel673 a écrit :

Bonjour philou155,  
 
sur Zoneminder arrivez-vous a controler la camera ?


 
Bonjour
 
Je n'ai pas tester, car seul l'enregistrement m'interesse.

n°732895
Mesfet
Posté le 22-04-2013 à 22:22:49  profilanswer
 

Bubbah a écrit :

Encore une mise a jour sur www.maygion.com -> v05.53 !
pour moi ca marche maintenant bien en Onvif avec mon Syno (en fait depuis la v05.48 du 12 avril).  
Apparement il y a encore eu des ameliorations dans ce sens mais pas encore de controle Pan & Tilt.
En tout cas MayGion prone l'ouverture avec l'outil mkbin.exe inclus dans le package. Celui-ci est dispo depuis 09.07.2010 avec une note pour les DIY'ers (bidoulleurs), donc je ne pense pas qu'il ait l'intention de verouiller quoi que ce soit.
 
http://www.gadgetvictims.com/2013/ [...] ricam.html


 
Merci Bubbah pour tes avant-premières. Je m'en vais vite tester le nouveau FW pour le suppport ONVIF avec nos synos et surtout l'amélioration du Wifi. En effet, j'ai constaté à de nombreuses reprises qu'un pb du Wifi (routeur Wifi débranché, hors de portée du signal wifi) faisait planter lamentablement la caméra. Il fallait recharger le FW via FTP et rebooter le tout via telnet.

n°732900
Mesfet
Posté le 22-04-2013 à 23:12:11  profilanswer
 

je viens de tester, je vois bien la caméra sous Surveillance Station de Synology, en revanche lorsque je valide, elle est indiqué comme étant déconnecté. Je suis en béta sur surv station et le HID est invalide. Y-aurait-il un rapport avec mon pb ?

n°732902
Mesfet
Posté le 22-04-2013 à 23:38:10  profilanswer
 

Je crois que le problème vient de ce paramètre HID. Il y a un menu proposant d'uplaoder le fichier d'authentification... c'est quoi ce fichier, j'ai tenté le board.dat...c'est pas ça.

n°732962
Bubbah
Real Men Don't Do Backup
Posté le 23-04-2013 à 17:39:37  profilanswer
 

Mon DS213+ est sous DSM 4.2-3211 avec Surveillance Station 6.0-2383
J'ai une connexion stable malgré un HID non-authentifié (Invalid License File). Ca ne devrait affecter que le P2P que je n'utilise de toutes façons pas. Surveillance Station était assez foireux pendant la phase beta.


---------------
Bubbah - www.gadgetvictims.com
n°732965
philou155
Posté le 23-04-2013 à 17:45:25  profilanswer
 

Bon pour information, j'ai reussi à avoir l'image en 16/9 enregistrement HD sous zone minder.
 
J'ai mis a jour la camera et plus de probleme.
 
Merci a Bubbah

n°732966
macmpi
Posté le 23-04-2013 à 17:48:27  profilanswer
 

Bubbah a écrit :

J'ai une connexion stable malgré un HID non-authentifié (Invalid License File). Ca ne devrait affecter que le P2P que je n'utilise de toutes façons pas.

Pour le moment le statut de "HID non-authentifié" n'est qu'une information signifiant que la cam a détecté une incohérence de config du quadruplet (HID, UID, DDNS, MAC).
Ca n'a pas l'air d'influer sur le fonctionnement effectif de ces services, qui ne sont, pour l'heure, pas désactivés en cas d'incohérence. (voir info dans l'article en signature)
Peut-être que ca changera, on verra...


Message édité par macmpi le 23-04-2013 à 17:49:44

---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°733027
Mesfet
Posté le 24-04-2013 à 11:47:08  profilanswer
 

Bubbah a écrit :

Mon DS213+ est sous DSM 4.2-3211 avec Surveillance Station 6.0-2383
J'ai une connexion stable malgré un HID non-authentifié (Invalid License File). Ca ne devrait affecter que le P2P que je n'utilise de toutes façons pas. Surveillance Station était assez foireux pendant la phase beta.


 
Hello je teste la beta 6.0.2602 et j'ai remonté le problème à Synology.

n°733277
Mesfet
Posté le 26-04-2013 à 16:18:00  profilanswer
 

Je viens d'identifier le problème pour l'erreur sous surveillance station. En restant en 640x480, pas de problème. Par contre, en montant à 1280x720, elle se déconnecte. Avez-vous le même problème ? Cela a peut-être déjà été évoqué auparavant, je n'ai pas lu tous les posts.
Dommage que la fonction "patrouille" de surveillance Station n'est pas ouvert pour l'instant, cela aurait comblé le manque de la fonction preset (ceci explique surement cela).

n°733313
Bubbah
Real Men Don't Do Backup
Posté le 26-04-2013 à 21:00:35  profilanswer
 

j'ai installé cette version beta 6.0-2604 et je constate le même problème, mais en plus j'ai des déconnexions intermittentes toutes les 30 secondes (La zone message déroule une série de "connection lost"/"connection resumed" ), ce que je n'avais pas avec la version 'stable' de Surveillance Station.


---------------
Bubbah - www.gadgetvictims.com
n°733328
Mesfet
Posté le 26-04-2013 à 23:37:02  profilanswer
 

Bubbah a écrit :

j'ai installé cette version beta 6.0-2604 et je constate le même problème, mais en plus j'ai des déconnexions intermittentes toutes les 30 secondes (La zone message déroule une série de "connection lost"/"connection resumed" ), ce que je n'avais pas avec la version 'stable' de Surveillance Station.


 
Désolé de t'avoir inciter à tester la version béta  ;)  
J'ai également des déconnexions intempestives, j'ai remonté le problème à Synology.
A suivre...
 
En revanche, pour l'amélioration de la gestion du wifi sur le firmware 05.53, je ne constate plus ce problème qui me valait de débriquer la cam à chaque problème de réception wifi. Donc un vrai + pour ma part.

n°733972
crysvoyage​r
Posté le 03-05-2013 à 23:24:51  profilanswer
 

Bonjour,
 
J'ai une IP607 WX avec un X sur le devant http://www.escamera.com/m-jpeg-ser [...] es-ip607wx, compatible Maygion V3.
Je recherche les 2 fichiers cachés ldr.ini et board.dat présents dans les dossiers App et Www.
J'ai malheureusement écrasé ces fichiers (cachés) dans une mise à jour et depuis ma caméra fonctionne beaucoup moins bien....
 
Firmware de 05.20 à 05.28 puis 05.53 et là plantage avec accès FTP 1s toutes les 15s, après 48h et de multiples essais de connections, retour à la version 05.28.
 
Merci pour votre aide.
 
Si je me suis trompé de sujet, merci à un modérateur de déplacer mon message.

Message cité 1 fois
Message édité par crysvoyager le 04-05-2013 à 11:06:24
n°734010
macmpi
Posté le 04-05-2013 à 14:05:44  profilanswer
 

crysvoyager a écrit :

Je recherche les 2 fichiers cachés ldr.ini et board.dat présents dans les dossiers App et Www.


Ces fichiers sont en effet cachés selon les cam: tu les cherches comment?
Le meilleur moyen pour les voir c'est en telnet. Les client FTP les cachent.
 
Effectivement si le ldr.ini est écrasé ca peut causer des instabilités. Le Board.dat ne devrait pas avoir d'effet pour le moment.
On peut regénérer un ldr.ini avec les infos qui sont sur les étiquettes de la cam (identifiants ddns, UID, etc): ne les donne pas ici, mais juste dis-moi si tu as un code-barre 2D avec UID ou pas (fichiers ldr.ini différents).


---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°734014
crysvoyage​r
Posté le 04-05-2013 à 14:34:18  profilanswer
 

Merci pour ta réponse
J'utilise Filezilla en FTP et entrevu ces fichiers en cochant l'option "visualiser les fichiers cachés", avant l'écrasement par copie des dossiers app et www (grosse erreur).
Au dos de la caméra, une étiquette sans code barre mais une adresse DDNS.


Message édité par crysvoyager le 04-05-2013 à 14:50:18
n°734016
macmpi
Posté le 04-05-2013 à 15:17:00  profilanswer
 

ATTENTION! Ta cam est un modèle différent plus ancien (pas H264, surement HW différent)
Pas sur du tout que la manip ci-dessous fonctionne!...(elle doit fonctionner sur les cam H264 de ce topic)
 
Un peu surprenant quand même, car ces fichiers sont cachés par le serveur sur la cam à priori (en tout cas le ldr.ini), et sont dans le répertoire qui contient app/ et www/: ils ne devraient donc pas être effacés par une copie de ces dossiers là...à moins effectivement de les écraser avec des fichiers du même nom en plus des dossiers app/ et www/
 
Bref...
L'idéal serait de voir de près en telnet ce qu'il reste comme fichier avant de l'écraser pour sûr avec la manip ci-dessous.
 
Voici un ldr.ini très basique: copier ce fichier (sans les numéros de ligne!) et changer les llCCCC dans les lignes 3, 4, 5 avec les valeurs qui sont sur l'étiquette (l pour lettre, C pour Chiffre), en supposant que le prestataire DDNS soit bien iview.hk (sinon adapter ça aussi).
Sauvegarder le fichier comme un fichier texte, nommé lrd.ini,  format UNIX (pas PC, ni Mac !) avec un éditeur de texte.
Puis le transférer sur la cam par FTP dans le répertoire contenant app/ et www/
Redemarrer la cam et voir ce que ca donne.
 

Code :
  1. [ddns]
  2. provider=iview.hk
  3. ddns_usr=llCCCC
  4. ddns_pwd=llCCCC
  5. ddns=llCCCC.iview.hk
  6. enable=1
  7. mode
  8. [ini]
  9. version=1
  10. [system]
  11. mac=
  12. wifimac=
  13. [oem_smarteye]
  14. enable=1
  15. mac
  16. mac2
  17. mid
  18. pid
  19. sn
  20. se_ddns_svr
  21. se_ddns_port=80
  22. se_ddns_interval=60
  23. se_ddns_name
  24. se_ddns_user
  25. se_ddns_pwd


Message édité par macmpi le 04-05-2013 à 15:21:55

---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°734025
crysvoyage​r
Posté le 04-05-2013 à 17:17:00  profilanswer
 

J'ai recréé le fichier ldr avec iview.hk comme porté sur l'étiquette et en suivant tes conseils.
Mais si je comprends bien en voyant le contenu, ce fichier ne sert que pour le DDNS ou est il incomplet ?
J'ai une IP externe fixe (Alice) donc je n'utilise pas de service DDNS.
Dans DDNS dynamique je retrouve les valeurs des lignes 3-4-5, donc le fichier est bien reconnu !
Merci encore pour ton aide.

n°734030
macmpi
Posté le 04-05-2013 à 17:38:16  profilanswer
 

crysvoyager a écrit :

Merci encore pour ton aide.

La caméra est plus stable maintenant?
Ce fichier est utilisé au lancement de la cam pour parametrer plusieurs choses, dont le ddns, que l'on s'en serve ou pas.
Il semble que ce qui demarre la cam préfère voir une config correcte, et sinon repart en boucle, ce qui crée l'instabilité.
Selon les versions de cam et de logiciel interne, ce fichier règle d'autres choses, comme la config de secours (adresses IP fixes, MAC address), l'identifiant P2P, etc...


---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°734037
crysvoyage​r
Posté le 04-05-2013 à 18:09:04  profilanswer
 

Je reconnais que cela semble beaucoup plus stable.
Pour cette caméra je vais rester au fw 05.28 pour encore longtemps....
Merci pour m'avoir sorti de la panade.

n°734078
craym0nk
Posté le 05-05-2013 à 05:19:46  profilanswer
 

FRENCH GOOGLE TRANSLATE:
Toutes mes excuses, je suis de langue maternelle anglaise d'Australie. J'accède à ce site via Google Chrome avec la traduction automatique est activée. Peut-être que quelqu'un peut m'aider avec mon problème?
 
J'ai Dericam H502W caméra IP-ID002A, je me suis cassé firmware il ya plusieurs semaines. J'ai fait correction partielle grâce à Bubbah & Vasycara. Caméra travaillait avec 5.20 du firmware mais seulement si je botte souple (via l'interface www). Si je boot dur (débranchez le câble d'alimentation), un appareil photo retourne au mode de récupération 192.168.1.111.
 
Je ne pouvais accéder telnet et ftp, par hasard, je suis tombé commande "exec reboot" de telnet et de démarrage de l'appareil en mode de marche.
 
La nuit dernière, je passe à Maygion firmware 5.53 via www. Les deux app.bin et www.bin mise à niveau sans faute. HID a été authentifié. Botte souple via www travaillait.
 
Une fois de plus, reboot hard par câble d'alimentation et je suis bloqué en mode de récupération. Nouveau problème, la caméra est maintenant coincé dans la boucle de redémarrage toutes les 30 secondes. Donc je ne peux pas accéder à telnet ou ftp pour assez longtemps pour faire des changements.
 
Quelqu'un peut-il suggérer une façon de résoudre ce problème?
 
 
ENGLISH:
Apologies, I am native English speaker from Australia. I am accessing this site via Google Chrome with automatic translation enabled. Maybe someone can help with my problem?
 
I have Dericam H502W IP-CAMERA-ID002A, I broke firmware many weeks ago. I made partial fix thanks to Bubbah & Vasycara. Camera was working with 5.20 firmware but only if I soft boot (through www interface). If i hard boot (unplug power cable), camera went back to recovery mode 192.168.1.111.
 
I could access telnet and ftp, by chance I ran command "exec reboot" from telnet and camera boot to full working mode.
 
Last night I upgrade to Maygion firmware 5.53 via www. Both app.bin and www.bin upgrade without fault. HID was authenticated. Soft boot via www was working.
 
Once again, hard reboot by power cable and I am stuck in recovery mode. New problem, camera is now stuck in reboot loop every 30 seconds. So I cannot access telnet or ftp for long enough time to make changes.
 
Can anyone suggest a way to fix?
 
 
 
System Information (  Fail to fetch data)
 
Software Version: 00.00.05.53  
Web Version: ipcam(2013.04.15)  
OCX: 20120526  
Hardware Version:  H264  
Firmware Build Date: Apr 21 2013 14:59:03  
Compiler: gcc 3.4.2  
Run Time: 0Day(s) 00:03:40  
Device Time: 05-04-2013 11:13:35  
HID: 6CEDA591CB6870DD9F9C49707E427334(Authenticated)

Message cité 1 fois
Message édité par craym0nk le 05-05-2013 à 05:24:32
n°734104
macmpi
Posté le 05-05-2013 à 12:45:44  profilanswer
 

craym0nk a écrit :

Apologies, I am native English speaker from Australia.

Thanks for the effort in posting in French.
5.53 is also very unstable on my Dericam, so I'd recommand sticking to 5.48 (labeled 5.49 on Maygion site) for now.
Good thing you can telnet: please try to remove the cs file in /tmp/eye/app when you can: just type (or paste & return) the following  
rm -f /tmp/eye/app/cs
as soon as you can open a telnet session, either on 192.168.1.111 or your nominal LAN address.
 
At next reboot you'll have a more peacefull & reliable telnet/FTP access on 192.168.1.111, and you'll do the rest below.
 
On your PC, use mkbin tool from 5.49 archive to extract app.bin from that same archive: it will give you 2 files: cs.def.ini and cs.
Put those 2 files in /tmp/eye/app with your FTP client. Double-check uploaded cs file size is correct with the original file on your PC.
Now reboot: cam should operate normally.
Then with Web interface, update the web service with www.bin contained in that same Maygion archive.
And you should be done.

Message cité 1 fois
Message édité par macmpi le 05-05-2013 à 17:29:03

---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°734106
webvan
Posté le 05-05-2013 à 13:05:42  profilanswer
 

M'étant fait avoir avec une fausse webcam 1.0mp (Ontop RT8633) je pense que je vais prendre celle-ci, deux questions :  
- quelqu'un sait si elle est compatible avec l'application iPhone Foscal Surveillance Pro ?
- le meilleur prix actuellement c'est où ? Sur aliexpress du lien dans le premier message elle est à $80 maintenant (apparemment $74 au départ).
Merci !


---------------
ATH AD700 - AKG K414P/K420/K430 -  Bose QC20/25 - Havit G1 - Jabra 65T - Sennheiser HD212/RS160/RS180 - HD681B - Apple EarPods - Klipsch S4a - Philips SHB4000 BT - TRN V80 Mes Tests Casques
n°734306
craym0nk
Posté le 07-05-2013 à 14:16:07  profilanswer
 

macmpi a écrit :

rm -f /tmp/eye/app/cs.


 
macmpi, you are the master! Removing the cs file stopped the 30 second reboot loop immediately. And thank you for communicating with me in English.
 
Unfortunately my original problem (since before I loaded 5.53) remains. No matter which firmware I use 5.48, 5.20, if I remove the power cord to restart the camera I end up in recovery mode. I think I have done something to break init.
 
I was looking around the file system and came across /etc_rc/inittab:

Code :
  1. # cat inittab
  2. ::sysinit:/etc_ro/rcS
  3. ttyS1::respawn:/bin/sh


The script /etc_rc/rcS is called on sysinit. I'm guessing it should only run if the firmware is damaged, I think on my camera it is running every time the power cord is removed. If I log in via telnet and call exec reboot the camera will restart and operate as it should. It is also OK if I reboot from the www interface. Here is the contents of /etc_rc/rcS:

Code :
  1. # cat rcS
  2. #!/bin/sh
  3. mount -a
  4. mkdir -p /var/run
  5. mkdir /tmp/eye
  6. mount -t jffs2 /dev/mtdblock5 /tmp/eye
  7. cat /etc_ro/motd
  8. cd /sbin
  9. internet.sh
  10. sleep 1
  11. ifconfig eth2.1 192.168.1.111
  12. cd /bin
  13. #ftpd&
  14. fd&
  15. telnetd&
  16. wpp&
  17. apploader&
  18. #./cs&
  19. mii_mgr -s -p 0 -r 0 -v 0x3900
  20. mii_mgr -s -p 1 -r 0 -v 0x3900
  21. mii_mgr -s -p 2 -r 0 -v 0x3900
  22. mii_mgr -s -p 3 -r 0 -v 0x3900
  23. #for syslogd
  24. mkdir -p /var/log


This post on Open IP Camera forums talks about an /tmp/eye/init.sh file which I do not have. Are you familiar with it, maybe the cause of my problems? http://www.openipcam.com/forum/ind [...] ml#msg1207
 
Any ideas what might be wrong?
 
BAD FRENCH GOOGLE TRANSLATION:
macmpi, vous êtes le maître! Retrait du fichier cs arrêté immédiatement la deuxième boucle 30 de redémarrage. Et merci pour communiquer avec moi en anglais.
 
Malheureusement, mon problème initial (depuis avant que je chargeais 5,53) demeure. Peu importe le firmware j'utilise 5,48, 5,20, si je retire le cordon d'alimentation pour redémarrer l'appareil photo je me retrouve en mode de récupération. Je pense que j'ai fait quelque chose pour briser initialisation.
 
Je regardais autour du système de fichiers et suis tombé sur /etc_rc/ inittab: CODE
 
Le script /etc_rc/rcS est appelé sysinit. Je suppose qu'il ne doit s'exécuter si le firmware est endommagé, je pense que sur mon appareil photo est en marche chaque fois que le cordon d'alimentation est débranché. Si je me connecte via telnet et appelle exec reboot r l'appareil va redémarrer et fonctionner comme il se doit. Il est également OK si je redémarre à partir de l'interface www. Voici le contenu de /etc_rc/rcS: CODE
 
Ce post sur les forums ouverts Caméra IP parle d'un fichier /tmp/eye/init.sh que je n'ai pas. Êtes-vous familier avec elle, peut-être la cause de mes problèmes? LINK
 
Des idées ce qui pourrait être le problème?

Message cité 2 fois
Message édité par craym0nk le 07-05-2013 à 14:21:32
n°734310
macmpi
Posté le 07-05-2013 à 15:13:30  profilanswer
 

craym0nk,
Please make sure cs.def.ini is properly installed in app/ and that you have ldr.ini in eye/ (check this one with telnet as FTP server hides it). You may cut&paste your ldr.ini content in a PM for me to check-it. Also make sure cs file has correct size (if flash full, it may be truncated) and execute rights (chmod 755 cs   if not)
Also you may copy and remove (or just rename) cs.ini (your settings) to see how it goes with blank user config parameters.
 
If this does not help, read your PMs. ;)
 
PS:
Init phase (some good findings ;)). It's all fine, and can not be altered by application firmware updates.

Message cité 1 fois
Message édité par macmpi le 08-05-2013 à 17:42:11

---------------
Les informations détaillées sur le logiciel de la cam, et le hacking c'est ICI
n°734323
Mesfet
Posté le 07-05-2013 à 19:13:08  profilanswer
 

craym0nk a écrit :


 
macmpi, you are the master! Removing the cs file stopped the 30 second reboot loop immediately. And thank you for communicating with me in English.
 
Unfortunately my original problem (since before I loaded 5.53) remains. No matter which firmware I use 5.48, 5.20, if I remove the power cord to restart the camera I end up in recovery mode. I think I have done something to break init.
 
I was looking around the file system and came across /etc_rc/inittab:

Code :
  1. # cat inittab
  2. ::sysinit:/etc_ro/rcS
  3. ttyS1::respawn:/bin/sh


The script /etc_rc/rcS is called on sysinit. I'm guessing it should only run if the firmware is damaged, I think on my camera it is running every time the power cord is removed. If I log in via telnet and call exec reboot the camera will restart and operate as it should. It is also OK if I reboot from the www interface. Here is the contents of /etc_rc/rcS:

Code :
  1. # cat rcS
  2. #!/bin/sh
  3. mount -a
  4. mkdir -p /var/run
  5. mkdir /tmp/eye
  6. mount -t jffs2 /dev/mtdblock5 /tmp/eye
  7. cat /etc_ro/motd
  8. cd /sbin
  9. internet.sh
  10. sleep 1
  11. ifconfig eth2.1 192.168.1.111
  12. cd /bin
  13. #ftpd&
  14. fd&
  15. telnetd&
  16. wpp&
  17. apploader&
  18. #./cs&
  19. mii_mgr -s -p 0 -r 0 -v 0x3900
  20. mii_mgr -s -p 1 -r 0 -v 0x3900
  21. mii_mgr -s -p 2 -r 0 -v 0x3900
  22. mii_mgr -s -p 3 -r 0 -v 0x3900
  23. #for syslogd
  24. mkdir -p /var/log


This post on Open IP Camera forums talks about an /tmp/eye/init.sh file which I do not have. Are you familiar with it, maybe the cause of my problems? http://www.openipcam.com/forum/ind [...] ml#msg1207
 
Any ideas what might be wrong?
 
BAD FRENCH GOOGLE TRANSLATION:
macmpi, vous êtes le maître! Retrait du fichier cs arrêté immédiatement la deuxième boucle 30 de redémarrage. Et merci pour communiquer avec moi en anglais.
 
Malheureusement, mon problème initial (depuis avant que je chargeais 5,53) demeure. Peu importe le firmware j'utilise 5,48, 5,20, si je retire le cordon d'alimentation pour redémarrer l'appareil photo je me retrouve en mode de récupération. Je pense que j'ai fait quelque chose pour briser initialisation.
 
Je regardais autour du système de fichiers et suis tombé sur /etc_rc/ inittab: CODE
 
Le script /etc_rc/rcS est appelé sysinit. Je suppose qu'il ne doit s'exécuter si le firmware est endommagé, je pense que sur mon appareil photo est en marche chaque fois que le cordon d'alimentation est débranché. Si je me connecte via telnet et appelle exec reboot r l'appareil va redémarrer et fonctionner comme il se doit. Il est également OK si je redémarre à partir de l'interface www. Voici le contenu de /etc_rc/rcS: CODE
 
Ce post sur les forums ouverts Caméra IP parle d'un fichier /tmp/eye/init.sh que je n'ai pas. Êtes-vous familier avec elle, peut-être la cause de mes problèmes? LINK
 
Des idées ce qui pourrait être le problème?


 
 I have the same problem !

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  12  13  14  ..  26  27  28  29  30  31

Aller à :
Ajouter une réponse
 

Sujets relatifs
Ecran HD avec connection HDMI pour jouer ?Caméra wifi TP-Link TL-SC4171G
Clef usb wifi / livebox[Topic Unique] Ecran Iiyama ProLite B2480HS-1 (24").
[Topic Unique] Cooler Master Storm Sentinel Advance II[Topic Unique] QPAD 5K Limited Edition
module wifi intégré carte mère asus z77[topîc unique] Monitor Samsung SincMaster B2440
Connexion WiFi - Imprimante HP-3070A 
Plus de sujets relatifs à : [Topic Unique] H.264 IPCAM HD WIFI Pan & Tilt + IR-Cut + SDcard


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR