Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1485 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Switch 8 ports cisco qui fait planter le réseau

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Switch 8 ports cisco qui fait planter le réseau

n°161942
evan52
Posté le 01-04-2019 à 18:56:08  profilanswer
 

Bonjour,
 
je devais installer un petit switch cisco catalyst 2960X 8 ports ( neuf) , sur un  petit batiment.  Ce bâtiment est relié au bâtiment principale par une fibre  dans notre salle serveur avec nos switch coeur de réseau ( full cisco, des 3850) 24 ports fibres.
En général, l'interco, je la fait en etherchannel avec 2 ports.
Là, par manque de port, j'en utilise qu'un seul.  
 
Coté coeur, c'est configuré comme ça :  
 
Current configuration : 210 bytes
!
interface GigabitEthernet2/0/20
 description XXXXXX
 switchport mode trunk
 auto qos trust
 service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy
end
-----------------------------------------------------------------------
 
Côté switch de distri, c'est configuré comme ça :
 
 
 
interface GigabitEthernet0/12
 description Lien XXXXXXX
 switchport mode trunk
 srr-queue bandwidth share 10 10 60 20
 queue-set 2
 priority-queue out
 mls qos trust cos
 auto qos voip trust
end
 
Quand je branche ce switch, ça me fait tomber le réseau! Les switch core ne sont plus joignables! Dès que je l'enlève, ça revient....
 
Le spanning tree est en mode pvst des 2 côtés...

mood
Publicité
Posté le 01-04-2019 à 18:56:08  profilanswer
 

n°161945
Ivy gu
Posté le 01-04-2019 à 19:19:39  profilanswer
 

ça arrive même si tu ne branches que le port vers l'autre switch ?
est-ce que ça déclenche un changement de root bridge ?


---------------
Infused with cruelty, malice, and abstract jazz music.
n°161967
evan52
Posté le 02-04-2019 à 13:23:19  profilanswer
 

Ivy gu a écrit :

ça arrive même si tu ne branches que le port vers l'autre switch ?
est-ce que ça déclenche un changement de root bridge ?


 
ça arrive dès que je branche mon switch sur le coeur de réseau ( via un port fibre avec module SFP). Tu veux dire en branchant un port cuivre?  
Côté coeur, c'est un switch fibre.
 
 
Sinon, j'ai bien sur retirer le switch qui me fout le bazarre, en port console, je regarde la conf, quand je fais un sh run conf | include spanning
il m'indique ça :
spanning-tree mode pvst
spanning-tree extend system-id
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 spanning-tree portfast edge
 
 
il me fout mes ports de distri en "edge", alors que je passe la commande #spanning tree portfast, me rappelle plus trop la différence?
 
par contre, quand je fais #sh spanning-tree   il me met "No spanning tree instance exists", après, là le switch est plus relié à rien, peut être le faut il pour voir remonter qqchose?
 
idem quand je fais #sh spanning-tree root
m'affiche rien.
 

n°161968
Ivy gu
Posté le 02-04-2019 à 13:28:05  profilanswer
 

evan52 a écrit :


 
ça arrive dès que je branche mon switch sur le coeur de réseau ( via un port fibre avec module SFP). Tu veux dire en branchant un port cuivre?  
 
 


 
non je veux dire en ne branchant que ça sur le switchs, pas de poste client ou d'autre switch ou autre équipement.
 
pour spanning tree oui si le switch n'est branché à rien il ne va pas te dire grand chose.


---------------
Infused with cruelty, malice, and abstract jazz music.
n°161971
evan52
Posté le 02-04-2019 à 13:46:12  profilanswer
 

Ivy gu a écrit :


 
non je veux dire en ne branchant que ça sur le switchs, pas de poste client ou d'autre switch ou autre équipement.
 
pour spanning tree oui si le switch n'est branché à rien il ne va pas te dire grand chose.


 
 
Il n'y avait rien de branché sur le switch hormis le port fibre reliant  ce switch. j'ai refait un test à midi, idem, dès que je branche ce switch 8 ports, le réseau tombe ( le coeur de réseau devient inaccessible donc tout le réseau tombe). Dès que je débranche ( j'étais au tél avec un collègue qui avait lancer un ping), ça revient quasi immédiatement ( perte de 2 ping).  
 
là je fais un erase en conf usine du switch, je vais refaire toute la conf, et retester. Mais j'ai un doute car tout nos switch de distris sont configurés pareil hormis le nbre de port, les vlans.  

n°161974
logre
Posté le 02-04-2019 à 14:36:23  profilanswer
 

evan52 a écrit :


 
 
Il n'y avait rien de branché sur le switch hormis le port fibre reliant  ce switch. j'ai refait un test à midi, idem, dès que je branche ce switch 8 ports, le réseau tombe ( le coeur de réseau devient inaccessible donc tout le réseau tombe). Dès que je débranche ( j'étais au tél avec un collègue qui avait lancer un ping), ça revient quasi immédiatement ( perte de 2 ping).  
 
là je fais un erase en conf usine du switch, je vais refaire toute la conf, et retester. Mais j'ai un doute car tout nos switch de distris sont configurés pareil hormis le nbre de port, les vlans.  


 
Allez...
 
T'as été voir les logs des switchs?   :ange:  

n°162030
batcha
Posté le 03-04-2019 à 12:13:55  profilanswer
 

logre a écrit :


 
Allez...
 
T'as été voir les logs des switchs?   :ange:  


 
Check ton root bridge et ton port-priority.
 
interface GigabitEthernet0/22
 description VERS_SW13
 switchport mode trunk
 switchport voice vlan 400
 mls qos trust cos
 spanning-tree port-priority 32
 
 


---------------
http://forum.hardware.fr/hfr/Achat [...] #t16193277 ==> Topic Vente
n°162046
Charon_
Posté le 03-04-2019 à 22:38:22  profilanswer
 

Hello,
 
Je ne vois pas trop le lien avec le fait que ton réseau tombe si tu ne branches qu’un câble de ce 2960X vers ton switch de distribution.
portfast edge va justement forcer ton switch à croire qu’il se connecte à des Host, donc boucle possible si tu laisses cela actif avec au moins 2 câbles vers d’autres Switch.
Fais en sorte de le désactiver sur ces ports vers tes distributions dans un premier temps.

Message cité 2 fois
Message édité par Charon_ le 03-04-2019 à 22:39:50
n°162070
evan52
Posté le 04-04-2019 à 17:07:44  profilanswer
 

logre a écrit :


 
Allez...
 
T'as été voir les logs des switchs?   :ange:  


 
 
Les log s'arrêtent au mois de janvier donc, je n'ai rien pu voir.

n°162071
evan52
Posté le 04-04-2019 à 17:28:04  profilanswer
 

Charon_ a écrit :

Hello,
 
Je ne vois pas trop le lien avec le fait que ton réseau tombe si tu ne branches qu’un câble de ce 2960X vers ton switch de distribution.
portfast edge va justement forcer ton switch à croire qu’il se connecte à des Host, donc boucle possible si tu laisses cela actif avec au moins 2 câbles vers d’autres Switch.
Fais en sorte de le désactiver sur ces ports vers tes distributions dans un premier temps.


 
 
Hello,
Le  câble qui relie les 2 switchs est en trunk sur les 2 ports ( jarretières fibres) sur modules SFP. Des 2 côtés. Il n'y a rien d'autres de brancher quand je fais le test. Dès qu'il est branché le core part en vrille, dès que je le retire, ça remonte.
 
Le root bridge est le  coeur de réseau.  
 
 
Root ID    Priority    4097
             Address     XXXXXX
             Cost        6
             Port        456 (Port-channel1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
 
  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     XXXXXXX
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec
 
 
Du coup, je n'ai pas eu le temps de regarder aujourd'hui, je verrai demain si je peux refaire un test hors heures ouvrées, j'ai pas envie de foutre en vrac 400 utilisateurs.  

mood
Publicité
Posté le 04-04-2019 à 17:28:04  profilanswer
 

n°162091
evan52
Posté le 05-04-2019 à 08:23:51  profilanswer
 

Charon_ a écrit :

Hello,
 
Je ne vois pas trop le lien avec le fait que ton réseau tombe si tu ne branches qu’un câble de ce 2960X vers ton switch de distribution.
portfast edge va justement forcer ton switch à croire qu’il se connecte à des Host, donc boucle possible si tu laisses cela actif avec au moins 2 câbles vers d’autres Switch.
Fais en sorte de le désactiver sur ces ports vers tes distributions dans un premier temps.


 
 
C'est un switch 8 ports + 2 ports fibres. Le spanning tree est que sur les 8 ports. La liaison vers le coeur  passe par l'un des ports fibres, qui est en trunk.

n°162099
evan52
Posté le 05-04-2019 à 12:57:41  profilanswer
 

Quel est la différence d'ailleurs entre spanning tree portfast et spanning tree portfast edge?
 
 
Sur mes switchs neufs avec IOS récent, quand je tape spanning tree portfast, il me met spanning tree portfast edge directement.

n°162148
logre
Posté le 08-04-2019 à 10:04:29  profilanswer
 

evan52 a écrit :

 


Les log s'arrêtent au mois de janvier donc, je n'ai rien pu voir.

 

eh bien connecte toi en live sur le switch (cli) pendant les problèmes, tu devrais voir des choses (messages d'erreurs, cpu au taquet etc...) et comment ça les logs s'arrêtent en janvier? :O La date de ton switch est bien config?

 
evan52 a écrit :

Quel est la différence d'ailleurs entre spanning tree portfast et spanning tree portfast edge?

 


Sur mes switchs neufs avec IOS récent, quand je tape spanning tree portfast, il me met spanning tree portfast edge directement.

 


Si on se réfère aux posts suivant https://learningnetwork.cisco.com/thread/72871;

 

Chez Cisco un portfast edge est un portfast "intelligent", qui se transforme en spanning-tree port standard quand il reçoit une trame BPDU (pouvant le faire passer en état bloqué s'il détecte une loop). Ce qui n'est pas le cas d'un portfast de base (pour ça qu'on met le BPDU Guard en supplément - qui permet de bloquer le port s'il recoit une trame BPDU sur un port sensé ne pas en recevoir, bloquant les boucles)

  


Message édité par logre le 08-04-2019 à 10:07:20
n°162149
Charon_
Posté le 08-04-2019 à 10:32:38  profilanswer
 

Hello,
 
Si tes logs s'arrêtent en Janvier, c'est simplement que tu les regards en console via le "buffer".  
Tu n'as qu'à simplement étendre cette plage de mémoire.
 
logging buffer xxxxxx(taille) informational ou debug
 
Généralement, il faudrait plutôt exporter tes logs sur un syslog. Pour cela, chez Cisco c'est :
 
logging trap xxxxxxx (taille) informational ou debug ( ces deux derniers vont te donner pas mal de logs)
 
Pour spanning-tree  portfast, c'est exactement la même chose.
c'est juste le nouveau code qui rajoute ce mot clef.
 
Tu as aussi les variantes :
 
spanning-tree portfast trunk (pour un port host en mode trunk)
spanning-tress portfast network (pour un port entre switches)

n°162150
evan52
Posté le 08-04-2019 à 10:47:18  profilanswer
 

Merci de vos réponses.
 
Pour le syslog, c'est en cours de mise en place.  
 
Pour le logging buffer, il est configuré comme ça :
 
logging buffered 40000
 
Pour le test en live, je dois le faire en dehors de heures ouvrés, donc ce soir vers 18h30 19h

n°162154
Charon_
Posté le 08-04-2019 à 11:45:41  profilanswer
 

Histoire d'anticiper un peu.
 
Pourrais-tu poster la configuration de ton switch 2960 ? ( show run)
Evidemment, il faudrait prendre soin d'enlever les information sensibles de ton infra : NTP, DNS, login/password etc.
 
Peux-tu également indiquer quels sont les commandes exactes que tu comptes mettre en place sur tes switchport qui vont se connecter vers tes autres switch d'infra ?

n°162166
evan52
Posté le 08-04-2019 à 18:24:08  profilanswer
 

Le switch sera relié au coeur de réseau via Gi0/12, port avec module SFP
 
Pour la partie host, seul 2 ports seront utilisés pour l'instant, 2 pc, et plus tard un téléphone IP  
 

Charon_ a écrit :

Histoire d'anticiper un peu.
 
Pourrais-tu poster la configuration de ton switch 2960 ? ( show run)
Evidemment, il faudrait prendre soin d'enlever les information sensibles de ton infra : NTP, DNS, login/password etc.
 
Peux-tu également indiquer quels sont les commandes exactes que tu comptes mettre en place sur tes switchport qui vont se connecter vers tes autres switch d'infra ?


 
 
 

Citation :

Current configuration : 11220 bytes
!
! Last configuration change at 14:40:49 MET-DST Fri Apr 5 2019
!
version 15.2
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname XXXX
!
boot-start-marker
boot-end-marker
!
logging buffered 40000
enable secret 5 XXXXXXX
enable password 7 XXXXXXXXX
!
username admin privilege 15 password 7 XXXXXXX
aaa new-model
!
!
aaa group server radius XXXX-RADIUS
 server-private XXXXX auth-port 1812 acct-port 1812 key XXXXX.....
!
aaa authentication login default group XXXX local
aaa authorization console
aaa authorization exec default group XXXXX local if-authenticated
!
!
!
!
!
!
aaa session-id common
clock timezone MET 1 0
clock summer-time MET-DST recurring last Sun Mar 2:00 last Sun Oct 3:00
system mtu routing 1500
!
!
!
!
!
!
ip domain-name XXXXX
ip name-server XXXXX
ip name-server XXXXX
 
 
crypto pki trustpoint TP-self-signed-1880037760
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-1880037760
 revocation-check none
 rsakeypair TP-self-signed-1880037760
!
!
crypto pki certificate chain TP-self-signed-1880037760
 certificate self-signed 01
  XXXXXX
 
 
 
 
 
 
 
 
 
        quit
!
spanning-tree mode pvst
spanning-tree extend system-id
auto qos srnd4
!
!
!
!
cdp timer 50
cdp holdtime 120
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/1
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/2
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/3
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/4
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
interface GigabitEthernet0/5
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/6
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/7
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/8
 description Poste Info
 switchport access vlan 310
 switchport mode access
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
 spanning-tree portfast edge
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
 description Lien vers Coeur de reseau
 switchport mode trunk
 srr-queue bandwidth share 1 30 35 5
 priority-queue out
 mls qos trust cos
 auto qos trust
!
interface Vlan1
 description Vlan Management
 ip address xx.XX.XX.XX 255.255.255.0
 no ip route-cache
!
ip default-gateway XXXX
ip forward-protocol nd
!
no ip http server
ip http authentication aaa
ip http secure-server
ip http secure-trustpoint TP-self-signed-1884257920
ip ssh version 2
!
!
!
logging trap warnings
logging host XXX
logging host XXX
logging host XXX
logging host xXX
logging host XXX
access-list 99 permit XXX
.....
.....
access-list 99 deny   any
!
!
snmp-server group snmp39 v3 auth
snmp-server group snmpcg39 v3 auth
snmp-server group snmpcg39 v3 priv
snmp-server view CG39 internet included
snmp-server view CG39 mib-2 included
snmp-server view CG39 system included
snmp-server view CG39 cisco included
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps transceiver all
snmp-server enable traps call-home message-send-fail server-fail
snmp-server enable traps tty
snmp-server enable traps license
snmp-server enable traps auth-framework sec-violation
snmp-server enable traps config-copy
snmp-server enable traps config
snmp-server enable traps config-ctid
snmp-server enable traps trustsec-sxp conn-srcaddr-err msg-parse-err conn-config-err binding-err conn-up conn-down binding-expn-fail oper-nodeid-change binding-conflict
snmp-server enable traps energywise
snmp-server enable traps fru-ctrl
snmp-server enable traps entity
snmp-server enable traps event-manager
snmp-server enable traps ike policy add
snmp-server enable traps ike policy delete
snmp-server enable traps ike tunnel start
snmp-server enable traps ike tunnel stop
snmp-server enable traps ipsec cryptomap add
snmp-server enable traps ipsec cryptomap delete
snmp-server enable traps ipsec cryptomap attach
snmp-server enable traps ipsec cryptomap detach
snmp-server enable traps ipsec tunnel start
snmp-server enable traps ipsec tunnel stop
snmp-server enable traps ipsec too-many-sas
snmp-server enable traps power-ethernet group 1
snmp-server enable traps power-ethernet police
snmp-server enable traps cpu threshold
snmp-server enable traps bridge newroot topologychange
snmp-server enable traps stpx inconsistency root-inconsistency loop-inconsistency
snmp-server enable traps syslog
snmp-server enable traps vtp
snmp-server enable traps vlancreate
snmp-server enable traps vlandelete
snmp-server enable traps flash insertion removal
snmp-server enable traps port-security
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps stackwise
snmp-server enable traps bulkstat collection transfer
snmp-server enable traps errdisable
snmp-server enable traps mac-notification change move threshold
snmp-server enable traps vlan-membership
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp-server host XXX version 3 auth snmpXX
snmp mib flash cache
!
!
!
banner motd ^CC
 ------------------------------------------------------------
|             VOUS ETES CONNECTE A UN EQUIPEMENT             |
|  DONT LES ACCES SONT RESTREINTS AU SEUL PERSONNEL AUTORISE |
|                          ******                            |
|       TOUTE INTRUSION SUR UN SYSTEME INFORMATIQUE          |
| EST INTERDITE PAR LES ARTICLES 323-1 A 323-7 DU CODE PENAL |
|                          ******                            |
| ARTICLE 323-1:                                             |
| "LE FAIT D'ACCEDER OU DE SE MAINTENIR, FRAUDULEUSEMENT,    |
|  DANS TOUT OU PARTIE D'UN SYSTEME DE TRAITEMENT AUTOMATISE |
|  DE DONNEES EST PUNI DE DEUX ANS D'EMPRISONNEMENT ET DE    |
|  30000 EUROS D'AMENDE. LORSQU'IL EN EST RESULTE SOIT LA    |
|  SUPPRESSION OU LA MODIFICATION DE DONNEES CONTENUES DANS  |
|  LE SYSTEME, SOIT UNE ALTERATION DU FONCTIONNEMENT DE CE   |
|  SYSTEME, LA PEINE EST DE TROIS ANS D'EMPRISONNEMENT ET DE |
|  45000 EUROS D'AMENDE."                                    |
 ------------------------------------------------------------
^C
!
line con 0
 password 7 XXX
line vty 0 4
 password 7 XXX
 length 0
 transport input ssh
line vty 5 15
 password 7 XXX
 transport input ssh
!
ntp server XXX
!
end
 
 
 


 
 
 
 
 
 

Citation :

sh vtp status
VTP Version capable             : 1 to 3
VTP version running             : 2
VTP Domain Name                 : XXXXXXX
VTP Pruning Mode                : Enabled
VTP Traps Generation            : Enabled
Device ID                       : XXXXXX
Configuration last modified by 0.0.0.0 at 4-2-19 14:18:05
 
Feature VLAN:
--------------
VTP Operating Mode                : Client
Maximum VLANs supported locally   : 255
Number of existing VLANs          : 6
Configuration Revision            : 0

n°162187
logre
Posté le 09-04-2019 à 15:16:21  profilanswer
 

Alors ca a donné quoi ?

n°162236
evan52
Posté le 11-04-2019 à 09:13:29  profilanswer
 

logre a écrit :

Alors ca a donné quoi ?


 
 
Pas eu le temps de le faire, normalement vers 13h aujourd'hui.

n°162285
evan52
Posté le 12-04-2019 à 18:20:15  profilanswer
 

Pour info, le switch a été branché, il est ok.  
 
Nous avons procédé à un reboot du coeur de réseau. Et changé un des gbics. Ce la a solutionné le problème, la conf ne présentait pas d'erreur. Pas de plantage réseau constaté sur les 24 h.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Switch 8 ports cisco qui fait planter le réseau

 

Sujets relatifs
Besoin d'aide réseau simulationRéinitialiser carte réseau onduleur EATON 5PX
problème réseau asymétrique Windows Serveur 2012 R2"Comment" faire pour avoir plusieurs réseau? question conne =/
Installation réseau domestiqueAdressage d'un réseau privé non conforme. A changer?
Routeur et Wifi Guest, et isolation entre réseaudroits et devoirs admin réseau
Plus de sujets relatifs à : Switch 8 ports cisco qui fait planter le réseau


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR