Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1644 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  208  209  210  211  212  213
Auteur Sujet :

[arduino] Topic Unique blabla @ Arduino

n°312646
zig2
Posté le 19-08-2020 à 12:49:09  profilanswer
 

Reprise du message précédent :

NEmergix a écrit :

Hello !
J'ai une carte Nano 33 BLE mais je suis assez déçu de la range maximal du bluetooth.
 
Un moyen pour la booster ? (antenne , ect ect ...)
 
Sinon il existe un autre board en BLE qui est plus puissant ( pas forcément arduino ) ?
 
Merci


Tu as les ESP32, mais je ne sais pas si c'est plus puissant.

mood
Publicité
Posté le 19-08-2020 à 12:49:09  profilanswer
 

n°312954
crepator4
Deus ex machina
Posté le 21-08-2020 à 23:52:41  profilanswer
 

Arduino typewriter
https://www.open-electronics.org/arduino-typewriter/


---------------
...survivre à ses Medecins...
n°313021
fredo3
soa
Posté le 23-08-2020 à 12:56:59  profilanswer
 

Salut
 
J'ai le problème suivant.
Mes ESP32 (avec RTC intégrée) ne sont pas encore arrivés de Chine (3 mois d'attente... merci le COVID).
Du coup je dois me rabattre sur un ESP8266 que j'ai en stock, mais sans RTC intégrée.
 
Le soucis c'est que j'ai besoin de connaître l'heure pour loguer certains info. Je pensais initialiser l'heure via Wifi/internet/NTP au boot uniquement et par la suite utiliser une RTC, vu que je n'aurais pas de connectivité wifi/internet par la suite.
Or comme je n'ai qu'un ESP8266 et pas de RTC, il va falloir que je trouve temporairement un autre moyen.
 
Il y aurait une solution technique pour que l'ESP8266 compte l'heure qui passe, en gardant une marge d'erreur faible du genre 1s max?
 
edit:
Je viens de tomber sur ca:
https://www.instructables.com/id/TE [...] -WITHOUT-/


Message édité par fredo3 le 23-08-2020 à 13:13:10
n°313024
- Rocket -
Posté le 23-08-2020 à 13:31:02  profilanswer
 

Tu peux utiliser les timers. La précision dépendra de l'oscillateur de l'ESP.

 

J'ai déjà fait ça sur un Uno, mais je connais mal l'ESP.

 

Edit : 1s par jour ? 1s par heure ? 1s par minute ? 1s par seconde ? :o

Message cité 2 fois
Message édité par - Rocket - le 23-08-2020 à 13:33:10
n°313039
Aline BOQS
nourrit son cabri au lait.
Posté le 23-08-2020 à 17:01:47  profilanswer
 

Perso, je ferais ce qu'indique un gars dans les commentaires : faire un appel au moins une fois
par jour à un serveur NTP, afin d'actualiser l'heure si nécessaire.  :jap:  
 
Sa bidouille n'est pas mauvaise en soi, mais trop "aléatoire" sous certains aspects.


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313044
Natopsi
☄️Just end it already!☄️
Posté le 23-08-2020 à 18:20:03  profilanswer
 

- Rocket - a écrit :

Tu peux utiliser les timers. La précision dépendra de l'oscillateur de l'ESP.
 
J'ai déjà fait ça sur un Uno, mais je connais mal l'ESP.
 
Edit : 1s par jour ? 1s par heure ? 1s par minute ? 1s par seconde ? :o


On fait facilement mieux qu'une seconde par jour avec un oscillateur à quartz de base :o
 
Mais je recommande quand même d'utiliser un OCXO qui permet d'aller titiller une erreur inférieure à une seconde par an  [:amaniak:4]  
 
 :o


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°313066
fredo3
soa
Posté le 24-08-2020 à 08:13:46  profilanswer
 

- Rocket - a écrit :

Tu peux utiliser les timers. La précision dépendra de l'oscillateur de l'ESP.

 

J'ai déjà fait ça sur un Uno, mais je connais mal l'ESP.

 

Edit : 1s par jour ? 1s par heure ? 1s par minute ? 1s par seconde ? :o

 

1s par heure me suffit, après je resynchronise.
Je pense que la solution va le faire.

Message cité 1 fois
Message édité par fredo3 le 24-08-2020 à 08:14:30
n°313300
Aline BOQS
nourrit son cabri au lait.
Posté le 26-08-2020 à 19:58:08  profilanswer
 

Bichour les loulous electrarduineux  :D  
 
Je reviens avec mon "cuip-cuip" à base d'ATtiny85. Je vais pas faire durer le suspense : c'est un échec.
Ok, ça c'est fait. Now, je détaille un peu.  :D   ( http://elm-chan.org/works/sd8p/report.html )
 
J'ai manqué de courage, et j'attendais des commandes.
 
J'ai reçu un petit bordel lecteur µSD, et comme il est sérigraphié quasiment à l'identique du
lecteur SD que j'avais déjà testé, ben j'ai débranché le normal et rebranché sur le µ.
 
Déjà, ça n'a rien sorti : pas un cuip, pas un cuip-cuip, rien que dalle nada niet popov  :(  
 
Bon, j'ai cherché un peu, et la solution est que les modules ne sont pas cablés pareil : le SD normal
a une entrée 5 V et 3,3 V séparées, alors que le µSD n'a qu'une entrée 5 V.
Vous devinerez donc le bug arriver à l'horizon ?  :whistle:  
J'avais connecté la SD en 3,3 et donc, bah la µSD aussi. [:tinostar].
Brefle, en branchant sur le +5, ça fonctionne très bien.
 
Puis, vu que le son est très faible et que je veux installer ce bordel sur ma charriolle, me faut de la patate.
J'ai donc raccordé un petit module ampli 3W à base de PAM3403 (ou un truc comme ça).
 
Grosso-merdo, ben le HP n'aime pas ça.  :sweat:  
Le volume est réglable, mais le son est pourri, et le HP tressaute.
 
Je suppose qu'il faut remplacer le condo sur le HP par une inductance, enfin le truc dont le gars parle
dans son article...Mais je n'y comprends rien, je ne suis même pas certain de quel composant il parle, ni
même si ça changerait quelque chose au final.
 
Je suis donc déception. J'ai passé des heures sur ce machin, je vous ai fait chier avec, et je vous ai pris la tête
avec ça. J'en suis sincèrement désolé, et je vous prie de m'en excuser.  [:chipp]  
Ceci dit, j'ai appris des trucs, donc tout ça n'était pas en vain.  :jap:  
 
Question : sachant que j'ai déjà utilisé un mini player MP3 avec ampli intégré DFPlayer, on ne devrait pas
essayer de trouver si ce module tout fait, ne pourrait pas démarrer la lecture d'un MP3 dès qu'on le met
sous tension ?  
On en avait un peu parlé il y a quelques temps.
 
https://wiki.dfrobot.com/DFPlayer_Mini_SKU_DFR0299  


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313301
Gonzoide
And I've just finished my milk
Posté le 26-08-2020 à 20:10:58  profilanswer
 

fredo3 a écrit :


 
1s par heure me suffit, après je resynchronise.
Je pense que la solution va le faire.


Si tu prends la lib NTPClient, elle se repose sur les timers et se synchronise à ta demande en NTP, donc tu as la précision (relative) sans taper en permanence sur le un serveur NTP
 

Code :
  1. void fetchTime() {
  2.   unsigned long currentMillis = millis();
  3.   if (lastMillis == 0 || currentMillis - lastMillis > fetchDelayMillis) {
  4.     lastMillis = currentMillis;
  5.     timeClient.update();
  6.   }
  7.     time_t rawtime = timeClient.getEpochTime();
  8.     struct tm  ts;
  9.     char       buf[80];
  10.     ts = *localtime(&rawtime);
  11.     strftime(buf, sizeof(buf), "%d/%m  %H:%M", &ts);
  12.     printTime(buf);
  13. }


 
Dans mon cas, fetchDelayMillis représente l'intervalle après lequel je force un appel serveur.

n°313302
crepator4
Deus ex machina
Posté le 26-08-2020 à 20:20:08  profilanswer
 

Aline BOQS a écrit :

Bichour les loulous electrarduineux  :D  
 
Je reviens avec mon "cuip-cuip" à base d'ATtiny85. Je vais pas faire durer le suspense : c'est un échec.
Ok, ça c'est fait. Now, je détaille un peu.  :D   ( http://elm-chan.org/works/sd8p/report.html )
 
J'ai manqué de courage, et j'attendais des commandes.
 
J'ai reçu un petit bordel lecteur µSD, et comme il est sérigraphié quasiment à l'identique du
lecteur SD que j'avais déjà testé, ben j'ai débranché le normal et rebranché sur le µ.
 
Déjà, ça n'a rien sorti : pas un cuip, pas un cuip-cuip, rien que dalle nada niet popov  :(  
 
Bon, j'ai cherché un peu, et la solution est que les modules ne sont pas cablés pareil : le SD normal
a une entrée 5 V et 3,3 V séparées, alors que le µSD n'a qu'une entrée 5 V.
Vous devinerez donc le bug arriver à l'horizon ?  :whistle:  
J'avais connecté la SD en 3,3 et donc, bah la µSD aussi. [:tinostar].
Brefle, en branchant sur le +5, ça fonctionne très bien.
 
Puis, vu que le son est très faible et que je veux installer ce bordel sur ma charriolle, me faut de la patate.
J'ai donc raccordé un petit module ampli 3W à base de PAM3403 (ou un truc comme ça).
 
Grosso-merdo, ben le HP n'aime pas ça.  :sweat:  
Le volume est réglable, mais le son est pourri, et le HP tressaute.
 
Je suppose qu'il faut remplacer le condo sur le HP par une inductance, enfin le truc dont le gars parle
dans son article...Mais je n'y comprends rien, je ne suis même pas certain de quel composant il parle, ni
même si ça changerait quelque chose au final.
 
Je suis donc déception. J'ai passé des heures sur ce machin, je vous ai fait chier avec, et je vous ai pris la tête
avec ça. J'en suis sincèrement désolé, et je vous prie de m'en excuser.  [:chipp]  
Ceci dit, j'ai appris des trucs, donc tout ça n'était pas en vain.  :jap:  
 
Question : sachant que j'ai déjà utilisé un mini player MP3 avec ampli intégré DFPlayer, on ne devrait pas
essayer de trouver si ce module tout fait, ne pourrait pas démarrer la lecture d'un MP3 dès qu'on le met
sous tension ?  
On en avait un peu parlé il y a quelques temps.
 
https://wiki.dfrobot.com/DFPlayer_Mini_SKU_DFR0299  


 
J'ai pas tout suivi , mais verifie l'impedance du haut parleur , et surtout au depart essaye avec un hp , un peu costaux (les petits genre ceux de radio reveil/petite radio portable tapent + dans les 500milliwat qu'autre chose ,et encore , en plus d'etre limite en frequence)


---------------
...survivre à ses Medecins...
mood
Publicité
Posté le 26-08-2020 à 20:20:08  profilanswer
 

n°313306
Aline BOQS
nourrit son cabri au lait.
Posté le 26-08-2020 à 20:55:49  profilanswer
 

crepator4 a écrit :


 
J'ai pas tout suivi , mais verifie l'impedance du haut parleur , et surtout au depart essaye avec un hp , un peu costaux (les petits genre ceux de radio reveil/petite radio portable tapent + dans les 500milliwat qu'autre chose ,et encore , en plus d'etre limite en frequence)


Hmmm...non.
 
J'ai un 4 ohm de puissance inconnue et de diametre ~8 cm et un autre, plus grand, de 12 ohm et puissance 15 W.
Ca déconne avec les deux.


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313307
crepator4
Deus ex machina
Posté le 26-08-2020 à 21:00:18  profilanswer
 

autre idée , la sortie "arduino" sature l'entrée de l'ampli (malgré le potard ) teste sur un autre ampli genre enceinte amplifié d'ordi

 

sinon ggogletrad :

Citation :

Lorsque vous connectez les sorties audio à l'amplificateur, le composant haute fréquence doit être filtré avec LPF. N'entrez pas les signaux PWM directement sur l'amplificateur ou l'amplificateur et les enceintes peuvent être endommagés.


de ton link http://elm-chan.org/works/sd8p/report.html


Message édité par crepator4 le 26-08-2020 à 21:07:56

---------------
...survivre à ses Medecins...
n°313308
Natopsi
☄️Just end it already!☄️
Posté le 26-08-2020 à 21:04:19  profilanswer
 

C'est pas 100mV le standard pour un signal audio? Forcément si tu balance du 3.3V ou 5V crête à crête sans atténuateur sérieux ça ne peut que faire de la merde.


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°313310
crepator4
Deus ex machina
Posté le 26-08-2020 à 21:27:44  profilanswer
 

y'a un exemple de brranchement sur ampli :
 
http://www.technoblogy.com/pictures/kvm/audiopitchshifter2.gif
http://www.technoblogy.com/show?1L02


Message édité par crepator4 le 26-08-2020 à 21:27:55

---------------
...survivre à ses Medecins...
n°313320
Aline BOQS
nourrit son cabri au lait.
Posté le 26-08-2020 à 23:40:29  profilanswer
 

Natopsi a écrit :

C'est pas 100mV le standard pour un signal audio? Forcément si tu balance du 3.3V ou 5V crête à crête sans atténuateur sérieux ça ne peut que faire de la merde.


Non mais pour ça on est d'accord hein.
 
C'est juste que j'essaie de faire un truc propre : mais ça veut pas.
 
"An optional 100μH series inductor on the PWM output will reduce power consumption. " <== c'est une inductance
qu'il faut ? Je ne sais même pas ce que c'est !  :lol:  
Une self ou un machin comme ça ?  :??:


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313321
crepator4
Deus ex machina
Posté le 26-08-2020 à 23:44:32  profilanswer
 

inductance ,oui, mais reduire la conso c'est pas vraiment vital pour le debut .


Message édité par crepator4 le 26-08-2020 à 23:44:42

---------------
...survivre à ses Medecins...
n°313365
Aline BOQS
nourrit son cabri au lait.
Posté le 27-08-2020 à 14:49:13  profilanswer
 

"Bon, Liline qu'est un gars, tu nous bassines depuis des mois avec ton <cuip-cuip à la con>, mais
il existe ou tu nous fais juste chier pour passer le temps ? "  :o  
 
C'est la question qui revient le plus souvent dans mes rêves (mes cauchemars, en fait)  :D  
 
OUIIIIIIIIIIIIII il existe bel et bien !!! Le vlà :
 
https://youtu.be/pivh_TWzp0I
 
 
Petite explication : c'est la seule breadboard dispo, les autres sont AUSSI en cours d'utilisation pour
d'autres projets (le coucou...) aussi il y a deux trucs dessus.
Le cuip-cuip fonctionne sur le t85 dans la moitié inférieure.
Tout ce qui est au-dessus, c'est ce qui me sert à flasher les Tiny. [:tinostar]
 
Ce que vous voyez ici est le modèle fonctionnel, DE BASE. J'ai enlevé l'ampli PAM8403 parce qu'il
fout la merde.
Le cuip-cuip est joué en boucle parce que le module player ne sait faire que ça, jouer en boucle le
contenu de la µSD (et y'a que "cuip-cuip" dessus).
 
Je n'ai donc pas essayé le firmware modifié par le camarade Rat de Compétition, étant donné que ça
déconne avec un ampli au cul. Le volume est audible bien entendu, mais pas suffisamment pour pouvoir
être utilisé en environnement urbain.
 
Je me demande donc s'il y aurait moyen de bidouiller la sortie son afin d'avoir une qualité "audio propre" ?
Sur le schéma et dans l'article, le gars parle d'un "100 µH inductor" à mettre en série sur la sortie de
manière à pouvoir attaquer un ampli.
Nous, on a mis une capa. Ca marche, mais ça doit pas être top... :sweat:  
 
J'ai une inductance de récup, enfin je pense que c'est ça. Un petit tore avec du cuivre émaillé tortillé autour.
Avec l'inscription : L4460 dessus.
Je sais pas ce que ça veut dire, mais j'ai vu que "L" c'est le symbole des inductances.
 
Ce machin a deux fils d'un coté, et deux de l'autre. M'ouais...
 
Deux questions :
- les petits inspecteurs chinois ESRmeters sont capables d'identifier ce composant ?
- j'essaie de la mettre à la place de la capa du HP à l'arrache ?


Message édité par Aline BOQS le 27-08-2020 à 14:50:36

---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313367
fredo3
soa
Posté le 27-08-2020 à 15:03:23  profilanswer
 

Gonzoide a écrit :


Si tu prends la lib NTPClient, elle se repose sur les timers et se synchronise à ta demande en NTP, donc tu as la précision (relative) sans taper en permanence sur le un serveur NTP
 

Code :
  1. void fetchTime() {
  2.   unsigned long currentMillis = millis();
  3.   if (lastMillis == 0 || currentMillis - lastMillis > fetchDelayMillis) {
  4.     lastMillis = currentMillis;
  5.     timeClient.update();
  6.   }
  7.     time_t rawtime = timeClient.getEpochTime();
  8.     struct tm  ts;
  9.     char       buf[80];
  10.     ts = *localtime(&rawtime);
  11.     strftime(buf, sizeof(buf), "%d/%m  %H:%M", &ts);
  12.     printTime(buf);
  13. }


 
Dans mon cas, fetchDelayMillis représente l'intervalle après lequel je force un appel serveur.


Han  :love:  
 
Merci :jap:

n°313380
crepator4
Deus ex machina
Posté le 27-08-2020 à 16:27:24  profilanswer
 

 

y'en a un qui te contre
https://www.youtube.com/watch?v=x2vbetEqA4g :o

 

https://www.youtube.com/watch?v=g3BdqatOi6c

 

http://www.mediafire.com/file/uyre [...] d.rar/file

 

edit avec attiny85 :
How to Implement Arduino ATtiny85 Sleep Mode and Bird Chirp Generator (Arduino ATtiny睡眠模式與鳥叫聲)
https://www.youtube.com/watch?v=tVwQ8cb8HbQ

 

https://learn.adafruit.com/adafruit [...] mal-sounds

Message cité 1 fois
Message édité par crepator4 le 27-08-2020 à 17:42:11

---------------
...survivre à ses Medecins...
n°313381
Aline BOQS
nourrit son cabri au lait.
Posté le 27-08-2020 à 16:33:07  profilanswer
 

Bon ben Fredo3, tu vas te retrouver perdu entre mes posts alakon  :whistle:  
 
Toujours avec le cuip-cuip : ça y est enfin, je touche au but, j'ai trouvé un setup qui fonctionne !!!
 
Avec le miniplayer MP3 toutanhin de DFRobot : https://wiki.dfrobot.com/DFPlayer_Mini_SKU_DFR0299
 
Suffit de cabler une des deux sorties stéréo (DAC_R ou DAC_L) sur l'une des entrées du PAM8403.
Puis de relier en permanence ADKEY_1 au GND pour que ça joue le "cuip-cuip" dès la mise sous tension ou
l'insertion de la µSD.
Et le réglage du volume PAM8403 marche du tonnerre de feu  [:mossieurpropre]  
 
L'inconvénient, c'est que que ça revient au même qu'avec le t85 : le son est joué en permanence.  :sweat:  
 
Les avantages :
- la µSD est intégrée = moins de problemes à gérer
- le cablage est beaucoup plus facile et rapide
- aucun parasite en sortie, même après l'ampli
 
Maintenant, ne reste plus qu'à trouver un moyen pour ne jouer le son qu'une seule fois.
 
Rappel : ce truc sera raccordé sur un clignotant de ma caisse, afin de jouer le cuip-cuip au verrouillage/deverrouillage
à la telco. Comme dans les films américains  :love:  
 
Le premier souci étant que la voiture clignote un coup pour fermer, et deux coups pour ouvrir (ou le contraire, mais
ça ne change rien à l'arrivée)...
Je crains que les deux coups de cligno ne fassent jouer le cuip-cuip deux fois de suite. Ce qui serait completement con. :/


Message édité par Aline BOQS le 27-08-2020 à 16:37:34

---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313383
Aline BOQS
nourrit son cabri au lait.
Posté le 27-08-2020 à 16:36:40  profilanswer
 


Je sais déjà le faire, ça.
 
Le souci, c'est que c'est valable chez toi, dans un environnement calme et quasi-silencieux.
Mais en milieu urbain, tu peux oublier.  :lol:


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313390
crepator4
Deus ex machina
Posté le 27-08-2020 à 18:33:09  profilanswer
 

Bordel l'audio rends pas si mal avec cette config/ampli a l'arrache
https://www.instructables.com/id/Ta [...] o-Without/

 

Avec risque et perils :o

Citation :

Why have you no resistor in the base of the transistor? As you have it you are drawing too much current from the Arduino pin and it is being damaged. Eventually this pin will fail and will not work anymore. It will not instantly stop working but over time it will.


Message édité par crepator4 le 27-08-2020 à 18:37:56

---------------
...survivre à ses Medecins...
n°313396
Aline BOQS
nourrit son cabri au lait.
Posté le 27-08-2020 à 20:36:34  profilanswer
 

Je te dis que j'ai déjà essayé, ça marche mais c'est pas jojo en réalité.
 
Mon biniou est destiné à être installé dans ma bagnole, aussi le volume doit être élevé afin
qu'on entende le cuip-cuip d'assez loin  :o  
 
Tu n'as jamais remarqué le bruit ambiant plutôt conséquent quand tu es en ville ?
Encore qu'on doit plus vraiment l'entendre avec l'habitude  :D


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313397
crepator4
Deus ex machina
Posté le 27-08-2020 à 20:42:06  profilanswer
 

bein l'instructable m'interrese aussi :o  ,mais , à la base ,je vois pas le probleme a rajouter un ampli sur un truc basique .


---------------
...survivre à ses Medecins...
n°313399
Aline BOQS
nourrit son cabri au lait.
Posté le 27-08-2020 à 21:18:18  profilanswer
 

T'es marrant toi  :o  
 
Tu sembles me répondre avec des trucs similaires, donc tu penses bien que je crois que tu me réponds. Banane !  :D


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°313428
fredo3
soa
Posté le 28-08-2020 à 11:32:52  profilanswer
 

Bon, mon module GSM SIM800, semble rebooter en boucle, alors qu'il fonctionnait implacablement durant 6 mois.
 
On est d'accord, c'est un problème matériel ou est-ce que j'ai raté quelque chose?
 
https://i.imgur.com/rHm7J2x.png

n°313429
zig2
Posté le 28-08-2020 à 11:37:11  profilanswer
 

fredo3 a écrit :

Bon, mon module GSM SIM800, semble rebooter en boucle, alors qu'il fonctionnait implacablement durant 6 mois.
 
On est d'accord, c'est un problème matériel ou est-ce que j'ai raté quelque chose?
 
https://i.imgur.com/rHm7J2x.png


 :hello:  
 
J'ai lu que cela pouvait venir de l'alimentation trop faible (au hasard de mes lectures :d).

n°313431
fredo3
soa
Posté le 28-08-2020 à 12:58:47  profilanswer
 

Oui j'avais ce problème au tout début quand j’utilisais l'alim fournie via l'adaptateur USB->UART.
Du coup je suis passé en UART natif et pin directement branché sur l'alim 5V. Ca a bien marché durant 6 mois :/
 
Peut-être que c'est le régulateur de tension du module qui est semi-HS.


Message édité par fredo3 le 28-08-2020 à 12:59:21
n°315431
kray
Bad show?
Posté le 24-09-2020 à 22:34:52  profilanswer
 

Bonjour,
 
Ca tombe bien que ça parle d'alim. J'ai besoin de minimum 2A en 5V et autant dire que l'arduino n'y arrive pas.
Est-ce qu'il y a une alim de labo recommandée par le topic?


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°315524
rat de com​bat
attention rongeur méchant!
Posté le 25-09-2020 à 18:42:42  profilanswer
 

Si tu veux vraiment acheter une alim de labo direction --> https://forum.hardware.fr/hfr/elect [...] _372_1.htm en précisant ton budget et tes besoins (nombre de sorties, courant max, tension max, ...).
 
Si tu cherches juste du 5V fixe direction A... pour une alim fixe genre alim de Rasperry Pi ou chargeur de téléphone ou autre (ne prends pas le moins cher et attention au courant max).

n°315595
kray
Bad show?
Posté le 26-09-2020 à 22:34:12  profilanswer
 

rat de combat a écrit :

Si tu veux vraiment acheter une alim de labo direction --> https://forum.hardware.fr/hfr/elect [...] _372_1.htm en précisant ton budget et tes besoins (nombre de sorties, courant max, tension max, ...).
 
Si tu cherches juste du 5V fixe direction A... pour une alim fixe genre alim de Rasperry Pi ou chargeur de téléphone ou autre (ne prends pas le moins cher et attention au courant max).


 :jap: Je ne connaissais pas ce topic, j'y vais de ce pas


---------------
Neque porro quisquam est, qui dolorem ipsum quia dolor sit amet, consectetur, adipisci velit
n°315953
Nitescent
Posté le 02-10-2020 à 02:55:47  profilanswer
 

Bien le bonjour,
 
C'est faisable de contrôler un relais bistable depuis un Raspberry ET un Arduino?
 
Je me connecte à distance à un Raspberry Pi pour démarrer mon ordinateur et démarrer une alimentation grâce à deux relais.
 
Puis je me connecte à l'ordinateur, et l'idée serait de pouvoir arrêter l'alimentation depuis l'ordinateur par l'intermédiaire d'un Arduino une fois que j'ai terminé. Sans repasser par une connexion au Raspberry. (Teamviewer est un peu chiant des fois avec les connexions multiples...)
 
Je ne peux pas démarrer l'alimentation directement par l'Arduino puisque celui-ci est alimenté par celle-ci :o
 
C'est peut être un peu tordu tout ça, mais je préférerais une solution hardware dans ce genre qui marche bien, plutôt qu'une communication directe qui marche mal et super compliquée à mettre en place  
J'ai un dossier partagé entre le Pi et le PC et une fois sur deux le bordel n'est plus détecté...


---------------
Photos astro sur Flickr | Observatoire astronomique à distance Youtube
n°315959
Aline BOQS
nourrit son cabri au lait.
Posté le 02-10-2020 à 09:25:13  profilanswer
 

Nitescent a écrit :

Je ne peux pas démarrer l'alimentation directement par l'Arduino puisque celui-ci est alimenté par celle-ci :o


Hum...le raspi est alimenté par quoi comment ?  :whistle:


---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°315966
Lobster
Pour être bien clair :
Posté le 02-10-2020 à 10:23:20  profilanswer
 

Nitescent a écrit :

Je me connecte à distance à un Raspberry Pi pour démarrer mon ordinateur et démarrer une alimentation grâce à deux relais.
 
Puis je me connecte à l'ordinateur...


Un Wake On Lan n'est pas possible ?


---------------
Yargla !!! | La derniere alerte qualitaÿ : Comparaison des violences policières en 20 ans (topic macron)
n°316108
Nitescent
Posté le 04-10-2020 à 19:16:02  profilanswer
 

Voici mon système :
 
https://i.imgur.com/ro0QImG.jpg?1
 
 
C'est pour utiliser mon petit observatoire et mon télescope à distance.
Je me suis fabriqué un "hat" pour le Raspberry avec quelques relais. Le Raspberry a sa propre alimentation et il est tout le temps en marche avec une station météo.
 
Quand je veux faire des photos je me connecte au Raspberry Pi, et le relais en bas à gauche me permet de démarrer le PC.
Le relais en bas à droite me permet lui de démarrer l'alimentation principale pour la caméra, le télescope, etc etc.
 
Tout ça fonctionne parfaitement,
mais une fois que j'ai terminé mes photos à 4h du matin, j'arrête normalement l'ordinateur, et ensuite je dois me reconnecter au raspberry pour arreter l'alimentation. Sauf qu'à moitié endormis, une fois sur deux j'oublie ça :o
 
Donc je pensais à un relais bi-stable : je le met en marche depuis le Raspberry, et quand j'arrête je le fais depuis l'ordinateur avec l'arduino,
pas besoin de re-passer par le raspberry


---------------
Photos astro sur Flickr | Observatoire astronomique à distance Youtube
n°316115
_pollux_
Pan ! t'es mort
Posté le 04-10-2020 à 22:52:40  profilanswer
 

ça pourrait pas être réglé de façon logicielle ?

 

Genre un script sur le raspberry pour vérifier que l'ordinateur est éteint et si c'est le cas, ça coupe l'alim ?


Message édité par _pollux_ le 04-10-2020 à 22:52:57

---------------
Le topic du sport électronique@hfr : watch the l33t !
n°316116
SuperSic
Posté le 04-10-2020 à 22:57:54  profilanswer
 

+1
 
Ou voir si tu peux lancer automatiquement un script lorsque le PC s'éteint (@shutdown). Le script commanderait au raspberry pi d'éteindre l'alim.


---------------
"Les soldats vivent. Et se demandent pourquoi." Toubib (La Compagnie noire) | [TU] Killing Floor 1&2
n°316525
Aline BOQS
nourrit son cabri au lait.
Posté le 11-10-2020 à 21:19:19  profilanswer
 

:hello:  
 
Je me permets de poster un ptit deal sympatoche, un boitier + petit écran tactile
pour Raspi.
 
=> https://www.banggood.com/fr/Geekcre [...] rehouse=UK
 
Il faut choisir la version "UK", elle permet d'etre livré + vite et sans frais de port.
 
Petite réduction en entrant le code " BGGeeK13 " lorsqu'on est sur la page "paiement".
 
Aucune idée si c'est HS, mais je me suis dit que ça ferait peut-être plaisir à certains ici.  :jap:
PS : je ne sais plus, mais l'écran peut peut-être être branché sur un Arduino...  :??:


Message édité par Aline BOQS le 11-10-2020 à 21:20:21

---------------
-=* Feedback de Liline *=- _._ -=* Ptit bazar à Liline *=-  
n°319430
popol_55
Posté le 15-11-2020 à 11:40:02  profilanswer
 

Hello,
 
Pour ceux qui connaissent j'essaye de reproduire le comportement des HUE de Philips avec un détecteur de mouvement :
Ça baisse d'intensité peu avant l'extinction. Si je rebouge, ça revient à l'intensité normale.
Le but est de reproduire avec un arduino + détecteur de mouvement et un bandeau de LED.
 
Peut être que ça existe déjà ?


---------------
Philips HUE || Ikea Hack
n°319463
rat de com​bat
attention rongeur méchant!
Posté le 15-11-2020 à 16:31:51  profilanswer
 

Connais pas vos bidules connectés, mais d'après ce que tu dis c'est très simple. PWM pour le bandeau, un timer qui diminue progressivement le rapport cyclique du PWM et si(mouvement) alors(revenir au début). Je peux préciser si tu veux.

n°319741
Turkleton
I don't quite understand you
Posté le 17-11-2020 à 16:29:58  profilanswer
 

Vous partiriez sur quelle techno pour détecter une présence (une personne, un objet, …) à un point fixe entre une dizaine de centimètres ou quelques mètres ? J'ai pas besoin de savoir la distance, juste s'il y a un obstacle en face du capteur.
Infrarouge ? Ultrasons ? Autre ? (thermique ?)


---------------
If you think it could look good, then I guess it should
mood
Publicité
Posté le   profilanswer
 

<

 Page :   1  2  3  4  5  ..  208  209  210  211  212  213

Aller à :
Ajouter une réponse
 

Sujets relatifs
* Réparations de vos appareils électroniques & electromenager * 
Plus de sujets relatifs à : [arduino] Topic Unique blabla @ Arduino


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR