Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1145 connectés 

 



 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  355  356  357  358  359  360
Auteur Sujet :

[Topic Unique] Nas perso homemade

n°6871120
mad86
Posté le 04-03-2009 à 21:42:50  profilanswer
 

Reprise du message précédent :
des ptits howto pour la partie partage de fichiers :

 

Sous Debian

 

Sous Ubuntu

 

Le coup du beep pour dire que le NAS est opérationnel après un démarrage / redémarrage est un bonne idée :D

Message cité 1 fois
Message édité par mad86 le 04-03-2009 à 21:46:13

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
mood
Publicité
Posté le 04-03-2009 à 21:42:50  profilanswer
 

n°6871189
zeblods
Posté le 04-03-2009 à 22:30:08  profilanswer
 

Puis ce qu'on en est au petit HowTo, pour ceux qui veulent partager "simplement" en samba (CIFS) sous OpenSolaris :

 

Sur une console :
1. Se logger en root

su

 

2. Installer le serveur CIFS de OpenSolaris

pkg install SUNWsmbs
svccfg import /var/svc/manifest/network/smb/server.xml

 

3. Activer le serveur CIFS

svcadm enable -r smb/server

 

4. Pour pouvoir utiliser le serveur CIFS avec vos utilisateurs et vos mot de passes, il faut ajouter une ligne dans le fichier /etc/pam.conf

echo "other password required pam_smb_passwd.so.1 nowarn" >> /etc/pam.conf


Puis re-chiffrer le mot de passe pour chacun de vos utilisateurs (ici l'utilisateur zeblods)

passwd zeblods


Les utilisateurs qui seront rajouté par la suite seront automatiquement chiffré pour le serveur CIFS.

 

5. Rejoindre un groupe de travail (ici WORKGROUP)

smbadm join -w WORKGROUP

 

6. Partager une partition ZFS (ici partager la partition tank/data en tant que partage)

zfs set sharesmb=name=partage tank/data

 

Voila, votre partition est partagé, pour vérifier

sharemgr show -vp

 

TIPS 1 : Si vous n'arriver pas à joindre le groupe de travail, c'est que :
- Soit vous avez Samba qui est installé et qui tourne, pour vérifier

svcs | grep samba


Et si oui, désactiver Samba

svcadm disable svc:/network/samba
svcadm disable svc:/network/wins

 

- Soit le driver du serveur CIFS n'est pas chargé (ou mal chargé... ça m'est arrivé la première fois que je l'ai installé...)

rem_drv smbsrv
add_drv smbsrv
svcadm disable smb/server
svcadm enable -r smb/server

 

TIPS 2 : Pensez lorsque vous créez votre partition à définir la sensibilité de la casse à mixed (pour ne pas avoir de soucis avec vos montages sous Windows). Ceci permet de garder la sensibilité à la casse (TOTO sera bien différent de toto, utile pour les système *nix), mais empèchera d'avoir deux fichiers avec un nom identique (modulo la casse) dans un même répertoire (donc impossible d'avoir le fichier TOTO et toto dans le même répertoire, utile pour Windows)

zfs create -o casesensitivity=mixed tank/data

 

TIPS 3 : Pour gérer les droits d'accès par utilisateur, utilisez les ACL de ZFS : http://docs.sun.com/app/docs/doc/8 [...] =fr&a=view
Les droits des dossiers montés sur votre Windows seront exactement identique à ceux de votre utilisateur sous OpenSolaris.


Message édité par zeblods le 04-03-2009 à 22:30:23

---------------
Config mini-ITX
n°6871234
toto_67
Posté le 04-03-2009 à 23:04:43  profilanswer
 

j'ai presque tout le matos:

 

boitier Chenbro 34069 (commandé le 28/1 reçu le 4/3 ça rendre au compte goutte)
CM intel D945GGLF2 atom
carte pci promise fasttrack tx4310
lecteur cdrom portable combo de récup en option
2 dd WD green 1To +2 si tout marchera bien
1 dd 2,5" si nécessaire

 

reste à venir par la poste

 

un adaptateur ide/compact flash + carte 8go

 

et à choisir le système d'exploitation ? freenas, windows home server ou autre....

Message cité 1 fois
Message édité par toto_67 le 04-03-2009 à 23:06:36

---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6871309
Power Nabo​t
Verticalement désavantagé.
Posté le 05-03-2009 à 00:27:14  profilanswer
 

Une distrib' serveur de Ubuntu ou Debian aussi ;)


---------------
Encore une victoire de canard !
n°6871348
toto_67
Posté le 05-03-2009 à 02:08:54  profilanswer
 

j aimerai quelque chose de prêt à installer ou l'on passe pas des jours à paramétrer...


---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6871391
mad86
Posté le 05-03-2009 à 07:48:05  profilanswer
 

toto_67 a écrit :

j aimerai quelque chose de prêt à installer ou l'on passe pas des jours à paramétrer...


 
Tu pourras faire des tofs pour le post ou tu présente ton matos que je te rajoute en première page ;)
 
On a la même carte mère :D on pourra partager les retours d'exp :p Sinon tu comptes faires quoi dessus à part partage de fichiers car sinon c'est aussi vite fait que sous windows surtout si tu veux pas de sécurité utilisateurs :)


---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6871861
ITM
Avatar peint à la main
Posté le 05-03-2009 à 13:30:04  profilanswer
 

Config en cours ici aussi :hello:
 
Chenbro ES34069
MSI IM-945GC (Atom 330, 4 SATA II)
2Go GSKILL
SSD OCZ 30Go Solid
2 * WD 1To Green power
 
Le tout sous debian. Des tofs et plus de feedbacks quand j'aurais enfin un système opérationnel :o


---------------
iteme.free.fr | Mon feedback
n°6871893
toto_67
Posté le 05-03-2009 à 13:41:32  profilanswer
 

mad86 a écrit :


 
Tu pourras faire des tofs pour le post ou tu présente ton matos que je te rajoute en première page ;)
 
On a la même carte mère :D on pourra partager les retours d'exp :p Sinon tu comptes faires quoi dessus à part partage de fichiers car sinon c'est aussi vite fait que sous windows surtout si tu veux pas de sécurité utilisateurs :)


 
tof pour vendredi, c'est plein à craquer... et lourd.. un 1/2 partin !
 
faut que ça fasse : serveur de fichier avec un niveau de sécurité max (4 à 5 utilisateurs fixes), itune, accès par le net pour certain fichiers (photos par ex)
 
 


---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6871905
toto_67
Posté le 05-03-2009 à 13:46:02  profilanswer
 

ITM a écrit :

Config en cours ici aussi :hello:
 
Chenbro ES34069
MSI IM-945GC (Atom 330, 4 SATA II)
2Go GSKILL
SSD OCZ 30Go Solid
2 * WD 1To Green power
 
Le tout sous debian. Des tofs et plus de feedbacks quand j'aurais enfin un système opérationnel :o


 
j'ai pris un ctrl sata promise 4x sata ! pour le ssd j'hésite ? une compact flash avec un adapteur ide devrait suffrir ?
T'as cherché ou ton boitier ? la cm ?


---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6872111
jjacques52​9
®®®
Posté le 05-03-2009 à 16:00:32  profilanswer
 

Je viens de voir ce boitier :love: :love:  
Le seul truc génant c'est qu'on peut mettre qu'un seul disque dur 3"1/2, l'autre baie est pour un 2"1/2 :(
 
Je commence à me faire une idée de config dans ma tête:
   - mobal Intel D945GCLF2 (avec l'atom :D )
   - 1Go de Ram pas cher
   - OCZ solid series SSD 30Go pour l'OS
   - 2x WD Green 1To pour le stockage
   - un boîtier et une alim qui font pas de bruit
 
Le tout pour un serveur nas qui doit être économique (allumé h24) et extremement silencieu.


Message édité par jjacques529 le 05-03-2009 à 16:14:29
mood
Publicité
Posté le 05-03-2009 à 16:00:32  profilanswer
 

n°6872344
djum
Hardware for ever.
Posté le 05-03-2009 à 18:10:45  profilanswer
 

ITM a écrit :

Config en cours ici aussi :hello:
 
Chenbro ES34069
MSI IM-945GC (Atom 330, 4 SATA II)
2Go GSKILL
SSD OCZ 30Go Solid
2 * WD 1To Green power
 
Le tout sous debian. Des tofs et plus de feedbacks quand j'aurais enfin un système opérationnel :o


Ton expérience sous Debian me sera aussi d'une grande aide.
Comptes-tu mettre tes disques en Raid ?


---------------
Feedback --- Nas homemade
n°6872419
mad86
Posté le 05-03-2009 à 18:58:54  profilanswer
 

Maj du premier post ;)
 
Pour Itm et Toto_67 si vous pouviez mettre à jour au fur et à mesure vost post avec tofs et infos soft ;)


Message édité par mad86 le 05-03-2009 à 19:03:32

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6872602
madix
Mangeur de Chiantos
Posté le 05-03-2009 à 21:22:32  profilanswer
 

Passage a freenas 0.69 sans aucune perte de donnée mais avec une image de disque, l'iso me disait un truc du genre "failed to copy files" :o


---------------
Why not ?
n°6872605
toto_67
Posté le 05-03-2009 à 21:25:19  profilanswer
 

toto_67 a écrit :


 
tof pour vendredi, c'est plein à craquer... et lourd.. un 1/2 partin !
 
faut que ça fasse : serveur de fichier avec un niveau de sécurité max (4 à 5 utilisateurs fixes), itune, accès par le net pour certain fichiers (photos par ex)
 
 


 
tu parles du chenbro ?
 
il y a  
4x rack hotswap 3,5"
1X slim cd/dvd
1x2,5" internet sous le slim (perpendiculairement...)
PSU externe
 


---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6872646
mad86
Posté le 05-03-2009 à 21:49:04  profilanswer
 

toto_67 a écrit :


 
tu parles du chenbro ?
 
il y a  
4x rack hotswap 3,5"
1X slim cd/dvd
1x2,5" internet sous le slim (perpendiculairement...)
PSU externe
 


 
ça a l'air du beau boitier mais ça pique un peu niveau prix :p


---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6872689
toto_67
Posté le 05-03-2009 à 22:14:33  profilanswer
 

on trouve moins cher en Hollande ou en Allemagne faut faire gaffe au accessoires livrés
le boitier c'est bien fait de la tole doublé d'une coque en plastique gris métal


---------------
Iphone SE 2020 128Go - Red "Orange" iOS13.6 / Denon AVC-X6700H noir
n°6872880
mad86
Posté le 06-03-2009 à 07:40:31  profilanswer
 

toto_67 a écrit :

on trouve moins cher en Hollande ou en Allemagne faut faire gaffe au accessoires livrés
le boitier c'est bien fait de la tole doublé d'une coque en plastique gris métal


ok si t'as des liens :)
 
Pour en revenir à ce magazine, je vais tacher de me le trouver ce matin :)
 
Bon pour le magazine 9,95€ j'ai pas acheté c'est toujours 10€ d'économisé :p recap de l'article :

  • Samba basique
  • Vsftp
  • Mediatomb
  • Torrentflux


 
Quelqu'un aurait un boitier Silverstone  Sugo SG02B-F ?
J'aimerais savoir si tout mon matos logerais dedans surtout alim et rack lian-li avec mes modifs ventilos aussi :p Si oui je pense que je pourrais craquer le mois prochain :D


Message édité par mad86 le 06-03-2009 à 11:01:41

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6873193
djum
Hardware for ever.
Posté le 06-03-2009 à 13:12:45  profilanswer
 

Pourquoi ne l'as tu pas acheté ?
 
Il ne t'apprenait rien ?
Le sujet sur les NAS était naze ?
Autre raison ?


---------------
Feedback --- Nas homemade
n°6873247
mad86
Posté le 06-03-2009 à 13:45:18  profilanswer
 

djum a écrit :

Pourquoi ne l'as tu pas acheté ?

 

Il ne t'apprenait rien ?
Le sujet sur les NAS était naze ?
Autre raison ?

 

Rien de plus que les howto du net et seulement 4-5 pages regarde le avant d'acheter ;) pour la partie samba on peut regarder ensemble si t'as besoins, pour le reste ftp (j'ai pas besoin), mediatomb (je préfèrerais utiliser ushare mais bon y' a un tuto sur ubuntu-fr), et pour le reste bah torrentflux comme son nom doit l'indiquer doit gérer seulement le torrent pas edonkey donc je préfèrerais mldonkey qui lui gère tout :)
En bref ça vaut pas 10€ pour moi :p


Message édité par mad86 le 06-03-2009 à 13:45:55

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6873718
ITM
Avatar peint à la main
Posté le 06-03-2009 à 18:26:33  profilanswer
 

toto_67 a écrit :


 
j'ai pris un ctrl sata promise 4x sata ! pour le ssd j'hésite ? une compact flash avec un adapteur ide devrait suffrir ?
T'as cherché ou ton boitier ? la cm ?


Eh bien tout dépend ce que tu comptes faire et de l'OS que tu comptes embarquer :)
Moi j'ai pris une CM à 4 SATA pour pas trop m'embêter avec ces histoires d'adaptateurs. De plus, c'est pas *beaucoup* plus cher le SSD. et c'est carrément moins cher au Go. Pour le RAID, en logiciel ça donne de très bonnes perfs et tu n'es pas limité par les drivers des constructeurs => contrôle total.
Le boitier -> Aux US, pour 170$ (+75$ de FDP), ce qui fait 200€ en tout
La CM -> picco.nl
 

djum a écrit :


Ton expérience sous Debian me sera aussi d'une grande aide.
Comptes-tu mettre tes disques en Raid ?


Oui, en RAID 1, en utilisant ZFS. J'ai déjà tout une debian opérationnelle (install netinst + xfce4). Me reste le contrôle du ventilo, le RAID et je peux passer aux choses purement logicielles (serveurs) :)
T'as déjà un peu d'expérience sous Linux ?
 


---------------
iteme.free.fr | Mon feedback
n°6873852
@mdt
Posté le 06-03-2009 à 20:29:23  profilanswer
 

Matériel :
 
AMD Phenom X3 Triple-Core 8650  
2GO PC6400  
Western Digital Caviar Green 1 To 32 Mo Serial ATA II X2
ASUSTeK Terminator 3 M3N8200 (NVIDIA GeForce 8200) - Noir 137,92 €  
Raptor 36 Go de récup.
 
Instalation :
win2k3 sur le raptor 36 Go avec drivers raid modifiés par mes soins.
Les 2 disque de 1 To en raid 1 (raid carte mère)
 
Rôles :
FTP, serveur de téléchargement, administration à distance, vm-ware, N.A.S.
 
Débit du N.A.S. :
 
49 000 Ko/s en lecture  (gros fichier)
32 000 Ko/s en écriture (gros fichier)
 
A venir :  
 
Changer le disque système pour un plus gros (clonage si possible).
Augmenter la mémoire.


Message édité par @mdt le 24-03-2009 à 00:05:09
n°6873858
mad86
Posté le 06-03-2009 à 20:30:42  profilanswer
 

Je suis en train de regarder pour faire un RAID1 de mes 2 DDs 1To et j'ai l'impression que c'est un peu compliqué avec mdadm et je viens de regarder vite fait un tutos ZFS et ça semble un peu + simple. ZFS + ubuntu y'en a qui on déjà testé ?!? mdadm vs ZFS avis ?!? merci d'avance :D

 

@ITM tu pourrais me résumer les commandes que tu as exécutées pour installer / configurer ZFS sur ta debian :)
@mdt si tu pouvais éditer ton post au fur et à mesure je l'ajoute dans la présentation de la première page

Message cité 1 fois
Message édité par mad86 le 06-03-2009 à 20:34:14

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6874181
djum
Hardware for ever.
Posté le 06-03-2009 à 23:53:23  profilanswer
 

ITM a écrit :

...
Oui, en RAID 1, en utilisant ZFS. J'ai déjà tout une debian opérationnelle (install netinst + xfce4). Me reste le contrôle du ventilo, le RAID et je peux passer aux choses purement logicielles (serveurs) :)
T'as déjà un peu d'expérience sous Linux ?


Expérience néant, ou presque. J'en sais ce que l'on en apprend à l'école, en DUT info, pas plus (et encore, ça fait plus de 10 ans ...).
Par contre, je ne suis pas novice en info.
 
Pour le moment, en attendant la construction de mon Raid5 demain, j'essaie de comprendre pourquoi j'ai des débits pourris entre ma debian et mon Vista sachant que tout est connecté en Gigabit. Je tourne à 20 Mo de moyenne, non stable. Quand je copie un fichier de plusieurs gigas (iso debian), je tourne entre 7 Mo/s et 50 Mo/s. J'espérais avoir un débit stable aux alentours de 50 Mo/s.
J'ai essayé :
- install du driver de mon contrôleur réseau (sk98lin) => sans amélioration
- vérification des paramètres réseau : je suis bien en 1 Gb Full Duplex sur la Debian. Vista est en "auto" et me dit que je suis connecté à 1 Gb.
- maintenant, je regarde côté Vista ... J'ai progressé, avant j'avais du 13Mo/s stable et le fait de virer VMWare à débridé un peu le réseau mais ce n'est pas encore ça.
 
Sinon, pour la revue, dès que j'en ai tâté l'épaisseur, je me suis dit que 10 euros c'était de trop. J'ai feuilleté et je ne comprends toujours pas qui est la cible de ce magazine ... Je l'ai laissé sur place, pourtant, ça s'annonçait bien.


---------------
Feedback --- Nas homemade
n°6874339
mad86
Posté le 07-03-2009 à 08:25:11  profilanswer
 

@djum : Pour le vista y'a probablement 2-3 trucs à désactiver :
 



  • Désactiver l’offloading :

The following procedure to edit the Windows Registry should help you disable Task Offloading in Windows.
 
1. Click Start -  Search and type “regedit” (Start - Run in Windows XP/2003/2000). This launches the WIndows Registry.
 
2.  In the registry, navigate to the following registry key
 
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters]
 
HKEY_LOCAL_MACHINE
     \SYSTEM
          \CurrentControlSet
               \Services
                    \Tcpip
                         \Parameters
 
3. In the right pane, right-click and select New - DWORD (32-bit value) and set its name as “DisableTaskOffload” and set its value as “1“. Setting “1” will disable TCP Task offoading. Should you like to enable it back at a later time, set it “0” or simply delete the this key.
 

  • Désactiver SMB2.0    


1.    On the server that you shared your files, click Start, click Run then type Regedit and press Enter.
 
2.    Locate and select the key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
 
3.    On the Edit menu, point to New, and then click DWORD (32-bit) Value. Name this value "SMB2" without the quotation marks.
 
4.    Select the SMB2 value. If the value is not 0 (zero); on the Edit menu, click Modify. Change the Value data to 0 (zero) and click OK.
 
5.    Reboot the computer.
 
Et là c'est la procédure que je fais pour améliorer les transfert et pbs d'authentification entre XP/Vista ou 2008/XP et ça fonctionne beaucoup mieux ;) mais dans ton cas je pense surtout au NTLM et SMB2.

Message cité 1 fois
Message édité par mad86 le 07-03-2009 à 08:26:37

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6874491
djum
Hardware for ever.
Posté le 07-03-2009 à 11:49:16  profilanswer
 

mad86 a écrit :

@djum : Pour le vista y'a probablement 2-3 trucs à désactiver :
...
Et là c'est la procédure que je fais pour améliorer les transfert et pbs d'authentification entre XP/Vista ou 2008/XP et ça fonctionne beaucoup mieux ;) mais dans ton cas je pense surtout au NTLM et SMB2.


Voilà, c'est fait. Seulement, après mes débits en dent de scie, je suis repassé à 14 Mo/s stables. Le max théorique du 100Mb ... Bizarre.
 
Sinon, j'ai essayé de reconstruire mon raid5 ce matin (vu que j'avais arrêté sauvagement la construction qui durait plus de 5 heures) et c'est reparti ! Plus que 200 minutes à attendre. Le pire, c'est que je viens juste de m'en rendre compte. Je voulais aussi parler de mes débits IO du raid qui étaient pas géniaux mais vu qu'il reconstruit, je comprends mieux. Je vérifierais tout ça (réseau + IO) à la fin de la reconstruction.
Je vais essayer de trouver le matériel qu'il manque cet après-midi.


---------------
Feedback --- Nas homemade
n°6874753
ITM
Avatar peint à la main
Posté le 07-03-2009 à 15:28:12  profilanswer
 

mad86 a écrit :

@ITM tu pourrais me résumer les commandes que tu as exécutées pour installer / configurer ZFS sur ta debian :)


Ayé, ça marche, j'ai mon ZFS avec les deux disques en mirroir :) Je poste depuis le NAS d'ailleurs.
Assez ultime le boitier Chenbro : il y a même une LED qui permet de voir les accès à chaque disque dur, ce qui est très pratique pour bien voir ce qu'il se passe :)

 

Sinon, rien de plus simple pour créer tout ça : http://hightechsorcery.com/2008/09 [...] ardy-heron
=> en root et sous /tmp :
# apt-get install build-essential libfuse-dev libaio-dev zlib1g-dev scons
# wget http://download.berlios.de/zfs-fus [...] .0.tar.bz2
# tar -xjf zfs-fuse-0.5.0.tar.bz2
# cd zfs-fuse-0.5.0/src
# scons
# scons install

 

Après, faut bien lancer :
# modprobe fuse
# zfs-fuse

 

Pour créer ton pool (ici "storage" avec les deux disques en mirror) :
# mkdir /storage
# zpool create storage -m /storage mirror /dev/sdb /dev/sdc

 

Par contre au reboot, j'ai du refaire :
# modprobe fuse
# zfs-fuse
# zpool import storage
# zfs mount storage (je crois que c'est fait automatiquement par la ligne d'avant, me souviens plus)

Message cité 1 fois
Message édité par ITM le 07-03-2009 à 15:29:17

---------------
iteme.free.fr | Mon feedback
n°6874843
mad86
Posté le 07-03-2009 à 16:41:26  profilanswer
 

ITM a écrit :


Ayé, ça marche, j'ai mon ZFS avec les deux disques en mirroir :) Je poste depuis le NAS d'ailleurs.
Assez ultime le boitier Chenbro : il y a même une LED qui permet de voir les accès à chaque disque dur, ce qui est très pratique pour bien voir ce qu'il se passe :)
....

 

Effectivement comme ça on dirait que c'est plus simple que mdadm :)

 


Message édité par mad86 le 07-03-2009 à 17:59:26

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6874898
ITM
Avatar peint à la main
Posté le 07-03-2009 à 17:23:00  profilanswer
 

Bon ça y est j'ai fait mes groupes d'utilisateur et le serveur Samba est quasi OK.
Quelques retours de perfs pour le 1TO en mirroir (ZFS) et en 100Mbit (seulement :() :
 - Côté disque, lors des gros transferts, ils écrivent seulement de temps en temps : ils s'ennuient :D.
 - Côté CPU, ça varie par contre entre 20 et 30% (je rappelle que c'est un Atom 330).
 - Côté RAM, le ZFS-FUSE bouffe pas mal aussi, environ 7,5% de mes 2 Go pendant les transferts

Message cité 2 fois
Message édité par ITM le 07-03-2009 à 17:24:02

---------------
iteme.free.fr | Mon feedback
n°6874916
zeblods
Posté le 07-03-2009 à 17:40:00  profilanswer
 

ITM a écrit :

Bon ça y est j'ai fait mes groupes d'utilisateur et le serveur Samba est quasi OK.
Quelques retours de perfs pour le 1TO en mirroir (ZFS) et en 100Mbit (seulement :() :
 - Côté disque, lors des gros transferts, ils écrivent seulement de temps en temps : ils s'ennuient :D.
 - Côté CPU, ça varie par contre entre 20 et 30% (je rappelle que c'est un Atom 330).
 - Côté RAM, le ZFS-FUSE bouffe pas mal aussi, environ 7,5% de mes 2 Go pendant les transferts


Pour ce qui est de l'utilisation CPU, avec mon RAID-Z sur 8 disques + compression activé, en effectuant des copies de partition à partition j'avais des freez car mon ancien E6300 (core2duo de 1,86Ghz...) n'arrivait pas à suivre... Depuis je suis passé à un E6700 et ça va mieux !
 
Pour la RAM, ZFS est un gouffre ! En fait, sous Solaris, il utilise toute la RAM - 1Go pour faire du cache (donc 7Go sur mes 8Go de RAM sont réservé à ZFS). C'est surement pour ça que pendant tes copies de gros fichiers tes disques n'écrivaient que par intermittence...


---------------
Config mini-ITX
n°6874922
neodam
c'est joli mais ça sert a rien
Posté le 07-03-2009 à 17:48:44  profilanswer
 

y a moyen de gerer la charge memoire de zfs via des options ??
 
 
et sinon, pour ceux qui doutent encore de la conso des NAS home made.

Citation :


Nous avons testé le Pentium Dual Core E5200 sur une Asus P5Q-VM équipée d’un GM45 et de 2 Go de DDR2-800. Au repos, avec un disque dur, la machine consomme 42 watts. Sous Prime95, la consommation du système entier monte à 64 watts (soit moins que le TDP – farfelu – donné par Intel). Sur la configuration de référence avec la GeForce 8800 GTS 512 Mo, les valeurs sont de 71 watts et 135 watts. A titre indicatif, le couple Pentium Dual Core E5200 et Asus P5Q-VM remplace un ensemble Pentium Dual Core E2180 et une Asus P5B-VM dont les consommations respectives sont de 63 watts et 88 watts.


 
http://www.tt-hardware.com/modules [...] =0&thold=0
 

n°6874933
mad86
Posté le 07-03-2009 à 18:00:01  profilanswer
 

ITM a écrit :

Bon ça y est j'ai fait mes groupes d'utilisateur et le serveur Samba est quasi OK.
Quelques retours de perfs pour le 1TO en mirroir (ZFS) et en 100Mbit (seulement :() :
 - Côté disque, lors des gros transferts, ils écrivent seulement de temps en temps : ils s'ennuient :D.
 - Côté CPU, ça varie par contre entre 20 et 30% (je rappelle que c'est un Atom 330).
 - Côté RAM, le ZFS-FUSE bouffe pas mal aussi, environ 7,5% de mes 2 Go pendant les transferts

 

Partie RAID via ZFS

 

Bon je fais plus simple :p avec une synthèse de tes manips + Wiki Ubuntu ZFS + Gestion ZFSpool

 

1°) sudo -s (pour éviter de mettre sudo avant chaque commande)
2°) vim /etc/apt/sources.list
3°) insérer les 2 lignes suivantes :
deb http://ppa.launchpad.net/brcha/ubuntu intrepid main
deb-src http://ppa.launchpad.net/brcha/ubuntu intrepid main
4°) apt-get update
5°) apt-get install zfs-fuse
6°) mkdir /storage
7°) zpool create storage -m /storage mirror /dev/sdb /dev/sdc
8°) Reboot => shutdown -r now
9°) Vérification du pool ZFS => zpool list

 

Si tout est OK cela devrait renvoyer quelque chose comme :

 
Code :
  1. NAME      SIZE   USED  AVAIL    CAP  HEALTH  ALTROOT
  2. storage   931G  88,5K   931G     0%  ONLINE  -
 

Partie partage

 

1°) Modifier les autorisations de /storage pour être tranquille :

 
Code :
  1. chown mon_user /storage
  2. chgrp mon_user /storage
  3. chmod ugo=wrx /storage
 

2°) Modifier le smb.conf pour accéder à /storage sans sécurisation :

 
Code :
  1. [global]
  2.         workgroup = workgroup
  3.         netbios name = nas
  4.         security = share
  5. [storage]
  6.         path = /storage
  7.         comment = stockage sur NAS
  8.         read only = no
  9.         guest ok = yes
 

Partie ushare :

 
Code :
  1. apt-get install ushare

+ tous les autres paquets qui sont suggérés (chez moi ça marche pas sans)

Code :
  1. dpkg-reconfigure ushare


Modif du fichier ushare.conf :

Code :
  1. # /etc/ushare.conf
  2. # Edit this file with 'dpkg-reconfigure ushare'
  3. # Configuration file for uShare
  4. # uShare UPnP Friendly Name (default is 'uShare').
  5. USHARE_NAME=Nas
  6. # Interface to listen to (default is eth0).
  7. # Ex : USHARE_IFACE=eth1
  8. USHARE_IFACE=eth0
  9. # Port to listen to (default is random from IANA Dynamic Ports range)
  10. # Ex : USHARE_PORT=49200
  11. USHARE_PORT=
  12. # Port to listen for Telnet connections
  13. # Ex : USHARE_TELNET_PORT=1337
  14. USHARE_TELNET_PORT=
  15. # Directories to be shared (space or CSV list).
  16. # Ex: USHARE_DIR=/dir1,/dir2
  17. USHARE_DIR=/storage/MOVIE,/storage/PICTURE,/storage/MUSIC
  18. # Use to override what happens when iconv fails to parse a file name.
  19. # The default uShare behaviour is to not add the entry in the media list
  20. # This option overrides that behaviour and adds the non-iconv'ed string into
  21. # the media list, with the assumption that the renderer will be able to
  22. # handle it. Devices like Noxon 2 have no problem with strings being passed
  23. # as is. (Umlauts for all!)
  24. #
  25. # Options are TRUE/YES/1 for override and anything else for default behaviour
  26. USHARE_OVERRIDE_ICONV_ERR=
  27. # Enable Web interface (yes/no)
  28. ENABLE_WEB=
  29. # Enable Telnet control interface (yes/no)
  30. ENABLE_TELNET=
  31. # Use XboX 360 compatibility mode (yes/no)
  32. ENABLE_XBOX=
  33. # Use DLNA profile (yes/no)
  34. # This is needed for PlayStation3 to work (among other devices)
  35. ENABLE_DLNA=yes
 

Partie téléchargements :

 
Code :
  1. apt-get install torrentflux
 

Partie serveur de streaming MP3 compatible Itunes (faut que je teste car le but est de pouvoir récup les MP3s de mon NAS sur mon ipod touch :p

 
Code :
  1. apt-get install mt-daapd
 

Configuration suivant How-To


Message édité par mad86 le 13-04-2009 à 18:27:36

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6874964
mad86
Posté le 07-03-2009 à 18:28:09  profilanswer
 

Bon je suis en train de tester les débits moi aussi :p c'est toujours pas terrible :( explication de mon architecture :
 

  • Nas en CPL 85 Mbit/s sur une freebox v5
  • Portable en wifi 54g sous Ubuntu intrepid


Resultat d'un transfert d'une image ubuntu-serveur de 630Mo = environ 1Mo / s
 
la commande top sur mon nas me renvoie les infos suivantes :
 
http://mad86.free.fr/nas/top_storage.png
 
J'ai des pointes de 7% d'utilisation ram pour zfs-fuse mais bon globalement c'est pas autant consommateur en ressources que vous ?!?
 
J'ai pour l'instant aucune interface graphique et je sais pas si je compte en mettre car avec ssh je peux visiblement à peu près tout faire faut que je teste un wget d'un lien sur un site de direct downloads si ça marche.


---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6874986
leloire
I has sushi
Posté le 07-03-2009 à 18:45:27  profilanswer
 

flag!

n°6875066
neodam
c'est joli mais ça sert a rien
Posté le 07-03-2009 à 20:18:44  profilanswer
 

l'interface graphique est tjrs optionnel sous linux.
 
pour tes tests de debits.
elimine les elements qui peuvent influencer la vitesse.
donc vire moi le cpl et le wifi.
mes boitiers CPL je fais du max 2Mo/sec avec donc ça ne m'etonne guere tes debits si ton nas est branché dessus.
 
au pire test en etant branché direct dessus avec un cable reseau croisé!

n°6875237
mad86
Posté le 07-03-2009 à 22:54:56  profilanswer
 

neodam a écrit :

l'interface graphique est tjrs optionnel sous linux.
 
pour tes tests de debits.
elimine les elements qui peuvent influencer la vitesse.
donc vire moi le cpl et le wifi.
mes boitiers CPL je fais du max 2Mo/sec avec donc ça ne m'etonne guere tes debits si ton nas est branché dessus.
 
au pire test en etant branché direct dessus avec un cable reseau croisé!


 
Je testerais ça demain ;) direct sur la freebox


---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6875449
mad86
Posté le 08-03-2009 à 10:22:05  profilanswer
 

Bon je viens d'installer ushare et ça semble fonctionner :D streaming sur une PS3 :p voici un exemple de consommation en ressources durant un streaming de di** de 700Mo :

 

http://mad86.free.fr/nas/top-ushare.png

 

ça commence à prendre bonne forme tout ça :D faut que je trouve mes soucis de lenteurs samba et que je configure mldonkey et ça roule :D


Message édité par mad86 le 08-03-2009 à 10:33:19

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6875508
ITM
Avatar peint à la main
Posté le 08-03-2009 à 11:25:13  profilanswer
 

zeblods a écrit :


Pour ce qui est de l'utilisation CPU, avec mon RAID-Z sur 8 disques + compression activé, en effectuant des copies de partition à partition j'avais des freez car mon ancien E6300 (core2duo de 1,86Ghz...) n'arrivait pas à suivre... Depuis je suis passé à un E6700 et ça va mieux !
 
Pour la RAM, ZFS est un gouffre ! En fait, sous Solaris, il utilise toute la RAM - 1Go pour faire du cache (donc 7Go sur mes 8Go de RAM sont réservé à ZFS). C'est surement pour ça que pendant tes copies de gros fichiers tes disques n'écrivaient que par intermittence...


Ouch' ! C'est bon à savoir :)
D'ailleurs j'ai remarqué que la courbe des transferts réseaux et la courbe d'écriture sur le disque étaient parfaitement complémentaires :'(
En gros, le réseau tourne à fond, puis s'éffrondre dès que les disques grattent, puis repart des que les disques ne grattent plus, et ainsi de suite... Tu sais d'où ça peut provenir ? Pourtant je suis loin d'atteindre des pics de consommation de ressource :??:
Par ailleurs, j'ai pas de script de démarrage / arret de tout ce qui est ZFS-FUSE. Je sais ce qu'il faut faire au démarrage, mais y a-t-il des commandes spécial à faire lorsqu'on arrete le système, en particulier qui concernent les pools ?


---------------
iteme.free.fr | Mon feedback
n°6875518
zeblods
Posté le 08-03-2009 à 11:46:19  profilanswer
 

ITM a écrit :


Ouch' ! C'est bon à savoir :)
D'ailleurs j'ai remarqué que la courbe des transferts réseaux et la courbe d'écriture sur le disque étaient parfaitement complémentaires :'(
En gros, le réseau tourne à fond, puis s'éffrondre dès que les disques grattent, puis repart des que les disques ne grattent plus, et ainsi de suite... Tu sais d'où ça peut provenir ? Pourtant je suis loin d'atteindre des pics de consommation de ressource :??:


Ça je ne sais pas par contre car je n'ai pas genre de problème sous OpenSolaris, essaye plutôt de demander directement au dev de ZFS-FUSE car ça à l'aire d'être spécifique au portage sous Linux.
 

ITM a écrit :


Par ailleurs, j'ai pas de script de démarrage / arret de tout ce qui est ZFS-FUSE. Je sais ce qu'il faut faire au démarrage, mais y a-t-il des commandes spécial à faire lorsqu'on arrete le système, en particulier qui concernent les pools ?


Une fois de plus je ne sais pas car c'est spécifique à Linux (sous OpenSolaris le driver ZFS est directement intégré au kernel : le système d'exploitation boot directement depuis une partition ZFS)


---------------
Config mini-ITX
n°6875527
mad86
Posté le 08-03-2009 à 11:54:40  profilanswer
 

ITM a écrit :


Ouch' ! C'est bon à savoir :)
D'ailleurs j'ai remarqué que la courbe des transferts réseaux et la courbe d'écriture sur le disque étaient parfaitement complémentaires :'(
En gros, le réseau tourne à fond, puis s'éffrondre dès que les disques grattent, puis repart des que les disques ne grattent plus, et ainsi de suite... Tu sais d'où ça peut provenir ? Pourtant je suis loin d'atteindre des pics de consommation de ressource :??:
Par ailleurs, j'ai pas de script de démarrage / arret de tout ce qui est ZFS-FUSE. Je sais ce qu'il faut faire au démarrage, mais y a-t-il des commandes spécial à faire lorsqu'on arrete le système, en particulier qui concernent les pools ?


 
Je pense que ça vient de ta compilation ... moi en configurant tout ça à partir des paquets prévus pour ubuntu tout ce charge tout seul au démarrage ;)
 
Pour mes test de débits entre mon poste fixe et mon nas tout 2 reliés via un switch giga => au départ je suis à 9 Mo /s pour arrivé à 6 Mo / s stable et je pense que c'est dût au RAID. Donc à priori les lenteurs de samba sont liées au wifi :(

Message cité 1 fois
Message édité par mad86 le 08-03-2009 à 12:09:34

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
n°6875611
ITM
Avatar peint à la main
Posté le 08-03-2009 à 13:01:50  profilanswer
 

mad86 a écrit :


 
Je pense que ça vient de ta compilation ... moi en configurant tout ça à partir des paquets prévus pour ubuntu tout ce charge tout seul au démarrage ;)
 
Pour mes test de débits entre mon poste fixe et mon nas tout 2 reliés via un switch giga => au départ je suis à 9 Mo /s pour arrivé à 6 Mo / s stable et je pense que c'est dût au RAID. Donc à priori les lenteurs de samba sont liées au wifi :(


Tu pourrais me dire ce que le paquet zfs-fuse a installé dans /etc/ ? Je suppose que tu devrais avoir un script SXX, un script KXX et un dernier dans /etc/init.d/ ?


---------------
iteme.free.fr | Mon feedback
n°6875708
mad86
Posté le 08-03-2009 à 14:16:11  profilanswer
 

@ ITM : je ne trouve rien de ce genre en faisant un ls /etc il y aurait 1 autre manière pour voir ce dont tu as besoin ? :)

 

En tout cas je suis en train de matter un film pour tester ushare et aucun ralentissement à signaler :D j'en ai un en HD de 8Go faut que je teste là je pense que ça va exploser :p


Message édité par mad86 le 08-03-2009 à 14:22:03

---------------
<><><><><><><><><><><>  Mon Feed  <><><><><><><><><><><>
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  355  356  357  358  359  360

Aller à :
Ajouter une réponse
 

Sujets relatifs
[Topic Unique] Nexus RX-8500 850 watts : la plus silencieuse des 850[Conseils?] Mini-PC pour faire un NAS *simple*
Netgear ReadyNas Duo[Topic Unique] Thermaltake Element S,G,T et V MAJ 05/11/09
TOPIC gainward 4870 GOLDEN SAMPLE 1024Nas perso mini-pc
[TOPIC D'AIDE]Les cartes ATI et les problèmes du "pilote VGA standard" 
Plus de sujets relatifs à : [Topic Unique] Nas perso homemade


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR