Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1766 connectés 

 

 

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  ..  61  62  63  64  65  66
Page Suivante
Auteur Sujet :

[Topic FreeBSD] nouvelle version 10.0 dispo !!

n°1368945
Magicpanda
Pushing the envelope
Posté le 19-11-2014 à 07:49:52  profilanswer
 

Reprise du message précédent :
une belle et bonne nouvelle pour le projet freebsd
 
http://www.phoronix.com/scan.php?p [...] px=MTg0Mzc
 
ca tombe bien, il reste à porter les drivers kms, à finir launchd, etc


---------------
" Quel est le but du capital ? Le but du capital c'est produire pour le capital. L'objectif, lui, est illimité. L'objectif du capital c'est produire pour produire." - Deleuze || André Gorz - Vers la société libérée
mood
Publicité
Posté le 19-11-2014 à 07:49:52  profilanswer
 

n°1369145
Magicpanda
Pushing the envelope
Posté le 21-11-2014 à 00:14:22  profilanswer
 

une bonne partie des talks de eurobsdcon dispo ici
 
https://va.ludost.net/files/eurobsdcon/2014/


---------------
" Quel est le but du capital ? Le but du capital c'est produire pour le capital. L'objectif, lui, est illimité. L'objectif du capital c'est produire pour produire." - Deleuze || André Gorz - Vers la société libérée
n°1369264
kisscoolz
Posté le 23-11-2014 à 19:53:13  profilanswer
 

Hola,
 
J'ai un soucis après avoir mis a jour mon arbre de ports.  
 
Quand j'utilise pkg_version pour voir les ports qui ne sont pas à jour j'ai droit à un paquet d'erreurs.  
 
J'ai pu reproduire l'erreur avec la commande make -V PKGNAME -C /usr/ports/sysutils/tmux/ qui donne  
 

Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
"/usr/ports/Mk/bsd.sites.mk", line 991: Malformed conditional (!empty(_PERL_CPAN_ID) && ${_PERL_CPAN_FLAG:tl} == "cpan" )
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
"/usr/ports/Mk/bsd.port.mk", line 3021: warning: Missing closing parenthesis for defined()
Unknown modifier 't'
 
"/usr/ports/Mk/bsd.port.mk", line 3021: Malformed conditional (((!defined(OPTIONS_DEFINE) && !defined(OPTIONS_SINGLE) && !defined(OPTIONS_MULTI)) && !define
d(OPTIONS_GROUP) && !defined(OPTIONS_RADIO) || defined(CONFIG_DONE_${UNIQUENAME:tu}) || defined(PACKAGE_BUILDING) || defined(BATCH)))
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
Unknown modifier 't'
 
"/usr/ports/Mk/bsd.port.mk", line 5588: Unclosed conditional/for loop
"/usr/ports/Mk/bsd.port.mk", line 5588: Unexpected end of file in for loop.
 
"/usr/ports/Mk/bsd.port.mk", line 5588: Unclosed conditional/for loop
"/usr/ports/Mk/bsd.port.mk", line 5588: Unexpected end of file in for loop.
 
"/usr/ports/Mk/bsd.port.mk", line 5588: Unclosed conditional/for loop
"/usr/ports/Mk/bsd.port.mk", line 5588: Unexpected end of file in for loop.
 
"/usr/ports/Mk/bsd.port.mk", line 5588: Unclosed conditional/for loop
"/usr/ports/Mk/bsd.port.mk", line 5588: Unexpected end of file in for loop.
 
"/usr/ports/Mk/bsd.port.mk", line 6091: Unclosed conditional/for loop
"/usr/ports/Mk/bsd.port.mk", line 6091: Unexpected end of file in for loop.
 
1 open conditional:
at line 5658 (evaluated to true)
make: fatal errors encountered -- cannot continue


 
J'ai pas ce soucis avec l'ancienne arborescence.  
 
Quelqu'un aurait une idée du pourquoi du comment ? Je suis sous FreeBSD 8.


Message édité par kisscoolz le 23-11-2014 à 19:55:36

---------------
http://lacabanedeladmin.trickip.net/
n°1369265
kisscoolz
Posté le 23-11-2014 à 21:15:47  profilanswer
 

En fin de compte c'est ma version qui est plus supporté. Je suis en 8.3. Ils ont rendu incompatible les ports avec les version plus anciennes du système. Je trouve ca extremiste comme solution :/  
 
Bref, j'ai trouvé un moyen de contourner le blockage en attendant de faire la mise a jour.


---------------
http://lacabanedeladmin.trickip.net/
n°1371524
anapivirtu​a
Boh.
Posté le 03-01-2015 à 21:07:37  profilanswer
 

Au fait 10.1 est out. :o


---------------
Twitter | Si vis pacem, para bellum.
n°1371628
black_lord
Modérateur
Truth speaks from peacefulness
Posté le 06-01-2015 à 09:31:18  profilanswer
 

kisscoolz a écrit :

En fin de compte c'est ma version qui est plus supporté. Je suis en 8.3. Ils ont rendu incompatible les ports avec les version plus anciennes du système. Je trouve ca extremiste comme solution :/  
 
Bref, j'ai trouvé un moyen de contourner le blockage en attendant de faire la mise a jour.


 
c'est un choix qui a été fait en connaissance de cause : pour le nouveau système de packages il a fallu casser la rétro compat. A noter que ta distro n'est plus supportée.


---------------
uptime is for lousy system administrators what Viagra is for impotent people - mes unixeries - github me
n°1371757
kisscoolz
Posté le 09-01-2015 à 21:22:27  profilanswer
 

black_lord a écrit :


 
c'est un choix qui a été fait en connaissance de cause : pour le nouveau système de packages il a fallu casser la rétro compat. A noter que ta distro n'est plus supportée.


 
C'est un peu ce que j'ai dit dans le post que t'as quoté  :sarcastic:  
 
Et au cas où tu aurais pas vu, j'ai aussi dit que j'avais trouvé un moyen de contourner le problème  :o  


---------------
http://lacabanedeladmin.trickip.net/
n°1371758
kisscoolz
Posté le 09-01-2015 à 21:31:24  profilanswer
 

black_lord a écrit :

 

c'est un choix qui a été fait en connaissance de cause : pour le nouveau système de packages il a fallu casser la rétro compat. A noter que ta distro n'est plus supportée.

 

Et tant que je suis en mode taquin

 

FreeBSD n'est pas une distribution, c'est un système d'exploitation à part entière  :whistle:


Message édité par kisscoolz le 09-01-2015 à 21:31:49

---------------
http://lacabanedeladmin.trickip.net/
n°1372414
b0ugie
Posté le 21-01-2015 à 08:35:09  profilanswer
 

[:gaga drapal]

 

Je viens de découvrir que les news pour ezjails ne sont pas très bonnes pour la suite (https://elektropost.org/ezjail/msg00147.html) :(

 

Vous connaissez des équivalents qui supportent le nouveau jail.conf et vnet/vimage ?


Message édité par b0ugie le 21-01-2015 à 08:35:24
n°1372590
Plam
:o
Posté le 23-01-2015 à 17:06:53  profilanswer
 

Drapal, j'ai un FreeBSD 10 qui me sert de NAS de backup avec un petit mirroir ZFS et un script de snapshots tournants :jap:
 
Des gens ont testé de faire du ZFS send/receive entre un ZFS FreeBSD et un ZFSoL sur une Debian ?


---------------
Xen-orchestra.com // NodeJS c'est le bien :o // Ossifié, comme fusionné dans son cockpit
mood
Publicité
Posté le 23-01-2015 à 17:06:53  profilanswer
 

n°1379069
gizmo15
Posté le 21-07-2015 à 14:09:21  profilanswer
 

Bonjour à vous,
 
Des personnes ici utilisent bhyve sous freebsd? nous envisageons de l'utiliser pour un serveur de virtu avec des bridges.
 
Des retours d'exp?
 
Merci

n°1381577
gizmo15
Posté le 30-09-2015 à 14:33:18  profilanswer
 

Bonjour à vous,

 

Je me heurte à un soucis que je ne comprends pas

 

En gros voici la plateforme:
internet -------- box ------------- lan1 ------------ routeur FreeBSD -------- lan2

 

le routeur à accès internet sans soucis, mais c'est pas le cas des vm sur le lan2.

 

VM aussi sur freebsd, le ping passe sans soucis mais pas la résolution de nom oO

 

une capture lors d'un ping sur google.fr:

Code :
  1. root@Firewall:~ # tcpdump -i vtnet1
  2. tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
  3. listening on vtnet1, link-type EN10MB (Ethernet), capture size 65535 bytes
  4. 11:22:04.038253 IP 172.16.55.2.22163 > 192.168.0.252.domain: 40296+ A? google.fr. (27)
  5. 11:22:08.828158 IP 172.16.55.2.56559 > google-public-dns-a.google.com.domain: 4738+ AAAA? 2.freebsd.pool.ntp.org. (40)
  6. 11:22:09.072190 IP 172.16.55.2.18492 > google-public-dns-a.google.com.domain: 40296+ A? google.fr. (27)
  7. 11:22:11.109640 IP 172.16.55.2.22163 > 192.168.0.252.domain: 40296+ A? google.fr. (27)
  8. 11:22:13.844824 IP 172.16.55.2.36048 > 192.168.0.252.domain: 64060+ A? 0.freebsd.pool.ntp.org. (40)
  9. 11:22:18.856428 IP 172.16.55.2.10531 > google-public-dns-a.google.com.domain: 64060+ A? 0.freebsd.pool.ntp.org. (40)
  10. 11:22:20.862141 IP 172.16.55.2.36048 > 192.168.0.252.domain: 64060+ A? 0.freebsd.pool.ntp.org. (40)
  11. 11:22:21.125566 IP 172.16.55.2.18492 > google-public-dns-a.google.com.domain: 40296+ A? google.fr. (27)
  12. 11:22:30.904832 ARP, Request who-has 172.16.55.1 tell 172.16.55.2, length 28
  13. 11:22:30.904851 ARP, Reply 172.16.55.1 is-at 2a:f6:f0:97:37:51 (oui Unknown), length 28
  14. 11:22:30.905147 IP 172.16.55.2.10531 > google-public-dns-a.google.com.domain: 64060+ A? 0.freebsd.pool.ntp.org. (40)
  15. 11:22:35.933338 IP 172.16.55.2.23285 > 192.168.0.252.domain: 42471+ AAAA? 0.freebsd.pool.ntp.org. (40)
  16. 11:22:40.978190 IP 172.16.55.2.30468 > google-public-dns-a.google.com.domain: 42471+ AAAA? 0.freebsd.pool.ntp.org. (40)
  17. ^C
  18. 13 packets captured
  19. 13 packets received by filter
  20. 0 packets dropped by kernel
 

Voici ma conf PF:

Code :
  1. ext_if="vtnet0"
  2. int_if="vtnet1"
  3. nat pass on $ext_if from $int_if:network to any -> ($ext_if)
 

et le rc.conf:

Code :
  1. hostname="Firewall"
  2. keymap="fr.iso.acc.kbd"
  3. ifconfig_vtnet0="inet 192.168.0.190 netmask 255.255.255.0"
  4. ifconfig_vtnet1="inet 172.16.55.1 netmask 255.255.255.0"
  5. defaultrouter="192.168.0.254"
  6. sshd_enable="YES"
  7. ntpd_enable="YES"
  8. # Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
  9. dumpdev="AUTO"
  10. # Router
  11. gateway_enable="YES"
  12. pf_enable="YES"                           # Enable PF (load module if required)
  13. pf_rules="/etc/pf.conf"               # rules definition file for pf
  14. pf_flags=""                                      # additional flags for pfctl startup
  15. pflog_enable="YES"                     # start pflogd(8)
  16. pflog_logfile="/var/log/pflog"  # where pflogd should store the logfile
  17. pflog_flags=""                                 # additional flags for pflogd startup
  18. pflogd_enable="YES"
 

Un ping depuis la vm vers une IP d'internet passe sans soucis, mais aucune résolution de nom.

 

J'avoue ne pas comprendre pk oO

 

Une idée?

 

tout est sous FreeBSD 10.2

 

Merci


Message édité par gizmo15 le 30-09-2015 à 14:33:34
n°1381580
gizmo15
Posté le 30-09-2015 à 17:17:20  profilanswer
 

réponse trouvée: les drivers utilisé par KVM, je suis passé de virtio à e1000 et plus de soucis

n°1381583
b0ugie
Posté le 30-09-2015 à 18:24:39  profilanswer
 

gizmo15 a écrit :

réponse trouvée: les drivers utilisé par KVM, je suis passé de virtio à e1000 et plus de soucis


Ce n'est vraiment pas la joie Freebsd sur du KVM avec la 10.X. J'ai aussi eu tout plein de bugs liés à ça (probleme avec le checksum offloading par exemple). Et dernièrement j'ai craqué et je suis passé de XenServer à proxmox pour me simplifier la vie.
 
PS: il faudrait update le titre du topic :o

n°1381587
gizmo15
Posté le 30-09-2015 à 19:39:43  profilanswer
 

de xenserver à proxmox? ca reste du kvm non?
 
après le proxmox sur lequel c'est installé est en 4 beta donc ca aide peut être pas

n°1381593
b0ugie
Posté le 30-09-2015 à 22:22:15  profilanswer
 

gizmo15 a écrit :

de xenserver à proxmox? ca reste du kvm non?
 
après le proxmox sur lequel c'est installé est en 4 beta donc ca aide peut être pas


Oui. C'est sans doute comme tu dis lié au driver de la carte réseau. Par défaut c'est du e1000 sur proxmox.

n°1381672
b0ugie
Posté le 03-10-2015 à 19:34:27  profilanswer
 

gizmo15 a écrit :

réponse trouvée: les drivers utilisé par KVM, je suis passé de virtio à e1000 et plus de soucis


J'ai refait des tests récemment. Le problème arrive uniquement lorsque l'on se sert d'un FreeBSD en mode routeur.
Sur des transfères (testé avec iperf) entre VMs avec une seule carte réseau, j'ai fais x10 en passant de e1000 à virtio.


Message édité par b0ugie le 04-10-2015 à 20:54:53
n°1381713
gizmo15
Posté le 04-10-2015 à 19:27:22  profilanswer
 

j'utilise effectivement freebsd en routeur.

n°1382111
torlik
Posté le 13-10-2015 à 16:44:22  profilanswer
 

Personne n'a de problème avec les sockets d'appli dans les jails en 10.2 ?  
 
Par exemple ma jail mysql, me dit qu'il ne peut pas créer le socket dans /tmp. J'ai rollback en 10.1 et hop tout roule.....

n°1382155
b0ugie
Posté le 14-10-2015 à 07:28:34  profilanswer
 

J'ai eu installé un mysql dans une jail en 10.2 et de mémoire je n'avais pas eu de problèmes.

n°1382159
gizmo15
Posté le 14-10-2015 à 08:22:36  profilanswer
 

Bonjour à vous,
 
Petite question: je me heurte à soucis au niveau sqlite3 avec nodejs sur une 10.2. Impossible d'installer le module
 
Voici l'erreur: https://pad.lqdn.fr/p/Nodejs-Freebsd
 
L'un d'entre vous à déjà rencontré ce genre de soucis?
 
Merci

n°1386068
lebibi
Notre torture c'est la tourtel
Posté le 25-01-2016 à 00:47:46  profilanswer
 

le SSD de mon serveur (multimedia) ayant rendu l’âme j'en ai profité pour tout réinstaller sous FreeBSD (debian avant).
 
Pour l'instant rien a redire, tout fonctionne comme auparavant.
Pas encore eu l'occasion de regarder la fonctionnalité des jails, mais que du bon pour l'instant :)
 
Est ce que l'un d'entre vous aurait un bon script d'init pour xbmc/kodi avec un démarrage en standalone, avec création de pid + forcer le user et en daemon ?
 
Actuellement je le lance avec un script sh :
 
/usr/local/bin/sudo -b -u mon_user /usr/local/bin/xinit /usr/local/bin/kodi --standalone -fs
 
Si je tente avec daemon, il ne démarre pas :(


Message édité par lebibi le 25-01-2016 à 00:50:27

---------------

n°1389870
lebibi
Notre torture c'est la tourtel
Posté le 26-04-2016 à 14:46:43  profilanswer
 

plop bon ayant un peu dompté ma BSD, je test les jails.

 

Lorsque l'on compile le système pour le jail via cette commande :

 

"cd /usr/src && make world DESTDIR=/jails/www"

 

Est ce qu'a la fin de la création du jail je peux bêtement copier ce dossier en vu d'un autre jail, ou alors non il faut à chaque fois faire le make world avec le dossier de destination qui va bien ?

 

EDit : je me répond, c'est plus rapide de copier le système de base depuis une ISO ^^


Message édité par lebibi le 26-04-2016 à 15:25:38

---------------

n°1389912
lesaintk
Il était une fois,
Posté le 27-04-2016 à 10:50:26  profilanswer
 

Pourquoi n'utilise tu pas un utilitaire comme ezjail / cbsd / qjail /cbsd ?


---------------
FIN.
n°1389922
empoisonne​ur
Fucked Up Beyond Any Repair
Posté le 27-04-2016 à 16:13:22  profilanswer
 

Ou même manuellement, en passant par des "thin jails" ou des snapshots ZFS : https://clinta.github.io/freebsd-jails-the-hard-way/ ?
 
Perso, j'aime bien les "thin jails" en fait, en cas de mise à jour système, il n'y a qu'une seule mise à jour à faire :D


---------------
Situation Normal : All Fucked Up.
n°1392442
gizmo15
Posté le 19-07-2016 à 12:48:41  profilanswer
 

Hôla,
 
Petite question: un soft de backup à recommander?
J'ai essayé backup ninja, mais y a des commandes bash linux dedans qui sont pas dispo sur un bash freebsd de ce que j'ai testé.
 
Merci

n°1392846
deeplodoku​s
Posté le 31-07-2016 à 18:34:16  profilanswer
 

Salut ! Utilisateur depuis très longtemps de Linux, je passe mon serveur (bon j'ai pas grand chose dessus)  sous freebsd :)

 

bon ce message est plus un drap qu'autre chose... :)  à bientôt !

n°1396019
lebibi
Notre torture c'est la tourtel
Posté le 12-10-2016 à 11:39:09  profilanswer
 

Version 11 dispo, en cours d'upgrade ^^
 
Quelle est la technique pour mettre à jour ses jails ?


---------------

n°1396401
gizmo15
Posté le 21-10-2016 à 00:13:41  profilanswer
 

Bonsoir,
 
Petite question:
je souhaite mette sur mon desktop freebsd 10.3 avec slim et mate.
mate pas de soucis ca ce lance, sauf que slim même avec slim_enable dans le rc.conf il ne se lance jamais.
Une idée du pk?
 
un startx fonctionne nickel.
j'ai bien renseigné le .xinitrc dans mon profile avec exec mate-session mais ca change rien.
 
Merci

n°1396448
deeplodoku​s
Posté le 22-10-2016 à 21:56:43  profilanswer
 

:bounce: yop!

 

(bon je sais que je peux rtfm et ask google mais je pose la question ici en parallèle de me renseigner)

 

je peux installer freebsd sur une partition en utilisant grub2 qui est sur une partition /boot séparée sans tout bousiller? des choses particulières à savoir? freebsd gère luks et lvm sans tout péter? :D

 

détails:
partition table DOS
/dev/sda1 ext2 1G /boot (grub2 ubuntu)
/dev/sda2 mon root ubuntu
/dev/sda3 libre (15G), ce serait ici que j'aurais soit le root freebsd ou bien un bsd label (ça fait un moment que j'ai pas mis les pieds dans les bsd, je me souviens plus trop :whistle: )
/dev/sda4 extended qui contient /dev/sda5 luks qui contient du lvm

 

merci bien :jap:

 

edit: bon je pense tout simplement faire le test sur une VM avant de faire ça sur mon disque, mes moyens de recovery en cas de soucis sont très limités actuellement :) (pas peur de péter mon grub2, mais peur de perdre ma lvm)

 

edit2: nickel dans une VM:
- installer freebsd et partitionner manuellement
- reboot sous linux (freebsd semble ne pas installer de bootloader dans le MBR mais utiliser le flag "bootable" de la slice BSD, donc avec un bootloader déjà présent ça continue à utiliser le grub de linux)
- 2 modifs à faire: (base debian)
/etc/grub.d/40_custom

Code :
  1. menuentry "FreeBSD" {
  2.     set root='(hdX,Y)'
  3.     kfreebsd /boot/loader
  4. }


/etc/default/grub: comment out GRUB_HIDDEN_TIMEOUT=0
puis update-grub

 

bon, je vais voir ce que donne freebsd11 sur un laptop :)

 

edit3: et nickel direct sur mon laptop, à ceci près que j'ai bien fait de vérifier le /etc/fstab de freebsd avant de rebooter ayant installé depuis une clef usb (je sais pas si freebsd gère les UUID dans fstab, mais l'installeur en tout cas n'utilise pas les UUID pour le fstab; et du fait de la clef usb utilisée pour booter/installer, mon disque dur était indiqué comme /dev/ad1 au lieu de ad0). bon, maintenant, faire marcher le wifi et installer tout le tralala :)

 

à bientôt! :hello:


Message édité par deeplodokus le 23-10-2016 à 01:12:39
n°1396493
gizmo15
Posté le 24-10-2016 à 10:15:11  profilanswer
 

Bon je me réponds:  
passer de 10.2 à 11 directement c'est sale et ca pas marche super :D
 
du coup, 11 + xorg + slim + mate et roulez \o/
 
me reste à gérer la langue dans slim.

n°1399983
gizmo15
Posté le 23-01-2017 à 13:38:57  profilanswer
 

Bonjour,

 

petite question:
le paramètre ipv6_defaultrouter n'est pris en compte dans aucune de mes VM, si je passe la route à la main ca fonctionne, une idée d'où ca peut venir?

 

ce sont des FreeBSD 11.

 

Merci

 

edit: c'est valable aussi pour les v4 donc defaultrouter

 

edit2: soucis trouvé, l'édition du rc.conf par la web console de proxmox rajoutait un saut de ligne.


Message édité par gizmo15 le 23-01-2017 à 14:42:30
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  ..  61  62  63  64  65  66
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
[OpenBSD] Le topic du poisson qui pique (6.1 out! En route vers 6.2)Problème d'update Fedora (version de kernel, nvidia inside)
ubuntu version 6. qqqch ecran noir instal sur portableCat en version colorée ?
ldap / samba - guide - CA MARCHE !! WIKI dispoPidgin 2.6.0 (Voice and video support)
quelle version linux?[FreeBSD 5.4 Stable] Pure-FTPd et FXP
Plus de sujets relatifs à : [Topic FreeBSD] nouvelle version 10.0 dispo !!



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR