Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
727 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [ATI] Pilotes libres x11-driver-video-ati x11-driver-video-radeonhd

 

 

 Mot :   Pseudo :  
 
 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16
Page Précédente
Auteur Sujet :

[ATI] Pilotes libres x11-driver-video-ati x11-driver-video-radeonhd

n°1113905
mikala
Souviens toi du 5 Novembre...
Posté le 17-02-2009 à 14:11:44  profilanswer
 

Ce sujet a pour but de traiter des pilotes vidéos libres permettant d'utiliser les cartes graphiques d'ATI/AMD.
A l'heure actuelle il existe deux pilotes videos :  
 

         
          wiki radeon sur x.org  
          Le pilote ati supporte actuellement les cartes graphiques basées sur les chipsets R100/R200, R300/R400/R500 et R600/R700
          Le support 3d est considéré comme stable pour les cartes graphiques basés sur les R100/R200, R300/R400/R500 a partir de Mesa 7.2 et des x11-driver-video-ati.6.9
          Ce même support 3d est en cours de réécriture au niveau de mesa (Article de Phoronix)
          Le support de Randr 1.2 est inclus.
 

 
             Wiki du pilote radeonhd
             Cette branche propose :
            -  le support  des cartes à partir du chipset R500
            -  le support de xv pour les cartes de la génération R6xx et R7xx (sous réserve de l'utilisation des drm ad hoc qui seront incluses dans le kernel 2.6.30)
            -  une accélération 2D (EXA) pour les cartes R6xx et R7xx
            -  Il n'y a pas de support 3d  a l'heure actuelle mais il y  a de la documentation fourni par ATI et le travail est en cours.
           

  •   c) Tableau comparatif des pilotes libres ( radeon versus radeonhd (RHD) )


 
          On peut retrouver un tableau à jour concernant les possibilités de ces driver en suivant ce lien vers le wiki ad hoc.
          http://www.littleboboy.net/%7Emikala/screenshot/ati/Radeon.png
          On note ainsi un support de Xv sur les Chipsets R100 à R400 et un support du Textured Vidéo du R100 au R500.
          Le Textured Video consiste « simplement  » à utiliser le moteur 3D afin de fournir Xv, je vous invite à lire ceci (Article de l'un des développeurs de radeonhd) et encore  
          un article de Phoronix.
 
 
 


 

  • Documents fournis par ATI/AMD  


http://www.x.org/docs/AMD/R5xx_Acceleration_v1.4.pdf <- Documentation relative aux R5xx
http://www.x.org/docs/AMD/R6xx_R7xx_3D.pdf <-----   Documentation relative aux R6xx,R7xx
http://www.x.org/docs/AMD/ d'une manière générale
 
http://ati.amd.com/developer/open_ [...] ation.html
 

  • d) Quelques comparatifs réalisés par Phoronix entre les pilotes libre et le pilote propriétaire d'AMD (fglrx ou Catalyst):  


            En 2D
            Chipset R500  x11-driver-video-ati-6.10 vs Catalyst 8.12
            Radeon HD 4850 avec les Catalyst 8.12 et le driver radeonhd en 2d (avec le support de exa de la branche r6xx_r7xx)
            Mesa vs Catalyst sur les R5xx
            Comparatif des performances 2D concernant les R6xx et R7xx Pilotes libres contre Propriétaires
 
 
 
                                                                                                                                                     Changelog des pilotes xf86-video-ati
 
 

  • xf86-video-ati 6.11.0  

          Annonce et Changelog sur la Mailing List de Xorg
          Annonce sur Phoronix
          Un détail intéressant dans la lecture du changelog de cette version est ceci:  
         

Citation :

6.12.0 will be soon to follow with accel support for r6xx/r7xx chips


.
          On peut donc imaginer l'apparition d'EXA sous peu en lieu et place de shadowfb
          Pour le reste il y a essentiellement des corrections de bugs depuis le 6.10
 


          Comme annoncé il y a l'apparition du support de EXA et de X-Video pour les R600 et R700 sous réserver d'avoir un DRM a jour au niveau kernel.
          Après quelques corrections de bugs
 


 
              Ce sont essentiellement des corrections de bugs et une amélioration du Textured Video pour les r2xx et r3xx
 


 
                    Au sommaire, corrections de bugs, ajout de quelques pci ids  
 
 
 
                                                                                                                                                     [Changelog des pilotes  xf86-video-radeon-hd
 
 


 
           On notera l'apparition du support de X-Video pour les cartes R6xx et R7xx.
                            l'accélération 2D disponible désormais pour ces deux générations
                            l'activation du DRI par défaut pour les cartes R5xx et R6xx
                            le support des cartes basés sur le RS880 et le RV790.
                            une amélioration du support de Randr 1.3
 


 
           On notera entre autre :  
                   - le support des chipsets RV740, M92, M93, M97.
                   - le support du  HDMI audio sur les chipsets RS690 et R700.
                   - le support pour de la gestion d'énergie.
                   - une amélioration de la lecture des tables  AtomBIOS .
                   - EXA (l'accélération 2D) est désormais activé par défaut sauf sur les cartes basées sur le RV740.
                   - une meilleure gestion du rétro-éclairage (compatibilité avec xbacklight 1.1.1)  
                   - et de nombreuses corrections de bugs ;)


Message édité par mikala le 27-10-2009 à 22:58:32

---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
mood
Publicité
Posté le 17-02-2009 à 14:11:44  profilanswer
 

n°1114076
the_k586
♥ Punk à Chats ♥
Posté le 17-02-2009 à 21:39:50  profilanswer
 

[:drapal]
Malgré que je n'ai JAMAIS réussi a faire marcher ni mes 9700 ni mes 9600 ni ma 9800XT ! (et c'est pas faute d'avoir essayé :o )


---------------
♦ bl0g ♦ // ♠ Twitter ♠ // << Just for the lulz ! The Only reason anyone does anything >> // Free Open DNS
n°1114098
burn2
ça rox du poney
Posté le 17-02-2009 à 22:12:29  profilanswer
 

Je drapalise aussi pour suivre l'actualité. :)


---------------
Mon topic sur OpenSuse ;)
n°1114121
guepe
J'ai du noir sur la truffe ?
Posté le 17-02-2009 à 22:57:03  profilanswer
 

Carrement pareil ! (possesseur d'une R300 Mobility qui fonctionne depuis toujours avec x11-driver-video-ati)
Je regrette la faiblesse des drivers pour la 3D, meme les effets super legers de compositing via metacity passent mal (bon mon ecran est en 1600*1200 c'est quand meme beaucoup).
 
Sinon je suis content depuis que randr 1.2 est implemente, sur un laptop... ca permet de s'en servir sans problemes pour des presentations (avec impressive par exemple, c'est  :love: )


---------------
Un blog qu'il est bien
n°1114199
Tom_
Posté le 18-02-2009 à 10:57:51  profilanswer
 

[:drapal] Je drapalise aussi vu que je vais peut-être changé de carte graphique prochainement.
 
Le support de Xv est présent en expérimental ... c'est déja pas mal. :) Quelqu'un sait si c'est prévu ou non d'implémenter la lecture hardware de videos (genre pour lire des videos HD)?  
 
Merci  :jap:

n°1114313
TNZ
FX-8350 powered ...
Posté le 18-02-2009 à 14:27:04  profilanswer
 

J'vais suivre aussi ... Radeon X800XT/3650 sous KDE 4.2 :D

n°1114337
thana54
made in concept
Posté le 18-02-2009 à 15:43:50  profilanswer
 

Tom_ a écrit :

[:drapal] Je drapalise aussi vu que je vais peut-être changé de carte graphique prochainement.
 
Le support de Xv est présent en expérimental ... c'est déja pas mal. :) Quelqu'un sait si c'est prévu ou non d'implémenter la lecture hardware de videos (genre pour lire des videos HD)?  
 
Merci  :jap:


C'est prévu, mais je me suis perdu dans les techno citées :/

n°1114356
toutsec
Posté le 18-02-2009 à 16:20:49  profilanswer
 

[:kikidonc]

n°1114357
mikala
Souviens toi du 5 Novembre...
Posté le 18-02-2009 à 16:21:19  profilanswer
 

Dans un premier temps ce sera le support deXvMC qui permettra d'utiliser le GPU pour certaines applications.
Ce support est semble t'il en cours d'intégration dans les pilotes propriétaires d'ATI/AMD.
Du coté de NVIDIA il  y a Video Decode and Presentation API for Unix l'équivalent du coté d'ATI étant XvBA qui repose notamment sur l'Unified Video Decoder (UVD).


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1114677
guepe
J'ai du noir sur la truffe ?
Posté le 19-02-2009 à 14:36:16  profilanswer
 

Une news sur les drivers ati : http://www.phoronix.com/scan.php?p [...] &px=NzA3NA
 
Pas de gros changements  :jap:


---------------
Un blog qu'il est bien
mood
Publicité
Posté le 19-02-2009 à 14:36:16  profilanswer
 

n°1114684
mikala
Souviens toi du 5 Novembre...
Posté le 19-02-2009 à 14:39:26  profilanswer
 

c'est déja inscrit dans le premier message (que je complète petit a petit) :)
cependant l'information importante est dans le changelog du 6.11 :D
a priori exa sera disponible pour  les r6xx et r7xx


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1115052
Mjules
Modérateur
Parle dans le vide
Posté le 20-02-2009 à 11:15:11  profilanswer
 

un petit lien vers le topic sur les chips intel aussi dans l'entête  ? :D

 

http://forum.hardware.fr/forum2.ph [...] post=68872


Message édité par Mjules le 20-02-2009 à 11:15:17

---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1115097
mikala
Souviens toi du 5 Novembre...
Posté le 20-02-2009 à 12:12:33  profilanswer
 

Il ne manque plus qu'un topic sur Xorg :o


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1117421
mikala
Souviens toi du 5 Novembre...
Posté le 27-02-2009 à 11:56:24  profilanswer
 

Conformément au changelog des xf86-driver-video-ati-6.11, l'accélération 2D fait son apparition dans la version git des futurs xf86-driver-video-ati.
source : http://www.botchco.com/agd5f/?cat=3
L'accélération est donc présente tant au niveau des pilotes  radeonhd (dans la branche r6xx-r7xx) mais également au niveau de la branche principale des pilotes ati.
Pour être tester il nécessite cependant l'utilisation d'un DRM (voir le topic dédié a xorg pour plus d'informations) particulier.
Il faut noter que ce dernier compile désormais sous le 2.6.29.
 
l'activation se réalise dans la section Device :

Citation :


Section "Device"
        Driver      "ati"
        [...]
        Option      "AccelMethod" "exa" # default shadowfb
        Option      "DRI" "on"
         [...]
EndSection  


 
ce qui donne chez moi  
 

Citation :

% uname -a && xvinfo
Linux cryptic.littleboboy.net 2.6.29-desktop-0.rc6.1.1mnb #1 SMP Tue Feb 24 15:44:36 EST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU     E8500  @ 3.16GHz GNU/Linux
X-Video Extension version 2.2
screen #0
  Adaptor #0: "Radeon Textured Video"
    number of ports: 16
    port base: 57
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 2
      "XV_BICUBIC" (range 0 to 2)
              client settable attribute
              client gettable attribute (current value is 2)
      "XV_VSYNC" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
    maximum XvImage size: 8192 x 8192
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)


 
 
A priori selon l'article de Phoronix, la DRM arrivera dans le kernel 2.6.30 :D


Message édité par mikala le 27-02-2009 à 18:17:23

---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1117526
mikala
Souviens toi du 5 Novembre...
Posté le 27-02-2009 à 19:40:36  profilanswer
 

bon a priori le support XV a été également transféré dans la branche principale de radeonhd :o même si il n'est pas encore activé par défaut.
Je pense que l'activation par défaut ne surviendra a priori pas avant  que  drm-next soit inclus dans le kernel (donc comme dit plus haut le 2.6.30). Vu que cela laisse place a quelques mois on peut éventuellement espérer l'arrivée de quelques briques pour l'accélération 3d au niveau de Mesa.


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1118388
ledesillus​ionniste
Posté le 03-03-2009 à 19:12:21  profilanswer
 

merci pour ce topic !


---------------
Le dépannage de votre pc sur Nivelles Gosselies Fleurus Genappe Les-Bons-Villers Liberchies http://www.monpcfonctionne.com
n°1121733
mikala
Souviens toi du 5 Novembre...
Posté le 14-03-2009 à 05:17:58  profilanswer
 

Up, sortie des 6.12 ou l'on note  surtout un travail concernant les  r600/700 avec le support de EXA et de X-Video


Message édité par mikala le 14-03-2009 à 05:36:50

---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1122077
cactus
Posté le 15-03-2009 à 22:56:36  profilanswer
 

[:blueflag]  
(merci Mikala ! ;) )

n°1123215
mikala
Souviens toi du 5 Novembre...
Posté le 20-03-2009 à 12:23:29  profilanswer
 

En ce qui concerne les utilisateurs de mandriva, la version de drm nécessaire a l'utilisation de EXA et de Xvideo va faire son apparition dans le kernel de mandriva \o/ (basé sur le 2.6.29)
l'annonce est ici http://lists.mandriva.com/cooker/2009-03/msg01170.php


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1124610
ogaby
Posté le 26-03-2009 à 21:15:52  profilanswer
 

Bon j'ai installé le pilote et j'en suis globalement content. Les perfs en 2D sont franchement meilleures que le pilote proprio.
Seulement GoogleEarth est chez moi très lent et ça fini par planté. Donc je me demande si l'accélération 3D est activée.
Quand je lance glxgears, je vois bien les roues et un xvinfo me donne

Citation :

Adaptor #1: "Radeon Textured Video"
    number of ports: 16
    port base: 58
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21


 
Mon xorg

Citation :

Section "Device"
        Identifier      "Configured Video Device"
        Option          "UseFBDev"              "true"
        #Driver "radeon"
        Driver      "ati"
        Option      "AccelMethod" "exa" # default shadowfb
        Option      "DRI" "on"
        Option "GARTSize" "64"
         # 0-64 Megabytes of gart (system) memory used.
         # Wrongly defaults to 8MB sometimes, see your logfile.
         # Bigger seems better.
EndSection


Citation :

lsmod | grep drm
drm                    65256  3 radeon
agpgart                28776  2 drm,ati_agp


Normalement j'ai bien la 3D non?


---------------
Mon album vidéo  Mes vidéos sur Hadopi
n°1124613
Pat Atra
le virus sympa!
Posté le 26-03-2009 à 21:49:46  profilanswer
 

ogaby a écrit :

Donc je me demande si l'accélération 3D est activée.


Eh bien ça dépend de ta carte graphique...
Par ici pour les détails...
 
Sinon, est-ce que ce driver gère les ventilos correctement?
Parce que ça a beau être libre, mais si mon portable chauffe à cause de ces drivers, il est hors de question de l'utiliser. :o  
Si ça fonctionne, par contre, je renonce aux fenêtres molles de kwin 4.

n°1124623
ogaby
Posté le 26-03-2009 à 22:28:59  profilanswer
 

Ma carte n'est pas sous la branche radeonhd mais ati. J'ai une Radeon Xpress 200M et c'est donc la puce RV380/M22 ici: http://dri.freedesktop.org/wiki/AT [...] de9ab5602a


---------------
Mon album vidéo  Mes vidéos sur Hadopi
n°1124642
Pat Atra
le virus sympa!
Posté le 27-03-2009 à 00:10:28  profilanswer
 

Donc ça devrait marcher si on en croit cette page.
 
Est-ce que ça, ça marche? comme ils citent du R300 également comme exemple...


Message édité par Pat Atra le 27-03-2009 à 00:12:14
n°1124649
ogaby
Posté le 27-03-2009 à 07:45:29  profilanswer
 

Je me rappelais plus comment tester si mesa est actif. Merci :jap:

Citation :

glxinfo|grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 NO-TCL


 
Donc c'est actif chez moi mais GoogleEarth ne marche pas bien. Perso, j'en fais pas une maladie car c'est un soft que j'ouvre rarement. En comparant les perfs de l'ordi, je préfère le pilote libre.
 
Ce week-end, j'essaierai quelques options là: http://dri.freedesktop.org/wiki/AT [...] 20eaf29566
mais sans trop insister.
 
Merci encore.


---------------
Mon album vidéo  Mes vidéos sur Hadopi
n°1124678
Pat Atra
le virus sympa!
Posté le 27-03-2009 à 09:55:49  profilanswer
 

De rien.  :jap:  
 
Et j'en profite pour reposer ma question:
Sinon, est-ce que les drivers libres gèrent les ventilos correctement?  

n°1124812
ogaby
Posté le 27-03-2009 à 18:27:15  profilanswer
 

Bon la dernière fois que j'ai ouvert mon portable, je crois qu'il n'y avait pas de ventilo sur la CG.  
 
Bon peut-être que quelqu'un te répondra mais jamais entendu in problème de ce côté là.


---------------
Mon album vidéo  Mes vidéos sur Hadopi
n°1124819
Mjules
Modérateur
Parle dans le vide
Posté le 27-03-2009 à 18:50:32  profilanswer
 

ogaby a écrit :

Bon j'ai installé le pilote et j'en suis globalement content. Les perfs en 2D sont franchement meilleures que le pilote proprio.
Seulement GoogleEarth est chez moi très lent et ça fini par planté. Donc je me demande si l'accélération 3D est activée.
Quand je lance glxgears, je vois bien les roues et un xvinfo me donne

Citation :

Adaptor #1: "Radeon Textured Video"
    number of ports: 16
    port base: 58
    operations supported: PutImage
    supported visuals:
      depth 24, visualID 0x21


 
Mon xorg

Citation :

Section "Device"
        Identifier      "Configured Video Device"
        Option          "UseFBDev"              "true"
        #Driver "radeon"
        Driver      "ati"
        Option      "AccelMethod" "exa" # default shadowfb
        Option      "DRI" "on"
        Option "GARTSize" "64"
         # 0-64 Megabytes of gart (system) memory used.
         # Wrongly defaults to 8MB sometimes, see your logfile.
         # Bigger seems better.
EndSection


Citation :

lsmod | grep drm
drm                    65256  3 radeon
agpgart                28776  2 drm,ati_agp


Normalement j'ai bien la 3D non?


 
xvinfo ne te dira rien sur l'accélération 3D, vu que c'est un utilitaire pour connaitre l'état de l'extension Xvidéo.
 

ogaby a écrit :

Je me rappelais plus comment tester si mesa est actif. Merci :jap:

Citation :

glxinfo|grep render
direct rendering: Yes
OpenGL renderer string: Mesa DRI R300 20060815 x86/MMX/SSE2 NO-TCL


 
Donc c'est actif chez moi mais GoogleEarth ne marche pas bien. Perso, j'en fais pas une maladie car c'est un soft que j'ouvre rarement. En comparant les perfs de l'ordi, je préfère le pilote libre.
 
Ce week-end, j'essaierai quelques options là: http://dri.freedesktop.org/wiki/AT [...] 20eaf29566
mais sans trop insister.
 
Merci encore.


 
 
oui, là, c'est actif. De mémoire, google earth lent, c'est un bug connu lié à un manque d'accélération d'une extension mais je sais plus laquelle.
 
Sinon, mesa est toujours actif sauf si mal installé vu que c'est la lib qui implémente OpenGL. Après, elle coopère ou non avec le pilote DRI pour accélérer le tout, ici le DRI est actif.
Notons également que dans les versions récentes de Mesa, on peut avoir un rendu direct non accéléré.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1124836
mikala
Souviens toi du 5 Novembre...
Posté le 27-03-2009 à 20:21:28  profilanswer
 

un petit post pour confirmer que Xvideo et exa fonctionne désormais par défaut avec le kernel de mandriva a partir de la version  
mikala@osiris [~] % uname -r
2.6.29-desktop-1mnb


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1124859
wolverine2​4425
Hello the world
Posté le 28-03-2009 à 02:54:57  profilanswer
 

uname -r  
2.6.28-ARCH
j'ai installé
aur/xf86-video-radeonhd-git-r6xx-r7xx
ça marche sur une radeon hd3870

Spoiler :

xvinfo
Xlib:  extension "Generic Event Extension" missing on display ":0.0".
X-Video Extension version 2.2
screen #0
  Adaptor #0: "RadeonHD Textured Video"
    number of ports: 16
    port base: 85
    operations supported: PutImage  
    supported visuals:
      depth 24, visualID 0x21
    no port attributes defined
    maximum XvImage size: 8192 x 8192
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)


I l :love: ve arch
 
Bon now j'attends le support 3d


---------------
It's No life!
n°1124860
mikala
Souviens toi du 5 Novembre...
Posté le 28-03-2009 à 02:57:09  profilanswer
 

en fait je voulais préciser que les backports de drm étaient incluses dans le kernel de mandriva ;)
Étant donné la position des développeurs de arch, ils seraient intéressants de leur proposer une telle disposition éventuellement non ?


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1124880
Pat Atra
le virus sympa!
Posté le 28-03-2009 à 12:55:22  profilanswer
 

ogaby a écrit :

Bon la dernière fois que j'ai ouvert mon portable, je crois qu'il n'y avait pas de ventilo sur la CG.

Ah bon. Ayant déjà eu des problèmes de surchauffe de carte graphique, je pensais qu'il y avait un moyen de refroidir la chose...
Du coup, je n'ai plus d'excuse pour ne pas essayer.


Message édité par Pat Atra le 28-03-2009 à 12:55:35
n°1124881
burn2
ça rox du poney
Posté le 28-03-2009 à 13:01:27  profilanswer
 

Ce qu'il faut comprendre:
Chaque portable est différent, parfois y a un ventilateur directement pour le gpu parfois non. Si c'est le cas, y a une forte probabilté qu'il soit dépendant de la température gpu pour les pc portable. Si ce n'est pas le cas, c'est via calloduc et envoyé sur le rad cpu, donc par transfert, plus le gpu chauffe, plus le ventilateur du cpu tournera vite car fera chauffer le cpu.  
 
Le gros problème sur les pc portable, c'est donc:
-est ce que l'état 2D est bien géré! Baisse des fréquences, mise en veille de ce qui est inutilisé, sinon chauffe gpu = ventilo qui turbine quelque soit la solution...  
Et c'est souvent ça qui est mal géré. :/  
 
Pour mon cas chez nvidia, avec le pilote nv ou nouveau ça turbine niveau ventilateur car mon gpu est mal mis en veille en idle et sa fréquence pas baissée, pourtant je n'ai qu'un seul ventilateur sur le cpu. Et ça en général les pilotes libres sont loins de gérer le matériel si proche d'une manière hardware pour bouger les states idle etc.
Par analogie c'est comme si votre cpu intel n'avait pas de powerstep et de réduction de fréquence + mise en veille des unités inutilisées.  
 
Mais bon ce support est variables en fonction des gpu et des séries. Donc à tester.


Message édité par burn2 le 28-03-2009 à 13:05:36

---------------
Mon topic sur OpenSuse ;)
n°1124889
ogaby
Posté le 28-03-2009 à 14:33:06  profilanswer
 

Mjules a écrit :

oui, là, c'est actif. De mémoire, google earth lent, c'est un bug connu lié à un manque d'accélération d'une extension mais je sais plus laquelle.
...


Après une recherche sur le net, j'ai vu qu'il faut désactiver l'affichage de l'atmosphère. Et maintenant c'est tout bon. :)
 
Pour ce qui est de la température, je monte quand je lance google earth puis redescend quand je ferme. Donc je pense que c'est bien géré (chez moi ou avec ma carte).
 
@burn2
le calloduc c'est le tube plein en cuivre?


---------------
Mon album vidéo  Mes vidéos sur Hadopi
n°1124890
burn2
ça rox du poney
Posté le 28-03-2009 à 14:39:09  profilanswer
 

Ouep pour le calloduc.


---------------
Mon topic sur OpenSuse ;)
n°1124898
sebfun
parallel universe
Posté le 28-03-2009 à 16:29:46  profilanswer
 

bonjour
 
ha ya même un topik consacrer a ce driver
drapal  [:cerveau drapal]  
 
sinon j'ai installer les paquets radeon hd dans synaptic (ubuntu) , j'ai virer "fglrx"  
et éditer mon xorg.conf comme ceci  

Code :
  1. Section "Device"
  2. Identifier "Configured Video Device"
  3.         Driver          "ati"
  4.         Option          "MonitorLayout"          "CRT, TMDS"
  5.         Option          "EnablePageFlip"        "on"
  6. EndSection
  7. Section "Monitor"
  8. Identifier "Configured Monitor"
  9. EndSection
  10. Section "Screen"
  11. Identifier "Default Screen"
  12. Monitor  "Configured Monitor"
  13. Device  "Configured Video Device"
  14. EndSection
  15. Section "ServerFlags"
  16. Option "DontZap" "false"
  17. EndSection


comment vérifier que je tourne bien sur le driver libre ?


Message édité par sebfun le 28-03-2009 à 16:31:07
n°1124908
Mjules
Modérateur
Parle dans le vide
Posté le 28-03-2009 à 18:39:16  profilanswer
 

Driver "ati"
 
tu es sur le libre.
 
et il y a 2 pilotes : ati et radeonhd


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°1124913
sebfun
parallel universe
Posté le 28-03-2009 à 19:42:03  profilanswer
 

:jap:

n°1124917
wolverine2​4425
Hello the world
Posté le 28-03-2009 à 21:52:09  profilanswer
 

Bon après essai de la version git de radeonhd, c'est pas encore au point, en effet j'ai un problème de scrolling, problème de rafraîchissement dans firefox, donc je revient à la version "stable" de radeonhd, a moins que quelqu'un à un tuyau à me filer pour y remédier, donc je visiterais ce topic un peu plus souvent .Pour les pilotes proprio de ATI je les mettrais bien mais j'ai un problème de freeze aléatoire que j'avais aussi sous windows, j'en conclus que les pilotes proprio sont pas encore au point aussi, avec radeonhd "stable" aucun problème sauf un glxgears merdique de 500 et quelques, c'est bête pour une hd3870, je pense que je vais me rabattre vers Nvidia car là ça fait trop, à moins que j'attends que ATI veulent bien fournir la documentation aux développeurs radeonhd(qui font un travail formidable).


---------------
It's No life!
n°1124919
mikala
Souviens toi du 5 Novembre...
Posté le 28-03-2009 à 22:13:32  profilanswer
 

Personnellement je me sers des drivers ati avec EXA d'activé.
Concernant les drivers propriétaires es tu sur que l'accélération 3D soit active ?
Pour finir ATI/AMD a fourni une quantité d'information relative au R600/R700 et le travail sur la 3D est en cours (sans compter le travail de réécriture de la partie radeon de mesa)


---------------
Forum des Internes Antilles-Guyane|Mandriva GNU/Linux 2010.0 |
n°1124925
wolverine2​4425
Hello the world
Posté le 29-03-2009 à 01:25:33  profilanswer
 

les drivers libres ati et radeonhd sont deux projets bien distinct , en tout cas au lieu de EXA j'ai remis XAA et je n'ai plus de problèmes de scrolling , pour ATI proprio je te rassure l'accelération 3D était bien active, compiz fonctionne comme sur des roulettes, mais ces histoires de freezes "aléatoires", ça arrive surtout lorsque je navigue via firefox(les autres j'ai pas essayé), j'ai bien cherché dans tous les sens mais rien de concluant :( , donc je me suis tourné vers les libres radeonhd qui eux sont impeccable(pas de freezes), je signale bien que çà le fait aussi sous windows avec les catalysts que linux avec les catalysts, donc soit je ne comprend plus rien, ou soit les pilotes catalysts(windows et linux) sont mal codés quelques parts, alors pour l'instant je reste sous radeonhd qui fonctionne impeccable. Au cas ou je laisse mon xorg.conf.Et un petit lien d'une personne ayant le même problème de scrolling.http://bbs.archlinux.org/viewtopic.php?id=66603

Citation :

Section "ServerLayout"
 Option "AIGLX" "true"
 Identifier     "Xorg Configured"
 Screen      0  "Screen0" 0 0
 InputDevice    "Keyboard0" "CoreKeyboard"
 InputDevice    "Mouse1" "CorePointer"
EndSection
 
Section "ServerFlags"
 Option "AllowMouseOpenFail"  "true"
 Option "AutoAddDevices" "False"
 
EndSection
 
Section "Files"
 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/misc:unscaled"
 FontPath     "/usr/share/fonts/misc"
 FontPath     "/usr/share/fonts/75dpi:unscaled"
 FontPath     "/usr/share/fonts/75dpi"
 FontPath     "/usr/share/fonts/100dpi:unscaled"
 FontPath     "/usr/share/fonts/100dpi"
 #FontPath     "/usr/share/fonts/PEX"
# Additional fonts: Locale, Gimp, TTF...
 #FontPath     "/usr/share/fonts/cyrillic"
# FontPath     "/usr/share/lib/X11/fonts/latin2/75dpi"
# FontPath     "/usr/share/lib/X11/fonts/latin2/100dpi"
# True type and type1 fonts are also handled via xftlib, see /etc/X11/XftConfig!
 FontPath     "/usr/share/fonts/Type1"
 #FontPath     "/usr/share/fonts/ttf/western"
 #FontPath     "/usr/share/fonts/ttf/decoratives"
 #FontPath     "/usr/share/fonts/truetype"
 #FontPath     "/usr/share/fonts/truetype/openoffice"
 #FontPath     "/usr/share/fonts/truetype/ttf-bitstream-vera"
 #FontPath     "/usr/share/fonts/latex-ttf-fonts"
 #FontPath     "/usr/share/fonts/defoma/CID"
 #FontPath     "/usr/share/fonts/defoma/TrueType"
EndSection
 
Section "Module"
        Load  "ddc"  # ddc probing of monitor
 Load  "dbe"
 Load  "dri"
 Load  "drm"
 Load  "extmod"
 Load  "glx"
        Load  "bitmap" # bitmap-fonts
 Load  "freetype"
 Load  "int10"
 Load  "vbe"
 Load  "evdev"
 #Load  "type1"
 #Load  "record"  
 #Load  "synaptics"
EndSection
 
Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "keyboard"
        Option      "CoreKeyboard"
 Option "XkbRules" "xorg"
 Option "XkbModel" "pc105"
 Option "XkbLayout" "fr"
 Option "XkbVariant" "oss"
 Option "XkbOptions" "compose:rwin"
EndSection
 
Section "InputDevice"
        Identifier      "Mouse1"
        Driver          "evdev"
 #Option          "Protocol" "evdev"
 #Option          "Dev Phys" "usb-0000:00:1a.0-2/input0"
        Option          "Device"                "/dev/input/event4"
 Option  "SendCoreEvents" "true"
        Option          "Protocol"              "IMPS/2"
        Option          "ZAxisMapping"          "4 5"
        Option          "Buttons"               "5"
 Option          "CorePointer"
 Option          "Name"                  "Razer DeathAdder"
EndSection
 
# Auto-generated by Archie mkxcfg
 
Section "Monitor"
 Identifier "Monitor0"
 Option "DPMS" "true"
 HorizSync    31.5 - 74.5
 VertRefresh  59.88 - 60.32
 Modeline "1920x1200_60.00"  193.16  1920 2048 2256 2592  1200 1201 1204 1242  -HSync +Vsync #MB24VW
EndSection
 
# Auto-generated by Archie mkxcfg
 
 
Section "Device"
 Identifier  "Card0"
 Driver      "radeonhd"
 VendorName  "All"
 BoardName   "All"
 Option      "AccelMethod" "xaa"  
 Option      "DRI" "True"  
 #Option      "AccelDFS"    "1"  
 #Option     "EnablePageFlip" "1"  
 #Option     "AccelMethod"  "ShadowFB"
 #Option     "XAANoOffscreenPixmaps" "true"  
 #Option     "ColorTiling" "1"
EndSection
 
 
Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 DefaultColorDepth 24
  SubSection "Display"
  Depth     24
  Modes "1920x1200"
 EndSubSection
 SubSection "Display"
  Depth     32
  Modes "1920x1200"
 EndSubSection
EndSection
 
Section "DRI"
 Mode 0660
EndSection
 
Section "Extensions"
  Option "Composite" "Enable"
EndSection


 
edit de mikala: j'ai viré le spoiler pour un simple quote, c'est plus simple en terme de lisibilité


Message édité par mikala le 09-04-2009 à 16:48:16

---------------
It's No life!
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  16
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  [ATI] Pilotes libres x11-driver-video-ati x11-driver-video-radeonhd

 

Sujets relatifs
ubuntu 8.10 pas de video dans players mais youtube okLes Chipsets Graphiques Intel - Version 2.11.0 Dispo !
Créer une vidéo à partir d'une imageMonter un lecteur video sous linux
installation pilotes nvidia mandriva 2009Passage a Linux - je garde ma NVidia ou je peux prendre une ATI ?
j'arrive pas a lire un dvd video sur kubuntuAchat laptop avec des bon graphismes avec drivers libres
lecture audio vidéo sur Asus Express GateComment faire pour dans un coin de la video une autre video plus petit
Plus de sujets relatifs à : [ATI] Pilotes libres x11-driver-video-ati x11-driver-video-radeonhd



Copyright © 1997-2016 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR