Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1616 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Problème serveur DELL

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème serveur DELL

n°1133735
kayl669b
Posté le 20-08-2020 à 13:35:13  profilanswer
 

Salut à tous!
Voilà j'ai un très très gros soucis. J'ai un petit magasin de prêt a porter avec un serveur et plusieurs ordinateurs.
Depuis quelques mois, la boite qui m'a installé le serveur (DELL poweredge T300) et installé le logiciel (gestion de stock, étiquetage etc.) a complètement disparu de la circulation.
J'étais en train de chercher une solution alternative et depuis hier CATASTROPHE... Le serveur ne marche plus.  
Au démarrage, après le laïus habituel, j'ai une ligne commençant par Client MAC ADDR, avec un petit curseur qui tourne et des petits points qui apparaissent.
Avec mes faibles connaissance, j'ai ouvert, dépoussiéré l’intérieur pensant à un faux contact. En ouvrant l'avant je me suis aperçu que sur 3 HDD, un seul avait un voyant vert fixe et les 2 autres des voyants vert et orange clignotants (predictive failure d'après le site de DELL). Bizarre que 2 disques lachent en même temps non?
En fouillant un peu plus, je me suis aperçu que le RAID utilisé est un RAID5 et que 2 disques sont marqué comme MISSING quand je fais CTRL+R au moment du boot.
Je suis complètement perdu. J'habite dans une zone rurale et impossible de trouver un dépanneur rapidement.
Que puis je faire dans l'immédiat?
Merci pour votre aide.

mood
Publicité
Posté le 20-08-2020 à 13:35:13  profilanswer
 

n°1133779
HPIR40
Posté le 20-08-2020 à 18:14:00  profilanswer
 

Bonjor

 

Désolé d'être un oiseau de mauvaise augure, mais as tu une sauvegarde externe à ce serveur ou non?

 

Car sur un raid5 si 2 disques sont HS c'est fini, on ne peux plus rien faire. Un raid 5 resiste à la perte d'1 disque mais pas 2....et même un dépanneur ne pourra résoudre le problème, les données ne pourront pas être récupérées.

 

Pour les disques qui lachent en même temps c'est trés rare mais cela arrive. Je pense plutot qu'un disque a laché, tu ne l'a pas vu et donc le serveur a fonctionné en mode dégradé, jusqu'a ce que le deuxieme disque lache et tu en es donc là.

Message cité 1 fois
Message édité par HPIR40 le 20-08-2020 à 18:15:49
n°1133801
kayl669a
Posté le 20-08-2020 à 19:57:44  profilanswer
 

Salut HPIR40.
Tout d'abord, merci pour ta réponse.
Normalement, c'est la société qui gérait le serveur qui s’occupait de faire des sauvegarde à distance.
Plus aucune nouvelle d'eux, ils ont disparut de la circulation.
 
Pensez vous qu'il est possible de mettre ces disques dans un PC classique pour tester leur étant avec un logiciel du style chrystal disk info?
Existe t il un adaptateur SAS-SATA?

n°1133818
NaCl
L'addition va être salée...
Posté le 20-08-2020 à 22:24:39  profilanswer
 

Slt
 
Faudrait un PC avec une carte SAS, tel qu'une LSI 9210-8i (tu peux en trouver pour une bouchée de pain sur eBay), et un câble SFF-8087 vers SFF-8482 (le 8087 ira se brancher sur la carte LSI et le 8482 sur les DD à tester).  
 
Par contre attention les cartes SAS sont souvent en PCIe x4.
 
Normalement si tout va bien CrystalDiskInfo devrait pouvoir récupérer les info SMART des DD SAS, faudra juste sortir les disques HS du serveur et les brancher a la carte LSI sur l'autre PC...


---------------
... ou pas
n°1133840
satoshi
Posté le 21-08-2020 à 10:32:30  profilanswer
 

HPIR40 a écrit :


Pour les disques qui lachent en même temps c'est trés rare mais cela arrive. Je pense plutot qu'un disque a laché, tu ne l'a pas vu et donc le serveur a fonctionné en mode dégradé, jusqu'a ce que le deuxieme disque lache et tu en es donc là.


 
c'est effectivement l'hypothèse la plus probable, surtout sur ces vieux PE Txxx sans hotswap... la led frontale se fait vite oublier... :(
 
"Parfois", simplement débrancher - rebrancher le DD permet au voyant de revenir au vert. A test, ça ne coûte rien, ça "marche" genre une fois sur cent...
 

kayl669a a écrit :


Pensez vous qu'il est possible de mettre ces disques dans un PC classique pour tester leur étant avec un logiciel du style chrystal disk info?
Existe t il un adaptateur SAS-SATA?


Non, pas d'adaptateur. Juste une carte SAS comme expliqué par NaCl. Mais à part lire le SMART, ça ne t'avancera pas à grand chose :/
 
Sur 3x DD RAID5, 2x HS, pour moi c'est mort :o :(

Message cité 1 fois
Message édité par satoshi le 21-08-2020 à 10:32:57
n°1133841
cotorep
Posté le 21-08-2020 à 10:51:04  profilanswer
 

Bonjour
 
je te confirme la diagnostique malheureusement
pas de sauvegarde sur bandes ou NAS ?
apres il existe des societes de recuperations de données mais cela coute chere : comme ontrack
 
pour éviter ce type de probleme , je déploie régulièrement chez nos clients le logiciel  Dell SupportAssist Version 1.3 , ce logiciel permet d'ouvrir un ticket chez dell automatiquement en cas de panne matériel , il fait un check et envoi un rapport a leur support. ( sous resserve d'avoir un contrat de maintenance chez eux)

n°1133860
kayl669b
Posté le 21-08-2020 à 13:30:05  profilanswer
 

Je vous remercie à tous pour votre gentillesse. Je vais essayer de voir avec la carte SAS.
Merci encore!!!

n°1133873
NaCl
L'addition va être salée...
Posté le 21-08-2020 à 16:18:53  profilanswer
 

Après il serait peut-être possible de démarrer le serveur sur un live CD linux et tenter de lire les infos S.M.A.R.T. directement (si la carte PERC du serveur fait passer les infos SMART des disques durs) à partir de Linux... Bien que je n'y croie pas trop.
 
Sinon pour l'hypothèse de satoshi, faudrait ouvrir la bestiole et rebrancher chacun des DD. Ça se présente comme à peu près comme ça (sur cette photo je doute que le serveur ait une carte PERC) :
 
https://reho.st/self/5d3cde81a5fa857ed33978e2cca18ac0982671da.jpg


---------------
... ou pas
n°1133938
HPIR40
Posté le 22-08-2020 à 10:52:51  profilanswer
 

satoshi a écrit :


 
c'est effectivement l'hypothèse la plus probable, surtout sur ces vieux PE Txxx sans hotswap... la led frontale se fait vite oublier... :(
 
"Parfois", simplement débrancher - rebrancher le DD permet au voyant de revenir au vert. A test, ça ne coûte rien, ça "marche" genre une fois sur cent...
 


 
C'est pour cela que je préfére nettement le raid software au raid hardware
 
Avec le raid software c'est trés facile de mettre en place un miniscript qui check l'état du raid tous les jours et envoi ensuite un mail sur l'état du raid.  
Avec le raid hardware ce n'est pas la même chose.

n°1133991
satoshi
Posté le 22-08-2020 à 20:04:15  profilanswer
 

Justement, sur les Txxx ont mettait bien souvent du PERC S100 ou S300... qui sont des cartes Softraid :)
 C'est a priori l'une de ces cartes installée car (sauf erreur) le controlleur SAS/6i built-in ne fait pas de raid 5 :)


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Problème serveur DELL

 

Sujets relatifs
Problème Routeur Tp-link avec OpenVpn[RESOLU] Fibre Free - Problème de débit ascendant
Problème de lags sur mon serveur de jeu[RESOLU] Problème wifi 5ghz entre carte wifi Asus et routeur Xiaomi
CPL - Problème voyant rougeOrange probleme redirection NAT
[Résolu] Probleme acces NAS via URLDDNS à travers routeur + LiveboxProblème avec commande PING
Problème routeur en point d'accès(pont) sur box 
Plus de sujets relatifs à : Problème serveur DELL


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR