Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1831 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Problème de lags sur mon serveur de jeu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème de lags sur mon serveur de jeu

n°1131368
spence fox​trot
^^
Posté le 02-08-2020 à 22:01:53  profilanswer
 

Bonjour,
 
Je ne sais pas si mon problème vient du "réseau" ou si c'est la configuration logicielle ou même hardware.
Cependant, j'ai un penchant pour le réseau.
 
Concrètement, j'ai un serveur physique sur lequel tourne plusieurs serveurs de jeu (ARK) et une VM debian pour un serveur Teamspeak, et mes joueurs ont énormément de lags (ils montent à des 200ms de ping), parfois ça redescend de façon courte, puis ça remonte.
 
Je remarque que lorsque mes joueurs rencontrent la monté de ping, ceux de TS aussi (400/600ms)
Moi en local, je reste à 1ms sur TS, et pas plus de 30/40ms sur le jeu (toujours en local)
Depuis le serveur, quand je fais des ping google au même moment, je ne dépasse pas 20ms
 
Ça se produit plus facilement quand il commence à y avoir plusieurs joueurs (10 par exemple)
 
Le serveur (un rack) :
IBM M3 x3550, 2 xeon x5687 (4c/8t/cpu, 3,6GHz), 128GB ram, windows server 2019 en version d'évaluation, installé sur SSD (M550 crucial).
Les cpu sont à 60° au mieux.
 
La connexion :
Fibre free delta (75° sur le cpu le plus chaud).
Je passe par la solution OverTheBox (vpn pro 400mb up&down). Le routeur est assemblé maison (atom n3050, 2C/2T 1,6GHz, 4GB ram).
J'ai donc une IP publique OVH avec l'anti-ddos principalement.
Tout en câble, pas de cpl/wifi etc...
 
Je suis seul, personne ne tire sur le réseau, pas de wifi sur les téléphones...
 
 
J'ai essayé de mettre le moniteur de ressource ainsi que le gestionnaire de tache pour essayer de faire correspondre les pics de ping avec, mais rien de concluant, à part le nombre de connexion TCP qui s'est mis à monter en même temps que le ping. Cependant, quand le ping redescend, les connexions TCP restent identiques en nombre (50).
 
L'OTB (routeur vpn) indique moins de 100mo d'utilisation de ram, et 80% idle.
 
 
Par où puis-je diriger mes investigations svp? :s


---------------
Revendre vos jeux Steam, Origin et Cie individuellement
mood
Publicité
Posté le 02-08-2020 à 22:01:53  profilanswer
 

n°1131602
flash_gord​on
Posté le 04-08-2020 à 14:20:45  profilanswer
 

Tiens, c'est intérréssant.
 
- j'ai parfois le même pb sur mon serveur ark perso. Quand mon pote se plaint, tous mes tests de ping sont bons
- J'ai aussi overthebox.
 
 
Bon j'ai pas le même volume d'utilisateurs, mais quand même.

Message cité 1 fois
Message édité par flash_gordon le 04-08-2020 à 14:23:25

---------------
Survivre à sa migration WP->Android /  Les features Windows que vous ne connaissez pas
n°1131619
spence fox​trot
^^
Posté le 04-08-2020 à 15:34:41  profilanswer
 

flash_gordon a écrit :

Tiens, c'est intérréssant.
 
- j'ai parfois le même pb sur mon serveur ark perso. Quand mon pote se plaint, tous mes tests de ping sont bons
- J'ai aussi overthebox.
 
 
Bon j'ai pas le même volume d'utilisateurs, mais quand même.


tu as quoi comme config?


---------------
Revendre vos jeux Steam, Origin et Cie individuellement
n°1131656
flash_gord​on
Posté le 04-08-2020 à 17:26:32  profilanswer
 

L'hote est un i7 2700k / 32gb de ram  (Windows server 2016),
La VM ark est sur hyper-V,  4 coeurs, 8gb ram.
 
Et bien sûr il glande rien en terme de CPU/ram quand ça se produit.
 
Perso j'ai envie d'incriminer ovh.


Message édité par flash_gordon le 04-08-2020 à 17:43:19

---------------
Survivre à sa migration WP->Android /  Les features Windows que vous ne connaissez pas
n°1133151
spence fox​trot
^^
Posté le 16-08-2020 à 14:22:10  profilanswer
 

Bon, OVH "ne peut pas intervenir" (réponse après 10 jours quand même... les 24h ouvrées, on repassera :s)
 
 
Je souhaite masquer mon IP publique fournisseur (FAI), pour que mes joueurs passent par une distante, de façon à éviter le DDOS sur mon IP FAI.
 
J'ai donc un VPS sous la main, qui propose l'antiddos.
 
Un ami me parle de GRE, mais je lis que ce n'est pas un protocole sécurisé...
 
Vous auriez des suggestions?


---------------
Revendre vos jeux Steam, Origin et Cie individuellement

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Problème de lags sur mon serveur de jeu

 

Sujets relatifs
[RESOLU] Problème wifi 5ghz entre carte wifi Asus et routeur XiaomiCPL - Problème voyant rouge
Orange probleme redirection NAT[Résolu] Probleme acces NAS via URLDDNS à travers routeur + Livebox
Problème avec commande PINGProblème routeur en point d'accès(pont) sur box
Problème Wifi avec ASUS PCE-AC88problème avec la WIFI
Problème réseaux récent avec HFRProblème débit bridé
Plus de sujets relatifs à : Problème de lags sur mon serveur de jeu


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR