Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2039 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [JS] Problème de Script

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[JS] Problème de Script

n°974472
niouts
Forums => Entre-Aide !!
Posté le 07-02-2005 à 18:46:08  profilanswer
 

Voilà mon script javascript :  

Code :
  1. <html>
  2. <head><title>Test</title></head>
  3. <body>
  4. <SCRIPT LANGUAGE="Javascript">
  5. document.writeln("Ceci est un test" );
  6. </SCRIPT>
  7. </body>
  8. </html>

Et bien croyez moi ou non, si je rajoute plein de lignes d'HTML (enfin des tableaux et du texte ...) ceci ne marche plus...Aucun affichage !
Aurai-je oublié quelque chose ??  :pt1cable:  
 
Merci de m'aider car là je ne comprends pas  :pfff:


Message édité par niouts le 07-02-2005 à 18:57:33
mood
Publicité
Posté le 07-02-2005 à 18:46:08  profilanswer
 

n°974477
masklinn
í dag viðrar vel til loftárása
Posté le 07-02-2005 à 18:50:09  profilanswer
 

la page complète stpmerssi
 
et <script type="text/javascript">, language n'est plus utilisé


---------------
I've never understood the compulsion to use Web technologies minus the Web's security and deployment models. It seems a bit like throwing the orange away and eating the peel. — @ justinschuh‬
n°974479
Hermes le ​Messager
Breton Quiétiste
Posté le 07-02-2005 à 18:52:39  profilanswer
 

1 )
 

Code :
  1. <script type="text/javascript">
  2. <!--
  3. //-->
  4. </script>


 
2) </head> est manquant. :heink:

n°974486
masklinn
í dag viðrar vel til loftárása
Posté le 07-02-2005 à 18:55:52  profilanswer
 

Hermes le Messager a écrit :


2) </head> est manquant. :heink:


 :cry:  
j'ai raté ça :cry:


---------------
I've never understood the compulsion to use Web technologies minus the Web's security and deployment models. It seems a bit like throwing the orange away and eating the peel. — @ justinschuh‬
n°974489
niouts
Forums =&gt; Entre-Aide !!
Posté le 07-02-2005 à 18:57:10  profilanswer
 

ok pour les infos...
j'ai remarqué que sur mon autre ordi ca marchait alors y aurait il des choses a faire sur internet explorer ou... je sais pas comment ca se fait...
 
PS : edit du premier message

n°974507
Hermes le ​Messager
Breton Quiétiste
Posté le 07-02-2005 à 19:02:24  profilanswer
 

niouts a écrit :

ok pour les infos...
j'ai remarqué que sur mon autre ordi ca marchait alors y aurait il des choses a faire sur internet explorer ou... je sais pas comment ca se fait...
 
PS : edit du premier message


 
Heu, tu es sûr d'avoir rajouté le </head> qui manque...  :heink:  

n°974529
niouts
Forums =&gt; Entre-Aide !!
Posté le 07-02-2005 à 19:09:28  profilanswer
 

oui sur et ca marche pas sur un des deux ordis...

n°974532
Hermes le ​Messager
Breton Quiétiste
Posté le 07-02-2005 à 19:10:08  profilanswer
 

niouts a écrit :

oui sur et ca marche pas sur un des deux ordis...


 
Javascript est désactivé. [:itm]

n°974566
niouts
Forums =&gt; Entre-Aide !!
Posté le 07-02-2005 à 19:30:25  profilanswer
 

Vous allez dire que je ne comprends rien  :pt1cable:  mais bon...
j'ai essayé de bidouiller internet explorer enfin d'activer javascript alors j'ai regardé dans les options internet et onglet avancé et j'ai coché/décoché tout ce qui l'était sur l'ordi ou les scripts fonctionnent... mais ca n'a rien changé !
 
bon sinon j'ai un second problème en parallèle (allons y !) qui est que la méthode getMonth() renvoie 1 plutot que 2 donc elle considère que nous somme en janvier...
 
voilà merci de vos conseils en tout cas ! :bounce:

n°974567
FlorentG
Unité de Masse
Posté le 07-02-2005 à 19:32:33  profilanswer
 

Pour activer JS, c'est dans les paramètres de sécurité, faut que l'option "Active Scripting" soit activée


---------------
last.fmflickr
mood
Publicité
Posté le 07-02-2005 à 19:32:33  profilanswer
 

n°974568
Hermes le ​Messager
Breton Quiétiste
Posté le 07-02-2005 à 19:33:07  profilanswer
 

lol, je parie que c'est ça son problème... [:toto le hros]

n°974620
niouts
Forums =&gt; Entre-Aide !!
Posté le 07-02-2005 à 20:02:32  profilanswer
 

si vous parlez des paramètres de sécurité :  
Script => Active Scripting, c'est activé... mais en fait lorsque j'ouvre une fenêtre avec internet explorer, la barre d'information s'affiche me disant que IE a restreint l'affichage du contenu actif du fichier...
cela a peut etre a voir... Encore désolé mais je pense que nous sommes presque à la solution du problème...
 
PS : en ce qui concerne getMonth() ?

n°974652
cerel
Posté le 07-02-2005 à 20:10:37  profilanswer
 

niouts a écrit :

Vous allez dire que je ne comprends rien  :pt1cable:  mais bon...
j'ai essayé de bidouiller internet explorer enfin d'activer javascript alors j'ai regardé dans les options internet et onglet avancé et j'ai coché/décoché tout ce qui l'était sur l'ordi ou les scripts fonctionnent... mais ca n'a rien changé !
 
bon sinon j'ai un second problème en parallèle (allons y !) qui est que la méthode getMonth() renvoie 1 plutot que 2 donc elle considère que nous somme en janvier...
 
voilà merci de vos conseils en tout cas ! :bounce:


 
Hmmm, tu es sur que ca commence a 1 ??
On sait jamais, peut-etre que janvier chez eux c'est 0 et non 1, du coup 1 serait bien fevrier ...
Va voir du cote de la doc...
 
Edit : Chez moi :
var dat = new Date();
dat.getMonth();
me renvoi 1, donc je suppose bien que le "decompte" des mois commence a 0 et non a 1 comme tu le pensais.


Message édité par cerel le 07-02-2005 à 20:12:24
n°974655
Hermes le ​Messager
Breton Quiétiste
Posté le 07-02-2005 à 20:12:29  profilanswer
 

Cerel a écrit :

Hmmm, tu es sur que ca commence a 1 ??
On sait jamais, peut-etre que janvier chez eux c'est 0 et non 1, du coup 1 serait bien fevrier ...
Va voir du cote de la doc...


 
De toutes manières, je comprend toujours pas à quoi peut servir la date en JS ?  :D  

n°974660
niouts
Forums =&gt; Entre-Aide !!
Posté le 07-02-2005 à 20:14:24  profilanswer
 

En ce qui concerne la date en effet, 0 correspond à Janvier...
Merci !  
et sinon pour mon problème de "sécurité" je peux faire comment pour désactiver cette barre d'information ?

n°974904
FlorentG
Unité de Masse
Posté le 07-02-2005 à 22:44:16  profilanswer
 

Tu peux pas, enfin c'est pas conseillé. C'est un paramètre de sécurité d'IE6-SP2...


---------------
last.fmflickr
n°975820
niouts
Forums =&gt; Entre-Aide !!
Posté le 08-02-2005 à 21:15:13  profilanswer
 

OK... en fait cet ordi n'est pas connecté à Internet enfin en plus c'est génant quand même...
 
Bref je l'ai enlevé grâce à un autre sujet du forum (promis si je le connecte à Internet je le remets) mais lorsque "j'execute" mon script javascript ben ca ne marche pas !
 
donc c'était un script assez long mais j'ai testé en ne mettant que cette ligne de code :

Code :
  1. document.write("coucou" )

mais il me met bien entendu plus la barre d'information mais ne m'affiche pas "coucou" non plus...
 
Donc un conseil sur tout ca ?

n°976022
FlorentG
Unité de Masse
Posté le 09-02-2005 à 08:14:55  profilanswer
 

Tu l'as mis à quel endroit ton document.write ?


---------------
last.fmflickr
n°976293
niouts
Forums =&gt; Entre-Aide !!
Posté le 09-02-2005 à 12:23:57  profilanswer
 

Code :
  1. <html>
  2.     <head><title>Test</title></head> 
  3.     <body>
  4.     <SCRIPT type="text/javascript">
  5.     document.write("coucou" ); //J'ai essayé avec ou sans ';'
  6.     </SCRIPT>
  7.    
  8.     <table>
  9.       .
  10.       .           //contenu du tableau...
  11.       .
  12.     </table>
  13.    
  14.     </body>
  15.     </html>

Voilà, si ca peut aider quelqu'un...  
Mais je pense que ce n'est peut être pas un problème de script puisque sur un autre ordi ca passe...  
 
mais bon si vous pouvez m'aider  :jap:

n°976396
Hermes le ​Messager
Breton Quiétiste
Posté le 09-02-2005 à 14:11:47  profilanswer
 

niouts a écrit :

Code :
  1. <html>
  2.     <head><title>Test</title></head> 
  3.     <body>
  4.     <SCRIPT type="text/javascript">
  5.     document.write("coucou" ); //J'ai essayé avec ou sans ';'
  6.     </SCRIPT>
  7.    
  8.     <table>
  9.       .
  10.       .           //contenu du tableau...
  11.       .
  12.     </table>
  13.    
  14.     </body>
  15.     </html>

Voilà, si ca peut aider quelqu'un...  
Mais je pense que ce n'est peut être pas un problème de script puisque sur un autre ordi ca passe...  
 
mais bon si vous pouvez m'aider  :jap:


 
 
A tout hasard, essaye :
 

Code :
  1. <html>
  2. <Head></head>
  3. <body onload='javascript:document.write("coucou" );'>
  4. </body>
  5. </html>


 
Sinon, essaye la même chose en remplaçant le contenu du onload par :
 
alert("coucou" );
 
Et dis nous ce qui se passe.  :o


Message édité par Hermes le Messager le 09-02-2005 à 14:12:33

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [JS] Problème de Script

 

Sujets relatifs
probleme avec l'api c MysqlCherche script pour pouvoir mapper des lecteur réseau
Problème d'insertion de données[MFC] Problème avec GetDocument()
probleme d'affichage urgent svpProblème PHP/Javascript
[Coppermine] Probleme d'installeproblème execution programme C sous windows
Probleme avec Target et utilisation des balises divprobleme findrecord
Plus de sujets relatifs à : [JS] Problème de Script


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR