Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1193 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [CSS] Problème avec hover & active

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[CSS] Problème avec hover & active

n°1195136
ANViL
yep...definitely ♫
Posté le 08-09-2005 à 16:01:15  profilanswer
 

j'ai actuellement un petit bug ennuyant lié aux liens en css.
 
Quand je clique sur un lien, j'arrive sur la page truc.htm (par ex) et si je reviens sur la page précédente, le lien vers la page truc.htm est affiché selon les paramètres spécifiés dans 'active'.
Et tant que je ne clique pas n'importe ou sur la page, ce lien restera affiché tel quel.
 
J'avoue, je ne suis pas spécialiste des link / visited / hover / active, je sais juste qu'il faut les mettre dans cet ordre.
 
Est-ce un problème lié à mon code ou bien faut-il spécifier une commande 'genre clear screen' ?
 

Citation :

.menu_gauche_cellules a:link {
 color: rgb(112,129,137);
 text-decoration: none;
 display: block;
 height: 100%;
 padding: 8px 0px 0px 12px;
}
 
.menu_gauche_cellules a:visited {
 color: rgb(112,129,137);
 text-decoration: none;
 display: block;
 height: 100%;
 padding: 8px 0px 0px 12px;
}
 
.menu_gauche_cellules a:hover {
 color: #C0C0C0;
 background-color: rgb(31,49,82);
 text-decoration: none;
 display: block;
 height: 100%;
 padding: 8px 0px 0px 12px;
}
 
.menu_gauche_cellules a:active {
 color: #C0C0C0;
 background-color: rgb(31,49,82);
 text-decoration: none;
 display: block;
 height: 100%;
 padding: 8px 0px 0px 12px;
}

mood
Publicité
Posté le 08-09-2005 à 16:01:15  profilanswer
 

n°1195741
ANViL
yep...definitely ♫
Posté le 09-09-2005 à 10:11:50  profilanswer
 

up

n°1195762
omega2
Posté le 09-09-2005 à 10:35:42  profilanswer
 

a:active situé en dernier
le dernier prime, donc c'est tout à fait normal comme comportement.

n°1195789
FlorentG
Unité de Masse
Posté le 09-09-2005 à 11:09:27  profilanswer
 

omega2 a écrit :

a:active situé en dernier
le dernier prime, donc c'est tout à fait normal comme comportement.


Non, c'est juste que quand on revient, le lien sur lequel on avait cliqué reste actif [:spamafote] Y'a rien à faire, c'est le comportement normal du navigateur, et ça permet de revoir d'où on vient, et de reprendre la lecture à partir de là...


---------------
last.fmflickr
n°1195798
ANViL
yep...definitely ♫
Posté le 09-09-2005 à 11:19:21  profilanswer
 

Ok merci  :)  
 
Même si c'est normal, je trouve que ça gène un peu.
Le seul moyen que j'ai trouvé pour palier à ça est de faire un refresh dès qu'on arrive sur la page, mais j'ai vu plus optimal  :sweat:

n°1195819
FlorentG
Unité de Masse
Posté le 09-09-2005 à 11:32:58  profilanswer
 

C'est un comportement normal de tous les navigateurs, donc les utilisateurs y sont tous confrontés, donc aucune gêne particulière ;) De manière générale, il faut éviter de vouloir contrôler le navigateur, vaut mieux laisser comme c'est par défaut (donc ici :active quand on revient en arrière), c'est le meilleur moyen pour l'utilisateur de s'y retrouver :)


---------------
last.fmflickr

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  [CSS] Problème avec hover & active

 

Sujets relatifs
Probleme avec un setInterval[RESOLUE] probleme de calcul de date sous access 2002.
[RESOLU]probleme regroupage fichiers texte[CSS] mise en page d'un menu vertical : pb sous FF
Problème de crt0.o[resolu] batch : Probleme copie fichier
probleme copier fichier depuis urlprobleme en fortran90...
probleme sur IEProblème Span
Plus de sujets relatifs à : [CSS] Problème avec hover & active


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR