Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2643 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème Span

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème Span

n°1193412
Beral2
Posté le 06-09-2005 à 17:38:51  profilanswer
 

Bonjour tout le monde.
 
J'utilise un "menu-image" non-déroulant : en fait, il y a roll over par déplacement de l'image de background.
Problème de cette méthode, qui dit image de background, dit ALT non disponible.
 
J'essaie donc d'utiliser une des méthode pour pouvoir insérer le titre en "vrai" caractère puis de le cacher (span {display: none}).
 
Comme vu ici, cette méthode n'est pas sans défaut mais vu qu'apparemment aucune ne l'est : http://www.mezzoblue.com/tests/rev [...] placement/
 
Sans problème sous Firefox, IE part en vrille (étonnant non ?).
 
En fait, j'ai l'impression que IE n'affiche pas le contenu du span mais lui "réserve" une place.
 
HTML :
---------------------------------------
<ul id="menu_secondaire" >
                <li><a id="have_your_say" href="consultations/index_en.htm"><span>Have your say</span></a></li>
                <li><a id="conferences" href="news/index.htm"><span>Conferences</span></a></li>
                <li><a id="tenders" href="calls/calls.html"><span>Calls for tender</span></a></li>
                <li><a id="grants" href="funding/grants/themes_2005/calls_prop_2005.htm"><span>Calls for proposals</span></a></li>
                <li><a id="networks" href="networks/index.htm"><span>Networks</span></a></li>
                <li><a id="info_service" href="informa/index.cfm"><span>Info service</span></a></li>
                <li><a id="publications" href="library/index.htm"><span>Library</span></a></li>
</ul>
---------------------------------------
Tout mon menu se décale, une idée svp ?
 
P.S. : rien à voir mais [cpp][/cpp], ça ne fonctionne plus ?

mood
Publicité
Posté le 06-09-2005 à 17:38:51  profilanswer
 

n°1193825
Beral2
Posté le 07-09-2005 à 09:40:55  profilanswer
 

up.

n°1193840
esox_ch
Posté le 07-09-2005 à 09:57:13  profilanswer
 

Heu ... par alt non disponible ... tu entends le pti carré qui apparait quand tu laisses la souris sur une image? Attention si c'est ça faut pas l'utiliser, c'est pas un fonctionnement "normal", l'element alt n'est pas fait pour ça.
 
Autre chose, pourquoi des span dans tes li ?  
 
File nous la page html qu'on regarde ça de plus pres


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°1193845
gatsusat
Posté le 07-09-2005 à 10:09:22  profilanswer
 

et pourquoi pas des TITLE ca fait pareil non di diou

n°1193854
Beral2
Posté le 07-09-2005 à 10:30:47  profilanswer
 

esox_ch : je connais la différence entre ALT et TITLE, ça fait un petit moment que je traine sur ce forum ;)
 
Alors les SPAN c'est justement pour : http://www.mezzoblue.com/tests/rev [...] placement/
 
Gatsusat: TITLE oui c'est ce que j'avais mis au début, mais ce que j'aimerais c'est que quand on enlève la CSS, tout le texte soit disponible (c'est du Times New Roman avec des listes de liens et du texte brut mais TOUT est disponible). Avec TITLE, non : les bullets des liens sont désespérement vides.
 
La page, je ne peux pas vous la montrer, pas encore publiée (mais bientôt, peut-être vous la jeterai-je en pature plus tard).
 
Merci.


Message édité par Beral2 le 07-09-2005 à 10:31:55
n°1193865
gatsusat
Posté le 07-09-2005 à 10:42:31  profilanswer
 

<li><a id="have_your_say" href="consultations/index_en.htm" title="Have your say">Have your say</a></li>  
 
là oki ?
 
ensuite en CSS il faut que a soit un block : donc display:block
puis pour faire disparaitre le texte, tu fais ceci : text-indent : -5000
 

n°1193869
esox_ch
Posté le 07-09-2005 à 10:44:40  profilanswer
 

gatsusat a écrit :

<li><a id="have_your_say" href="consultations/index_en.htm" title="Have your say">Have your say</a></li>  
 
là oki ?
 
ensuite en CSS il faut que a soit un block : donc display:block
puis pour faire disparaitre le texte, tu fais ceci : text-indent : -5000


 
T'a pas plus bourrin  :pt1cable: ?
 
Et pis on sais jamais ... qqn peut avoir 6 ecran cote a cote en 1600x1400 comme resolution ...  [:anauff]


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
n°1193872
Beral2
Posté le 07-09-2005 à 10:52:10  profilanswer
 

Mes "a" sont déjà en display: block.
 
Mon vrai problème est que cela marche sous Firefox (et Netscape) mais pas sous IE : je voulais donc savoir s'il y avait un "truc spécial" à faire  pour l'autre bouse de navigateur.
 
Si je ne trouve pas, je prendrai ton text-indent.

n°1194012
cerel
Posté le 07-09-2005 à 13:23:01  profilanswer
 

Comme "truc spécial" pour "l'autre bouse", je propose la cremation de ce dernier (ainsi que des maisons des auteurs pour faire plaisir aux pyromanes qui trainent).
 
Ahh, on me previent dans mon oreillette que ce n'est pas ce a quoi tu t'attendais.


Message édité par cerel le 07-09-2005 à 13:23:16
n°1194017
esox_ch
Posté le 07-09-2005 à 13:27:04  profilanswer
 

+1 :D


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait
mood
Publicité
Posté le 07-09-2005 à 13:27:04  profilanswer
 

n°1194075
gatsusat
Posté le 07-09-2005 à 14:04:45  profilanswer
 

esox_ch a écrit :

T'a pas plus bourrin  :pt1cable: ?
 
Et pis on sais jamais ... qqn peut avoir 6 ecran cote a cote en 1600x1400 comme resolution ...  [:anauff]


 
 
on voit que tu ne connais pas toutes les astuces en CSS
 
celle-ci permet d'avoir un menu en UL LI et avoir des images (background) à la place de texte et donc supprimer ce texte.
 

n°1194117
esox_ch
Posté le 07-09-2005 à 14:32:27  profilanswer
 

Je veux bien que ça marches (d'ailleurs je crois que masklinn a déjà posté plusieurs fois l'astuce ;) ). Parcontre c'est pas une raison pour que ce ne soit pas une metode legerement bourin :D


---------------
Si la vérité est découverte par quelqu'un d'autre,elle perd toujours un peu d'attrait

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Problème Span

 

Sujets relatifs
[Débutant] Problème J2EE - Méthode statiqueProblème de block/inline [résolu]
probléme avec visual C++ libraryProbléme visual C++ library error
CSS probleme avec le tag <label> dans firefoxProbleme avec le solver sous vba XP
Problème pour créer un script....[SQL] probleme insert basic avec sequences
Problème <span>Probleme balise peut etre balise span sous mozilla et pas sous ie
Plus de sujets relatifs à : Problème Span


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR