Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
748 connectés 

  FORUM HardWare.fr
  Programmation
  Divers

  [ACCESS]Probleme activex suite a un changement de poste

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

[ACCESS]Probleme activex suite a un changement de poste

n°371415
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 09:51:36  profilanswer
 

Bonjour,  
 
Dans le cadre d'un stage en entreprise je developpe une application access, suite a un changement de poste l'un de mes controle ne marche plus :
 
si je lance mon formulaire en mode execution ou creation une fenertre d'erreur me dit "Pas d'objet dans ce controle"
 
En mode creation un objet me servant a ouvrir une boite de dialogue de demande de fichier est blanche, j'en ai conclu que l'activex me permettant de demander un fichier a l'utilisateut deconnait, si j'essaie de le remettre (en mode creation "autres controles -> Common Dialogs Control"
une fenetre d'erreur me dit : "Vous ne possedez pas la license requise pour l'utilisation ce controle activex
 
Vous avez essayé d'ouvrir un formulaire contenant un objet OLE ou un controle activex ou de créer un controle activex.
 
Pour obtenir la license appropriée, contactez la societé qui fournit l'objet OLE ou le controle activex"
 
 
Si en mode execution je clique qd meme sur le bouton censé m'ouvrir ma boite de dialogue de demande de fichier j'ai une erreur "438 : propriete ou methode non gérée par cette objet"
 
 
 
Comment re-faire marcher ca????(ben voui avant que je change de poste, j'avais win2000 et office2000, pour mon nouveau poste, win98, office97, access2000, ca marchait niquel!!!)
 
Merci d'avance

mood
Publicité
Posté le 25-04-2003 à 09:51:36  profilanswer
 

n°371427
ratibus
Posté le 25-04-2003 à 09:57:34  profilanswer
 

salut
 
j'ai eu le meme genre de pb cette année au cours d'un développement access  
 
en fait ceci est du à l'absence du fichier où il y a le controle que tu utilises chez le poste où ça marche pas.
 
si tu lances sur ce poste l'éditeur vb et que tu vas voir les références utilisées tu auras une ligne avec marqué MANQUANT ...
c'est ce controle là qu'il faudra installer sur la machine

n°371440
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:09:22  profilanswer
 

Dans les references sous VBA j'ai rien avec manquant (enfin, j'ai pas trouvé, c'est marqué ou???)
 
Voila ce que j'ai de coché :
 
Visual basic for application
Microsoft access 9.0 object library
OLE automation
Microsoft activex data objects 2.1 library
Microsoft DAO object library
Microsoft Forms 2.0 Object library
 
 
 
Et dans le cas ou une de ces reference est manquante où puis-je trouver le fichier et comment l'installer????
 
Merci d'avance

n°371482
ratibus
Posté le 25-04-2003 à 10:25:09  profilanswer
 

il faut que tu regardes sur le poste qui fonctionne si les références sont les memes (fais attention au numéro de versions des références)
 
ensuite si tu cliques sur la ligne d'un référence dans la fenetre il y a marqué le chemin du fichier utilisé pour cette référence
 
ensuite il faut mettre ce fichier et le mettre sur le poste qui ne fonctionne pas et "l'enregistrer"

n°371496
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:27:07  profilanswer
 

le truc c'est que je peux pas aller voir sur l'autre poste.....
y'a un mec qui bosse dessus :pt1cable:  :pt1cable:  :pt1cable:

n°371509
ratibus
Posté le 25-04-2003 à 10:30:57  profilanswer
 

ça sort de mes compétences :D

n°371517
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:34:30  profilanswer
 

ben en fait vu que y'en a aucun qui soit marqué en manquant je vois pas trop d'ou ca peut venir.....

n°371519
walli
Posté le 25-04-2003 à 10:34:43  profilanswer
 

Ca serait pas plutot une histoire de l'activeX non instancié dans la base de registre ?


---------------
NP :
n°371526
ratibus
Posté le 25-04-2003 à 10:36:24  profilanswer
 

walli a écrit :

Ca serait pas plutot une histoire de l'activeX non instancié dans la base de registre ?


 
si c'est ça  :)  
mais faut d'abord savoir lequel pour pouvoir l'enregistrer avec regsrv32.exe

n°371541
walli
Posté le 25-04-2003 à 10:42:21  profilanswer
 

ratibus a écrit :


 
si c'est ça  :)  
mais faut d'abord savoir lequel pour pouvoir l'enregistrer avec regsrv32.exe


 
si yen a pas 36.000 il peut toujours essayer de les instancier un à un...  [:ddr555]


---------------
NP :
mood
Publicité
Posté le 25-04-2003 à 10:42:21  profilanswer
 

n°371546
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:44:43  profilanswer
 

en tout y'en a une 100aine
apres j'en utilise 6
On fait comment pour les re-instancier???

n°371552
walli
Posté le 25-04-2003 à 10:48:14  profilanswer
 

harrysauce a écrit :

en tout y'en a une 100aine
apres j'en utilise 6
On fait comment pour les re-instancier???


 
Tu doubles cliques sur les .reg  [:spamafote]


---------------
NP :
n°371558
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:54:00  profilanswer
 

je veux bien mais les fichiers en question sont des .olb, .tlb, .dll......
pas de .reg

n°371566
ratibus
Posté le 25-04-2003 à 10:57:56  profilanswer
 

faut utiliser regsvr32.exe
 
pour enregistrer toto.dll

Code :
  1. regsvr32.exe toto.dll


 
pour supprimer toto.dll (ça touche pas au fichier)

Code :
  1. regsvr32.exe /u toto.dll


Message édité par ratibus le 25-04-2003 à 10:58:36
n°371569
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 10:59:47  profilanswer
 

ok, je vais essayer ca, merci
 
et sinon est-ce que vous pensez que ca peut venir du fait qu'a la base sur le pc y'avait Office 97 et que ensuite j'ai installe juste Access2000, pas toute la suite office, juste access?????

n°371588
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 11:06:11  profilanswer
 

ca marche toujours pas

n°371631
ratibus
Posté le 25-04-2003 à 11:19:47  profilanswer
 

harrysauce a écrit :

ca marche toujours pas


t'as fait koi précisemment ?

n°371674
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 11:46:21  profilanswer
 

j'ai re-instancié tous les modules qui étaient cochés ds mes references (enfin, juste les dll, parce que les autres il voulait pas...)
 
Et puis la je viens d'installer toute la suite office.....ca marche toujours pas!!! Ca me fait bien chier parce que c'est mon projet de stage et que si je peux pas le faire je suis un peu ds la merde..... :(

n°371676
ratibus
Posté le 25-04-2003 à 11:49:30  profilanswer
 

t'as pu comparer les références entre le poste où ça marche et celui où ça ne marche pas ?
 
c'est la première chose à faire  
 
ça sert çà rien de réinstancier des références présentes dans la liste d'Access car si elles sont dans cette liste c'est qu'elles sont déjà instanciées  :)  
 
faut trouver celle qui n'est pas instanciée et ensuite de l'instancier sur le poste où ça marche pas

n°371683
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 11:56:20  profilanswer
 

j'irai voir a midi et demi qd le gars se sera cassé de son poste......
 
 
dc tu penses qu'entre son poste et le mien y'a des trucs en plus/mois ds les references???
 
Les references utilisées sont pas stockées ds le projet access??? ca serait bizarre qu'il ne me la coche pas!!!

n°371691
ratibus
Posté le 25-04-2003 à 12:04:13  profilanswer
 

en fait soit y a des références manquantes sur le poste où ça marche pas (mais tu m'as dis que non)
soit c'est des versions différentes des références et c'est là que ça peut poser problème

n°371694
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 12:07:02  profilanswer
 

ok, je vais voir ca des que je peux et je re-post
 
MERCI!

n°371698
ratibus
Posté le 25-04-2003 à 12:12:14  profilanswer
 

avec plaisir  :)  
 
mais ça marche pas encore  
tu me remercieras qd ce sera OK  :D

n°371701
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 12:20:55  profilanswer
 

incomprehensible!!!!
 
j'ai ouvert mon projet sur l'autre poste : meme erreur que sur le mien, meme references
 
heuresement j'avais fait des sauvegardes et la ca marche, je regarde les references et c'est vrai qu'il y en a une de moins (Microsoft Forms 2.0 Object Library)
 
Je reviens sur mon poste je teste la sauvegarde qui marche....et la paf erreur, mais la reference n'y est pas non plus
 
Donc en fait je pense pas que ce soit un  probleme de reference....
 
Tu n'aurais pas un mail ou je pourrai t'envoyer mon projet afin que tu test???
 
Bon, sur ce, je vais bouffer! :D

n°371707
ratibus
Posté le 25-04-2003 à 12:29:08  profilanswer
 

ben si justement c'est un problème de référence  :)  
 
quand ça ne marche pas c'est que tu n'as pas la référence Microsoft Forms 2.0 Object Library
 
il faut donc que tu regardes quel fichier est associé à cette référence

n°371740
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:25:26  profilanswer
 

ratibus a écrit :

ben si justement c'est un problème de référence  :)  
 
quand ça ne marche pas c'est que tu n'as pas la référence Microsoft Forms 2.0 Object Library
 
il faut donc que tu regardes quel fichier est associé à cette référence


non, sur le poste ou ca marche, le truc form y est mais le projet access ne marche pas
 
si je prend une sauvegarde, le truc form n'y est pas, mais ca marche
 
 
par contre sur mon poste aucune des 2 (donc avec et sans le truc form) ne marchent!!!!!
 
c'est pour ca que c'est incomprehensible!!!
 
De plus je ne peux supprimer le truc form : access me dit qu'il est utilisé, par contre je sais pas par quoi!!!

n°371742
walli
Posté le 25-04-2003 à 13:27:40  profilanswer
 

C'est  :pt1cable:  ton affaire !!


---------------
NP :
n°371746
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:28:37  profilanswer
 

walli a écrit :

C'est  :pt1cable:  ton affaire !!
 

un peu oué, et ca me fait carrement chier parce que ma note de stage repose la dessus!!!!!

n°371751
walli
Posté le 25-04-2003 à 13:31:58  profilanswer
 

harrysauce a écrit :

un peu oué, et ca me fait carrement chier parce que ma note de stage repose la dessus!!!!!


 
j'aurais bien testé ton truc mais j'ai pas access sur mon poste


---------------
NP :
n°371763
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:37:35  profilanswer
 

walli a écrit :


 
j'aurais bien testé ton truc mais j'ai pas access sur mon poste  


dommage, merci qd meme!

n°371764
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:38:31  profilanswer
 

vous pensez pas que ca peut venir de win98 qui gererai pas les activex ou les boites de dialogue ou je sais pas quoi d'autre de la meme facon que win2000??????

n°371765
ratibus
Posté le 25-04-2003 à 13:38:35  profilanswer
 

alors des nouvelles du fichiers ?

n°371769
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:39:17  profilanswer
 

ratibus a écrit :

alors des nouvelles du fichiers ?


comment ca?
la ca marche toujours pas......

n°371774
ratibus
Posté le 25-04-2003 à 13:41:06  profilanswer
 

c koi le fichier associé à Microsoft Forms 2.0 Object Library  

n°371781
ratibus
Posté le 25-04-2003 à 13:45:01  profilanswer
 

g trouvé  
le fichier en question est fm20.dll


Message édité par ratibus le 25-04-2003 à 13:45:37
n°371782
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:46:32  profilanswer
 

je vais essayer mais je pense vraiment pas que ca vienne de la vu que sur mon poste avec et sans c'est pareil.....

n°371783
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:48:42  profilanswer
 

j'ai rajouté c:\windows\system\fm20.dll comme reference a ma sauvegarde sur le poste qui marche pas et c'est pareil.....
heuresement que j'avais fait une sauvegarde de la sauvegarde  :pt1cable:

n°371786
ratibus
Posté le 25-04-2003 à 13:51:25  profilanswer
 

en fait c'est pas dans les références qu'il faut le mettre  
je me suis gouré
 
tu ouvres ton fichier access sur le poste où ça marche pas et tu vas dans le menu outils/controles activex
 
dans la lsite qui s'affiche tu regardes si y a les controles Microsoft Forms 2.0
sinon tu fais "Inscrire dans la base de registre" et tu choisis le fichier "fm20.dll"

n°371787
ratibus
Posté le 25-04-2003 à 13:53:34  profilanswer
 

regarde tes MP

n°371790
harrysauce
Miaaaooou!
Posté le 25-04-2003 à 13:55:47  profilanswer
 

ratibus a écrit :

en fait c'est pas dans les références qu'il faut le mettre  
je me suis gouré
 
tu ouvres ton fichier access sur le poste où ça marche pas et tu vas dans le menu outils/controles activex
 
dans la lsite qui s'affiche tu regardes si y a les controles Microsoft Forms 2.0
sinon tu fais "Inscrire dans la base de registre" et tu choisis le fichier "fm20.dll"

c'est fait

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  Divers

  [ACCESS]Probleme activex suite a un changement de poste

 

Sujets relatifs
Probleme de guillemet[C] Probleme fgets (resolu)
[VBA][ACCESS] une liste deroulante qui change de table ???fonction mail() probleme avec la gestion des emails non envoyé
PERL probleme d'envois de mailprobleme de tampon?
PHP+SQL+Flash problème !!!MySQL Access Denied
Probleme avec un champ Date sous Access... 
Plus de sujets relatifs à : [ACCESS]Probleme activex suite a un changement de poste


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR