Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
472 connectés 

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Suivante
Auteur Sujet :

Led et port USB

n°1439055
Xezbeth
Posté le 21-06-2006 à 18:33:00  profilanswer
 

Reprise du message précédent :
Si il est relié a la masse, ça perturbe rien a mon avis.
C'est quand il est relié au plus, la, a mon avis ça pertube le port USB...
 
T'en fait pas tu va bien trouver un moyen ;)

mood
Publicité
Posté le 21-06-2006 à 18:33:00  profilanswer
 

n°1439436
bluedevil
Posté le 22-06-2006 à 16:59:54  profilanswer
 

mmh, j'ai recuperé un microrupteur...  
c'est pas gagné :-/

n°1439437
shubaka
--== Elisez moi ==--
Posté le 22-06-2006 à 17:03:27  profilanswer
 

Pouquoi ne pas faire une detection de porteuse sur le bus USB ?!
 
La au moins, consommation ou pas .... tu detectes le peripheriques?!


---------------
TARTAGUEULE A LA RECRE... VIENS M'AFFRONTER ESPECE DE TAPETTE
n°1439440
bluedevil
Posté le 22-06-2006 à 17:26:36  profilanswer
 

je suis un peu limité en electronique, alors je ne voit pas trop comment detecter la porteuse sur le le bus, comment voudrai tu t'y prendre ?

n°1439644
shubaka
--== Elisez moi ==--
Posté le 23-06-2006 à 10:01:35  profilanswer
 

Salut,
 
En utilisant un opto coupleur pour recuperer l'activité D+ par exemple (si tu te fais ta propre alimentation), et faire un filtre passe haut (avec une fréquence réglable au cas où il y aurait une activité en mode veille de l'USB).
 
Si on voit une activité, un signal de sortie va activer une LED.
 
C'est le principe...


---------------
TARTAGUEULE A LA RECRE... VIENS M'AFFRONTER ESPECE DE TAPETTE
n°1439650
bluedevil
Posté le 23-06-2006 à 10:39:26  profilanswer
 

en principe je veut simplement que la led s'allume lorsqu'un periph usb est branché, donc en absence de celui-ci pas d'activité :)
 
un Opto coupleur devrai suffire dans ce cas, non ?
 
(merci pour toutes les indications tout le monde en tout cas  :love: )

Message cité 1 fois
Message édité par bluedevil le 23-06-2006 à 10:39:55
n°1439654
shubaka
--== Elisez moi ==--
Posté le 23-06-2006 à 10:53:21  profilanswer
 

Si ce n'est seuleument que ca ... ben une simple Led branché entre +5V et le GND de l'USB devrait suffir mais côté périphérique.
 
Comme ca lors de la connection, zou c'est allumé ...
 
Simple mais t'obliges a ouvrir le périphérique ... ou créer un câble ou un connecteur d'adaptation intégrant ce minuscule montage ;) (ce qui est préférable).
 
@+


---------------
TARTAGUEULE A LA RECRE... VIENS M'AFFRONTER ESPECE DE TAPETTE
n°1439728
Natopsi
☄️Just end it already!☄️
Posté le 23-06-2006 à 13:48:22  profilanswer
 

bluedevil a écrit :

en principe je veut simplement que la led s'allume lorsqu'un periph usb est branché, donc en absence de celui-ci pas d'activité :)
 
un Opto coupleur devrai suffire dans ce cas, non ?
 
(merci pour toutes les indications tout le monde en tout cas  :love: )


Tu me donne idée : pourquoi pas utiliser un optocoupleur pour detecter l'insertion mecanique de la prise.
Lorsque tu met une prise, le metal reflechit la lumiere d'une led et ca va sur un phototransistor qui allume la led.

n°1440088
bluedevil
Posté le 24-06-2006 à 12:31:09  profilanswer
 

Oui, bonne idée natopsi :)
 
En y refelchissant je me suis dit que j'etait obligé de modifier mon rack usb, et du coup j'ai trouvé un moyen de faire contact avec la masse lors de l'entrée du peripherique usb  ;)  
 
 
Je vais tenter ça, on verra bien ^^
 
Merci beaucoup à tous  :love:

n°1440245
alfirin
Posté le 24-06-2006 à 19:33:51  profilanswer
 

On veut des pic!

mood
Publicité
Posté le 24-06-2006 à 19:33:51  profilanswer
 

n°1440608
bluedevil
Posté le 25-06-2006 à 18:34:46  profilanswer
 

promis ^^

n°1441213
Xezbeth
Posté le 27-06-2006 à 13:41:16  profilanswer
 

ouéééé! des tofs!! :D

n°1442707
bluedevil
Posté le 01-07-2006 à 16:07:02  profilanswer
 

J'ai modifié mon rack, et rajouté ce qu'il fallait : Le montage marche impec ^^
 
Pour le moment je le fait tenir à la patafix  :sol: car mon fer à souder à rendu l'ame -_-
Je vais en piquer un chez un amis ce soir je pense  :D  
 

n°1443554
swissforev​er
i7 Inside
Posté le 03-07-2006 à 21:36:19  profilanswer
 

quel montage as tu fait pour finir?


---------------
Swisscore
n°1443572
bluedevil
Posté le 03-07-2006 à 22:31:10  profilanswer
 

En fait, j'ai decouvert que la masse du port usb etait bloqué tant qu'un peripherique n'etait pas detecté...
Donc le principe deviens encore plus simple :
J'ai carement mis la masse de la led (celle-ci prend le 12v sur l'alim avec un resistance 470ohms) sur celle du port usb, il suffit de brancher et ça marche  :D (oui, tout ça pour...)
 
Juste un petit mystère persiste, les souris en usb ne declenche pas ce système Oo (j'ai testé des clefs usb, un baladeur, un appareil photo, le recepteur et ma telecommande ati, un disque dur, la freebox, un modem... ect enfin tout marche sauf les souris, mystère mystère  :??: )
 
 
Du coup j'ai finit mon montage, il me manque juste à intergrer proporement les leds (je vais utiliser un plexi et y faire un motif je pense ^^).
 
je post les images dès demain ;)


Message édité par bluedevil le 03-07-2006 à 22:35:01
n°1443759
Xezbeth
Posté le 04-07-2006 à 13:12:24  profilanswer
 

ha ben oui effectivement ca simplifie tout ^^
On est quand même heureux de tous t'avoir aidé... ^^

n°1443769
bluedevil
Posté le 04-07-2006 à 13:30:36  profilanswer
 

Oui ^^
C'est moi qui es heureux que vous m'ayez aidé plutot  :D  
Mais on peut perfectionner le système, l'idée de l'optocoupleur que proposai Natopsi serai la plus efficace je pense  ;)  
 
 
Donc, les photos :
 
Ce rack est fait pour mon boitier, que j'ai un peu modder :) (j'avai fait un topic il y a quelques temps, mais mon ftp a été supprimé... puis je n'ai pas trop eu le temp de my plonger avec les etudes :-/).
 
 
Donc ici le boitier il y a plusieurs mois, seule la façade est peinte (la photo date, mais on y voit l'eclairage correctement donc ^^)
 
http://bluewar3.free.fr/Bricolage/ [...] ier-on.jpg
 
 
Le boitier maintenant (un lecteur dvd noir, le reste du boitier a été peint en noir aussi, et un de bouton repeint en gris).
le scotch c'est pour tenir la facade, comme j'y bricole souvent j'ai la flemme de viser/deviser à chaque fois ^^
 
http://bluewar3.free.fr/Bricolage/ [...] scotch.jpg
 
 
Le rack que j'ai bricolé pour le boitier (j'ai pris un cache 5" 1/4, decoupé les trous au cutter chauffé, et visé le tout) :
P.S : les marque c'est du crayon à papier, j'ai fait des tracé pour l('integration du plexi
 
http://bluewar3.free.fr/Bricolage/ [...] oitier.jpg
 
 
 
Bon voilà, petit tour de l'ensemble, maintenant on teste le rack : le cable orange est mis le le 12v de l'alim, 2 resistance de 470ohms pour chaque led (je n'avai pas de resistance supèrieure à 1/4w donc j'en ai mis 2 en derivation pour eviter la chauffe). Et chaque led est relié à la masse du port usb dont elle est le temoin.
 
http://bluewar3.free.fr/Bricolage/BlackGate/rien.jpg
 
http://bluewar3.free.fr/Bricolage/ [...] droite.jpg
 
http://bluewar3.free.fr/Bricolage/ [...] gauche.jpg
 
http://bluewar3.free.fr/Bricolage/BlackGate/2usb.jpg
 
 
 
Ensuite je vais graver un plexi pour integrer les led proprement (cay mieux quand même ^^) :
 
http://bluewar3.free.fr/Bricolage/BlackGate/plexi.jpg
 
J'ai gribouillé ça hier, c'est surtout pour montrer l'emplacement du plexi  :p


Message édité par bluedevil le 04-07-2006 à 13:31:38
n°1443776
shubaka
--== Elisez moi ==--
Posté le 04-07-2006 à 13:45:25  profilanswer
 

La peinture brillante pas top .... (enfin les degouts et les douleurs :D)..
 
Sinon chapeau pour le travail ;)
 
:hello:

n°1443779
bluedevil
Posté le 04-07-2006 à 13:53:01  profilanswer
 

les photos trompent, ça ne brille pas autant ^^
 
En temp normal les reflets sont comme sur le bouton pwoer (le bleu) ici : http://bluewar3.free.fr/Bricolage/ [...] oitier.jpg

n°1443797
Xezbeth
Posté le 04-07-2006 à 15:33:41  profilanswer
 

ha ouais c'est géniale!! :) ;) :D
franchement chapal!!
 
sinon les périfériques que tu branche fonctionnent parfaitement, y'a aucune influence sur la réception de l'USB?

n°1443812
bluedevil
Posté le 04-07-2006 à 16:14:50  profilanswer
 

"j'ai testé des clefs usb, un baladeur, un appareil photo, le recepteur et ma telecommande ati, un disque dur, la freebox, un modem..."
 
Ah par le modem sagem que je n'ai pas pu essayé (comme j'ai la freebox...), le reste fonctionnai sans problème =)

n°1443867
swissforev​er
i7 Inside
Posté le 04-07-2006 à 18:16:41  profilanswer
 

ouai avec 20mA ca devrais pas poser de blem... :-) peut etre que la souris utilise pas la meme chose l'usb? style que la masse n'est pas prise et que les 2 data font office de masse, soit une soit l'autre, style comme si c'étais en open collector je sais pas


---------------
Swisscore
n°1443870
Ma-Nux
Posté le 04-07-2006 à 18:18:26  profilanswer
 

Salut !
Vous l'avez échapé belle avec l'idée de départ avec le relais !
 
1°) je savais pas que ça existait un relais qui pompe plus que ce qu'il commute .  :ouch:  
Et oui , un relais avec une bobine de 12V et 167W , ça fait chez moi près de 14A.
I(a) = P(w) / U(v) = 167(w) / 12(v) = 13,91(a) .
J'en ai même vu un qui fait 12V 960W ... soit 80A rien que pour commuter . :lol:  
En fait , ils se sont planté , c'est l'impédance en OHM , c'est pas des Watts .
Ça m'étonne que personne ne l'ai pas remarqué !!!
Je comprend pourquoi certains fabriquans sortent des alims de plus de 1000W  :lol:  :lol:  :lol:  suivant les relais , il les faut !  :lol:  
 
2°) sauf erreur de ma part , les ports USB délivrent maxi 500mA par port , sur certais hubs externes on peux tirer plus à condition de ne brancher qu'un périphérique et que l'alim soit assez puissante . A ma connaissance , les seul périphériques qui pompent le plus sont les scanner USB (sans alim externe , je le sais , j'en au un qui pompe 490mA) . Bons dans tout les cas , il aurais jamais supporté 14A .  :lol:  
 
Pour détecter la présence d'un connecteur USB , je déconseille l'emplois de relais électromécaniques à cause de l'effet de self à chaque coupure d'alim de la bobine , vaut mieux employer des micro-switch en faisant juste un petit trous sur le côté de la prise pour que le téton du constact puisse passer :  
http://www.selectronic.fr/article. [...] .8229-9999
 
ou en utilisant un optocoupleur , mais la ça complique un peu pour ceux qui ont pas l'habitude car il faut un peu plus de composants .
http://www.selectronic.fr/article. [...] .7391-9999

n°1444168
swissforev​er
i7 Inside
Posté le 05-07-2006 à 18:45:25  profilanswer
 

c'est utilisé pour passer justement a des tensions différentes!


---------------
Swisscore
n°1655594
mhamed8
Posté le 30-11-2007 à 20:31:20  profilanswer
 

bonjour, je cherche un schemas simple a ampli.opperationnel d'un detecteur de depassement.
merci.

n°1655818
swissforev​er
i7 Inside
Posté le 01-12-2007 à 17:47:01  profilanswer
 

comparateur quoi!

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Suivante

Aller à :
Ajouter une réponse
 

Sujets relatifs
Big Typhoon ou 9500 LEDPb Led Boitier
Zalman 9500 LED compatible avec ma cm ou pas? Compatibilité Zalman 9500 LED
COMMENT ,faire clignoter 4 LED avec un microswitch ?Intégrer des LED dans une alim ?
[topic unique]Zalman VF900-cu et LED[Resolu] Probleme port ethernet suite a overclocking
comment ne pas cramer mon port AGP 
Plus de sujets relatifs à : Led et port USB


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR