Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2136 connectés 

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Led et port USB

n°1437777
bluedevil
Posté le 18-06-2006 à 15:26:17  profilanswer
 

Bonjour  ;)  
 
 
Je me suis recement bricolé un rack usb de 2 ports, en façade (sur une baie 5" 1/4).
J'ai egalement prevu de mettre une/deux led sur cette baie, et j'avai prevu de bricoler tout ça, de telle sorte que la/les leds ne s'allume que lorsque l'on branche un peripherique usb dans ces ports (1 led d'acitivité pour chaque port en façade en quelque sorte).
 
 
Je post donc ici pour demander si les ports usb sont alimentés par default, ou si le courant n'i circule que lorsque le peripherique est branché, et si dans ce cas on peu tirer un peu de jus sans risque  :pt1cable: .
 
Sinon une autre solution pi être  :??:

mood
Publicité
Posté le 18-06-2006 à 15:26:17  profilanswer
 

n°1437783
Sully02
The dreamer
Posté le 18-06-2006 à 15:44:35  profilanswer
 

Ba en fait lorsqu'un nouveau matériel est détecté dans l'usb, c'est l’ordinateur qui fournit du courant au périphérique grâce aux fils GND et VBUS (jusqu’à 100mA).
 
Donc je ne sais pas s'il y a du courant quand il n'y a rien.
 
J'essai de te tenir au courant pour ca!


Message édité par Sully02 le 18-06-2006 à 15:46:46
n°1437789
bluedevil
Posté le 18-06-2006 à 15:55:34  profilanswer
 

merci de la reponse  :)  
 
Je vais aller recuperer un multimètre pour essayer de voir ça.
 
 
Sinon, lorsque le peripherique est detecté, le courant passe, je peut donc en deriver une partie pour des leds, ou ça risque d'influencer le port usb ?


Message édité par bluedevil le 18-06-2006 à 15:55:57
n°1437836
vladvasili​u
Posté le 18-06-2006 à 17:53:25  profilanswer
 

j'dois pas etre un des gars les plus douees en electrique / electronique du coin, mais j't'emmene quand meme mon point de vue:
si tu branches une led en serie avec le consommateur, normalement elle devrait s'allumer uniquement quand il y a du courant qui y passe (ie il y a un consommateur derriere). le pb, c'est que tous les periph. n'utilisent pas l'alimentation usb. les apareils photo (reflex, tout au moins) n'utilisent pas le courant venant du port usb. il n'y a donc pas de consommateur, donc le courant ne passe par par la diode, qui ne s'allume pas.
 
en ce qui concerne l'influence, j'imagine que la puissance d'une del n'est pas genante, a condition que ce que tu branches dessus ne soit pas a la limite de la puissance d'un port usb (0,1A, si j'me plante pas :D), sinon il peut y avoir certains pb, selon la tolerance de ta carte mere.

n°1437844
Sully02
The dreamer
Posté le 18-06-2006 à 18:28:05  profilanswer
 

+1! Le dépassement de la limite du courant (0,1A) peut contrarier le fonctionnement des périphériques connectés au bus USB!

n°1437848
vladvasili​u
Posté le 18-06-2006 à 18:33:55  profilanswer
 

cela dit, palier a ca doit pas etre trop dur. y'a pas que les cartes meres comme sources de courant dans la vie :D j'vois pas pk on pourrait pas utiliser l'alim comme source pour alimenter les periphs. usb. apres tout, c'la meme source +5V, et elle est censee tenir plus de 0,1A. sinon, le systeme avec la diode serait le meme, et ca marcherait avec la meme reserve (le periph. consomme ou pas).

n°1437853
bluedevil
Posté le 18-06-2006 à 18:43:56  profilanswer
 

mmh, je pourrai prendre sur l'alim oui.
Mais il faudrai detecter la connection d'un peripherique sur le port usb...
 
Pour la del ça ne devrai pas gener en effet, mais autant faire quelque chose de propre :)
 
Quelqu'un aurai une idée pour detecter l'acitivté du port usb ?

n°1437869
Sully02
The dreamer
Posté le 18-06-2006 à 19:06:07  profilanswer
 

Ba là je ne sais pas trop quoi te dire à part que la détection d'un nouveau périphérique se fait grâce au changement de la tension entre les fils D+ et D- (câble vert et câble blanc du port usb).
 
Peut-être que ca peut t'aider... :??:

n°1437913
bluedevil
Posté le 18-06-2006 à 19:45:31  profilanswer
 

j'ai fait 2 - 3 test au multimètre, on dirai que les ports son alimentés en permanence :(
 
je ne m'y connai pas assez en eletronique pour savoir ce que je peut faire avec une difference de tension. on peut la detecter mais après comment faire en sorte de fermer le circuits des leds Oo (en supposant que je les branche à l'alim)

n°1437952
vladvasili​u
Posté le 18-06-2006 à 21:32:46  profilanswer
 

mon histoire d'alim etait de remplacer l'alimentation du port usb venant de la carte mere par la "vraie" alim
maintenant, t'as tjs une tension entre le + et le - de l'alim, ca c'est normal :s
ta diode, tu la branches dans le sens du courant, sur un fil, tu la mets pas entre deux broches du port usb, mais entre une broche du port et la broche correspondante de l'apareil.

mood
Publicité
Posté le 18-06-2006 à 21:32:46  profilanswer
 

n°1437954
bluedevil
Posté le 18-06-2006 à 21:40:57  profilanswer
 

Oui j'avai bien compris ça, mais on ne peut pas detecter la presence ou non d'un peripherique, c'est pour ça que je pensai à un montage qui detecte la presence du peripherique, et declenche donc la fermeture du circuit de la led (qui est relié directement à l'alim car plus simple).

n°1437955
vladvasili​u
Posté le 18-06-2006 à 21:43:59  profilanswer
 

ca doit etre faisable de detecter du courant dans un des cables usb. par contre, c'pas a moi qu'il faut demander comment faire :D

n°1437956
bluedevil
Posté le 18-06-2006 à 21:46:59  profilanswer
 

hihi, je vais attendre que quelqu'un puisse m'aider alors :p
 
en attendant j'epluche google, mais sans succès jusque là :-/

n°1437969
tomsoft
Posté le 18-06-2006 à 22:23:55  profilanswer
 

dite moi si je me trompe :
 
http://img364.imageshack.us/img364/2743/sanstitre6xy.jpg
 
en gros, sans perif usb, le relais ne recoit pas ses 5volts, donc  il ne ferme pas le contact ...
 
 
a l'insertion du perif usb, le relais recoit ses 5volts, il ferme le conatc, qui allume la led :)
 
a l'ejection du perif, le contact s'ouvre, la led s'etteint  :jap:


Message édité par tomsoft le 18-06-2006 à 22:26:25
n°1437973
vladvasili​u
Posté le 18-06-2006 à 22:31:52  profilanswer
 

hum, ca a pas l'air trop mal, meme si j'vois pas vraiment l'interet du relais. le pb, c'est que ca marche pas si le periph' utilise pas l'alimentation usb.
l'idee serait plus de voir s'il y'a pas moyen de detecter une activite sur le port usb, genre en essayant de voir si du courant s'bouge sur une des deux lignes serie.

n°1437974
Natopsi
☄️Just end it already!☄️
Posté le 18-06-2006 à 22:33:18  profilanswer
 

Avec un shunt (resistance de trés faible valeur) et un ampli operationnel en comparateur reglable, c'est totalement possible  ;)  
Le shunt est en serie sur l'alim. de l'usb. Sa trés faible valeur (0.1 Ohm par exemple) ne perturbe en rien l'alimentation du peripherique, mais a ses bornes, il se crée une trés faible difference de tension lorsque l'on connecte un peripherique, qui est detectée par le comparateur qui allume la led. Surtout que des circuits integres integrent quatre amplis operationnels, ca doit pas coûter trop cher et c'est la meilleure solution  ;)


Message édité par Natopsi le 18-06-2006 à 22:33:53

---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1437975
tomsoft
Posté le 18-06-2006 à 22:33:58  profilanswer
 

le relais, c'est pour pas pomper sur l'alim usb qui ne delivre que 0.1A :jap:
 

n°1437976
Natopsi
☄️Just end it already!☄️
Posté le 18-06-2006 à 22:34:30  profilanswer
 

Et un relais pompe 50ma  :o


Message édité par Natopsi le 18-06-2006 à 22:34:39

---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1437977
tomsoft
Posté le 18-06-2006 à 22:35:20  profilanswer
 

:ouch: jpensais que ca pompait rien   :sweat:

n°1437980
Natopsi
☄️Just end it already!☄️
Posté le 18-06-2006 à 22:41:09  profilanswer
 

J'en prends un au hazard:
http://www.selectronic.fr/article. [...] =60.1193-1

Citation :

Bobine : 5 VDC / 167 W


Donc remplace le W par Ohm (c'est pareil),
5/167 = 0.030 A donc 30mA  ;)


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1437983
bluedevil
Posté le 18-06-2006 à 22:44:51  profilanswer
 

30mA le relais c'est vrai que :-/
 
Et pour ton système natopsi, je n'ai jamais utilisé d'ampliop dans un montage, c'est difficile à mettre en oeuvre, ou rien de bien sorcier ?
(et au niveau prix ? le shunt pas de probl, mais l'ampliop Oo ?)

n°1438167
bluedevil
Posté le 19-06-2006 à 16:24:27  profilanswer
 

En fait, après test le port usb delivre en permanence ses 5V...
 
 
J'ai pu trouver des infos ici : http://www.abcelectronique.com/acquier/usb2_fr.htm
 
http://www.abcelectronique.com/acquier/Images/contypea.gif
 
    * Vitesse Haute - 480Mbits/s (USB 2)
    * Vitesse Pleine - 12Mbits/s (USB 1)
    * Vitesse Basse - 1,5Mbits/s (USB 1)
 
 
L'identification se fait entre les pont 2 (D-) et 3 (D+).
 
C'est different selon les peripherique, ainsi, un periph usb "faible vitesse" (se fera identifié en mettant D- sur 3,3V et 1,5 kOhms.
Un peripherique pleine vitesse fera la même chose sur D+, jusque là ça ne gène pas, par contre :
 

Citation :

Les appareils haute vitesse démarreront dès qu'ils seront connectés en tant qu'appareils pleine vitesse (1,5 kOhms à 3,3V). Une fois qu'il sera attaché il émettra un Chirp à haute vitesse pendant la réinitialisation et établira une connexion à grande vitesse si le Hub le supporte. Si l'appareil fonctionne en mode haute vitesse, alors la résistance de rappel est retiré pour équilibrer la ligne.


 
 
 
J'ai aussi noté, que lorsque je faisait contact entre les pont 1 et 3 avec ne resistance (une led ici), windows tentai d'indentifier un peripherique usb...


Message édité par bluedevil le 19-06-2006 à 17:17:03
n°1438205
Natopsi
☄️Just end it already!☄️
Posté le 19-06-2006 à 18:04:15  profilanswer
 

J'ai pondu une simulation vite fait.
Donc j'ai calculé une résistance qui "joue" le periphérique USB censé consommer 50mA. J'ai mis un comparateur qui alimente une led.
Voila ce que ca donne:
La, le peripherique est débranché (interrupteur ouvert):
http://img505.imageshack.us/img505/7137/image99vh.png
Et la, il est branché, la led s'alume:
http://img518.imageshack.us/img518/3025/image103wb.png


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1438209
bluedevil
Posté le 19-06-2006 à 18:19:46  profilanswer
 

Ca semble être la meilleure solution, mais ça ne marchera que si le peripherique usb s'alimente sur le port usb (sauf si je n'ai pas tout suivit :p)
 
Chaque perpherique usb peut avoir sa consomation propre, si les 50mA varient, le montage sera toujour fonctionnel ?
 
(je ne connaissai même pas la fonction de comparateur de tension de l'ampli op, un vrai bijoux cette invention ^^)

n°1438212
Sully02
The dreamer
Posté le 19-06-2006 à 18:21:56  profilanswer
 

Natopsi a écrit :

J'ai pondu une simulation vite fait.
Donc j'ai calculé une résistance qui "joue" le periphérique USB censé consommer 50mA. J'ai mis un comparateur qui alimente une led.
Voila ce que ca donne:
La, le peripherique est débranché (interrupteur ouvert):
http://img505.imageshack.us/img505/7137/image99vh.png
Et la, il est branché, la led s'alume:
http://img518.imageshack.us/img518/3025/image103wb.png


Ah! Ca c'est du montage sur ISIS non? :D

n°1438213
bluedevil
Posté le 19-06-2006 à 18:27:24  profilanswer
 

oui ^^

n°1438272
swissforev​er
i7 Inside
Posté le 19-06-2006 à 20:28:14  profilanswer
 

vladvasiliu a écrit :

j'dois pas etre un des gars les plus douees en electrique / electronique du coin, mais j't'emmene quand meme mon point de vue:
si tu branches une led en serie avec le consommateur, normalement elle devrait s'allumer uniquement quand il y a du courant qui y passe (ie il y a un consommateur derriere). le pb, c'est que tous les periph. n'utilisent pas l'alimentation usb. les apareils photo (reflex, tout au moins) n'utilisent pas le courant venant du port usb. il n'y a donc pas de consommateur, donc le courant ne passe par par la diode, qui ne s'allume pas.
 
en ce qui concerne l'influence, j'imagine que la puissance d'une del n'est pas genante, a condition que ce que tu branches dessus ne soit pas a la limite de la puissance d'un port usb (0,1A, si j'me plante pas :D), sinon il peut y avoir certains pb, selon la tolerance de ta carte mere.


 
si tu met en série, tu vas tout cramer!!! ou alors ca va pas bien fonctionner, si jamais aux ports séries,je suis électro et je fais des fois, on met des leds en parallèle avec Tx et Rx, donc tu dois pouvoir mettre sure les données, sans trop chambouler le truc... mais c'est pas sur....


---------------
Swisscore
n°1438437
Natopsi
☄️Just end it already!☄️
Posté le 20-06-2006 à 10:20:48  profilanswer
 

bluedevil a écrit :

Ca semble être la meilleure solution, mais ça ne marchera que si le peripherique usb s'alimente sur le port usb (sauf si je n'ai pas tout suivit :p)
 
Chaque perpherique usb peut avoir sa consomation propre, si les 50mA varient, le montage sera toujour fonctionnel ?
 
(je ne connaissai même pas la fonction de comparateur de tension de l'ampli op, un vrai bijoux cette invention ^^)


Si la consommation augmente, c'est juste la tension qui va baisser pour le periph, jusqu'a 4.90v si 100mA
Si elle baisse, la tension de la résistance baisse et le systéme a moins de chance de reperer le branchement. Enfin si mes conaissances sont bonnes, il y a deux type d'usb : le low power et le high power.
Le low power est plutot dans les ordis portables et est capable de delivrer 100mA, et le high power, generalement sur les pc fixe, est capable de delivrer 500mA.
Faudrait voir comment transitent les données ^^'


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1438542
Sully02
The dreamer
Posté le 20-06-2006 à 14:56:06  profilanswer
 

Natopsi a écrit :

Si la consommation augmente, c'est juste la tension qui va baisser pour le periph, jusqu'a 4.90v si 100mA
Si elle baisse, la tension de la résistance baisse et le systéme a moins de chance de reperer le branchement. Enfin si mes conaissances sont bonnes, il y a deux type d'usb : le low power et le high power.
Le low power est plutot dans les ordis portables et est capable de delivrer 100mA, et le high power, generalement sur les pc fixe, est capable de delivrer 500mA.


+1! Ya aussi le Self-powered, c'est à dire les fonctions auto alimentées. Ils peuvent tirer jusqu'à une unité de charge et faire dériver le reste de leur alimentation d'une source extérieure. Si cette source extérieure venait à manquer, il doit y avoir des résreves en place de manière à ne pas tirer plus d'une unité de charge du Bus.

n°1438550
Gigathlon
Quad-neurones natif
Posté le 20-06-2006 à 15:19:35  profilanswer
 

Natopsi a écrit :

Le low power est plutot dans les ordis portables et est capable de delivrer 100mA, et le high power, generalement sur les pc fixe, est capable de delivrer 500mA.
Faudrait voir comment transitent les données ^^'


 
En fait c'est même 1A par hub, dans un pc un hub présente 2 ports.
 
Du coup, on peut tirer jusqu'à 1A sur un périphérique à condition qu'il soit seul sur son hub, même si certains abrutis ont commercialisé des modems dont la protection par fusible se déclanchait à 1.5A... et pour tout le monde, c'était la faute aux chipsets VIA :/
 
Pour les données c'est comme de l'ethernet, 1 paire croisée (enfin idéalement) véhiculant des signaux différentiels (D sur un des fils, /D sur l'autre), ce qui permet après soustraction des signaux d'éliminer les interférences.
 
D+ - D- = D
 
Si un parasite affecte D+, il affectera de la même manière D-, ce qui nous donne:
 
D+ = D + parasite
D- = /D + parasite
D = D+ - D- = (D + parasite) - (/D + parasite) = D - /D
 
Par dessus ça y'a un protocole, mais je l'ai pas étudié... :o


Message édité par Gigathlon le 20-06-2006 à 15:20:25
n°1438554
bluedevil
Posté le 20-06-2006 à 15:31:42  profilanswer
 

Pour detecter la presence d'un periph il faudrai donc voir le transit de données correspondant à la detection du periph par l'OS :-/

n°1438674
Xezbeth
Posté le 20-06-2006 à 20:03:56  profilanswer
 

heu... et si tu fesait un contact mécanique qui ferait comme un interupteur lorsque tu branche le périfirique? [:spamafote]
Genre une lamelle ou un zigouigoui dans le genre qui ferme le circuit des que tu rentre la prise USB.
Ca ferait un circuit indépendant, qui frais du mal a personne...
 
m'enfin moi je dit ça... :D

n°1438755
bluedevil
Posté le 20-06-2006 à 22:24:39  profilanswer
 

j'ai déjà essayé....
j'imaginai pas une prise usb aussi petite :-/
Une petite lamelle metalique passe, mais avec un isolant, même si je l'enduit de colle ça ne passe plus...
 
il faudrai que je trouve autre chose que de l'alu ou du fil de fer, cay pas le top :-/
Enfin, si tu vois une solution je prend sans hesiter :) !!!

n°1438805
Natopsi
☄️Just end it already!☄️
Posté le 21-06-2006 à 00:36:49  profilanswer
 

Un microswitch.
Quand on rentre une prise, contact!


---------------
ACH/VDSHFRCoin:7Z2K2a9BLZ1yo1v8uMr4rg7qD3vtBFXZ6p◈1435mm⚡
n°1438814
bluedevil
Posté le 21-06-2006 à 01:08:22  profilanswer
 

+1 ^^
 
il me semble que les plus petit sont de l'ordre de 12x6x6 ou quelque chose comme ça.
 
Je vais voir si je peut faire une entaille sur le port usb :)

n°1438866
Xezbeth
Posté le 21-06-2006 à 11:17:58  profilanswer
 

oui j'avais pas pensé au microswitch...
Ca pourrait ptetre passer avec un peux de chance.
 
Je tesetrais moi aussi quand  j'en aurais l'ocasion ;)

n°1438932
bluedevil
Posté le 21-06-2006 à 14:24:46  profilanswer
 

Déjà on ne peu pas faire d'entaille sur le dessus ou le dessous du port usb (la partie la plus large), car il s'y trouve des petits "teuteu" qui bloque la prise usb branchée...
 
Il reste donc les côté qui font 9 voir 9 mm, va falloir couper la languette du microrupteur :-/
je vais voir si je peut en recuperer pour tester ;)

n°1438950
Natopsi
☄️Just end it already!☄️
Posté le 21-06-2006 à 15:28:33  profilanswer
 

Encore mieux ;)
Tu fait un petit trou dans la prise et tu met un petit contact isolé de la masse. Lorsque tu branche la prise, ca le met a la masse et tu peut par consequent allumer une led ;)

n°1438954
bluedevil
Posté le 21-06-2006 à 15:40:49  profilanswer
 

j'avai pensé à ça au debut, mais je pensai que ça risquai de perturber les ports usb :-/
 
edit : j'ai un peu pensé à ton idée natopsi, mais comment veut tu placer ce petit contact afin que celà fonctionne oO ?


Message édité par bluedevil le 21-06-2006 à 17:53:17
n°1439055
Xezbeth
Posté le 21-06-2006 à 18:33:00  profilanswer
 

Si il est relié a la masse, ça perturbe rien a mon avis.
C'est quand il est relié au plus, la, a mon avis ça pertube le port USB...
 
T'en fait pas tu va bien trouver un moyen ;)

mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
 

Sujets relatifs
Big Typhoon ou 9500 LEDPb Led Boitier
Zalman 9500 LED compatible avec ma cm ou pas? Compatibilité Zalman 9500 LED
COMMENT ,faire clignoter 4 LED avec un microswitch ?Intégrer des LED dans une alim ?
[topic unique]Zalman VF900-cu et LED[Resolu] Probleme port ethernet suite a overclocking
comment ne pas cramer mon port AGP 
Plus de sujets relatifs à : Led et port USB


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR