Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1683 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Problème serveur apache2

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème serveur apache2

n°1431266
yethi
Posté le 12-03-2019 à 13:20:34  profilanswer
 

Bonjour à tous
 
Je tente de monter un site sur mon nas (WD My CLoud)
 
J'ai a priori tout bien configuré mais lorsque je relance apache2 j'ai le message
 
<VirtualHost> cannot occur within <VirtualHost>
 
J'ai cherché partout et je n'ai qu'une seule section <VirtualHost> </VirtualHost> (dans le .conf de mon site)
Donc impossible qu'elle soit contenue à l’intérieur d'une autre ....  
 
Il doit y avoir autre chose ailleurs...mais quoi ???
 
Merci d'avance
 

mood
Publicité
Posté le 12-03-2019 à 13:20:34  profilanswer
 

n°1431268
kaari
Fuck Yeah !
Posté le 12-03-2019 à 13:31:59  profilanswer
 

Erreur de syntaxe ? .conf importé depuis l'intérieur d'un vhost ?


---------------
Mon topic ventes ;)
n°1431278
memaster
ki a volé mon 62?
Posté le 12-03-2019 à 17:41:05  profilanswer
 

yethi a écrit :

Bonjour à tous
 
Je tente de monter un site sur mon nas (WD My CLoud)
 
J'ai a priori tout bien configuré mais lorsque je relance apache2 j'ai le message
 
<VirtualHost> cannot occur within <VirtualHost>
 
J'ai cherché partout et je n'ai qu'une seule section <VirtualHost> </VirtualHost> (dans le .conf de mon site)
Donc impossible qu'elle soit contenue à l’intérieur d'une autre ....  
 
Il doit y avoir autre chose ailleurs...mais quoi ???
 
Merci d'avance
 


en fait non :whistle:


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1431286
yethi
Posté le 12-03-2019 à 19:08:59  profilanswer
 

memaster62 : qu'est ce que tu veux dire par "en fait non" ??
 
kaari :
j'ai copié le fichier /etc/apache2/sites-available/000-default.conf en /etc/apache2/sites-available/yethi.conf
 
j'ai modifé la ligne  documentRoot pour indiquer le repertoire ou se trouve pour l'instant 1 seul fichier html
 
j'ai activé mon site avec un a2ensite ce qui a eu pour effet de créer un lien dans /etc/apache2/ sites-enabled : normal
 
voici mon fichier yethi.conf
<VirtualHost yethi.ovh:80>
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/yethi
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
 
alors pourquoi ce message quand je relance apache ???
 
une piste : l'accès au "tableau de bord" du nas ce fait direct quand je tape son IP dans un navigateur...donc le port 80 est défini ailleurs ???
avec un virtualHost ???
 
merci


Message édité par yethi le 12-03-2019 à 19:09:51
n°1431290
kaari
Fuck Yeah !
Posté le 12-03-2019 à 20:07:25  profilanswer
 

L'organisation change en fonction des distros donc je ne connais pas 000-default.conf, ou encore httpd.conf (qui appelle les conf de sites-available).
 
Regarde s'il y a un VirtualHost dans 000-default.conf. Regarde le contenu du fichier de conf qui include stes-enabled/*.conf, si l'include est dans un vhost, c'est de la que vient le probleme :/


---------------
Mon topic ventes ;)
n°1431296
yethi
Posté le 12-03-2019 à 20:26:33  profilanswer
 

le fichier 000-default.conf contient le minimum pour qu'un site fonctionne....il n'est pas activé
 
le repertoire sites-enabled contient ces 1 fichier et 3 liens :
 
-rwxr-xr-x 1 root root 101 Sep  3  2015 restsdk.conf
lrwxrwxrwx 1 root root  56 Oct  5 00:30 wdnas-rest-api.conf -> /etc/apache2/sites-available/wdnas-rest-api-trusted.conf
lrwxrwxrwx 1 root root  32 May  3  2018 wdnas-ui.conf -> ../sites-available/wdnas-ui.conf
lrwxrwxrwx 1 root root  29 Mar  3 16:03 yethi.conf -> ../sites-available/yethi.conf
 
le seul .conf qui contient une section <VirtualHost> c'est yethi.conf
 
..............???


Message édité par yethi le 12-03-2019 à 21:04:08
n°1431298
kaari
Fuck Yeah !
Posté le 12-03-2019 à 21:02:33  profilanswer
 

Et ca ne te donne pas d'indication sur la raison pour laquelle les autres fichiers fonctionnent et pas le tiens ? xO unrelated
 
Mais oui +1 memaster62, j'avais même pas vus :o


Message édité par kaari le 12-03-2019 à 21:55:20

---------------
Mon topic ventes ;)
n°1431300
memaster
ki a volé mon 62?
Posté le 12-03-2019 à 21:08:42  profilanswer
 

la conf d'un virtualhost est en principe assez simple. donc tu n'as pas lu la doc ou les examples. :sweat:


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1431318
yethi
Posté le 13-03-2019 à 07:04:35  profilanswer
 

oui ca a l'air simple...et j'ai regardé des exemples...  
 
mais le message d'erreur que je recois me dit que la section <virtualHost> de mon fichier yethi.conf est incluse à l'interieur d'une autre section <virtualHost>
 
je pense que c'est lié au tableau de controle du nas qui est lui aussi sur le port 80 et qui dispose d'un vost 'global' ???


Message édité par yethi le 13-03-2019 à 07:32:24
n°1431359
yethi
Posté le 13-03-2019 à 18:59:31  profilanswer
 

j'ai tenté ceci
 
fichier yethi.conf
 
<VirtualHost *:80>
        ServerName www.yethi.ovh  
        ServerAdmin webmaster@localhost
        DocumentRoot /var/www/yethi
        ErrorLog ${APACHE_LOG_DIR}/error.log
        CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
 
mais toujours la même erreur ligne 1....

mood
Publicité
Posté le 13-03-2019 à 18:59:31  profilanswer
 

n°1431490
yethi
Posté le 16-03-2019 à 21:00:48  profilanswer
 

salut memaster62 avec ta réponse "en fait non " j'ai l'impression que tu as la réponse à ma question ???
 
je precise que j'ai reussit à acceder  ma page html en virant la section virtualHost,en passant par le port 81
 
le seul problème c'est que dans ce cas pour acceder au site hebergé sur mon nas je dois taper l'adresse www.yethi.ovh:81
 
Ca doit bien etre possible en passant par le port 80 ????
 
merci

n°1431492
memaster
ki a volé mon 62?
Posté le 16-03-2019 à 21:16:00  profilanswer
 

essaye voir avec une directive serverAlias? ;)


---------------
ma conduite intérieure .:R | memaster pilote officiel de la HFR Badoit-Auchan F1 Team | zéro tracas, zéro blabla MMa.ster
n°1431500
yethi
Posté le 17-03-2019 à 09:41:30  profilanswer
 

un serveurAlias n'est utilisable qu'a l'interieur d'une section VirtualHost....


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  Problème serveur apache2

 

Sujets relatifs
Démarrer le serveur automatiquement au reboot de la machine.Serveur Web / Powershell centos 7
Problème démarrage Ubuntu suite MàJ ZentyalServeur Ubuntu KVM + Kimchi VPS innaccessible en SSH de l'exterieur
Problème sur aptGestion des logs sur un serveur dédié.
(Léger) problème avec mes règles Sieveprobleme apres instalation de ubuntu 14.04
Serveur Nas : OMV/Seafile/NextcloudTor service problème (kali)
Plus de sujets relatifs à : Problème serveur apache2


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR