Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1614 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème wifi après install de drivers nvidia sous Ubuntu

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème wifi après install de drivers nvidia sous Ubuntu

n°1063326
gelatine_v​elue
Posté le 30-07-2008 à 15:54:09  profilanswer
 

Bonjour tout le monde! [:jmav]  
 
Je me suis monté hier une machine Ubuntu. D'offfice, il me détecte ma connexion wifi, tout va bien. Il me dit qu'il utilise des drivers propriétaires pour faire marcher ma carte wifi (une Atheros AR5212/5213).
 
J'installe ensuite les drivers pour la carte graphique (Nvidia geforce 4 MX 440) en faisant la suite de commandes suivantes. L'install de ubuntu est fraîche.
 


sudo apt-get --purge remove nvidia-glx nvidia-glx-legacy nvidia-settings nvidia-kernel-common
 linux-restricted-modules-`uname -r` linux-restricted-modules-common
 
sudo rm /etc/init.d/nvidia-* #Dans mon cas le répertoire est vide
 
sudo apt-get install build-essential linux-headers-`uname -r` xserver-xorg-dev
 
wget http://fr.download.nvidia.com/XFree86/Linux-x86/173.08/NVIDIA-Linux-x86-XXXXX-pkg1.run
 
#un petit ctrl+alt+F4 pour passer en console
 
sudo /etc/init.d/gdm stop
 
sudo sh NVIDIA-Linux-x86-XXXXX-pkg1.run
#non à la premiére questions pour aller chercher je sais plus quoi sur internet
#aprés, laissé le faire sa petite cuisine
#répondez oui pour qu'il configure votre xorg.conf
#puis redémarrer
sudo reboot


 
La c'est bon, après reboot les drivers graphiques fonctionnent, mais ma carte wifi n'est plus reconnue. Un lspci la liste bien, mais un ifconfig montre juste la boucle locale 127.0.0.1.
 
Après quelques recherches il semblerait que c'est le fait d'avoir un remove des linux-restricted-modules qui a causé ça. Du coup, comment les réinstaller (sans internet)? Je peux toujours booter avec le live cd et avoir accès à internet, ou utiliser une clef usb depuis mon pc windauze.
 
Avec le live cd j'ai bien accès au contenu du disque dur, mais je sais pas commet faire pour dire à apt-get d'installer les packages dessus (et si il y a des dépendances?  [:alph-one] ) et pas sur le système de fichiers virtuels qu'il utilise. Je ne sais pas non plus si le fait de les réinstaller risque de créer un conflit avec les drivers graphiques.
 
Bref, vous aurez compris mon souci, toute aide sera très appréciée...
 
David.

mood
Publicité
Posté le 30-07-2008 à 15:54:09  profilanswer
 

n°1063379
ogaby
Posté le 30-07-2008 à 18:26:27  profilanswer
 

Salut
 
Dans synaptics, tu as la possibilité de dire que ton CD ROM est une source de dépôt (je ne sais pas où c'est car j'ai KDE). Puis ensuite tu installes.
 
Alternative:
Dans /etc/apt/source.list, tu dois avoir une ligne comme ca:
# deb cdrom:[Ubuntu 8.04 _Hardy Heron_
et tu changes en
deb cdrom:[Ubuntu 8.04 _Hardy Heron_
 
Et ensuite t'installes avec apt-get

n°1063386
gelatine_v​elue
Posté le 30-07-2008 à 19:02:05  profilanswer
 

ogaby a écrit :

Salut
 
Dans synaptics, tu as la possibilité de dire que ton CD ROM est une source de dépôt (je ne sais pas où c'est car j'ai KDE). Puis ensuite tu installes.
 
Alternative:
Dans /etc/apt/source.list, tu dois avoir une ligne comme ca:
# deb cdrom:[Ubuntu 8.04 _Hardy Heron_
et tu changes en
deb cdrom:[Ubuntu 8.04 _Hardy Heron_
 
Et ensuite t'installes avec apt-get


 
Merci pour ta réponse qui m'aurait sans duote sauvé la vie si j'avais pas trouvé jsute avant.
En effet, installer madwifi a résolu le problème.  
Le fait qu'il se présente sous la forme d'une archive sans dépendances aide beaucoup aussi!
Merci qui? Merci madwifi![:zcoold]  
Et merci ogaby!

n°1063392
Fork Bomb
Obsédé textuel
Posté le 30-07-2008 à 19:25:52  profilanswer
 

Juste pour faire mon chieur (et pour les prochaines fois aussi)
 
Pourquoi installer les drivers nVidia "à la main" ?
La dernière version était-elle indispensable ?
 
Tu as des paquets qui te font ça.
 
Tu tapes 2/3 commandes, tu tues X et c'est bon.
-----------
 [:delarue3]  
On m'indique dans l'oreillette qu'il y a aussi Synaptic pour installer et que c'est pas bien de faire peur aux gens comme ça.

Message cité 1 fois
Message édité par Fork Bomb le 30-07-2008 à 19:44:38

---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1063394
gelatine_v​elue
Posté le 30-07-2008 à 19:49:19  profilanswer
 

Fork Bomb a écrit :

Juste pour faire mon chieur (et pour les prochaines fois aussi)
 
Pourquoi installer les drivers nVidia "à la main" ?
La dernière version était-elle indispensable ?
 
Tu as des paquets qui te font ça.
 
Tu tapes 2/3 commandes, tu tues X et c'est bon.
-----------
 [:delarue3]  
On m'indique dans l'oreillette qu'il y a aussi Synaptic pour installer et que c'est pas bien de faire peur aux gens comme ça.


 
Dans ton oreillette on t'indique de la merde [:fender] . J'ai essayé par la méthode d'ubuntu, en cliquant avec la souris dans des cases, avec le driver libre, avec le proprio, mais aucun ne marchait, à cause des paquets linux-restricted-modules.
Je suis sûr de mon coup, ai passé 2 soirées entières avec 2 pc différents (mais avec des nvidia dedans), avant de trouver une soluce qui marche.


Message édité par gelatine_velue le 30-07-2008 à 19:49:49
n°1063399
Fork Bomb
Obsédé textuel
Posté le 30-07-2008 à 20:24:52  profilanswer
 

Juste comme ça, par acquis de conscience, on peut voir ton sources.list ?


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°1063413
gelatine_v​elue
Posté le 30-07-2008 à 23:12:13  profilanswer
 

Je n'avais pas changé l'activation ou pas des depots multiverse et universe si c'est ta question. Les drivers essayés je les ai téléchargés sous forme d'archive ou bien j'ai laissé fare ubuntu en tentant de démarrer la composition de tte façon. Je peux pas te le filer la , je suis sous une machine windows. Les symptomes étaient les suivants: résolution en 50 hz 800*600 max et pas de démarrage de la composition possible.
De tte façon osef, c'était mon wifi qui marchait pas ^^


Message édité par gelatine_velue le 30-07-2008 à 23:17:07

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  Problème wifi après install de drivers nvidia sous Ubuntu

 

Sujets relatifs
Force de signal wifi a 0%decompresser un fichier sur ubuntu
probleme de resolution de nom entre dns et fichier hostsProblème de droits avec Pure-ftp
nVidia ou ATi/AMD en entrée de gamme pour GNU/Linux ?Reseau wifi marche pu'
ubuntu live : réglagesProbléme accée site facebook
Problème sur Squid + winbind[Red Hat] PRoblème ext3 get inode loc
Plus de sujets relatifs à : Problème wifi après install de drivers nvidia sous Ubuntu


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR