Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
739 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Probleme carte SAS

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme carte SAS

n°1417635
gg25
Posté le 21-04-2018 à 00:25:00  profilanswer
 

Bonsoir à tous,
J'espère être dans la bonne catégorie.
 
Je suis entrain de monter un serveur de stockage (24To) sous Freenas.
 
Pour se faire, j'ai une carte mère Z87-GD65 Gaming, processeur Intel i5, 32 Go de RAM, 12 disques durs 2To.
Le boitier que j'ai acheté permet de racker directement les disques à l'intérieur sur 3 rangées de 4 disques. 3 connecteurs SAS permet de relier le boîtier à la carte mère.
J'ai 2 cartes SAS3081E PCI-E ayant chacune 2 connecteur SAS.
J'ai désactivé leur bios pour laisser Freenas les gérer (raid logiciel).
 
Mais j'ai un problème.
Quand une seule carte est connectée, pas de problème Freenas trouve les 8 disques dessus. Mais quand je connecte la seconde avec ses 4 disques, il semble y avoir un conflit entre les 2 cartes. Freenas remonte un code erreur 0x00004002 par port et presque aucun disque n'est reconnu. J'ai inversé les cartes, changé les ports PCI-e, reset du BIOS de la carte mère, activé et désactivé les BIOS des cartes mais toujours cette erreur. :heink: :fou:  
Etrangement, si rien n'est connecté sur les deux cartes, aucun conflit ne se crée...  :??: :heink:  
 
N'est-il pas possible d'utiliser deux cartes en même temps ? Une limite de taille des disques ? Saturation du Bus PCI-E ?
Si une âme charitable avait une idée pour me sortir de cette impasse je suis preneur  :)  
 
Merci d'avance :)


Message édité par gg25 le 21-04-2018 à 00:35:01
mood
Publicité
Posté le 21-04-2018 à 00:25:00  profilanswer
 

n°1417636
Je@nb
In ze cloud
Posté le 21-04-2018 à 11:38:15  profilanswer
 

Ce sujet a été déplacé de la catégorie Systèmes & Réseaux Pro vers la categorie Linux et OS Alternatifs par Je@nb

n°1417638
goblin_rie​ur
ingé systemes unix
Posté le 21-04-2018 à 13:03:14  profilanswer
 

ca depand de tes cartes ... beaucoup de cartes SAS ne supportent pas de ne pas être unique dans une machine.  
en général toute carte qui n'a pas son propre bios indépendant du bios motherboard ...  tu dois te méfier .
 
je ne connais pas ce modele de carte précisément mais tu peux etre dans ce cas.
 
il arrive aussi que certainees cartes aient des microswitch (boitiers dip4/6/8/14/16) soudés, dont certains doivent etre "bougés" pour permetre l'identification de carte comme n°1 n°2 et N°3 par exemple ....    
 
desactiver les bios dédiés  des cartes est TJRS une mauvaise idée .... à long terme
 
aussi certains bios/hardware sont pas fiables genre ils brident les nports PCI ou n ports PCIe en fonction du nombre de materiels attachés.....  
 
 :hello:  
 
faut voir ta conf materielle dans son ensemble  pas se focaliser surl le fait que tes cartes sont pas bien ensembles.  :hello:  ayant déjà été emmerdé avec ce genre de choses, j'ai pris l'habitude d'achetter chez les brokers du vrai hardware-serveur  au lieu de PC typés serveurs... :)   en plus ça revient bien moins cher au final en général ....   (genre 600euros max disques compris pour un 2*6cores*2threads 60Go extensible à 288Go  avec 2 raid controlleur SAS de 4*300Go et 2*147Go (2 slots restés vides) )....  tout en restant compatibles linux/bsd/freeNAS  :hello:


Message édité par goblin_rieur le 21-04-2018 à 13:10:56

---------------
Collectionner les vieux serveurs c'est chouette mais c'est lourd et ça prend de la place ;)
n°1417643
gg25
Posté le 21-04-2018 à 13:41:15  profilanswer
 

Merci de prendre le temps à ma question.
 
J'ai fais un test ce matin. J'ai retiré tous les disques et démarré le serveur. Puis je les ai inséré un à un. Freenas à reconnu les 12 disques pour la première fois !  
Mais quand j'ai voulu créer un pool, le serveur est rentré dans une boucle infinie entrainant la perte de contrôle. J'ai dû faire un hard reboot pour reprendre la main sur la machine et bien-sûr échec de la création du pool.
http://image.noelshack.com/fichiers/2018/16/6/1524310353-img-20180421-124118.jpg
Le da3 correspond au disque lu, et il le fait pour tous les disques en boucle...

n°1417644
goblin_rie​ur
ingé systemes unix
Posté le 21-04-2018 à 13:52:37  profilanswer
 

t'as pas de bol le asc0,0 signifie bien error mais "inconnue" ou "sans infos"...alors pour avancer...   courage....
 
une error normale se présente comme :


(da3:mpt0:0:14:0): WRITE(10). CDB: 2a 0 42 0 45 f0 0 0 8 0
(da3:mpt0:0:14:0): CAM status: SCSI Status Error
(da3:mpt0:0:14:0): SCSI status: Check Condition
(da3:mpt0:0:14:0): SCSI sense: MEDIUM ERROR asc:14,1 (Record not found)
and
(da7:mpt0:0:13:0): SCSI status error
(da7:mpt0:0:13:0): READ(10). CDB: 28 0 29 e d7 0 0 0 38 0
(da7:mpt0:0:13:0): CAM status: SCSI Status Error
(da7:mpt0:0:13:0): SCSI status: Check Condition
(da7:mpt0:0:13:0): SCSI sense: UNIT ATTENTION asc:29,0 (Power on, reset, or bus .....

 
 
et là on sais ce que c'est.... mais dans ton cas... non.....     je sais pas t'aider plus là...


---------------
Collectionner les vieux serveurs c'est chouette mais c'est lourd et ça prend de la place ;)

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Probleme carte SAS

 

Sujets relatifs
problème de partitionsProblème avec Roundcube, adresse mail bizarre....
Problème lors de l'installation de Kali Linux sur Virtual BoxProblème HP proliant G4 ML350
Problème plus de Boot - Parrot Security / Windows 10Problème de reconnaissance matériel à l'installation de Ubuntu
problème de réduction et fermeture des fenêtre sur ubuntu[RESOLU] Problème IP publique, service no-ip
Problème installation Linux Problème affichage en mode MSHybrid (laptop)
Plus de sujets relatifs à : Probleme carte SAS


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR