Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1732 connectés 

  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Serveur DHCP avec plusieurs VLAN (packet tracer)

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Serveur DHCP avec plusieurs VLAN (packet tracer)

n°121697
kenzay
Posté le 15-06-2014 à 21:29:46  profilanswer
 

Bonjour,
 
 
J'ai réalisé le montage suivant sur le logiciel packet tracer : http://gyazo.com/4717a8ad0ec8970e858885e683a705f0
 
 
- Tous les Switchs sont sur le même domain VTP, les Switchs Core (qui sont donc de niveau 3) sont en mode serveurs et les autres en mode clients.
 
- Les interfaces VLAN sont paramétrées de cette manière : http://gyazo.com/8d743182f986c98c1dfe257df8f8457b
 
- L'adresse du DHCP est 192.168.1.2 et sa passerelle est 192.168.1.1.
 
- Les pools du DHCP ont été créés.
 
- Les interfaces qui sont entre chaque Switch sont en mode trunk et ceux reliées aux PC sont en mode access.
 
 
J'aimerais que le serveur DHCP distribue automatiquement les @IP aux PC mais avec la configuration suivante les requêtes DHCP échoue.
 
 
Est-t-il possible sur packet tracer de créer un serveur DHCP pour plusieurs VLAN sans routeur et sous-interfaces ?
 
Si oui, que manque-t-il a ce montage pour fonctionner ?

mood
Publicité
Posté le 15-06-2014 à 21:29:46  profilanswer
 

n°121699
ahbahlut
UTC-8
Posté le 15-06-2014 à 23:12:10  profilanswer
 

Salut, t'as pas posté au bon endroit, ça va lock.
 
Mais sinon il faut que tu configures le DHCP relay pour que cela fonctionne.
 
exemple pour l'interface VLan10

!
interface VLan10
  ip address 192.168.10.1 255.255.255.0
  ip helper-address <adresse du serveur dhcp>
!


Message édité par ahbahlut le 15-06-2014 à 23:14:18
n°121703
kenzay
Posté le 16-06-2014 à 08:55:15  profilanswer
 

Malgré l'ajout des ip helper-address mon serveur DHCP ne fonctionne toujours pas.
Mes pools sont ils bien configurés ? : http://nsa34.casimages.com/img/201 [...] 991815.png
 
Ps : Dans quel section suis-je censé poster ?

Message cité 1 fois
Message édité par kenzay le 16-06-2014 à 10:25:11
n°121709
Nicodonald
Posté le 16-06-2014 à 09:41:07  profilanswer
 

Bah non tes vlans ont des gateway en dehors de leur plage réseau :o rien que ça c'est pas logique. Ta passerelle sert a sortir de ton réseau, si elle ne se trouve pas dans ton réseau tu ne peux pas la contacter.

n°121711
kenzay
Posté le 16-06-2014 à 10:02:09  profilanswer
 

Oui j'ai fait erreur sur les gateways ce problème est maintenant corrigé mais les requêtes DHCP échoue toujours.
 
http://nsa33.casimages.com/img/201 [...] 573053.png


Message édité par kenzay le 16-06-2014 à 10:25:43
n°121712
ahbahlut
UTC-8
Posté le 16-06-2014 à 10:06:39  profilanswer
 

kenzay a écrit :


Ps : Dans quel section suis-je censé poster ?


 
A mon avis le post aurait été plus adapté   dans : Réseaux grand public / SoHo>Réseau  :o  
 
Peux tu coller dans un message la conf d'un de tes switches L3 (show run) ?


Message édité par ahbahlut le 16-06-2014 à 10:08:37
n°121713
kenzay
Posté le 16-06-2014 à 10:17:33  profilanswer
 

Configuration du switch Core 1 :
 - http://nsa34.casimages.com/img/201 [...] 277931.png
 - http://nsa34.casimages.com/img/201 [...] 946420.png
 
C'est un réseau que je vais devoir reproduire en entreprise je me suis donc dit que je suis au bon endroit  :(


Message édité par kenzay le 16-06-2014 à 10:35:30
n°121717
ahbahlut
UTC-8
Posté le 16-06-2014 à 11:46:05  profilanswer
 

T'as activé le routage sur ton l3 ?
 

ip routing

n°121718
kenzay
Posté le 16-06-2014 à 12:25:34  profilanswer
 

Je viens de l'activer.


Message édité par kenzay le 16-06-2014 à 13:09:22
n°121722
ahbahlut
UTC-8
Posté le 16-06-2014 à 14:17:45  profilanswer
 

Il va falloir envisager de laisser la main à des gens qui savent faire, si tu ne connais pas l'ip routing, le dhcp relay et tu te trompe sur les passerelles, je vois mal comment tu vas t'en sortir.
 
Je dis ça sans méchanceté, mais le réseau ce n'est pas quelque chose qui s'improvise :o

Message cité 1 fois
Message édité par ahbahlut le 16-06-2014 à 14:18:08
mood
Publicité
Posté le 16-06-2014 à 14:17:45  profilanswer
 

n°121723
kenzay
Posté le 16-06-2014 à 14:31:01  profilanswer
 

Je tiens juste a te préciser que je suis actuellment en stage mais je ne suis pas vraiment encadré, je me débrouille donc par moi-même, j'ai néanmoins réussi à reproduire le même système mais en créant des pools sur un routeur ce qui n'est pas possible sur les switch 3560. N'ayant pas trouver assez d'information sur internet je me suis donc penché sur ce forum.
 
Je ne savais pas qu'il y'avait une commande pour activé le routage sur ce switch, pour ce qui est des relais dhcp je les avais mis mais une fois chez moi pour prendre des screenshots les .pkt ne voulais pas s'ouvrir car j'ai la mauvaise version du logiciel, j'ai donc essayer de reproduire cela rapidement mais sur l'ancienne version l'ip helper-address était une commande non connue. Pour ce qui est des passerelles j'avais mis les bonnes mais j'ai fait erreur en refaisant le schèma chez moi.


Message édité par kenzay le 16-06-2014 à 14:41:03
n°121728
bardiel
Debian powa !
Posté le 16-06-2014 à 18:38:07  profilanswer
 

ahbahlut a écrit :

Il va falloir envisager de laisser la main à des gens qui savent faire, si tu ne connais pas l'ip routing, le dhcp relay et tu te trompe sur les passerelles, je vois mal comment tu vas t'en sortir.


De base si déjà il utilise Packet Tracer, c'est qu'il apprend hein, je dis ça sans méchanceté :o
 
Après pour la question du routeur, si c'est au niveau software que ça bloque, ton serveur DHCP (Windows ou Linux) peut très bien accueillir un routeur, car il s'agit d'une fonction "de base" [:spamatounet]  
Et ainsi pas besoin de switch coeur de réseau, de simples switchs supportant les VLANs suffisent (ce qui coûte en plus légèrement moins cher :o )


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°121730
bardiel
Debian powa !
Posté le 17-06-2014 à 00:21:24  profilanswer
 

Bon, en modifiant comme je le met dans mon précédent message :
http://img4.hostingpics.net/pics/566523rzo.png
Voici la liste des commandes à taper et le récapitulatif de la configuration... testé sous Packet Tracer 6.0.1.0011

Spoiler :

configuration "Routeur" :
Serveur DHCP sur G 0/0
"CORE1" sur G 0/1
 
configuration "CORE 1" :
"Routeur" sur G 1/2
"CORE2" sur G 1/1
VLAN 10 sur Fa 0/1
VLAN 20 sur Fa 0/2
 
configuration "CORE 2" :
"CORE2" sur G 1/1
VLAN 30 sur Fa 0/1
VLAN 40 sur Fa 0/2
 
Serveur DHCP : adresse ip 192.168.1.1 / masque 255.255.255.0 / GW 192.168.1.254
TOUS les postes clients sont en full DHCP, y compris la passerelle.
 
Descriptifs des commandes :
 
Router>en
Router#conf t
Router(config)#hostname Routeur
Routeur(config)#interface g 0/0
Routeur(config-if)#ip address 192.168.1.254 255.255.255.0
Routeur(config-if)#no shut
Routeur(config-if)#exit
Routeur(config)#interface g 0/1
Routeur(config-if)#no shut
Routeur(config-if)#exit
Routeur(config)#interface g 0/1.1
Routeur(config-subif)#encap dot1Q 10
Routeur(config-subif)#ip address 192.168.10.1 255.255.255.0
Routeur(config-subif)#ip helper-address 192.168.1.1
Routeur(config-subif)#no shut
Routeur(config-subif)#exit
Routeur(config)#interface g 0/1.2
Routeur(config-subif)#encap dot1Q 20
Routeur(config-subif)#ip add 192.168.20.1 255.255.255.0
Routeur(config-subif)#ip helper-address 192.168.1.1
Routeur(config-subif)#no shut
Routeur(config-subif)#exit
Routeur(config)#interface g 0/1.3
Routeur(config-subif)#encap dot1Q 30
Routeur(config-subif)#ip add 192.168.30.1 255.255.255.0
Routeur(config-subif)#ip helper-address 192.168.1.1
Routeur(config-subif)#no shut
Routeur(config-subif)#exit
Routeur(config)#interface g 0/1.4
Routeur(config-subif)#encap dot1Q 40
Routeur(config-subif)#ip add 192.168.40.1 255.255.255.0
Routeur(config-subif)#ip helper-address 192.168.1.1
Routeur(config-subif)#no shut
Routeur(config-subif)#exit
Ctrl+[Z]
Routeur#sh run
(...)
interface GigabitEthernet0/0
 ip address 192.168.1.254 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/1.1
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.1.1
!
interface GigabitEthernet0/1.2
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.1.1
!
interface GigabitEthernet0/1.3
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address 192.168.1.1
!
interface GigabitEthernet0/1.4
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
 ip helper-address 192.168.1.1
!
(...)
Routeur#copy run start
------------------------------
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname CORE1
CORE1(config)#interface f 0/1
CORE1(config-if)#switchport mode access
CORE1(config-if)#switchport access vlan 10
% Access VLAN does not exist. Creating vlan 10
CORE1(config-if)#exit
CORE1(config)#interface f 0/2
CORE1(config-if)#switchport mode access
CORE1(config-if)#switchport access vlan 20
% Access VLAN does not exist. Creating vlan 20
CORE1(config-if)#exit
CORE1(config)#interface g 1/1
CORE1(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to up
CORE1(config-if)#exit
CORE1(config)#interface g 1/2
CORE1(config-if)#swichport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/2, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/2, changed state to up
CORE1(config-if)#
Ctrl+[Z]
CORE1#sh run
(...)
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 20
 switchport mode access
!
(...)
interface GigabitEthernet1/1
 switchport mode trunk
!
interface GigabitEthernet1/2
 switchport mode trunk
!  
(...)
CORE1#copy run start
------------------------------
Switch>en
Switch#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#hostname CORE2
CORE2(config)#interface g 1/1
CORE2(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to up
CORE2(config-if)#exit
CORE2(config)#interface f 0/1
CORE2(config-if)#switchport mode access
CORE2(config-if)#switchport access vlan 30
% Access VLAN does not exist. Creating vlan 30
CORE2(config-if)#exit
CORE2(config)#interface f 0/2
CORE2(config-if)#switchport mode access
CORE2(config-if)#switchport access vlan 40
% Access VLAN does not exist. Creating vlan 40
Ctrl+[Z]
CORE2#sh run
(...)
interface FastEthernet0/1
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 40
 switchport mode access
!
(...)
interface GigabitEthernet1/1
 switchport mode trunk
!
(...)
CORE2#copy run start
Destination filename [startup-config]?  
Building configuration...
[OK]
CORE2#


Avec pour le serveur DHCP :
http://img4.hostingpics.net/pics/942271DHCP.png
Et le routeur :
http://img4.hostingpics.net/pics/205595routeur.png
Les switchs des VLANs en eux-même n'ont aucune configuration.
Et bien entendu, comme il s'agit de VLANs, ils ne peuvent communiquer entre eux...


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°121738
kenzay
Posté le 17-06-2014 à 10:30:33  profilanswer
 

Merci à toi Bardiel d'avoir pris le temps de m'afficher cette configuration mais c'est celle que j'ai déjà faite (en tout cas ça me servira de support si jamais je dois revenir dessus).  
 
Ce que je cherche à faire c'est de mettre en place (sans routeur) un serveur DHCP avec des switch de L3 et des VLAN ce qui sera plus ressemblant au réseau de mon entreprise, mais malgrès plusieurs recherches je n'ai rien trouvé à ce sujet et j'aimerais donc savoir si cela est possible sur ce logiciel.


Message édité par kenzay le 17-06-2014 à 10:34:14
n°121740
bartinoob
Nope.
Posté le 17-06-2014 à 11:00:37  profilanswer
 

C'est possible. J'avais fait une manip du genre avec plusieurs Vlan et un seul serveur DHCP pour tous. Fallait juste spécifier au niveau du switch niveau 3 (qui servait en gros de routeur pour moi) quelle était l'adresse du DHCP. Il me semble que j'avais dû autoriser l'accès au DHCP via une route qui va bien, vu que le serveur n'était pas sur la même plage que mes différents PC. (J'avais fait un truc du style :  
 
Vlan10 : serveurs  
Vlan2 : groupe de PC n°1
vlan3 : groupe de PC n°2
 
Je regarde ce que j'ai fait du fichier ce soir et je te l'uploade si je le retrouve.

n°121741
kenzay
Posté le 17-06-2014 à 11:13:16  profilanswer
 

Très bien, merci sa m'aiderai énormément :).

Message cité 1 fois
Message édité par kenzay le 17-06-2014 à 11:13:44
n°121745
bardiel
Debian powa !
Posté le 17-06-2014 à 16:59:21  profilanswer
 

Hmm je serais intéressé aussi par ce montage, la solution que j'ai donné étant "moche", s'il y a mieux...


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°121753
bartinoob
Nope.
Posté le 18-06-2014 à 00:11:10  profilanswer
 

kenzay a écrit :

Très bien, merci sa m'aiderai énormément :).


 
Hop, j'avais zappé, voilà le fichier : http://cjoint.com/?DFsakr4M7E8
 
Le 2eme switch L3 est à ignorer, je voulais tester le spanning-tree mais c'est apparemment pas pris en charge par packet tracer, d'où toutes les interfaces down. Ça date de quelques mois par contre donc j'me rappelle plus de toute la config  :(

n°121756
Nicodonald
Posté le 18-06-2014 à 08:10:16  profilanswer
 

Tu as quelle version de packet tracer ? je faisais du spanning tree avec

n°121758
bartinoob
Nope.
Posté le 18-06-2014 à 09:15:56  profilanswer
 

Il me semble que c'était la 6, j'avais pas mal cherché et j'avais pas réussi à avoir un truc qui fonctionnait, tous les résultats sur le net disaient que le spanning-tree était pas implanté pour le moment.

n°121759
ahbahlut
UTC-8
Posté le 18-06-2014 à 09:29:08  profilanswer
 

bardiel a écrit :


De base si déjà il utilise Packet Tracer, c'est qu'il apprend hein, je dis ça sans méchanceté :o


 
Mais je suis assez d'accord c'est juste que cette section du forum n'est pas là pour l'aide aux devoirs. Maintenant si la modération tolère, why not.
 
 
 
Voici ce que j'ai comme schéma, le même que celui initial, même adresse, mêmes vlan ID, tout pareil.
 
http://img4.hostingpics.net/thumbs/mini_461134schma.png
 
Conf du CORE1 :
 

CORE1#sh run
Building configuration...
 
Current configuration : 1670 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname CORE1
!
!
!
!
!
ip routing
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
 switchport mode access
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
 ip address 192.168.10.1 255.255.255.0
 ip helper-address 192.168.1.2
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip helper-address 192.168.1.2
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
 ip helper-address 192.168.1.2
!
interface Vlan40
 ip address 192.168.40.1 255.255.255.0
 ip helper-address 192.168.1.2
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
!
!
end


 
Il n'y a rien de très exotique, c'est pour ça que je ne voyais pas la difficulté, mais si ça peut t'aider.

n°121764
kenzay
Posté le 18-06-2014 à 10:18:37  profilanswer
 

ahbahlut a écrit :

Mais je suis assez d'accord c'est juste que cette section du forum n'est pas là pour l'aide aux devoirs.


On voit pas les choses de la même manière, toi tu pense que ça peut s'assimiler à des devoirs alors que je pense que c'est simplement une simulation simple qui va me permettre comprendre le fonctionnement du système réseau de l'entreprise, c'est plus efficace d'apprendre à faire avec un schéma simple plutot que d'essayer de comprendre avec un schéma complexe qui comporte un grand nombre de PC et VLAN car on peut facilement faire des erreurs.
 
 


Merci, je n'ai pas la même version que la tienne je vais voir une fois chez moi si je peut accèder au fichier.
 
 
 
En tout cas merci pour vos réponse  :) .


Message édité par kenzay le 18-06-2014 à 10:28:41
n°121775
bardiel
Debian powa !
Posté le 18-06-2014 à 11:23:34  profilanswer
 

De ce que je vois :

Citation :

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!


Donc ce qui est connecté sur ces ports doivent déjà être taggé ? Bof :o


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°121778
kenzay
Posté le 18-06-2014 à 11:32:31  profilanswer
 

Voilà tout est opérationnel, il me suffisait juste d'ajouté une ip a l'interface du vlan 1 :heink:.

n°121779
bartinoob
Nope.
Posté le 18-06-2014 à 11:33:32  profilanswer
 

bardiel a écrit :

De ce que je vois :

Citation :

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!


Donc ce qui est connecté sur ces ports doivent déjà être taggé ? Bof :o

 

Euh ... Lapin compris. C'était du vlan par ports, donc sur les switchs L2, tu dois effectivement définir le vlan à l'avance.

 

'Fin je crois que je pige pas du tout ce que tu racontes en fait :o

Message cité 1 fois
Message édité par bartinoob le 18-06-2014 à 11:34:20
n°121791
kenzay
Posté le 18-06-2014 à 14:01:13  profilanswer
 

J'en profite pour poser une question, est-ce possible de faire du routage inter-vlan (sans ajouter de routeur) avec cette configuration ?

n°121794
bartinoob
Nope.
Posté le 18-06-2014 à 14:11:53  profilanswer
 

Oui. D'ailleurs, il est déjà en place dans cette config.

n°121796
kenzay
Posté le 18-06-2014 à 14:25:14  profilanswer
 

Ah bon ? Peut tu m'indiquer à quel moment ça se fait s'il te plaît ?

n°121797
ahbahlut
UTC-8
Posté le 18-06-2014 à 14:27:28  profilanswer
 

bardiel a écrit :

De ce que je vois :

Citation :

interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!


Donc ce qui est connecté sur ces ports doivent déjà être taggé ? Bof :o


 
Les fa 0/1 et 0/2 sont connectés aux 2950, je ne vois pas le problème en fait ?
 
conf d'un 2950 :
 

Switch#sh run
Building configuration...
 
Current configuration : 1096 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
!
spanning-tree mode pvst
!
interface FastEthernet0/1
 switchport mode trunk
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 no ip address
 shutdown
!
!
line con 0
!
line vty 0 4
 login
line vty 5 15
 login
!
!
end


 
Autre chose, pour le stp ça fonctionne bien sur Packet Tracer 6. Positionnez 4 switches, reliez les tous avec leurs voisins, soit trois cables par switches. Vous allez voir que certaines lumières vertes des interfaces passent en orange, c'est bien que le stp est en fonction. Maintenant désactivez le stp : Switch(config)#no spanning-tree vlan 1, les lumières vont toutes passer au vert, et si vous générez du traffic vous allez voir le processus de packet tracer affoler votre CPU ;)

n°121798
ahbahlut
UTC-8
Posté le 18-06-2014 à 14:29:04  profilanswer
 

kenzay a écrit :

J'en profite pour poser une question, est-ce possible de faire du routage inter-vlan (sans ajouter de routeur) avec cette configuration ?


 

ahbahlut a écrit :

T'as activé le routage sur ton l3 ?
 

ip routing



 
:o

n°121799
kenzay
Posté le 18-06-2014 à 14:32:24  profilanswer
 

Il suffit donc simplement d'activer le routage sur les Switchs Core pour que les vlans communiquent entre eux :o ?

Message cité 1 fois
Message édité par kenzay le 18-06-2014 à 14:56:31
n°121800
bartinoob
Nope.
Posté le 18-06-2014 à 14:34:11  profilanswer
 

ahbahlut a écrit :

Autre chose, pour le stp ça fonctionne bien sur Packet Tracer 6. Positionnez 4 switches, reliez les tous avec leurs voisins, soit trois cables par switches. Vous allez voir que certaines lumières vertes des interfaces passent en orange, c'est bien que le stp est en fonction. Maintenant désactivez le stp : Switch(config)#no spanning-tree vlan 1, les lumières vont toutes passer au vert, et si vous générez du traffic vous allez voir le processus de packet tracer affoler votre CPU ;)


 
Bizarre, sur autre autre version de cette conf, j'avais justement tout qui passait en vert et plus aucun paquet qui passait correctement tellement ça spammait de partout. Faudra que je retente pour voir.

n°121804
ahbahlut
UTC-8
Posté le 18-06-2014 à 15:55:05  profilanswer
 

kenzay a écrit :

Il suffit donc simplement d'activer le routage sur les Switchs Core pour que les vlans communiquent entre eux :o ?


 
Oui, à la condition que le switch core ait connaissance des VLAN et qu'ils aient une adresse IP(=passerelle).

n°121817
bardiel
Debian powa !
Posté le 18-06-2014 à 20:57:58  profilanswer
 

bartinoob a écrit :

Euh ... Lapin compris. C'était du vlan par ports, donc sur les switchs L2, tu dois effectivement définir le vlan à l'avance.
 
'Fin je crois que je pige pas du tout ce que tu racontes en fait :o


T'as posé tes définitions de VLANs sur les 2950, et donc le lien entre les 2950 et les 3560 se fait déjà taggué.
Compare ma config, je n'ai défini mes VLAN que sur les switch "core", pas de trunk sur les liens "core" vers les 2950.
 
C'est sûr que si tu dois avoir plusieurs VLANs dans le même emplacement physique (le site), c'est une solution.
Pour ma part j'avais compris : chaque site à son propre VLAN.
 
Moi j'ai pris en configuration :
A Paris où se concentre toutes les liaisons, j'ai juste 1 modem/VPN/ce que tu veux qui vient de chaque site.
Je suis à Bordeaux, j'ai mon 2950 avec le VLAN 10. A Paris j'ai mon modem "Bordeaux" sur le port 1.
Je suis à Marseille, j'ai mon 2950 avec le VLAN 20. A Paris j'ai mon modem "Marseille" sur le port 2.
 
Toi c'est une configuration :
A Paris où se concentre toutes les liaisons, j'ai 1 modem/VPN/ce que tu veux qui vient de chaque site, branché n'imp on s'en fiche vu que tout est en trunk.
Je suis à Bordeaux, j'ai mon 2950 avec le VLAN 10 et 30.
Je suis à Marseille, j'ai mon 2950 avec le VLAN 10 et 40.
 
Juste une question d'organisation autre :D


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
n°121818
bartinoob
Nope.
Posté le 18-06-2014 à 21:21:00  profilanswer
 

Ah, ouais, je voulais tester deux "groupes" d'utilisateurs, donc j'ai tout mis sur le même site :p

n°121819
ahbahlut
UTC-8
Posté le 18-06-2014 à 21:27:45  profilanswer
 

bardiel a écrit :


T'as posé tes définitions de VLANs sur les 2950, et donc le lien entre les 2950 et les 3560 se fait déjà taggué.
Compare ma config, je n'ai défini mes VLAN que sur les switch "core", pas de trunk sur les liens "core" vers les 2950.
 
C'est sûr que si tu dois avoir plusieurs VLANs dans le même emplacement physique (le site), c'est une solution.
Pour ma part j'avais compris : chaque site à son propre VLAN.
 
Moi j'ai pris en configuration :
A Paris où se concentre toutes les liaisons, j'ai juste 1 modem/VPN/ce que tu veux qui vient de chaque site.
Je suis à Bordeaux, j'ai mon 2950 avec le VLAN 10. A Paris j'ai mon modem "Bordeaux" sur le port 1.
Je suis à Marseille, j'ai mon 2950 avec le VLAN 20. A Paris j'ai mon modem "Marseille" sur le port 2.
 
Toi c'est une configuration :
A Paris où se concentre toutes les liaisons, j'ai 1 modem/VPN/ce que tu veux qui vient de chaque site, branché n'imp on s'en fiche vu que tout est en trunk.
Je suis à Bordeaux, j'ai mon 2950 avec le VLAN 10 et 30.
Je suis à Marseille, j'ai mon 2950 avec le VLAN 10 et 40.
 
Juste une question d'organisation autre :D


 
L’intérêt des VLAN c'est bien de pouvoir faire cohabiter plusieurs réseaux logiques (couche 3 du modèle OSI) sur un même réseau physique. Dans ton cas les réseaux physiques sont séparés, à quoi s’embêter avec des vlan, un simple plan d'adressage IP suffit pour séparer les réseaux.


Message édité par ahbahlut le 18-06-2014 à 21:28:11
n°121847
bardiel
Debian powa !
Posté le 19-06-2014 à 13:59:17  profilanswer
 

Pourquoi s'embêter avec des VLANs ?
J'ai indiqué des villes volontairement séparés, après tout dans le même bâtiment avec un brassage sur plusieurs switchs, ça revient au même (étage RDC VLAN 10, 1er VLAN 20, sous-sol VLAN 30, baie informatique VLAN 40...)
 
Les 2 solutions sont pour moi aussi valable l'une que l'autre.


---------------
Grippe ? Coronavirus ? Portez votre masque correctement ! :D
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Systèmes & Réseaux Pro
  Réseaux

  Serveur DHCP avec plusieurs VLAN (packet tracer)

 

Sujets relatifs
Problème réception mail serveur perso avec nom de domaine 1and1Refroidissement serveur
DHCP et comportement d'un poste client au boot[Résolu] Comment faire pour mettre 2 Vlan sur un même port ?
[RESOLU] Connaitre l'@IP d'un DHCPConfig serveur
Problème sur mon serveur NASMappage Lecteurs Réseaux - Windows Serveur 2012
clé serveur 2003 invalideOutlook 2010 : Partage calendrier (sans Exchange) via serveur Webdav
Plus de sujets relatifs à : Serveur DHCP avec plusieurs VLAN (packet tracer)


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR