Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
930 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Configurer routeur en IP fixe

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Configurer routeur en IP fixe

n°786057
extra
Posté le 13-08-2014 à 17:35:59  profilanswer
 

Bonjour,
 
En déplacement ou en vacance dans la famille, j’utilise régulièrement les hotspots WiFi de mon FAI (SFR).
 
Le problème est que je suis à la limite de la couverture en gros je peux me connecter sur le bord de la fenêtre, mais pas à l'intérieur de la maison.
 
J'ai donc monté avec des anciens produits Dlink le montage suivant :
 
http://s10.postimg.org/3us5ebnph/Image1.jpg
 
Le premier point d'accès en mode client, il assure la réception du hotspot.
 
Le routeur fait le lien et remet les adresses dans le sous-réseau 192.168.0.x
 
Le dernier point d'accès, diffuse l'ensemble.
 
La seule chose qui m'embête dans ce système est que je n'ai pas accès au premier point d'accès en mode client si celui-ci n'est pas connecté à un hotspot qui lui donne une adresse IP. Je peux y accéder en mettant le routeur en IP fixe, mais du coup je n'ai plus accès à internet.
 
Sur le routeur j'ai essayé de mettre des paramètres fixes en copiant ceux présents en mode dynamique, mais cela ne fonctionne pas...
 
Si quelqu'un sait pourquoi ce serait cool :)
 
 copie d'écran du routeur en IP fixe (accès DWL2100 mais pas à internet)
http://s22.postimg.org/ods1svvj1/DI_604_2.jpg
 
copie d'écran de l'état du routeur en IP automatique (accès au DWL2100 si accès à internet)
 
http://s15.postimg.org/924owhkdz/DI_604_5.jpg


Message édité par extra le 13-08-2014 à 17:38:31
mood
Publicité
Posté le 13-08-2014 à 17:35:59  profilanswer
 

n°786117
duff99
Posté le 14-08-2014 à 08:39:00  profilanswer
 

:hello:
 
Déjà, pourquoi ne pas tout laisser sur un seul réseau ?


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786208
extra
Posté le 14-08-2014 à 12:13:08  profilanswer
 

Parce que l'on ne peut pas avoir le même sous-réseau à l'entrée WAN et LAN du routeur :)

n°786215
MikeTheFre​eman
Posté le 14-08-2014 à 12:36:37  profilanswer
 

Je vois ce que tu essaie de faire, d'ailleurs les dd-wrt (et d'autres je suppose) ont la fonction que tu essaies de réaliser (client dhcp côté wan puis bridge avec le lan) mais sur un seul équipement.
 
Je connais pas ces équipements, peut-être que la fonction est plus difficile à implémenter avec des équipements séparés.
 
Juste une chose qui me gêne côté routeur sur ton schéma : l'adresse ip dhcp client est bien configuré sur la patte wan du routeur ? Tu as bien configuré une adresse d'un range différent (que celui du wan) pour le lan ?
 
Et les adresses ip des access point ne sont pas essentielles normalement pour le fonctionnement dans le cas présent. D'ailleurs l'access point côté wan peut foutre la zone si tu lui laisse une ip de config.

n°786224
duff99
Posté le 14-08-2014 à 13:11:11  profilanswer
 

extra a écrit :

Parce que l'on ne peut pas avoir le même sous-réseau à l'entrée WAN et LAN du routeur :)


 
Oui évidemment, mais ton routeur dispose bien de ports LAN non ? (4 ?). Pourquoi vouloir à tout prix utiliser le port WAN ?


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786231
MikeTheFre​eman
Posté le 14-08-2014 à 13:27:35  profilanswer
 

duff99 : ça peut marcher mais c'est pas propre. Tu branches tes deux ap sur le lan de ton routeur. Sur un ap tu rentre les ssid/pass du hotposs auquel tu veux accéder et tu l'autre tu configure ton point d'accès perso. Le problème c'est que le hotspot va peut-être pas vouloir filer plusieurs adresses ip à la même mac address de l'AP.
 
Ce que cherche à faire extra est plus indiqué.

Message cité 1 fois
Message édité par MikeTheFreeman le 14-08-2014 à 13:28:20
n°786272
duff99
Posté le 14-08-2014 à 14:21:22  profilanswer
 

MikeTheFreeman a écrit :

duff99 : ça peut marcher mais c'est pas propre. Tu branches tes deux ap sur le lan de ton routeur. Sur un ap tu rentre les ssid/pass du hotposs auquel tu veux accéder et tu l'autre tu configure ton point d'accès perso. Le problème c'est que le hotspot va peut-être pas vouloir filer plusieurs adresses ip à la même mac address de l'AP.
 
Ce que cherche à faire extra est plus indiqué.


 
Oui je suis d'accord, c'est pas propre, m'enfin.. :lol:
 
Au fait, c'est normal que sur la conf WAN du routeur (image DI-604-2), le masque de sous réseau est "255.255.0.0" ?


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786369
extra
Posté le 14-08-2014 à 17:18:11  profilanswer
 

Citation :

 
Juste une chose qui me gêne côté routeur sur ton schéma : l'adresse ip dhcp client est bien configuré sur la patte wan du routeur ?  


 
Oui
 

Citation :

 
Tu as bien configuré une adresse d'un range différent (que celui du wan) pour le lan ?

 
OUI 192 168.20x pour le réseau HOTspot, 192.168.0.x pour le LAN
 

Citation :

Au fait, c'est normal que sur la conf WAN du routeur (image DI-604-2), le masque de sous réseau est "255.255.0.0" ?


Oui, c'est pour accéder au point d'accès client qui n'est pas dans le même sous réseau

n°786374
MikeTheFre​eman
Posté le 14-08-2014 à 17:35:27  profilanswer
 

C'est quoi le range de l'adresse ip que te donne le hotspot ?

n°786409
extra
Posté le 14-08-2014 à 19:19:14  profilanswer
 

Le hotspot SFR assigne une adresse en 192.168.2.x

mood
Publicité
Posté le 14-08-2014 à 19:19:14  profilanswer
 

n°786460
MikeTheFre​eman
Posté le 15-08-2014 à 00:01:07  profilanswer
 

Maintenant que j'y pense c'est un hotspot SFR, faut s'authentifier sur un portail je crois.
Mais je vois pas pourquoi ça merde, désolé :/

n°786946
duff99
Posté le 18-08-2014 à 12:58:21  profilanswer
 

extra a écrit :

Oui, c'est pour accéder au point d'accès client qui n'est pas dans le même sous réseau


 
Alors il y a un truc de pas cohérent où je suis vraiment à l'Ouest, mais regarde tes 2 images, sur l'une (Home, en statique), le masque est en 255.255.0.0, et sur l'autre (Status, dynamique) tu es bien en 255.255.255.0.
 
D'ailleurs, pourquoi se mettre en /16 ? Pour connecter seulement 1 AP ?
 
Edit: J'ai oublié de demander, mais.. tu as peut être déjà trouvé la solution ? :D


Message édité par duff99 le 18-08-2014 à 12:59:26

---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786948
extra
Posté le 18-08-2014 à 13:25:56  profilanswer
 

Bonjour,
 
Non, je n'ai pas trouvé la solution,
J'ai même branché le client en direct sur le PC, j'ai le même problème.
Le masque n'est pas le problème (enfin je pense)
Comme après le routeur je suis en 192.168.0.x et le hot spot en 192.168.2.x je mets le masque en 255.255.0.0 sinon je ne peux plus accéder au client...

n°786954
duff99
Posté le 18-08-2014 à 14:15:23  profilanswer
 

Résumons,

 

Le masque de sous réseau permet de définir la partie réseau et la partie hôte.

 

Les bits à 1 définissent la partie réseau, et les bits à 0 le nombre d'hôte que la plage IP peut accueillir (simplifié :O)

 

Sur un masque à 255.255.255.0, on a donc :

 

11111111.11111111.11111111.00000000

 

Donc une adresse IP en 192.168.2.1 en /16 (255.255.0.0) et une autre en 192.168.2.1 en /24 (255.255.255.0), ce n'est pas la même chose !


Message édité par duff99 le 18-08-2014 à 17:11:52

---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786955
MikeTheFre​eman
Posté le 18-08-2014 à 14:18:31  profilanswer
 

Le masque le plus recommandé dans ton cas est un /22 (255.255.252.0 : 192.168.0.1 à 192.168.3.254). D'ailleurs si tu configure ton lan en 192.168.3.X, tu peux même utiliser un /23 (255.255.254.0). Mais ça marche uniquement si tu branches l'ap sur un des ports lan de ton routeur et pas directement sur le port wan.
Si tu veux que ça marche via la patte wan, il faut que tu remplaces sur l'ap l'adresse de passerelle par défaut (et que tu mettes le masque /24 classique) par l'adresse donné par le hotspot sfr à l'interface wan de ton routeur en mode client dhcp (facile si le hotpost donne toujours la même).
 
Mais encore une fois, l'ip de l'ap ne sert plus à rien une fois que les identifiants accès au hostpot ont été configurés (tu peux même le faire en local avec ton laptop), sauf à vérifier s'il s'est effectivement bien connecté au hotspot sfr de manière administrative. C'est juste l'ip de gestion de l'ap, elle ne sert en rien pour la connectivité réseau (un point d'accès c'est du niveau 2).
 
Si tu n'arrives pas à te connecter avec l'ap directement connecté sur le laptop, c'est qu'il y a un soucis niveau de l'ap. Si tu as rentré le bon ssid ? le bon protocole (c'est un wifi ouvert ? etc) ? Tu as accès au portail d'authentification ? Est-ce que le port réseau de ton laptop a l'autosense, et si non est-ce que tu utilise bien un câble droit ?
On est bien d'accord que tu arrives à t'authentifier normalement avec juste le wifi de ton laptop ?
Tant que tu n'arriveras pas à la page portail sfr en désactivant le wifi intégré du laptop et en utilisant juste l'ap, tout le reste du matériel ne servira à rien.


Message édité par MikeTheFreeman le 18-08-2014 à 16:20:28
n°786982
duff99
Posté le 18-08-2014 à 17:00:26  profilanswer
 

Le hotspot SFR distribue sur la plage 192.168.2.x /16 ou 192.168.2.x /24 ?


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°786988
MikeTheFre​eman
Posté le 18-08-2014 à 17:26:33  profilanswer
 

192.168.2.X/24 je suppose.
 
Je pense qu'il pensait (Inception) que mettre un masque en /16 éviterait à son ap de passer par une passerelle et donc qu'en restant reste à l'intérieur du réseau (et contourner le fait que son interface wan n'a pas d'ip) il pourrait communiquer avec l'ap.
 
Sauf que comme l'ap est branché sur le wan et que cette interface est en mode routage et qu'elle fonctionne pas tant qu'elle a pas d'adresse (elle commutera rien).
 
Par contre je lui disais qu'il suffisait de configurer son ap en étant certain qu'elle va se connecter au hotspot. Après il n'a plus besoin de se connecter dessus et peut-être que son interface wan (en mode client dhcp) choppera une ip.
 
Mais là déjà il dit qu'il arrive pas à se connecter avec juste l'ap connecté à son laptop :/

n°786991
duff99
Posté le 18-08-2014 à 17:34:54  profilanswer
 

En /24 je suppose aussi :jap:

 

Donc j'ai pensé à un truc (pas très clair finalement la paramétrage) :

 

Le champ "Gateway" du routeur DI-604 correspond à l'interface WAN de ce routeur (donc 192.168.2.1).

 

Le hotspot distribue des adresses en 192.168.2.0/24.

 

Sachant qu'il a configuré l'IP de la patte WAN en 192.168.2.1/16 et que le hotspot donne des adresses en 192.168.2.0/24, comment veux-tu que les 2 réseaux communiquent ?

 

C'est pour ça que je trouvais logique de passer en /24 le masque sur le DI-604. Ce qui correspondrais en plus avec le paramétrage dynamique non ?

 

Edit : ou alors je suis parti loin :pt1cable:


Message édité par duff99 le 18-08-2014 à 17:46:41

---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°787006
extra
Posté le 18-08-2014 à 18:39:07  profilanswer
 

Je viens de refaire un test et je n'y comprends plus rien...
 
La PA client est branché via un câble réseau sur mon ordinateur portable :
 
L'ordinateur est en configuration automatique, j'ai accès au portail d'identification..
 
IPCONFIG /ALL donne :
 

Configuration IP de Windows
 
Carte Ethernet Connexion au réseau local :
 
   Suffixe DNS propre … la connexion. . . :  
   Description. . . . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)
   Adresse physique . . . . . . . . . . . : 00-26-9E-E6-29-AE
   DHCP activé‚. . . . . . . . . . . . . . : Oui
   Configuration automatique activée. . . : Oui
   Adresse IPv6 de liaison locale. . . . .: fe80::2cf8:1381:b62d:993c%10(préféré)  
   Adresse IPv4. . . . . . . . . . . . . .: 192.168.2.90(préféré)  
   Masque de sous-réseau. . . .ÿ. . . . . : 255.255.255.0
   Bail obtenu. . . . . . . . .ÿ. . . . . : lundi 18 ao–t 2014 18:13:41
   Bail expirant. . . . . . . . .ÿ. . . . : lundi 18 ao–t 2014 18:33:41
   Passerelle par défaut. . . .ÿ. . . . . : 192.168.2.1
   Serveur DHCP . . . . . . . . . . . . . : 192.168.2.1
   IAID DHCPv6 . . . . . . . . . . . : 234890910
   DUID de client DHCPv6. . . . . . . . : 00-01-00-01-19-1B-A0-1C-00-26-9E-E6-29-AE
   Serveurs DNS. . .  . . . . . . . . . . : 109.0.66.10
                                109.0.66.20
   NetBIOS sur Tcpip. . . . . . . . . . . : Activé


 
J'entre les paramètres manuellement, je n'ai plus accès au portail, Windows me signal un problème et me suggère de mettre le paramètre en automatique :)
 


Configuration IP de Windows
 
 
Carte Ethernet Connexion au réseau local :
 
   Suffixe DNS propre … la connexion. . . :  
   Description. . . . . . . . . . . . . . : Realtek RTL8168D/8111D Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)
   Adresse physique . . . . . . . . . . . : 00-26-9E-E6-29-AE
   DHCP activé‚. . . . . . . . . . . . . . : Non
   Configuration automatique activée. . . : Oui
   Adresse IPv6 de liaison locale. . . . .: fe80::2cf8:1381:b62d:993c%10(préféré)  
   Adresse IPv4. . . . . . . . . . . . . .: 192.168.2.90(préféré)  
   Masque de sous-réseau. . . .ÿ. . . . . : 255.255.255.0
   Passerelle par défaut. . . .ÿ. . . . . : 192.168.2.1
   IAID DHCPv6 . . . . . . . . . . . : 234890910
   DUID de client DHCPv6. . . . . . . . : 00-01-00-01-19-1B-A0-1C-00-26-9E-E6-29-AE
   Serveurs DNS. . .  . . . . . . . . . . : 109.0.66.10
                                109.0.66.20
   NetBIOS sur Tcpip. . . . . . . . . . . : Activé


Message édité par extra le 18-08-2014 à 18:40:17
n°787025
MikeTheFre​eman
Posté le 18-08-2014 à 19:27:43  profilanswer
 

Ben c'est normal, je suis pas expert en wireless mais en plus des clés pré configurées, les protocoles wpa utilisent également des clés temporaires.
Je vais éviter de dire trop de conneries mais en gros le processus de modification dynamique de clé ne peut pas se faire si tu te configures en statique et que tu overrides le processus d'obtention d'adresse dynamique etc.
 
J'avais eu la même install que toi chez moi (sauf que c'était sur un routeur all in one) et je ne pouvais pas configurer l'interface wan en statique quand je la configurais pour se connecter au réseau wifi de la box.
 
Mais normalement ça ne devrait pas l'empêcher d'aller sur le net, garde la config sur l'ap (l'ip on s'en fout, à la limite désactive-la si tu peux car le hotspot ne va peut-être pas aimer de voir une ip qu'il n'a pas attribué et dans le pire des cas ça peut tout faire foirer) et branche-la sur l'interface wan du routeur que tu configures en client dhcp. Configure le serveur dhcp côté lan sur ton routeur (avec n'importe quelle adresse réseau privée sauf 192.168.2.x) et dis-lui d'utiliser la config dns que le routeur a choppé sur le wan au cas où.
Configure le point d'accès côté lan avec les identifiants que tu veux et normalement à moins qu'il y ait une subtilité qui m'échappe, à ta première requête web tu devrais te retrouver sur le portail sfr.


Message édité par MikeTheFreeman le 18-08-2014 à 19:28:41
n°787041
extra
Posté le 18-08-2014 à 20:15:17  profilanswer
 

Effectivement je vais garder le système en l'état, il fonctionne et la manipe n'est pas si compliquée pour accéder et paramétrer le PA client.  
 
Merci à tous pour votre participation ;)
 

n°787050
MikeTheFre​eman
Posté le 18-08-2014 à 20:22:33  profilanswer
 

Dis-nous si ça fonctionne avec le routeur :fou:

n°787066
extra
Posté le 18-08-2014 à 21:02:11  profilanswer
 

Oui, cette façon fonctionne...  
 

n°787122
duff99
Posté le 19-08-2014 à 09:03:18  profilanswer
 

Tu peux nous résumer vite fais toute la config réseau ? Je suis un peu perdu là et j'aimerai bien comprendre :O


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°787126
extra
Posté le 19-08-2014 à 09:35:55  profilanswer
 

En faite elle n'a pas changé... car elle fonctionne depuis le début.  
Pour choisir un hotspot WiFi, je dois accéder et configurer le PA client, mon problème est qu'en IP dynamique si je ne suis pas connecté à un hotspot, le PA client à une adresse bidon et je n'ai pas accès au PA...
Je passe le routeur en IP fixe pour paramétrer le PA et je repasse en IP dynamique et c'est OK
Je pensais que l'on pouvait rester sur une IP fixe pour simplifier la manipe.


Message édité par extra le 19-08-2014 à 09:36:35
n°787135
duff99
Posté le 19-08-2014 à 10:03:20  profilanswer
 

Ok merci ;)


---------------
« Odi panem quid meliora. Ça ne veut rien dire, mais je trouve que ça boucle bien »
n°787141
MikeTheFre​eman
Posté le 19-08-2014 à 11:16:46  profilanswer
 

C'est ce que je disais depuis mon premier post si vous remarquez bien.
Bon en fait il n'y a jamais eu de problème d'accès.
 
Edité : en y réfléchissant c'est des conneries :jap:


Message édité par MikeTheFreeman le 19-08-2014 à 11:40:52
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  Configurer routeur en IP fixe

 

Sujets relatifs
Conseil > choix d'un routeur wifi puissantServer DNS maison,sous domaine, IP dynamique, la solution ?
Besoin d'aide pour choisir routeur + switch et configurationConnexion routeur DWR-921 via modem câble
Routeur Modem NAS ?Routeur wifi n 150 Mbps
Nouv. routeur : impossible de lui attrib. addresse IP 192.168.1.xReset du routeur via prise telecommandee et monitoring internet
IP Statique dans réseau géré en DHCP 
Plus de sujets relatifs à : Configurer routeur en IP fixe


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR