Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1711 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  [Résolu] Branchement ethernet déconnecte l'accès internet wifi

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] Branchement ethernet déconnecte l'accès internet wifi

n°851707
jura_savag​nin
Posté le 21-05-2015 à 11:41:52  profilanswer
 

Bonjour,
 
Un dessin vaut mieux qu'un long discours :
http://img11.hostingpics.net/thumbs/mini_777552Capture.jpg
 
Mon PC en wifi se déconnecte d'internet dés l'instant où je branche un câble ethernet; le débranchement rétablit la connexion.
Le câble ethernet est relié à un petit réseau, SANS ACCÈS au réseau internet, autour d'un routeur (NAS, 2 autres PC, imprimante)
 
Comment faire pour avoir simultanément accès à internet par la wifi, ET accès au réseau local par ethernet ???


Message édité par jura_savagnin le 22-05-2015 à 11:13:59
mood
Publicité
Posté le 21-05-2015 à 11:41:52  profilanswer
 

n°851709
deyko
Posté le 21-05-2015 à 11:47:11  profilanswer
 

Salut,
 
Il me semble que lorsque tu as deux connexions il faut que tu spécifies la route par défaut a prendre pour aller sur internet.
 
Lorsque tu branches ton cable ethernet, il doit prendre la priorité sur le Wifi.
 
http://www.google.fr/search?q=chan [...] gws_rd=ssl
 
Ca devrait t'aider.

n°851714
jura_savag​nin
Posté le 21-05-2015 à 12:12:45  profilanswer
 

Merci deyko,
 
Wi-fi est correctement positionné devant ethernet. Ce n'est donc pas la cause
http://img11.hostingpics.net/thumbs/mini_861070Capture.jpg
 
...
 

n°851758
deyko
Posté le 21-05-2015 à 14:29:41  profilanswer
 

Quelle est la plage IP des deux réseaux ? Il n'y a pas de conflit a ce niveau là?
 
La commande "traceroute" doit pouvoir t'aider a comprendre ce qu'il se passe.

n°851764
almer
Posté le 21-05-2015 à 14:37:20  profilanswer
 

+1
 
Et avec les 2 cartes activées/branchées :
un petit ipconfig /all
un petit route print


---------------
L'acouphène est un bon rempart à l'idiophilie
n°851786
jura_savag​nin
Posté le 21-05-2015 à 15:33:13  profilanswer
 

Merci almer de rejoindre deyko
 
Donc voilà,
http://i.imgur.com/KuvHtas.jpg
Pour traceroute, je veux bien un coup de main pour l'executer.


Message édité par jura_savagnin le 21-05-2015 à 15:37:39
n°851792
jura_savag​nin
Posté le 21-05-2015 à 15:47:39  profilanswer
 

Et voici, si ça peut servir, les options de mon routeur :
 
http://img15.hostingpics.net/thumbs/mini_398607linksys.png

n°851816
deyko
Posté le 21-05-2015 à 16:34:34  profilanswer
 

Dans ton "route print" on y voit 2 routes pour 0.0.0.0 ( ca correspond au chemin par défaut, donc utilisé pour internet)
 
La métrique la plus faible, (prioritaire) a pour interface: 192.168.1.103, ca correspond a la carte Broadcom Netlink Giga, ton réseau câblé.
 
Avec la commande "route delete" tu devrais supprimer la route 0.0.0.0 de ton réseau câblé.
 
https://technet.microsoft.com/fr-fr [...] s.10).aspx
 
Ton DHCP du réseau câblé te fourni une passerelle que tu ne souhaites pas utiliser, ca doit être la source du problème, pour ca que ton PC ne sait pas ou partir.


Message édité par deyko le 21-05-2015 à 16:43:05
n°851860
jura_savag​nin
Posté le 21-05-2015 à 19:42:54  profilanswer
 

J'ai utilisé la commande :
route delete 0.0.0.0 mask 0.0.0.0 192.168.2.1
 
Bien que supprimée, je n'ai pas pu accéder à internet.
En rebootant, la ligne était revenue :(

n°851863
Teflon1
Posté le 21-05-2015 à 20:26:15  profilanswer
 

essaie de désactiver le dhcp de ton routeur sur reseau local filaire ou au moins d'enlever la passerelle par défaut sur ta connexion filaire.

mood
Publicité
Posté le 21-05-2015 à 20:26:15  profilanswer
 

n°851914
jura_savag​nin
Posté le 21-05-2015 à 23:17:00  profilanswer
 

Merci Teflon1,  
 
... mais complétement à la ramasse, je ne m'en sors pas.
 
Voici ce que j'ai compris
Il me faut donc aller ds les paramètres du router et basculer sur static IP.  Oui mais il me faut renseigner IP, passerelle par defaut, ss masque, dns. Je trouve ça où ?
http://img15.hostingpics.net/thumbs/mini_985567Capture.jpg
 
Mais peut-être est-ce de ceci que vs me suggérez de changer :
http://img15.hostingpics.net/thumbs/mini_391731Capture.jpg
 
Quant à enlever la passerelle par defaut de ma connexion filaire, je suis encore plus paumé.
 
Pas faute d'avoir cherché un peu partout : sans cesse, les tutos indiquent qu'il faut renseigner les identifiants IP du FAI (ce que je ne peux pas)

n°851941
almer
Posté le 22-05-2015 à 09:31:18  profilanswer
 

tu peux essayer ça :
Sur la configuration Windows de ta carte réseau WiFi :
Dans les paramètres IP v4 (l'équivalent de ton dernier print screen) :
Bouton "Avancé" :
Tu décoches "métrique automatique".
Tu mets "1" en Métrique de l'interface.
Tu vérifies par Route Print que la destination 0.0.0.0 liée à 192.168.2.91 a bien un métrique de 1 tandis que la même destination via 192.168.1.103 a toujours son métrique de 20 (ou en tout cas un métrique supérieur). Si c'est le cas, ça devrait marcher.
 
 


---------------
L'acouphène est un bon rempart à l'idiophilie
n°851968
jura_savag​nin
Posté le 22-05-2015 à 11:11:29  profilanswer
 

Formidable, j'ai fait ça sur mes 2 PC en filaire et ça a fonctionné.
 
J'ai l'impression que cette solution alternative n'est pas la plus propre pour des puristes comme vs et que peut-être elle comporte des inconvénients, mais pour le moment, ça me convient royal !!!
 
 Merki bcp @ almer, Teflon1, deyko :jap:

n°851980
almer
Posté le 22-05-2015 à 11:39:11  profilanswer
 

Tant mieux.
C'est pas le plus propre mais c'est pas complètement déconnant non plus. A la base, le métrique est positionné en fonction de la "vitesse" de la carte afin de privilégier la plus rapide pour une même destination (en gros, parce que c'est plus compliqué en réalité). Là on va tricher pour forcer à passer par la carte Wifi pour chaque destination partagée entre les deux cartes. ça tombe bien, seule ta carte Wifi peux voir le net...

 

Comme l'ont dit deyko et Teflon1, la vrai solution est du côté de ton router filaire et de ses paramètres DHCP. Quelque part tu dois avoir un default-route positionné à 192.168.1.1 et c'est là qu'est le problème.
C'est quoi la référence exacte de ton router Cisco ?


Message édité par almer le 22-05-2015 à 11:40:01

---------------
L'acouphène est un bon rempart à l'idiophilie
n°851986
jura_savag​nin
Posté le 22-05-2015 à 11:49:22  profilanswer
 

Donc si je comprends bien, tt se joue au niveau du paramétrage du routeur.
La configuration Windows des cartes réseau (wi-fi & ethernet), devrait être laissée par défaut (ip & dns automatique)
 
La référence est WRT54GC
Jette un oeil un peu plus haut (hier 15:47), j'ai fait screen de toutes les fenêtres du routeur

n°851998
Teflon1
Posté le 22-05-2015 à 12:14:55  profilanswer
 

Bien vu pour les métriques, c'est une solution efficace.
 
l'autre solution est de n'avoir une passerelle par défaut que sur le réseau wifi et pas sur le réseau filaire. Car c'est par la passerelle par défaut que windows va passer pour router sur un réseau extérieur.
Dans la plupart des cas avec un serveur dhcp et avec windows, la passerelle par defaut sera automatiquement non vide, avec l'adresse du serveur dhcp.
Donc la solution pour enlever la passerelle par défaut est de mettre les PC en IP statique sur le réseau lan filaire et de ne pas spécifier de passerelle par défaut.  
A noter que tu n'est pas obligé de désactiver le dhcp sur le routeur pour etre en statique sur les PC.
Au final la solution des métriques est plus simple mais ne pas oublier de la retirer le jour ou tu n'en a plus besoin !

Message cité 1 fois
Message édité par Teflon1 le 22-05-2015 à 12:17:00
n°851999
almer
Posté le 22-05-2015 à 12:26:07  profilanswer
 

Rien vu dans la doc qui permette de renseigner une Gateway sur ce router au niveau DHCP server.
bon, en même temps, c'est un router hein, c'est pas déconnant qu'il se présente au client comme route par défaut ;)  
Après, tu peux peut être revoir ton architecture. Par exemple, pourquoi ton router ne "doit pas" voir le WAN ?


---------------
L'acouphène est un bon rempart à l'idiophilie
n°852001
almer
Posté le 22-05-2015 à 12:29:37  profilanswer
 

Teflon1 a écrit :

Donc la solution pour enlever la passerelle par défaut est de mettre les PC en IP statique sur le réseau lan filaire et de ne pas spécifier de passerelle par défaut.  
A noter que tu n'est pas obligé de désactiver le dhcp sur le routeur pour etre en statique sur les PC.


 
C'est une très bonne solution aussi.


---------------
L'acouphène est un bon rempart à l'idiophilie
n°852002
Teflon1
Posté le 22-05-2015 à 12:30:34  profilanswer
 

Sinon y'a une solution pour que le routeur ait un serveur DHCP sans passerelle par défaut : flasher le firmware avec dd-wrt puis configurer par l'interface web voire directement en CLI par telnet ... Pas la solution la plus élégante non plus :lol:

n°852004
jura_savag​nin
Posté le 22-05-2015 à 12:32:34  profilanswer
 

@ almer il me semble qu'il est question du gateway ds la fenêtre 1.4
http://img15.hostingpics.net/thumbs/mini_398607linksys.png
EDIT :
@Teflon1 j'ai songé à flasher ce fameux firmware dd-wrt, mais j'ai l'impression qu'il n'y a pas le bon chipset  
https://www.google.fr/search?q=Link [...] KKQnSIVXTc

Message cité 2 fois
Message édité par jura_savagnin le 22-05-2015 à 12:37:02
n°852006
almer
Posté le 22-05-2015 à 12:41:23  profilanswer
 

jura_savagnin a écrit :

@ almer il me semble qu'il est question du gateway ds la fenêtre 1.4


Non, rien à voir, là c'est la gestion du routage entre le router et le WAN.
Gateway : c'est bien moi, le router, qui donne accès au WAN (ce qui est faux d'ailleurs)
Router : C'est un autre router qui fait le boulot et tu trouves tout seul (RIP) ou je te dis qui c'est manuellement (Route entries) : Sauf que là, c'est pas possible non plus puisque ton router ne peut pas voir 192.168.2.1 qui est ta passerelle vers le WAN (ta box quoi).


---------------
L'acouphène est un bon rempart à l'idiophilie
n°852027
Teflon1
Posté le 22-05-2015 à 13:46:12  profilanswer
 

jura_savagnin a écrit :

@ almer il me semble qu'il est question du gateway ds la fenêtre 1.4
http://img15.hostingpics.net/thumb [...] inksys.png
EDIT :
@Teflon1 j'ai songé à flasher ce fameux firmware dd-wrt, mais j'ai l'impression qu'il n'y a pas le bon chipset  
https://www.google.fr/search?q=Link [...] KKQnSIVXTc


 
A oui pas de chance !
 

almer a écrit :


Non, rien à voir, là c'est la gestion du routage entre le router et le WAN.
Gateway : c'est bien moi, le router, qui donne accès au WAN (ce qui est faux d'ailleurs)
Router : C'est un autre router qui fait le boulot et tu trouves tout seul (RIP) ou je te dis qui c'est manuellement (Route entries) : Sauf que là, c'est pas possible non plus puisque ton router ne peut pas voir 192.168.2.1 qui est ta passerelle vers le WAN (ta box quoi).


 
Eventuellement tu peux essayer de passer en mode router, c'est a dire de dire au routeur que ce n'est pas lui le gateway sur le réseau. peut etre que le dhcp enleve la ligne default gateway dans ce cas !?

n°852032
almer
Posté le 22-05-2015 à 13:54:28  profilanswer
 

ça se tente :jap:


---------------
L'acouphène est un bon rempart à l'idiophilie
n°852066
jura_savag​nin
Posté le 22-05-2015 à 14:44:36  profilanswer
 

Je laisse de côté ttes vos pistes prometteuses pour me concentrer sur qques réglages (mais j'y reviendrai, promis)
 
 
A part le NAS qui doit vraiment avoir une IP fixe (marre de retaper sa nouvelle adresse à chaque fois), y a-t-il une utilité à faire de même pour les autres pc, imprimante ?
 
Sinon, c'est vraiment dépassé, ce matos qu'on m'a prêté, ou bien, pour l'usage bien particulier que je compte en faire, je vais pas trouver bcp mieux ? (oui c'est vrai le débit wifi est famélique, mais bon pour imprimer ou envoyer mes photos Smartphone >> Nas ...)
 
Si je devais restituer ce router, en occas' (génération 2/3 ans) pas trop cher, vs me conseilleriez quoi ?

n°852099
almer
Posté le 22-05-2015 à 16:08:21  profilanswer
 

Je vais peut être dire une connerie, mais tu as vraiment besoin d'un router ? C'est quoi ta box ?


---------------
L'acouphène est un bon rempart à l'idiophilie
n°852150
jura_savag​nin
Posté le 22-05-2015 à 19:21:38  profilanswer
 

Hum, ... pas loin en effet. :D  
 
1) Je n'ai pas de box !!! Je suis sur les 2/3 hotspots qui m'entourent.  
 
1 bis) j'ai emménagé il y a peu, ds un appart équipé de prise ethernet partout
 
2) Je comptais tester le mode tethering de mon smartphone (ma femme et moi avons chacun le forfait free 20 Go que ns n'utilisons presque pas)... à diffuser sur mon réseau local, si c'est envisageable techniquement
Mais là, vs me prenez au dépourvu, je comptais ouvrir un autre fil :ange:  ...


Message édité par jura_savagnin le 22-05-2015 à 19:29:04
mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Réseaux

  [Résolu] Branchement ethernet déconnecte l'accès internet wifi

 

Sujets relatifs
Accès à un smartphone android à distance en NATquel cable ethernet choisir ?
Couper le wifi de ma box et utiliser point d'acces wifiProbléme internet vraiment bizzare
Problème de debit internetMon PC fait baisser mon debit internet
Internet par satellite très médiocre. Pourquoi ?Cherche carte ethernet 2 ports avec passthrough
[Question] VPN et accès local 192.168.1.x[Résolu] Problème de branchement panneau de brassage VDI
Plus de sujets relatifs à : [Résolu] Branchement ethernet déconnecte l'accès internet wifi


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR