Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1604 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Apache ne démarre plus sur mon serveur

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Apache ne démarre plus sur mon serveur

n°1029780
pictureled
Posté le 10-07-2018 à 18:32:44  profilanswer
 

Bonjour à tous,
 
J'ai un soucis avec mon serveur web maison sur Raspberry Pi 3.
 
J'ai un site héberger dessus et mon certificat ssl était expiré. En essayant de le renouveler il se trouve que apache s'est stoppé et il ne veut plus démarrer.
 
Quand j'essaie la commande  
 

Code :
  1. systemctl restart apache2.service


 
Voilà l'erreur  
 

Code :
  1. apache2.service - The Apache HTTP Server
  2.    Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
  3.    Active: failed (Result: exit-code) since Tue 2018-07-10 06:35:38 GMT; 20min ago
  4.   Process: 389 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)
  5. juil. 10 06:35:36 raspberrypi systemd[1]: Starting The Apache HTTP Server...
  6. juil. 10 06:35:37 raspberrypi apachectl[389]: apache2: Syntax error on line 225 of /etc/apache2/apache2.conf: Could not ope…irectory
  7. juil. 10 06:35:37 raspberrypi apachectl[389]: Action 'start' failed.
  8. juil. 10 06:35:37 raspberrypi apachectl[389]: The Apache error log may have more information.
  9. juil. 10 06:35:38 raspberrypi systemd[1]: apache2.service: Control process exited, code=exited status=1
  10. juil. 10 06:35:38 raspberrypi systemd[1]: Failed to start The Apache HTTP Server.
  11. juil. 10 06:35:38 raspberrypi systemd[1]: apache2.service: Unit entered failed state.
  12. juil. 10 06:35:38 raspberrypi systemd[1]: apache2.service: Failed with result 'exit-code'.
  13. Hint: Some lines were ellipsized, use -l to show in full.


 
Et voilà ce que contient la ligne 225
 

Code :
  1. IncludeOptional sites-enabled/*.conf


 
J'ai essayé de rechercher une solution mais je suis un peu perdu étant débutant.
 
Quelqu'un pour m'aiguiller sur ce qui serait la cause ?
 
Je vous remercie d'avance !!

mood
Publicité
Posté le 10-07-2018 à 18:32:44  profilanswer
 

n°1029781
Andorria
Posté le 10-07-2018 à 18:35:14  profilanswer
 

:hello:
 
"Could not ope…irectory"
 
could not open directory = n'a pas pu ouvrir le dossier
 
apache n'arrive pas à ouvrir le dossier "sites-enabled", "/etc/apache2/sites-enabled", tu devrais creuser de ce côté là


---------------
Mon topal d'achat/vente, divers... - Mon profil HWBOT - TEAM HFR HWBOT
n°1029782
pictureled
Posté le 10-07-2018 à 18:47:48  profilanswer
 

Merci pour ta réponse rapide.
 
Comment je peux faire pour creuser ce problème ?
Désolé je suis un peu novice...

n°1029847
erlum
Posté le 11-07-2018 à 11:01:38  profilanswer
 

Il faut que tu permettes à Apache d'accéder au dossier en changeant les autorisation du dossier.
 
sudo chmod 755 /etc/apache2/sites-enabled/

n°1029854
pictureled
Posté le 11-07-2018 à 11:59:59  profilanswer
 

erlum a écrit :

Il faut que tu permettes à Apache d'accéder au dossier en changeant les autorisation du dossier.
 
sudo chmod 755 /etc/apache2/sites-enabled/


 
Merci pour ta réponse !
 
Alors j'ai pu avancer un peu. Mais j'ai du faire quelques gaffe...
 
Mon certificat ssl étant expiré et n'ayant pas réussi à le renouveler, j'ai voulu supprimer celui en cours et en créer un nouveau sauf que apache reste bloqué sur le premier. Il doit rester des fichiers à modifiés.
 
Maintenant j'ai ce message  
 

Code :
  1. juil. 11 09:52:52 raspberrypi systemd[1]: Starting The Apache HTTP Server...
  2. juil. 11 09:52:52 raspberrypi apachectl[12147]: AH00526: Syntax error on line 42 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
  3. juil. 11 09:52:52 raspberrypi apachectl[12147]: SSLCertificateFile: file '/etc/letsencrypt/live/pilepoilsplumes.fr/fullchain.pem' does not exist or is empty
  4. juil. 11 09:52:52 raspberrypi apachectl[12147]: Action 'start' failed.


 
Et au niveau de la ligne 42 c'est  

Code :
  1. SSLCertificateFile /etc/letsencrypt/live/nom_de_domaine.fr/fullchain.pem


 
Sauf que ce fichier à été supprimé.
 
Comment réparer cet erreur et par l'occasion recréer un nouveau certificat ssl ?

n°1029855
Steve2
Posté le 11-07-2018 à 12:02:17  profilanswer
 

Bonjour,
 
Perso je parierais plutôt sur un problème matériel: carte SD en train de décéder.
tu devrais vérifier si tu n'a pas d'autres erreurs en lecture-écriture.
Que dit la commande dmesg ?
 
EDIT
Grilled, j'ai rien dis

Message cité 1 fois
Message édité par Steve2 le 11-07-2018 à 12:04:26
n°1029869
pictureled
Posté le 11-07-2018 à 13:56:20  profilanswer
 

Steve2 a écrit :

Bonjour,
 
Perso je parierais plutôt sur un problème matériel: carte SD en train de décéder.
tu devrais vérifier si tu n'a pas d'autres erreurs en lecture-écriture.
Que dit la commande dmesg ?
 
EDIT
Grilled, j'ai rien dis


 
C’etait une bonne idée mais je pense que mon adresse to même vient bien de mon certificat ssl et des fichiers que j’ai effacé...


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  Hébergement

  Apache ne démarre plus sur mon serveur

 

Sujets relatifs
Serveur de stockage maisonServeur maison down sans raison apparente
serveur NAS sans modemAccés Serveur de temps sur reseau local
serveur kimsufi dedié et nom de domaineOrdinateur Win 10 + modem Wifi = Serveur web local ?
Serveur proxy et black listage de site internet.serveur DNS idisponible/pas de configuration IP valide ???
Synchronisation de fichier/Sauvegarde distante via serveur dédiéHerbergement de son propre serveur mail chez Orange
Plus de sujets relatifs à : Apache ne démarre plus sur mon serveur


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR