Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1579 connectés 

  FORUM HardWare.fr
  Réseaux grand public / SoHo
  FAI

  Diagnostique problème internet

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Diagnostique problème internet

n°1098504
yoshi42
Posté le 01-12-2019 à 14:20:42  profilanswer
 

Bonjour à tous,
Je vous écris depuis mon téléphone portable (connecté à Internet via le réseau GSM). Les ordinateurs sur mon réseau n'ont plus d'accès à Internet (enfin partiellement: voir explications ci-dessous).
Dans ce genre de situation je fais une succession de tests pour identifier la nature du problème et je dois avouer que je suis dans une situation où je ne comprends plus rien...
 
Ma config
J'ai une machine dédiée qui fait Serveur DHCP, routeur et borne wifi. Les ordinateurs du reseau sont connectés via ethernet (switch netgear gigabit) et wifi. J'ai une Freebox V5 connecté sur mon routeur.
 
La situation
Le réseau local fonctionne parfaitement (en Ethernet et en wifi). Je peux faire un ping des machines, échanger des fichiers.... Par contre à priori pas d'accès à Internet. Le ping www.google.fr n'aboutit pas ni le ping 8.8.8.8.
J'ai débranché la Freebox et je l'ai raccordé directement en Ethernet sur une des machines. Je ne peux toujours pas faire le ping 8.8.8.8.
Par contre ce qui est incroyable et que je n'explique absolument pas c'est qu'en ouvrant Firefox, je peux aller sur www.google.fr et utiliser la recherche, pareil pour Gmail (je peux consulter et envoyer mes mails!). Même les vidéos sous youtube fonctionnent. J'ai vidé la cache, supprimer les cookies, redemarrer l'ordinateur et la box.... Même résultat tous les services google (y compris youtube) fonctionnent. Alors que je suis censé ne pas être connecté (aucun ping vers l'extérieur ne passe).
Bien sûr à part les sites google aucun autre site n'est accessible sous le navigateur (quand je fais une recherche Google et que je clique sur un site parmi les résultats, il est inaccessible)
 
C'est vraiment une énigme, Je ne comprends pas comment je peux avoir accès aux seuls sites de Google sans connexion passante.
Si je fais un ipconfig pour l'interface réseau connecté à la box, J'ai une IP 88.X.X.237 (X pour la confidentialité ;-)) et une passerelle 88.X.X.254. Le ping sur la passerelle ne passe pas!!
 
Avez vous un début d'explication ou une idée de test?
 
Merci bcp,

mood
Publicité
Posté le 01-12-2019 à 14:20:42  profilanswer
 

n°1098506
grotius
Posté le 01-12-2019 à 14:36:22  profilanswer
 

La plupart des sites ne répondent pas au ping et la fb peut aussi bloqué la requête.

n°1098512
yoshi42
Posté le 01-12-2019 à 15:12:19  profilanswer
 

Citation :

La plupart des sites ne répondent pas au ping et la fb peut aussi bloqué la requête


 
Bonjour,
8.8.8.8 est un serveur DNS google.
Il répond au ping comme l'immense majorité des serveurs... La Freebox ne bloque pas les requêtes ping. Le problème est ailleurs.

n°1098513
Andorria
Posté le 01-12-2019 à 15:25:40  profilanswer
 

Bonjour,
 
Google et Youtube fonctionnent car ils sont accessibles en IPv6.
Exemple: 2a00:1450:4007:80f::2003 est une des IPv6 correspondant à google.fr
 
Tu devrais pouvoir ping cette adresse si ma théorie est bonne.
 
Tu as un problème sur ton serveur DHCP (qui n'est pas la Freebox) ou un problème de routes sur IPv4.
Ta machine doit avoir une adresse IP dans le même sous réseau que la Freebox (typiquement 192.168.0.0/24), et une route par défaut (destination 0.0.0.0/0) ayant pour passerelle l'adresse IP de la freebox (typiquement 192.168.0.254).
De ce que tu dis, ton PC récupère une IP publique de la part de ta box, cela veut dire que tu l'a mis en mode bridge, sans avoir les compétences pour gérer cela. Tu devrais la passer en mode routeur.
 
Par ailleurs, j'espère que tu utilises le réseau 3G ou 4G, car sinon tu as bien du courage d'utiliser le GSM , tu dois avoir du temps devant toi ! :lol:

n°1098516
yoshi42
Posté le 01-12-2019 à 15:39:28  profilanswer
 

Merci Andorria pour cette réponse très intéressante!
En effet le ping sur l'ipv6 que tu donnes fonctionne très bien! Je vais donc étudier le pb de routage Ipv4 et je reviens vers toi.
 
"Pour le réseau GSM", C'est bien sûr un abus de langage pour parler du mobile ;-) je suis sur la 3G.

n°1098534
yoshi42
Posté le 01-12-2019 à 17:35:03  profilanswer
 

Bon j'ai rebranché la Freebox sur mon routeur (microPC dédié qui tourne sous ubuntu server) .
Je vais essayer de décrire mon réseau.
 
Sur mon routeur j'ai 3 interfaces reseau que j'ai renommé pour plus de clarté.
-eth_local : port ethernet vers le reseau local (connecté à un switch qui relie l'ensemble des machines du réseau local en filaire)
-wlan_local : interface wifi pour les machines du réseau local qui se connectent via wifi
-eth_adsl : port ethernet relié à la freebox
 
Pour plus de facilité j'ai fait un bridge entre les interfaces eth_local et wlan_local. J'ai appelé le bridge = bridge_local
 
L'IP forwarding est activé (sysctl net.ipv4.ip_forward=1)
La table de routage ressemble à cela:
Destination : 0.0.0.0   gw:88.X.X.254   flags: UG  iface: eth_adsl
Destination : 88.x.x.0  gw: 0.0.0.0   flags: U   iface: eth_adsl
Destination  : 192.168.0.0  gw: 0.0.0.0   flags: U   iface: bridge_local
 
Le serveur DHCP sur cette machine fonctionne et toutes les machines sur le sous-reseau connecté à l'interface bidge_local ont une ip correcte (192.168.0.X)
Le réseau local fonctionne très bien (Ethernet et Wifi)
 
Par contre impossible d'accéder à Internet. Je n'arrive pas à faire de ping sur la gw 88.X.X.254 (gateway pour les paquets vers l'extérieur = ip freebox)
 
Le mode routeur et le DHCP de la Freebox ne sont pas activés.  
 
A noté également que le ping de l'ipv6 ne passe plus quand je branche la Freebox sur mon routeur (Pour mon test précédent j'avais branché la Freebox directement sur un des ordinateurs du reseau local) et donc les services google ne sont plus accessibles sur les machines du réseau local.
 
Désolé pour le manque de mise en forme c'est pas simple de rédiger ça sur un clavier de smartphone :pt1cable: ...

n°1098553
Andorria
Posté le 01-12-2019 à 20:42:05  profilanswer
 

Il faut activer le NAT sur ton routeur. (iptables MASQUERADE etc...)
 
Si tu fais un ping depuis ton serveur ça devrait fonctionner (puisqu'il a l'IP publique, les paquets peuvent faire l'aller/retour, il est connu sur Internet contrairement aux machines de ton LAN)

n°1098574
yoshi42
Posté le 01-12-2019 à 22:16:07  profilanswer
 


Ci-dessous le fichier firewall que j'avais écrit il y a bien longtemps et qui s'exécute lors du démarrage du routeur.
 


#!/bin/bash
PYXrouteur=192.168.0.1 #Adresse locale de la passerelle
PYXrouteur_ext=88.X.X.237 #Adresse externe de la passerelle (IP fixe)
PYXNETWORK=192.168.0.0/24
FIREWALL=$PYXrouteur
WEB=$PYXrouteur #mettre "" si aucun serveur web
PORT=80 #le port du serveur web
FTP=192.168.0.2
FTPPORT=21
INTERNE="bridge_local" #interface ves le reseau a proteger
EXTERNE="eth_adsl" #interface vers internet (ADSL)
IPTABLES=/sbin/iptables
 
mode=$1
case "$mode" in
        'start')
                echo "******* PYXNETWORK FIREWALL ********"
 
                #On efface toutes les regles existantes
                for table in filter nat mangle;
                        do
                         $IPTABLES -t $table -F
                         $IPTABLES -t $table -X
                        done
 
                #On accepte tout ce qui vient du reseau interne
                $IPTABLES -A INPUT -s $PYXNETWORK -j ACCEPT
 
                #On accepte toutes les reponses associees au trafic sortant
                $IPTABLES -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
                $IPTABLES -A OUTPUT -m state --state NEW,ESTABLISHED -j ACCEPT
 
                #On accepte les recherches DNS a partir des serveur de nom connus (/etc/resolv.conf)
        #       for DNS in $(grep ^n /etc/resolv.conf | awk '{print $2}');
        #               do
        #                $IPTABLES -t filter -A INPUT -s $DNS -j ACCEPT
        #               done
                #On accepte la demande de connexion ssh
                $IPTABLES -A INPUT -p tcp --destination-port ssh -j ACCEPT
 
#On accepte la demande de connexion ssh
                $IPTABLES -A INPUT -p tcp --destination-port https -j ACCEPT
 
#On accepte la connexion sur le port 953 pour permettre a rndc (utilitaire inclus dans Bind) d'administrer le demon named
                $IPTABLES -A INPUT -p tcp --destination-ports 953 -j ACCEPT
                #On accepte la connexion sur le port 53 en TCP et UDP (pour Bind qui ecoute sur ces ports)
                $IPTABLES -A INPUT -p tcp --destination-port 53 -j ACCEPT
                $IPTABLES -A INPUT -p udp --destination-port 53 -j ACCEPT
 
 #On accepte le port 6969 en entree pour le serveur APE
                $IPTABLES -A INPUT -p tcp --destination-port 6969 -j ACCEPT
 
                 #si un serveur web est defini, on s'occupe de lui
                if [ -n "$WEB" ]
                then
                        echo ""
                        echo "Section WEB :"
                        #on accepte les requetes HTTP entrantes
                        $IPTABLES -t filter -A INPUT -p tcp --source-port www -j ACCEPT
#le FTP
                if [ -n "$FTP:" ]
                then
                        echo ""
                        echo "Section FTP :"
                        #On accepte les requetes ftp entrantes
                        $IPTABLES -t filter -A INPUT -p tcp --source-port ftp -j ACCEPT
                        $IPTABLES -t filter -A INPUT -p tcp --destination-port ftp -j ACCEPT
                        echo " Port FTP $FTPPORT ouvert: [OK]"
                        echo "interface web ouverte"
                        if [ $FIREWALL != $FTP ] #si le serveur n'est pas une passerelle
                        then
                                #On forward
                                $IPTABLES -t nat -A PREROUTING -p tcp -d $PYXrouteur_ext --dport ftp -j DNAT --to $FTP:$FTPPORT
                                echo " Forwarding FTP sur $FTP port $FTPPORT: [OK]"
                                #Forward des ports pour le mode passif du FTP
                                $IPTABLES -t nat -A PREROUTING -p tcp -d $PYXrouteur_ext --dport 55536:55663 -j DNAT --to $FTP
                                echo " FTP mode passif active- Forwarding des ports 55536:55663: [OK]"
                        fi
                fi
 
                #On refuse et on entre dans le journal tout ce qui est entrant et qui n'est pas speifie
                $IPTABLES -N logdeny
                $IPTABLES -t filter -A logdeny -j LOG --log-prefix "PYX-firewall:"
                $IPTABLES -t filter -A logdeny -j DROP
                #$IPTABLES -t filter -A INPUT -i !lo -m state --state NEW,INVALID -j logdeny
                #On active la conversion d'adresse reseau (IP forwarding)
                if [ -n "$INTERNE" ]
                then
                        echo 1 > /proc/sys/net/ipv4/ip_forward
                        #On accepte les paquets entre internet et le reseau local si:
                        # - Connexion existante
                        #Initatiation d'une nouvelle connexion par un membre du reseau local
                        $IPTABLES -A FORWARD -i $EXTERNE -o $INTERNE -m state --state ESTABLISHED,RELATED -j ACCEPT
                        $IPTABLES -A FORWARD -i $INTERNE -o $EXTERNE -j ACCEPT
                        if [ $EXTERNE = eth_adsl ]
                        then
                                #On convertit toute adresse IP sortante en l'IP externe du firewall (ici dynamique)
                                $IPTABLES -t nat -A POSTROUTING -s $PYXNETWORK -o $EXTERNE -j MASQUERADE
                        else
                                #On convertit toute adresse IP sortante en l'IP externe du firewall (ici fixe)
                                $IPTABLES -t nat -A POSTROUTING -o $EXTERNE -j SNAT --to $FIREWALL
                        fi
                fi
 
                echo ""
                echo "Firewall initialise [OK]"
        ;;
        'stop')
                #echo 0 > /proc/sys/net/ipv4/ip_forward
                #On efface toutes les regles existantes
                for table in filter nat mangle; do
                        $IPTABLES -t $table -F
                        $IPTABLES -t $table -X
                done
                echo ""
                echo "Firewall desactive"
        ;;
        *)
                echo "usage $0 start|stop"
        ;;
esac
 


 
Je précise que mon réseau fonctionne depuis plusieurs années. Il y a quelques jours j'ai perdu internet sans que je puisse identifier la cause du pb...
 

Citation :

Si tu fais un ping depuis ton serveur ça devrait fonctionner (puisqu'il a l'IP publique, les paquets peuvent faire l'aller/retour, il est connu sur Internet contrairement aux machines de ton LAN)


 
Oui, justement je ne comprends pas car mon routeur récupère l'adresse publique mais pourtant aucun ping ne passe...
 
Je me demande si ce n'est pas la Freebox qui est défaillante (après tout c'est un matériel qui a plus de 10 ans)...
 
Si tu as en tête des tests supplémentaires ou des vérifications à faire, n'hésite pas.
 
Je fais un hard reboot de la box, Ça ne change rien.
Je vais demander le remplacement par une freebox nouvelle version (revolution).

n°1098591
Andorria
Posté le 02-12-2019 à 09:29:57  profilanswer
 

Quand tu vas sur ton interface abonné Freebox, niveau adresse IP tu as quoi ? (1/4 des ports ou bien une IP complète ?)

n°1098596
yoshi42
Posté le 02-12-2019 à 10:28:35  profilanswer
 

Citation :

Quand tu vas sur ton interface abonné Freebox, niveau adresse IP tu as quoi ? (1/4 des ports ou bien une IP complète ?)


 
J'ai l'IP : 88.x.x.237 (ports 32768-49151)
 
Cette IP correspond à l'IP de mon routeur sur son interface eth_adsl  
(IP affichée via la commande hostname -I sur mon routeur)
 
88.x.x.237 192.168.0.1  2a01:e0a:x:x:x:x:x:afd6
 
L'interface de la freebox n'est pas très claire (car très peu détaillée)...
Il me semble que l'IP publique de la box devrait être l'adresse de la gateway pour la route defaut de mon tableau de routage (88.x.x.254), non?


Message édité par yoshi42 le 02-12-2019 à 10:51:20
mood
Publicité
Posté le 02-12-2019 à 10:28:35  profilanswer
 

n°1098631
Andorria
Posté le 02-12-2019 à 13:51:59  profilanswer
 

Tu as été migré sur la nouvelle architecture de Free (ipv6 sur leur réseau interne, ipv4 acheminé via un tunnel)
 
Tu devrais demander une IPV4 full stack sur ton interface abonné afin d'éliminer le problème de ports (tu dois NATer uniquement sur une certaine plage).
 
Ensuite, ce n'est pas la bonne gateway (encore une fois à cause du changement d'architecture), tu devrais laisser eth_adsl récupérer son IP en DHCP.

n°1098637
yoshi42
Posté le 02-12-2019 à 14:35:32  profilanswer
 

Merci encore pour ton aide précieuse!
 
Ils auraient pu notifier par mail ce changement d'architecture pour m'éviter de chercher pendant des heures le problème... ça aurait également permis d'éviter le déplacement d'un technicien suite à l'ouverture d'un ticket d'incident chez free.
 
J'ai demandé l'IPV4 full Stack. D'ici 30 minutes je pourrai faire des essais avec la nouvelle IP.

n°1098655
Andorria
Posté le 02-12-2019 à 16:01:10  profilanswer
 

Pourquoi envoyer un mail alors que moins d'1% des abonnés utilisent le mode bridge ... :/

 

Et un bon 90% ne savent pas ce qu'est une adresse IP...

n°1098658
yoshi42
Posté le 02-12-2019 à 16:26:34  profilanswer
 

Citation :

Pourquoi envoyer un mail alors que moins d'1% des abonnés utilisent le mode bridge ... :/
Et un bon 90% ne savent pas ce qu'est une adresse IP...


C'est pas faux  :)  
 
Bon tout marche parfaitement maintenant!
Merci encore :hello:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Réseaux grand public / SoHo
  FAI

  Diagnostique problème internet

 

Sujets relatifs
"Reseau de bureau" pour l'accès internet. Prudent ou pas?QNAP - Problème avec le gestionnaire de sauvegarde en rsync
probleme mise en reseaux serveur proxmoxQuel appareil pour réseau dont Internet depuis smartphone
2 routeurs internet sur le même réseau?Disque dur NAS sans réseau internet
Disque dur NAS sans réseau internetProblème de téléchargement besoin d'aide
Partage internet au réseau local via téléphone en 4g[Navigateur]Plus d'internet
Plus de sujets relatifs à : Diagnostique problème internet


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR