Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1608 connectés 

  FORUM HardWare.fr
  Windows & Software
  Win 10

  Win10 : Utiliser des identifiants sur un dossier partagé "public"

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Win10 : Utiliser des identifiants sur un dossier partagé "public"

n°3357773
Didipi
G4560 powered
Posté le 16-11-2019 à 13:03:19  profilanswer
 

Salut ! Ma question est sûrement idiote, mais je galère de mon côté. J'ai terminé mon serveur NAS sous openmediavault, et j'ai donc un dossier partagé via SMB. Je l'ai rendu accessible en lecture seule pour les utilisateurs invités, et pour les utilisateurs ayant un identifiant enregistré sur le serveur, un accès lecture/écriture.  
 
J'ai déjà galéré un bon moment pour y avoir accès tout court depuis mes PCs Windows (sous Linux c'était nickel) pour enfin me rendre compte que c'était un option à toucher dans la stratégie de groupe locale. Cependant maintenant, quand j'y accède, c'est automatiquement en tant qu'invité, et je ne peux pas créer de dossier, ni de fichier, forcément je ne suis pas connecté :D
 
Mais je ne vois pas comment faire pour me connecter, le dossier partagé étant accessible invités, je n'ai pas de demande d'identifiants quand j'essaie d'y accéder.
Quelqu'un saurait éclairer ma chandelle :pt1cable: ?
 


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
mood
Publicité
Posté le 16-11-2019 à 13:03:19  profilanswer
 

n°3357774
Ryo-Ohki
10th Rabbit
Posté le 16-11-2019 à 13:09:11  profilanswer
 

Didipi a écrit :


J'ai déjà galéré un bon moment pour y avoir accès tout court depuis mes PCs Windows (sous Linux c'était nickel) pour enfin me rendre compte que c'était un option à toucher dans la stratégie de groupe locale. Cependant maintenant, quand j'y accède, c'est automatiquement en tant qu'invité, et je ne peux pas créer de dossier, ni de fichier, forcément je ne suis pas connecté :D


 
Quelle option ?


---------------
The Lapin, reloaded  
n°3357787
Didipi
G4560 powered
Posté le 16-11-2019 à 14:24:16  profilanswer
 

"Activer les ouvertures de session invité non sécurisées"
J'ai cru avancer mais finalement pas tellement, j'ai essayer de "connecter un lecteur réseau" dans l'explorateur de fichiers, et il y avait une option "se connecter à l'aide d'informations d'identification différentes", je coche cette option, suivant, on me demande le mot de passe, et le nom d'utilisateur, j'en teste plusieurs mais j'ai une erreur comme quoi le nom d'utilisateur ou le mot de passe est incorrect. Et j'ai remarqué que si j'essaie d'entrer des identifiants bidons, j'ai accès en lecture, logique puisqu'il est public, mais que dès que j'essaie de passer par un compte enregistré, impossible.
 
J'ai pensé à une erreur venant du serveur, mais depuis mon téléphone avec network file explorer, j'arrive à accéder au dossier avec mes identifiants et j'ai accès à l'écriture, y a donc bien quelque chose qui m'échappe du côté de Windows :pt1cable:


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
n°3357790
Didipi
G4560 powered
Posté le 16-11-2019 à 14:39:32  profilanswer
 

J'ai vu sur des forums liés à openmediavault qu'en ajoutant la ligne "ntlm auth = yes" dans les options supplémentaires de SMB, ça réglait le souci et effectivement, c'est le cas, pour le moment plus de souci avec Windows, je considère le problème résolu :jap:


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
n°3357802
Ryo-Ohki
10th Rabbit
Posté le 16-11-2019 à 17:05:37  profilanswer
 

Mmmh. Problème de négociation NTLM ? En recherchant de mon côté je vois que ce réglage active le support de NTLMv1 sur ton NAS (qui est un protocole de sécurité obsolète). Or normalement depuis Vista les clients Windows n'utilisent plus que NTLMv2 par défaut.
 
Ca serait intéressant de voir le contenu de la valeur LmCompatibilityLevel dans ton registre, sous HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
 
(normalement 3)
 
https://ss64.com/nt/syntax-ntlm.html
 
Sauf si tu as touché à cette valeur ou au paramètre "niveau d'authentification LAN Manager" dans la stratégie locale.


Message édité par Ryo-Ohki le 16-11-2019 à 17:06:02

---------------
The Lapin, reloaded  
n°3357805
Didipi
G4560 powered
Posté le 16-11-2019 à 17:16:15  profilanswer
 

Chez moi cette valeur est à 1


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
n°3357807
Ryo-Ohki
10th Rabbit
Posté le 16-11-2019 à 17:36:45  profilanswer
 

Didipi a écrit :

Chez moi cette valeur est à 1


 
Ah bah voilà, ça explique tout. Egalement le besoin de la manip pour repasser en NTLMv1 avec "ntlm auth = yes" pour rétablir l'accès authentifié  :)


---------------
The Lapin, reloaded  
n°3357808
Didipi
G4560 powered
Posté le 16-11-2019 à 17:40:08  profilanswer
 

Donc si je passe cette valeur à 3 et que je retire l'instruction sur le serveur ça va passer ?
Merci pour ton aide en tout cas :)


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0
n°3357813
Ryo-Ohki
10th Rabbit
Posté le 16-11-2019 à 18:06:12  profilanswer
 

Je dirais oui. Par contre ton PC n'a pas d'autres interactions avec d'autres périphériques sur le réseau qui seraient susceptibles de ne plus marcher ? (ça reste bizarre cette valeur à 1 alors que ce n'est censément pas le défaut, enfin sauf si tu es toujours avec XP :D).
 
Au pire tu remet les valeurs que tu as maintenant si quelque chose ne marche plus.
 
Selon la doc de Samba (qui doit sous tendre OMV...)
 
https://www.samba.org/samba/history/samba-4.5.0.html
 
In order to improve security we have changed
the default value for the "ntlm auth" option from
"yes" to "no". This may have impact on very old
clients which doesn't support NTLMv2 yet.


Message édité par Ryo-Ohki le 16-11-2019 à 18:07:13

---------------
The Lapin, reloaded  
n°3357817
Didipi
G4560 powered
Posté le 16-11-2019 à 19:20:25  profilanswer
 

J'ai essayé de retirer l'instruction et de mettre la valeur à 3, et ça passe pas. Du coup tout en laissant la valeur à 3 (par défaut donc) j'ai remis l'instruction et ça passe, je vais laisser comme ça j'imagine, tant que ça marche :D


---------------
Mon topic d'achat/vente : https://forum.hardware.fr/forum2.ph [...] w=0&nojs=0

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Win 10

  Win10 : Utiliser des identifiants sur un dossier partagé "public"

 

Sujets relatifs
Win10 / Windows boot manager[RESOLU][Win10] retangle transparent
Clé usb d'install de win10 inreformatable et morte ???Nouvelle config alergique a win10 mais ok avec Linux
Chiffrement de disques et du dossier Google Drive (Windows/Android)Partage de dossiers sur un réseau domestique
Partage fichiers avec OpenELEC / KodiRecherche outil de partage et communication
Perte de dossier sur le bureau !Paramétrages de recherche dans un dossier
Plus de sujets relatifs à : Win10 : Utiliser des identifiants sur un dossier partagé "public"


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR