Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
881 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Formule excel

n°3134538
Fifou le m​agnifique
Posté le 29-07-2014 à 14:40:53  profilanswer
 

Bonjour tout le monde,
 
Alors voila, j'ai un petit souci sur excel que je vais tenter de vous expliquer clairement.
 
J'ai deux colonnes A et B. Les colonnes n'ont aucun lien entre elles.
 
Dans la colonne A, j'affiche soit des valeurs numériques soit #N/A.
Dans la colonne B, j'affiche soit des valeurs numériques soit #N/A.
 
Je cherche a afficher dans la colonne C le résultat suivant :
 
- Cas 1:  si A ≠ #N/A et B ≠ #N/A alors C = (A+B)/2
- Cas 2:  si A ≠ #N/A et B = #N/A alors C = A
- Cas 3:  si A = #N/A et B ≠ #N/A alors C = B
- Cas 4:  si A = #N/A et B = #N/A alors C = #N/A
 
Dans C, j'ai ecrit la formule suivante : =SI(ET(A2<>"#N/A";B2<>"#N/A" );((B2+A2)/2);SI(ET(ESTNA(A2);B2<>"#N/A" );B2;SI(ET(ESTNA(B2);A2<>"#N/A" );A2;0)))
 
Elle reprend chacun de mes cas :
 
- Cas 1: si A ≠ #N/A et B ≠ #N/A alors C = (A+B)/2 => SI(ET(A2<>"#N/A";B2<>"#N/A" );((B2+A2)/2)
- Cas 2: si A = #N/A et B ≠ #N/A alors C = B => SI(ET(ESTNA(A2);B2<>"#N/A" );B2
- Cas 3: si A ≠ #N/A et B = #N/A alors C = A => SI(ET(ESTNA(B2);A2<>"#N/A" );A2
- Cas 4: si A = #N/A et B = #N/A alors C = #N/A => ;0)))
 
Quand je teste chaque partie de la formule séparément, elles fonctionnent. Mais des que je les rassemble en une seule formule, les cas 2 et 3 ne fonctionnent plus ou plutot, l'un semble exclure l'autre (si 3 marche, 2 affiche #N/A et inversement).
 
Je ne vois pas du tout d'ou cela peut venir...si quelqu'un peut m'aider svp, ca serait bien sympa !

mood
Publicité
Posté le 29-07-2014 à 14:40:53  profilanswer
 

n°3134552
DjiDji5943​0
Posté le 29-07-2014 à 17:28:02  profilanswer
 

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule excel

 

Sujets relatifs
Formule Exceldemande d'aide formule Excel
Formule excelAide pour formule excel. - Nouvelle demande!
Formule EXCEL need help[excel] Répartition mensuelle - bug dans ma formule
excel aide formule[EXCEL] Exploiter le contenu calculé d'une cellule dans une formule
copier coller dans une formule excelExcel 2007 : Formule impossible à trouver
Plus de sujets relatifs à : Formule excel


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR