Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1463 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule excel

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Formule excel

n°3116882
coquillage​1
Posté le 27-02-2014 à 19:01:23  profilanswer
 

Bonjour je cherche à traduire ceci en formule excel:
 
Si C1=C3 et si D1=D3 alors 3 sinon si C1 inférieur à C3 et si D1 inférieur D3 alors 1 sinon si C1 supérieur à C3 et si D1 supérieur à D3 alors 1 sinon 0.
 
J'y arrive pas !!!! Merci d'avance

mood
Publicité
Posté le 27-02-2014 à 19:01:23  profilanswer
 

n°3116907
Benoit6363
Posté le 27-02-2014 à 21:23:15  profilanswer
 

Bonjour,
 
Voici une solution:
=SI(ET(C1=C3;D1=D3);3;SI(OU(ET(C1<C3;D1<D3);ET(C1>C3;D1>D3));1;0))
 
Cordialement

n°3117003
coquillage​1
Posté le 28-02-2014 à 16:56:56  profilanswer
 

merci beaucoup pour la réponse, mais il y a encore un pb :)  lorsque(C1<C3;D1<D3) ou (C1>C3;D1>D3 ) un "1" devrait normalement s'afficher... et c'est pas le cas !!

n°3117005
Benoit6363
Posté le 28-02-2014 à 17:08:07  profilanswer
 

Pourtant si.

n°3117010
coquillage​1
Posté le 28-02-2014 à 17:32:05  profilanswer
 

XD... c'est peut être mon algorithme qui n'est pas bon... Je n'ai pas fait de programmation depuis 1986 :)
Le but est de faire un concours de pronostics pour la coupe du monde.
En C1 et D1 on met le résultat du match et en C3 et D3, il y a le pronostic. Si le joueur trouve le score exact il a 3Pt, si il trouve le résultat du match (gagné / perdu / nul) il a 1PT sinon 0... Mais je m'aperçois c'est un peut être difficile pour une première approche d'excel. Merci en tous cas pour l'aide... vous m'avez fait progresser

n°3117029
Benoit6363
Posté le 28-02-2014 à 19:36:48  profilanswer
 

Effectivement l'algorithme est incorrect,
il manque le cas, ou le résultat du match est nul et le pronostic donne une équipe gagnante ou inversement.
 
Pour résoudre ce problème,
il faut utiliser une formule intermédiaire pour connaître le gagnant du match.
=SI(B2>C2;1;SI(B2<C2;2;0))
équipe 1 gagnante =1  
équipe 2 gagnante =2
Nul =0
 
Et ensuite calculer le score
=SI(ET(B2=B3;C2=C3);3;SI(D2=D3;1;0))
 
Voir le fichier joint:
http://cjoint.com/?DBCtKiZ47Av
 
Cordialement


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Formule excel

 

Sujets relatifs
Aide pour formule excel. - Nouvelle demande!Formule EXCEL need help
[excel] Répartition mensuelle - bug dans ma formuleexcel aide formule
[EXCEL] Exploiter le contenu calculé d'une cellule dans une formulecopier coller dans une formule excel
Excel 2007 : Formule impossible à trouverFormule Excel pour gras dans cellule si condition
Besoin d'une formule pour excel difficile svpFormule excel dans la meme cellule
Plus de sujets relatifs à : Formule excel


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR