Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1146 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Aide pour formule excel. - Nouvelle demande!

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Aide pour formule excel. - Nouvelle demande!

n°3108879
Tomasito
Posté le 18-12-2013 à 09:35:50  profilanswer
 

Salut à tous!
 
J'ai besoin d'aide pour construire une formule.
 
J'ai un tableau ou j'ai des longueurs en colonne G et des dates en colonne I.
Je souhaite dans une feuille différente faire la somme des longueurs uniquement si une date est renseigné dans la colonne correspondante.
 
http://hfr-rehost.dev.syn.fr/self/2e98dc47057c81508cb7f817f215feb0d656cfbb.png
 
Par exemple pour ce tableau je souhaite faire une fonction qui calcule la somme des colonnes G3 Et G5 (car comportant une date dans la colonne I) sur une feuille différente.
 
Suis-je obliger de faire une macro pour ça ou une fonction simple suffit?
 
NOUVELLE DEMANDE DU 18/12!!
 
J'ai une nouvelle demande :D
 
http://hfr-rehost.dev.syn.fr/self/5f6d3b82fc02db78f37cd8936559224eb005b57b.png
 
Je veux calculer en I4 la somme des longueurs en colonne E dont le mois en colonne F correspondant au mois spécifier en I3.
 
J'ai testé ça :

Citation :

=SOMME((MOIS(F:F)=MOIS(I3)*(E:E)))


Mais le résultat me donne 0
 
J'ai essayer avec des SOMME.SI et pareil.
 
Une idée?
 
Merci


Message édité par Tomasito le 19-12-2013 à 09:29:07

---------------
Mes achats / ventes
mood
Publicité
Posté le 18-12-2013 à 09:35:50  profilanswer
 

n°3108880
MaybeEijOr​Not
but someone at least
Posté le 18-12-2013 à 09:56:24  profilanswer
 
n°3108881
forceone1
Posté le 18-12-2013 à 09:59:27  profilanswer
 

bonjour,
 
une petite solution,
 
dans ton autre feuille, tu te cree en entete une somme de nligne  
ex : =SOMME(B2:B71)
puis dans chaque ligne en dessous tu copie cette formule a partir de la colonne b2
=SI(Feuil1!i2<> "";Feuil1!g2;0)
 
ou alors une formule de ce type :
=SI(Feuil1!i2<> "";Feuil1!g2;0)+SI(Feuil1!i3<> "";Feuil1!g3;0)+....

n°3108885
Tomasito
Posté le 18-12-2013 à 10:11:10  profilanswer
 

forceone1 a écrit :

bonjour,
 
une petite solution,
 
dans ton autre feuille, tu te cree en entete une somme de nligne  
ex : =SOMME(B2:B71)
puis dans chaque ligne en dessous tu copie cette formule a partir de la colonne b2
=SI(Feuil1!i2<> "";Feuil1!g2;0)
 
ou alors une formule de ce type :
=SI(Feuil1!i2<> "";Feuil1!g2;0)+SI(Feuil1!i3<> "";Feuil1!g3;0)+....


 
C'est quelque chose comme ça qu'il me faut, mais la colonne G pouvant contenir un très grand nombre de valeurs il faudrait pouvoir automatiser le truc plutôt que de faire un + à chaque fois et c'est là que je bloque.
Macro obligatoire?


---------------
Mes achats / ventes
n°3108886
MaybeEijOr​Not
but someone at least
Posté le 18-12-2013 à 10:26:26  profilanswer
 
n°3108887
yf38
Posté le 18-12-2013 à 10:33:01  profilanswer
 

Une solution utilisant somme.si comme proposé par MaybeEijOrNot. (voir formule, cellule G2):
http://reho.st/self/1e8c2a0410aaa9d9038e19dc88ff0258ab524ffc.png
Basé sur le fait qu'un cellule vide est considérée comme valant 0.
et si la formule est dans une autre feuille:
http://reho.st/self/a8be789aed8e232ea97468531c65b7cbe0f1e5d5.png


Message édité par yf38 le 18-12-2013 à 10:40:36
n°3108892
Tomasito
Posté le 18-12-2013 à 10:56:06  profilanswer
 

Effectivement le somme.si fonctionne parfaitement merci MaybeEijOrNot :jap:
 
Pour info j'ai utilisé le "<>" pour ne comptabiliser que les lignes dont la date est renseignée.


---------------
Mes achats / ventes
n°3108989
Tomasito
Posté le 19-12-2013 à 09:27:07  profilanswer
 

J'ai une nouvelle demande :D
 
http://hfr-rehost.dev.syn.fr/self/5f6d3b82fc02db78f37cd8936559224eb005b57b.png
 
Je veux calculer en I4 la somme des longueurs en colonne E dont le mois en colonne F correspondant au mois spécifier en I3.
 
J'ai testé ça :

Citation :

=SOMME((MOIS(F:F)=MOIS(I3)*(E:E)))


Mais le résultat me donne 0
 
J'ai essayer avec des SOMME.SI et pareil.
 
Une idée?
 


---------------
Mes achats / ventes
n°3108999
MaybeEijOr​Not
but someone at least
Posté le 19-12-2013 à 10:54:53  profilanswer
 

Code :
  1. =SOMME.SI(F:F;"="&$I$3;E:E)

n°3109001
MaybeEijOr​Not
but someone at least
Posté le 19-12-2013 à 11:04:44  profilanswer
 

En fait pour les mois il te faut une nouvelle colonne :
 
Dans la colonne G tu mets :
 

Code :
  1. =MOIS(F1)


 
Puis après tu travailles comme ça :
 

Code :
  1. =SOMME.SI(G:G;"="&MOIS($I$3);E:E)

mood
Publicité
Posté le 19-12-2013 à 11:04:44  profilanswer
 

n°3109007
DjiDji5943​0
Posté le 19-12-2013 à 12:21:48  profilanswer
 

=SOMMEPROD((MOIS(F2:F16)=MOIS(I3))*(E2:E16))
et si on donne des noms
=SOMMEPROD((MOIS(dates)=MOIS(I3))*(longueur))
 
toujours valable si tu inseres une nouvelle longueur, ou une nouvelle date (sans longueur)

Message cité 1 fois
Message édité par DjiDji59430 le 19-12-2013 à 12:49:21
n°3109017
Tomasito
Posté le 19-12-2013 à 15:09:51  profilanswer
 

DjiDji59430 a écrit :

=SOMMEPROD((MOIS(F2:F16)=MOIS(I3))*(E2:E16))
et si on donne des noms
=SOMMEPROD((MOIS(dates)=MOIS(I3))*(longueur))
 
toujours valable si tu inseres une nouvelle longueur, ou une nouvelle date (sans longueur)


 
J'ai testé le soucis c'est que pour les cellules de la colonne F vide il me renvoi la valeur 1 (et donc identique à janvier) ce qui fausse la somme :/


---------------
Mes achats / ventes
n°3109019
DjiDji5943​0
Posté le 19-12-2013 à 15:40:14  profilanswer
 

tu rajoutes une condition !
=SOMMEPROD((MOIS(dates)=MOIS(I3))*(longueur)*(date<>"" ))  
ou
=SOMMEPROD((MOIS(F2:F16)=MOIS(I3))*(E2:E16)*(F2:F16<>"" ))


Message édité par DjiDji59430 le 19-12-2013 à 15:40:35
n°3109024
Tomasito
Posté le 19-12-2013 à 16:35:33  profilanswer
 

Merci c'est effectivement la/une solution :jap:


---------------
Mes achats / ventes

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Aide pour formule excel. - Nouvelle demande!

 

Sujets relatifs
excel aide formuleEXCEL - AIDE FORMULE DE CALCUL
Aide sur formule EXCEL[RESOLU] Formule Excel : Besoin d'aide :)
Aide sur formule ExcelAide sur excel/Formule si
[Excel] Demande aide d'une formuleAide Pour Trouver une Formule sous Excel
Formule excel, besoin d'aideaide pour formule de condition sur excel
Plus de sujets relatifs à : Aide pour formule excel. - Nouvelle demande!


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR