Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
610 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel 2007 : Formule impossible à trouver

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Excel 2007 : Formule impossible à trouver

n°3048504
Maitreyome
Posté le 02-08-2012 à 12:30:08  profilanswer
 

Bonjour,
 
Je me torture l'esprit depuis 1 heure.
 
Je cherche à trouve la formule suivante : exemple
 
Si les cellules de la colonne B sont vides : faire la somme des valeurs de la colonne A.
 
J'ai testé    =SI(ESTVIDE(B7:B360);SOMME(A7:A360)) mais cela ne fonctionne pas
 
J'ai su faire l'inverse : c'est à dire si il y a une "X" dans les cellules de la colonne B : faire le total des valeurs de la colonne A.
 
=SOMME.SI(B7:B322;"X";A7:A322)
 
Une personne pour m'aider SVP ?  merci


Message édité par Maitreyome le 02-08-2012 à 12:33:47
mood
Publicité
Posté le 02-08-2012 à 12:30:08  profilanswer
 

n°3048562
yf38
Posté le 02-08-2012 à 18:32:31  profilanswer
 

Avec une colonne C de plus:
=si(estvide(B7);1;0)
et le résultat:
=sommeprod(C7:C360;A7:A360)

n°3048589
Xspawn_Lpc
Posté le 02-08-2012 à 21:38:56  profilanswer
 

Problème avec la fonction estvide() . Tiré de l'aide :

la fonction ESTVIDE renvoie la valeur logique VRAI si l’argument valeur est une référence à une cellule vide et la valeur logique FAUX dans les autres cas.


Tu ne peut pas faire un test sur plusieurs cellules
 


---------------
Quand on aime on ne compte pas. Quel Dilemme lorsque l'on aime compter !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel 2007 : Formule impossible à trouver

 

Sujets relatifs
Ajout d'un PST de 2 Go dans Outlook 2007 et impossible de supprimerImpossible d'ouvrir ma session
PowerDVD 12 impossible de lire blu-rayFormule Excel pour gras dans cellule si condition
Excel croit m'aider pour la saisie : ça me dérange . . .Document excel partagé impossible à enregistrer
Evolution d'Excel (et VBA) vers Open Office.org 3 
Plus de sujets relatifs à : Excel 2007 : Formule impossible à trouver


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR