Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1804 connectés 

  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel formule avec si(et(ou

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Excel formule avec si(et(ou

n°3205013
fsgirl
Posté le 11-10-2015 à 05:52:30  profilanswer
 

Bonjour,
 
Voici le tableau que j'ai :
A1="Femelle 1"
B1="Male 1"
C1="Vie 2"
D1="Male 1"
A2="Dominique"
B2="Dominique"
C2="Groenland"
D2="Dominique"
 
Je cherche une formule dans excel 2013 qui regroupe toutes ces conditions :
- si B1="Objet 1" ou B1="Ethnie 2" ou B1="Male 1"  
ET que
- si les cellules A2, B2, C2 et/ou D2 contiennent "Ouganda" et/ou "Groenland"
- alors la cellule A4 affiche "Ouganda"
 
J'ai essayé cette formule :  
=SI(OU(ET($B$1="Objet 1";$B$1="Ethnie 2";$B$1="Male 1" );ET($A$2="Ouganda";$B$2="Ouganda";$C$2="Ouganda";$D$2="Ouganda";$A$2="Groenland";$B$2="Groenland";$C$2="Groenland";$D$2="Groenland" )));"Ouganda";"" )  
 
Mais elle n'affiche rien alors que 3 conditions sont réunies pour afficher "Ouganda" en A4 : "Male 1" en B1 et "Male 1" en D1 ET "Groenland" en C2
 
Pouvez-vous m'aider SVP ??!!
 
Je suis perdue !!
 
Merci

mood
Publicité
Posté le 11-10-2015 à 05:52:30  profilanswer
 

n°3205050
DjiDji5943​0
Posté le 11-10-2015 à 12:29:33  profilanswer
 

Bonjour,
 
deja dans ton premier et()
 
$B$1="Objet 1";$B$1="Ethnie 2";$B$1="Male 1"   => toujours zéro
 
et dans 2 ème et(), tu ne peux avoir $A$2="Ouganda" et $A$2="Groenland" en meme temp => ton et() est toujours a Zéro !
donc a la fin tu as ""
 
=si(et(ou($B$1="Objet 1";$B$1="Ethnie 2";$B$1="Male 1" );ou($A$2="Ouganda";$A$2="Groenland";ou($B$2="Ouganda";$B$2="Groenland" );ou($C$2="Ouganda";$C$2="Groenland" );
ou($D$2="Ouganda";$D$2="Groenland" ));"Ouganda";"" )  
 
d'un autre coté, on a du mal a voir la relation entre dominique et ouganda !
 mets plutôt ton fichier en ligne en passant par  
http://www.cjoint.com/    par exemple, et en mettant les bonnes valeurs ! et en remplissant tes cellules manuellement avec le résultat espéré !


Message édité par DjiDji59430 le 11-10-2015 à 12:30:19

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Windows & Software
  Logiciels

  Excel formule avec si(et(ou

 

Sujets relatifs
formule [EXCEL] avec datesFormule Excel
Formule excelFormule Excel
demande d'aide formule ExcelFormule excel
Aide pour formule excel. - Nouvelle demande!Formule EXCEL need help
[excel] Répartition mensuelle - bug dans ma formuleexcel aide formule
Plus de sujets relatifs à : Excel formule avec si(et(ou


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR