Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
2013 connectés 

  FORUM HardWare.fr
  Video & Son
  Traitement Audio

  [MP3 CODEC] LAME 3.97 "stable" et 3.98 "alpha"

 



 Mot :   Pseudo :  
 
 Page :   1  2  3  4  5  6  7  8  9
Page Précédente
Auteur Sujet :

[MP3 CODEC] LAME 3.97 "stable" et 3.98 "alpha"

n°558460
gURuBoOleZ​Z
Posté le 19-12-2003 à 09:08:14  profilanswer
 

EDIT du 13.10.2006 : version 3.97 "stable" comprenant de très nombreuses améliorations par rapport à la version 3.96.1. La série des 3.98 alpha corrige certains problèmes rencontrés et est en phase de test. Téléchargement sur http://www.rarewares.org
 
EDIT du 26.07.2004 : la dernière version "stable" est désormais la 3.96.1,
qui corrige essentiellement un bug pouvant corrompre les encodages réalisé en mode VBR "fast" (--vbr-new). Il est donc fortement recommandé de ne plus utiliser la 3.96, et de passer à la 3.96.1. Par ailleurs, la série des 3.97 est également disponible sur www.rarewares.org.
 
EDIT du 07.03.2004 : la version 3.96 beta 1 est disponible sur www.rarewares.org - le changelog figure ici
 
 
EDIT du 12.01.2004 : La dernière version en date est la 3.95.1, qui n'est ni alpha ni beta mais bien finale.
Les deux premières pages de ce topic sont donc à oublier. La discussion autour de LAME 3.95 commence à partir d'ici.
 

 
Après 16 versions alpha couvrant une période d'un an, LAME 3.94 vient de franchir un cap, en passant au stade beta. La version n'est donc pas entièrement sûre, d'autant plus qu'un paquet de changements ont eu lieu depuis :  
 
LAME 3.94 beta December 15 2003
 
Takehiro Tominaga:

  • fixed block switching of nspsytune  
  • best huffman divide in the inner loop. This should improve the quality, but PAINFULLY slow. So it is not enabled by default. Use -q0 to use it.  
  • Changed -q option mapping. "-q2" until version 3.93 is now "-q3".  
  • saving bits by better scalefactor storing  
  • removed Vorbis support  
  • substep quantization. This should help breaking the SFB21 bloating problem  
  • made psychoacoustic model aware of ATH adjustements
  • use ATH value as short block masking lower limit
  • several fixes in psychoacoustic model  
  • more robust decoding


Mark Taylor / Gabriel Bouvigne:  

  • fixed issues in VBR header  


Mark Taylor:  

  • workaround against some hardware decoder defficiencies  


Aleksander Korzynski:

  • ability to compute the "Radio" ReplayGain and detect clipping on the fly. The ReplayGain value is stored into the Lame tag.

 
Gabriel Bouvigne:  

  • work on presets  
  • use presets by default for cbr/abr  
  • use presets by default for vbr  
  • analog silence detection in partitionned sfb21  
  • do not compute noise in upper 0 part of the spectrum  
  • only compute noise in modified scalefactor bands  


Guillaume Lessard:  

  • nogap related changes  


Alexander Leidinger:  

  • prevent closing the input fd prematurely if the input is a named pipe


[en rouge, changements avec impacts sur la qualité]
[en bleu, changements avec impacts sur la vitesse d'encodage]
 
Une certaine prudence s'impose, notamment pour le preset standard, très populaire. Mais les tests sont les bienvenus, d'autant plus que cette 3.94 devrait offrir un gain significatif en vitesse d'encodage :)
 
Disponible sur le site de rarewares, section mp3 :  
http://rarewares.hydrogenaudio.org


Message édité par gURuBoOleZZ le 13-10-2006 à 20:45:13
mood
Publicité
Posté le 19-12-2003 à 09:08:14  profilanswer
 

n°558479
HAL
Pas un jour sans un but
Posté le 19-12-2003 à 10:29:48  profilanswer
 

vu mon planning de fin d'année, je ne vais pas pouvoir le tester avant janvier :sweat:


Message édité par HAL le 19-12-2003 à 10:30:08
n°558491
Guigui
Posté le 19-12-2003 à 11:02:52  profilanswer
 

Pareil, mais je la prend quand meme sur mon portable : on ne sais jamais entre le foi gras et les huitre [:ddr555]


---------------
[Topic] Le DV
n°558564
HAL
Pas un jour sans un but
Posté le 19-12-2003 à 14:02:40  profilanswer
 

tu pourras faire des tests sur "Petit papa Noël" de Tino Rossi :D

n°558568
randolf
Modérateur
Outshined, fell on black days.
Posté le 19-12-2003 à 14:05:47  profilanswer
 

Et sur "Mon beau sapin"... :lol:


---------------
Envoyé depuis un PC nul, dans une salle réseau pourrie, sur un ordinateur de merde, à travers un réseau rempli de boites noires. ლ(ಠ益ಠ)ლ
n°558627
Guigui
Posté le 19-12-2003 à 16:13:45  profilanswer
 

rigolez pas, je les ai en mpc extreme :lol:


---------------
[Topic] Le DV
n°558629
randolf
Modérateur
Outshined, fell on black days.
Posté le 19-12-2003 à 16:15:29  profilanswer
 

[:fear]


---------------
Envoyé depuis un PC nul, dans une salle réseau pourrie, sur un ordinateur de merde, à travers un réseau rempli de boites noires. ლ(ಠ益ಠ)ლ
n°558704
_man_
Posté le 19-12-2003 à 18:49:54  profilanswer
 

Ben moi je vais essayer cette new beta en convertissant qques APE en MP3 pour le bô iPod que va m'aporter la mère Noël  :p

n°558737
freduche
Posté le 19-12-2003 à 20:40:11  profilanswer
 

:bounce:

n°561225
Janfy
Observateur
Posté le 26-12-2003 à 12:43:41  profilanswer
 

La version 3.95 est sortie en alpha dirait-on.

mood
Publicité
Posté le 26-12-2003 à 12:43:41  profilanswer
 

n°561247
gURuBoOleZ​Z
Posté le 26-12-2003 à 13:16:57  profilanswer
 

Où as-tu vu cela ?

n°561248
Janfy
Observateur
Posté le 26-12-2003 à 13:18:11  profilanswer
 

Sur le lien que tu donnes dans ton premier post.

n°561257
gURuBoOleZ​Z
Posté le 26-12-2003 à 13:30:44  profilanswer
 

Exact, merci de l'avoir signalé. Je n'avais pas eu vent de l'existence d'une branche 3.95. :)

n°561280
Janfy
Observateur
Posté le 26-12-2003 à 13:52:50  profilanswer
 

Par contre, concernant la version 3.94 beta, elle me fait planter virtualdub (et virtualdubmod) au moment d'accéder aux codecs de compression audio avec le message d'erreur suivant :
An out-of-bounds memory access (access violation) occurred in module 'LameACM'...
...while enumerating audio codec ID 00148370 (acompchoose.cpp:183).
 
C'est un bug connu ?

n°561318
Tang
Plug'n'Troll
Posté le 26-12-2003 à 15:37:57  profilanswer
 

Janfy a écrit :

Par contre, concernant la version 3.94 beta, elle me fait planter virtualdub (et virtualdubmod) au moment d'accéder aux codecs de compression audio avec le message d'erreur suivant :
An out-of-bounds memory access (access violation) occurred in module 'LameACM'...
...while enumerating audio codec ID 00148370 (acompchoose.cpp:183).
 
C'est un bug connu ?


Maintenant oui...
 
 
:lol:
On est vendredi et pi c'ets bientot le noel an, je compte sur l'armistice...
:o
Bon ceci est un drapeau très mal masqué...
Merci à Guru toujours à la pointe (et là ce n'est pas la newsletter clubic Hin Hin Hin!)
Tang


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561319
gURuBoOleZ​Z
Posté le 26-12-2003 à 15:38:17  profilanswer
 

Je ne me sers jamais da la version ACM de l'encodeur. Je sais que certains bugs la frappent, mais je ne peux te dire si celui que tu décris est référéncé.

n°561334
zegilles
Posté le 26-12-2003 à 16:04:24  profilanswer
 

Il me semble que la seule fonctionnant bien avec virtualdub est la 3.92

n°561338
Janfy
Observateur
Posté le 26-12-2003 à 16:14:29  profilanswer
 

Même avec la 3.92, j'ai des problèmes avec les versions 1.5.x de virtualdub ou virtualdubmod.

n°561538
randolf
Modérateur
Outshined, fell on black days.
Posté le 27-12-2003 à 02:43:13  profilanswer
 

Janfy a écrit :

Même avec la 3.92, j'ai des problèmes avec les versions 1.5.x de virtualdub ou virtualdubmod.  

Ce qui met un gros doute sur le fait que le bug vienne de Lame et non pas de ton système...  [:ogmios]


Message édité par randolf le 27-12-2003 à 02:43:22
n°561539
Tang
Plug'n'Troll
Posté le 27-12-2003 à 02:44:48  profilanswer
 

randolf a écrit :

Ce qui met un gros doute sur le fait que le bug vienne de Lame et non pas de ton système...  [:ogmios]


Salut Randolfinou,
Toujours modo? :lol: Allez bonne année, je ne doute pas que tu l'abordes avec "modération" en bon amateur de Zubrowska...
:lol:


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561546
Janfy
Observateur
Posté le 27-12-2003 à 02:51:36  profilanswer
 

randolf a écrit :

Ce qui met un gros doute sur le fait que le bug vienne de Lame et non pas de ton système...  [:ogmios]

Mais aucun problème avec les versions 14xx. Sur le forum doom9, quelqu'un a le même problème avec ces versions.

n°561582
dje33
27 moteurs Merlin 1D
Posté le 27-12-2003 à 03:35:57  profilanswer
 

Citation :

ability to compute the "Radio" ReplayGain and detect clipping on the fly. The ReplayGain value is stored into the Lame tag.


 
il y a un tag replaygain maintenant ?

n°561584
gURuBoOleZ​Z
Posté le 27-12-2003 à 03:42:41  profilanswer
 

Depuis un an environ. Je ne connais cependant aucun logiciel qui exploite cette valeur.
 
Si tu veux avoir accès en lecture aux tags lame dans leur intégralité (encspot n'affiche que ceux pour lesquels il a été programmé), télécharge lametag.exe et lametaggui.exe :  
 
http://www.hydrogenaudio.org/index [...] lametaggui

n°561587
Tang
Plug'n'Troll
Posté le 27-12-2003 à 04:27:16  profilanswer
 

gURuBoOleZZ a écrit :

Depuis un an environ. Je ne connais cependant aucun logiciel qui exploite cette valeur.
 
Si tu veux avoir accès en lecture aux tags lame dans leur intégralité (encspot n'affiche que ceux pour lesquels il a été programmé), télécharge lametag.exe et lametaggui.exe :  
 
http://www.hydrogenaudio.org/index [...] lametaggui


Intéressant je trouvais bizarer que les tags lame ne précisent pas le preset utilisé, j'imagine qu'en fait c'est indiqué mais qu'encspot ne l'affiche pas...
Je vais DL ton utilitaire pour voire, merci bien Guru...
Tang


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561588
gURuBoOleZ​Z
Posté le 27-12-2003 à 04:29:38  profilanswer
 

Je ne crois pas que les tags lame conservent l'empreinte du paramétrage saisi pour l'encodage (il reste des traces, comme le mode VBR ou le lowpass, mais la ligne de commande n'est pas sauvegardée).

n°561589
Tang
Plug'n'Troll
Posté le 27-12-2003 à 04:32:01  profilanswer
 

gURuBoOleZZ a écrit :

Je ne crois pas que les tags lame conservent l'empreinte du paramétrage saisi pour l'encodage (il reste des traces, comme le mode VBR ou le lowpass, mais la ligne de commande n'est pas sauvegardée).


Ah c'est dommage quand meme... L'ogg le mpc et l'ape conserve cette info et c'ets quand meme pratique...
Tu penses pouvoir demander à Gabriel sur HA si ce bonus est susceptible d'etre ajouté?


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561590
gURuBoOleZ​Z
Posté le 27-12-2003 à 04:37:31  profilanswer
 

Le mpc pas plus que vorbis ne conservent cette info à ma connaissance. Seul le nom du profil subsiste, mais pas les options avancées. Et dans le cas du mpc, certaines options entraînent un "malus", qui fait retrograder le nom du profil (essaie --standard --ms 0 pour voir).

n°561592
Tang
Plug'n'Troll
Posté le 27-12-2003 à 04:40:38  profilanswer
 

gURuBoOleZZ a écrit :

Le mpc pas plus que vorbis ne conservent cette info à ma connaissance. Seul le nom du profil subsiste, mais pas les options avancées. Et dans le cas du mpc, certaines options entraînent un "malus", qui fait retrograder le nom du profil (essaie --standard --ms 0 pour voir).

Ah pardon je parlais bien du profil (preset)... En fait je pensais pas qu'on pouvait modfier un preset enfin si avec les swictch mais précisément alors on ne peut plus parler de preset et alors le tag ne devrait pas tenir compte du preset de base...
Enfin disosn que ça serait logique... Non?


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561593
gURuBoOleZ​Z
Posté le 27-12-2003 à 04:45:14  profilanswer
 

tang a écrit :

alors on ne peut plus parler de preset et alors le tag ne devrait pas tenir compte du preset de base...
Enfin disosn que ça serait logique... Non?


 
Logique, oui, mais c'est oublier que certaines modifications des presets sont recommandables, sinon recommandées :  
 
lame --alt-preset standard/extreme -Z
mpc --<profil> --xlevel
mpc --<profil> --ms 15

n°561594
dje33
27 moteurs Merlin 1D
Posté le 27-12-2003 à 04:47:09  profilanswer
 

gURuBoOleZZ a écrit :


 
Logique, oui, mais c'est oublier que certaines modifications des presets sont recommandables, sinon recommandées :  
 
lame --alt-preset standard/extreme -Z
mpc --<profil> --xlevel
mpc --<profil> --ms 15


 
si ses options sont recomendable pourquoi ne pas les integrés par default dans le preset ?

n°561595
Tang
Plug'n'Troll
Posté le 27-12-2003 à 04:47:42  profilanswer
 

gURuBoOleZZ a écrit :


 
Logique, oui, mais c'est oublier que certaines modifications des presets sont recommandables, sinon recommandées :  
 
lame --alt-preset standard/extreme -Z
mpc --<profil> --xlevel
mpc --<profil> --ms 15


Euh oui exact je crois que c'ets toi ou HPL ou Zegilles qui m'avait parlé de -Z pour Lame 3.93 (par rapport à la 3.92.1 si je ne m'abuse)...
Cela étant si ces swicths sont recommandés en toutes logiques ils devrainet se voir incorporé dans les presets avec les prochaines versions des dits codecs, non? A moins que ce ne soit bcp plus compliqué que je ne me l'imagine (une fois de plus... ;))
:??:
 
EDIT: Grillé par Dje33, j'auari tout subi en cetet année 2003... :o


Message édité par Tang le 27-12-2003 à 04:48:32

---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561596
dje33
27 moteurs Merlin 1D
Posté le 27-12-2003 à 04:53:13  profilanswer
 

résolution pour l'année 2004
etre plus rapide que dje33 :D

n°561597
gURuBoOleZ​Z
Posté le 27-12-2003 à 05:02:31  profilanswer
 

Il y a plusieurs raisons à cette absence d'incorporation par défaut.  
Pour -Z par exemple, le switch permet de résoudre certains problèmes (rares), mais augmente le débit pour tout encodage. Et comme le but d'un preset n'est pas d'offrir la meilleure qualité mais la meilleure qualité à un débit optimum, exit le switch. On notera qu'avec le temps et l'évolution des capacités des disques durs, l'incidence du switch en matière de débit a fini par ne plus poser de problèmes, et il a été inclu par défaut dans la version 3.90.3
 
Pour le mpc, --xlevel est désormais associé par défaut aux presets dans plusieurs applications. Néanmoins, faute de développeur, l'encodeur CLI nécessite une saisie additionnelle du switch.
Pour --ms 15, là encore, perte d'efficience pour un gain qualitatif hypothétique. D'aucuns l'utilisent, car les 2-3 kbps généralement ajoutés par la commande ne gênent pas l'utilisateur qui encode à 230 kbps.

n°561598
Tang
Plug'n'Troll
Posté le 27-12-2003 à 05:10:34  profilanswer
 

gURuBoOleZZ a écrit :

Il y a plusieurs raisons à cette absence d'incorporation par défaut.  
Pour -Z par exemple, le switch permet de résoudre certains problèmes (rares), mais augmente le débit pour tout encodage. Et comme le but d'un preset n'est pas d'offrir la meilleure qualité mais la meilleure qualité à un débit optimum, exit le switch. On notera qu'avec le temps et l'évolution des capacités des disques durs, l'incidence du switch en matière de débit a fini par ne plus poser de problèmes, et il a été inclu par défaut dans la version 3.90.3
 
Pour le mpc, --xlevel est désormais associé par défaut aux presets dans plusieurs applications. Néanmoins, faute de développeur, l'encodeur CLI nécessite une saisie additionnelle du switch.
Pour --ms 15, là encore, perte d'efficience pour un gain qualitatif hypothétique. D'aucuns l'utilisent, car les 2-3 kbps généralement ajoutés par la commande ne gênent pas l'utilisateur qui encode à 230 kbps.


:jap: Merci pour ces éclaircissements Guru...
Sur ces entrefêtes ("Rhoo-tou-jours-des-jeux-de-mots!" autojoke en bonnet Duphorm...) je vais aller discuter avec le marchand de sable...
Et (mode vieux con sermonneur ON) vous feriez bien d'en faire autant jeunes hobbits...
:lol:
Bonne nuits...
Tang
Tanguy


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°561920
Chips
Posté le 27-12-2003 à 22:37:18  profilanswer
 

je viens de tester ( j'utilise razorlame 1.1.1 )
voila les options que qu'il utilise:
 -b 32 -m j -h -V 5 -B 256 -q 0 --vbr-new
ben ça plante grave :(

n°561930
hpl-nyarla​thotep
I failed in life
Posté le 27-12-2003 à 22:54:58  profilanswer
 

Et avec:
--alt-preset standard
ou
--alt-preset extreme
même résultat?

n°561956
gURuBoOleZ​Z
Posté le 28-12-2003 à 00:29:14  profilanswer
 

Tu entends quoi par "plantage" ? Si c'est le PC qui rame comme un canard asthmatique, je te renvoi au changelog :  
 
best huffman divide in the inner loop. This should improve the quality, but PAINFULLY slow. So it is not enabled by default. Use -q0 to use it.  

n°562024
Chips
Posté le 28-12-2003 à 11:24:58  profilanswer
 

non, lame plantait réellement.
mais pas aujourd'huit... sans doute mon PC qui était fatigué avec toutes les fêtes...
le q0 reste acceptable...
enfin peut etre que mes options sont débile aussi ( j'ai viré le -h depuis )

n°562437
Tang
Plug'n'Troll
Posté le 29-12-2003 à 02:33:19  profilanswer
 

Chips a écrit :

non, lame plantait réellement.
mais pas aujourd'huit... sans doute mon PC qui était fatigué avec toutes les fêtes...
le q0 reste acceptable...
enfin peut etre que mes options sont débile aussi ( j'ai viré le -h depuis )


En général qd le PC cesse de planter concouramment avec un changement de réglage le bon sens voudrait que l'on ait isolé un réglage fautif...
En particulier si les plantages étaient systematiques auparavant...
 
:ange:


---------------
• • • "La démocratie c'est bien mais il faudrait que les gens soient pas cons..." © Alpacou aux Nouilles • • •
n°562440
Elbarto
Posté le 29-12-2003 à 02:51:20  profilanswer
 

Salut,
 

Citation :

non, lame plantait réellement.  
mais pas aujourd'huit... sans doute mon PC qui était fatigué avec toutes les fêtes...

 
 
si ton PC plante lors de l'utilisation du codec Lame cela peut indiquer un probleme de stabilité du PC  
 
comme par exemple un trop gros overclocking, un problème avec les barettes Ram ou le CPU
 
je conseille de tester tes barettes avec logiciel memtest 3.0 :
 
http://www.memtest86.com/
 
il y a aussi cette version qui tourne sous Windows:
 
http://home.earthlink.net/~alegr/download/memtest.htm
 
si une erreur apparait avec memtest alors l'exploitation de lame peut poser des problèmes  
 
en effet Lame utilise la mémoire de telle façon que toute imperfection dans les barettes, le CPU ou la carte mère se solde par un plantage
 
j'en ai fait l'experience avec une carte mère A7V133 associé à un athlon XP, ce duo pose des problèmes de stabilité et dans tous les forums Asus la plupart de ceux qui ont ma config ont noté des problèmes d'utilisation avec le codec Lame, problème résolu uniquement quand le test memtest n'indique plus d'erreur


Message édité par Elbarto le 29-12-2003 à 02:54:15
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  8  9
Page Précédente

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Video & Son
  Traitement Audio

  [MP3 CODEC] LAME 3.97 "stable" et 3.98 "alpha"

 

Sujets relatifs
[foobar2000] conversion Ogg > MP3 !Lecteur CD MP3 : peut-il s'abimer à la verticale ?
Codec audio : image mais pas de son.Lame 3.93 installation?
Modification d un morceau MP3Codec MP3 pour Virtual Dub
Couper un MP3Mon Pionner MP3 refuse les CD MP3 ! ! !
MP3 sur un cd pour un balladeur 
Plus de sujets relatifs à : [MP3 CODEC] LAME 3.97 "stable" et 3.98 "alpha"


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR