Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1638 connectés 

  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Problème excel... [RESOLU]

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Problème excel... [RESOLU]

n°1380149
Yop69
Posté le 02-06-2006 à 18:43:16  profilanswer
 

Bonjour
 
Euh je ne sais pas si je suis dans la bonne catégorie..
 
Voila j'ai un problème sur excel.
 
j'ai un tableau contenant des valeurs :
http://photoyop.free.fr/excel.jpg
 
J'aimerais une formule qui pour un produit donné me mets le nombre d'occurence contenu dans la colonne b et pour chaque occurence trouvée, a multiplier par sa quantité correspondante.
 
exemple la formule =COUNTIF(B$4:B$23;"25 DVD+R VERBATIM 16x (cloche)" ) va me renvoyer le nombre d'occurence "25 DVD+R VERBATIM 16x (cloche)" de la colonne B mais cela ne me comptabilise pas la quantité derrière.
 
Suis-je assez clair ?


Message édité par Yop69 le 02-06-2006 à 20:38:43
mood
Publicité
Posté le 02-06-2006 à 18:43:16  profilanswer
 

n°1380180
galopin01
Posté le 02-06-2006 à 20:12:32  profilanswer
 

Bonjour,
Utilise SOMEPROD exemple :
=SOMMEPROD(((B$4:B$100=B$4)*1)*C$4:C$100)
cette formule est équivalente à :
=SOMMEPROD(((B$4:B$9="25 DVD+R VERBATIM 16x (cloche)" )*1)*C$4:C$9)
A+


---------------
roger
n°1380188
Yop69
Posté le 02-06-2006 à 20:38:28  profilanswer
 

galopin01 a écrit :

Bonjour,
Utilise SOMEPROD exemple :
=SOMMEPROD(((B$4:B$100=B$4)*1)*C$4:C$100)
cette formule est équivalente à :
=SOMMEPROD(((B$4:B$9=\"25 DVD+R VERBATIM 16x (cloche)\" )*1)*C$4:C$9)
A+


Yes merci galopin01 !

 

En fait tu m'as mis sur la voie, j'ai utilisé la fonction "=SUMIF(B$4:B$25;B32;C$4:C$25)" qui permet directement pour une condition donnée d'ajouter une quantité par rapport aux occurences trouvées

 

:jap:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  VB/VBA/VBS

  Problème excel... [RESOLU]

 

Sujets relatifs
[Resolu] string.lenght qui marche une fois sur deux[jsp] problème sur un useBean
Probleme validation xhtmlProblème en Access
pb tableau[résolu]Les iframes: problème pour le référencement!
(résolu) vba excel : probleme de typage string[resolu]probleme des saut d'image sous excel
[VBA Excel] [Résolu] Problème de librairies de fonctions vba[VB Excel] probleme dans textBox [RESOLU]
Plus de sujets relatifs à : Problème excel... [RESOLU]


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR