Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
844 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  Probleme de id=$_GET[id]

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme de id=$_GET[id]

n°876839
seven2004
Posté le 19-10-2004 à 11:13:41  profilanswer
 

Salut à tous,
 
Voila je vous explique mon probleme, mon site utilise les Cases pour les pages c'est à dire : index.php?Page=1 index.php?Page=2 index.php?Page=3 ect...
Donc je suis entrain de faire un mini forum et j'ai un probleme, quant je clique sur le sujet pour le voir bas sa va a cette adresse http://benjouke.free.fr/index.php?Page=16?id=1 et sa me dit : Warning: mysql_fetch_array(): supplied argument is not a valid, mais si je passe directement par : http://benjouke.free.fr/Forum4.php?id=1 sa marche tres bien.
Alors je voulais savoir comment faire avec le id=$_GET[id] pour que sa marche.
Merci d'avance.


---------------
Référencement par http://www.logicielreferencement.com
mood
Publicité
Posté le 19-10-2004 à 11:13:41  profilanswer
 

n°876846
deliriumtr​emens
sic transit intestinal...
Posté le 19-10-2004 à 11:18:37  profilanswer
 

http://benjouke.free.fr/index.php?Page=16?id=1
 
Y'aurait pas, des fois, un "?" en trop, non...

n°876847
seven2004
Posté le 19-10-2004 à 11:19:01  profilanswer
 

Non


---------------
Référencement par http://www.logicielreferencement.com
n°876850
Hermes le ​Messager
Breton Quiétiste
Posté le 19-10-2004 à 11:20:13  profilanswer
 

Seven2004 a écrit :

Salut à tous,
 
Voila je vous explique mon probleme, mon site utilise les Cases pour les pages c'est à dire : index.php?Page=1 index.php?Page=2 index.php?Page=3 ect...
Donc je suis entrain de faire un mini forum et j'ai un probleme, quant je clique sur le sujet pour le voir bas sa va a cette adresse http://benjouke.free.fr/index.php?Page=16?id=1 et sa me dit : Warning: mysql_fetch_array(): supplied argument is not a valid, mais si je passe directement par : http://benjouke.free.fr/Forum4.php?id=1 sa marche tres bien.
Alors je voulais savoir comment faire avec le id=$_GET[id] pour que sa marche.
Merci d'avance.


 
"&" avant le deuxième "?" :o (je parle de ta source PHP qui génère l'adresse évidemment...)

n°876851
deliriumtr​emens
sic transit intestinal...
Posté le 19-10-2004 à 11:20:50  profilanswer
 

Arf
 
index.php?Page=16&id=1
 

n°876852
skeye
Posté le 19-10-2004 à 11:20:58  profilanswer
 

...et avec page=16&id=1 ?:o
 
[edit]
Archi [:benou_grilled]


Message édité par skeye le 19-10-2004 à 11:21:21

---------------
Can't buy what I want because it's free -
n°876855
seven2004
Posté le 19-10-2004 à 11:22:07  profilanswer
 

deliriumtremens a écrit :

Arf
 
index.php?Page=16&id=1


A merci sa amrche !!!


---------------
Référencement par http://www.logicielreferencement.com
n°876858
Hermes le ​Messager
Breton Quiétiste
Posté le 19-10-2004 à 11:23:47  profilanswer
 

Seven2004 a écrit :

A merci sa amrche !!!


 
ça marchera mais ce sera pas valide la réponse, je te l'ai donnée.  :o


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  Probleme de id=$_GET[id]

 

Sujets relatifs
probleme d'arret chargement page lors evenement javascript[CSS] Problème de positionnement
Probleme de balise <br>[opengl] [linux] probleme de lib
Problème avec les accents en mysqlProblème identifiation http avec php
Probleme dans un formulaire d'insertion de news dans une bdd[wxwidget] Problème de compilation sous linux
[PHP]probleme pour recuperee une donnee passee en methode GET ou POST[PHP] Probleme avec $_GET....
Plus de sujets relatifs à : Probleme de id=$_GET[id]


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR