Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1277 connectés 

  FORUM HardWare.fr
  Programmation
  PHP

  pb avec la fonction mail

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

pb avec la fonction mail

n°912291
attentio
Posté le 01-12-2004 à 17:47:16  profilanswer
 

bonsoir, j'ai des ptits soucis avec la fonction.
en fait de mon site on "devrait" pouvoir envoyer des mails.
mais ça marche pas ... en fin pas tout le temps ...  
des fois ca marche mais il envoie simultanement au  destinateur deux fois le meme mail  :??:  
voici ma page de traitement :

Code :
  1. <?
  2. $msg=nl2br($msg);
  3. $recipient = $_POST['mail'];
  4. $subject = $_POST['sujet'];
  5. $msg = $_POST['message'];
  6. mail($recipient, $subject, $msg,"From: contact@{$_SERVER['SERVER_NAME']}\r\n"
  7.     ."Reply-To: contact@{$_SERVER['SERVER_NAME']}\r\n" );
  8. echo'<br><br><p align="center" ><b>';
  9. if(mail($recipient, $subject, $msg,"From: contact@{$_SERVER['SERVER_NAME']}\r\n"
  10.     ."Reply-To: contact@{$_SERVER['SERVER_NAME']}\r\n" ))
  11. echo'votre message a bien été envoyé à '.$recipient;
  12. else echo'le message n/a pas pu être envoyé correctement';
  13. ?>


 
d'ou cela peut venir (sauts de lignes, caracteres speciaux, ... je ne vois pas :(  
 
merci encore de votre aide


Message édité par attentio le 24-03-2005 à 20:51:38

---------------
L'ordinateur a de la mémoire mais aucun souvenir ...
mood
Publicité
Posté le 01-12-2004 à 17:47:16  profilanswer
 

n°912302
Berceker U​nited
PSN : berceker_united
Posté le 01-12-2004 à 18:11:22  profilanswer
 

attentio a écrit :

bonsoir, j'ai des ptits soucis avec la fonction.
en fait de mon site on "devrait" pouvoir envoyer des mails.
mais ça marche pas ... en fin pas tout le temps ...  
des fois ca marche mais il envoie simultanement au  destinateur deux fois le meme mail  :??:  
voici ma page de traitement :

Code :
  1. <?
  2. $msg=nl2br($msg);
  3. $recipient = $_POST['mail'];
  4. $subject = $_POST['sujet'];
  5. $msg = $_POST['message'];
  6. mail($recipient, $subject, $msg,"From: contact@{$_SERVER['SERVER_NAME']}\r\n"
  7.     ."Reply-To: contact@{$_SERVER['SERVER_NAME']}\r\n" );
  8. echo'<br><br><p align="center" ><b>';
  9. if(mail($recipient, $subject, $msg,"From: contact@{$_SERVER['SERVER_NAME']}\r\n"
  10.     ."Reply-To: contact@{$_SERVER['SERVER_NAME']}\r\n" ))
  11. echo'votre message a bien été envoyé à '.$recipient;
  12. else echo'le message n/a pas pu être envoyé correctement';
  13. ?>


 
d'ou cela peut venir (sauts de lignes, caracteres speciaux, ... je ne vois pas :(  
 
merci encore de votre aide


Normal tu l'executes deux fois .
1 fois à la ligne 6 et une fois à la ligne 9 :sarcastic:


Message édité par Berceker United le 01-12-2004 à 18:12:11
n°912491
Kyle_Katar​n
The World Is A Vampire ....
Posté le 01-12-2004 à 21:27:40  profilanswer
 

Oui, là c'est assez clair....


---------------
KC Softwares - VideoInspector (Codec Viewer) - AudioGrail
n°912499
attentio
Posté le 01-12-2004 à 21:35:21  profilanswer
 

:sleep: pour les 2 mails C resolu
par contre pour certains mails qui bloquent
j'ai fais des tests
 
si mon message est :

Code :
  1. test test test
  2. test


ca marche  
par contre si mon message est

Code :
  1. test test test
  2. test test


ca marche plus :(  
 
merci de votre aide
pour info je suis chez OVH

n°912507
Berceker U​nited
PSN : berceker_united
Posté le 01-12-2004 à 21:47:16  profilanswer
 

attentio a écrit :

:sleep: pour les 2 mails C resolu
par contre pour certains mails qui bloquent
j'ai fais des tests
 
si mon message est :

Code :
  1. test test test
  2. test


ca marche  
par contre si mon message est

Code :
  1. test test test
  2. test test


ca marche plus :(  
 
merci de votre aide
pour info je suis chez OVH


Au lieu de mettre test test prend un text bateau et refait ton test, il y a des scripts qui empeche certaine répétition.

n°912576
attentio
Posté le 01-12-2004 à 22:52:42  profilanswer
 

non ca n'a pas l'air de venir de la.
j'ai fais un test comme tu m'as dis : C completement aleatoire, je peux envoyer 3 fois de suite le meme message puis tout d'un coup impossible de le recevoir
 
je comprends pas ... de l'aide !!!!!


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  PHP

  pb avec la fonction mail

 

Sujets relatifs
retour erreur de la fonction php mail()Fonction mail()
gros pb avec la fonction mail ... helpfonction mail() -> adresse du messager[resolu]
fonction mail() ne tient pas compte de mes headersfonction mail() et formatage du message
Envoyer un mail "propre" avec la fonction mail()Fonction mail : problème d'espaces dans les emails
[PHP] edit : est-ce que la fonction mail() de PHP est un MUA ?Fonction mail et mauvaise adresse email
Plus de sujets relatifs à : pb avec la fonction mail


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR