Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
679 connectés 

  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Probleme d'actualisation

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme d'actualisation

n°1530503
florianfg
Posté le 19-03-2007 à 14:16:19  profilanswer
 

Bonjour, voila mon probleme, quand je fait des modifications sur mon site internet mes visiteurs, lors de leurs premières visites ne voit pas forcement les modifications que je viens d'effectuer, il faut qu'ils cliquent sur Actualiser ou 'F5'
y'a t-il une ligne a rajouter dans mon code html ? merci d'avance

mood
Publicité
Posté le 19-03-2007 à 14:16:19  profilanswer
 

n°1533552
florianfg
Posté le 26-03-2007 à 11:11:52  profilanswer
 

Personne pour m'aider ?

n°1533559
dartyduck
n00b AttitudE
Posté le 26-03-2007 à 11:20:05  profilanswer
 

Si ils doivent faire F5, c'est que tu as fait la modif alors qu'ils étaient déjà connectés à ton site. Solution: il faut que tu fasses tes modifs entre 3h et 4h du mat, là ou il n'y a personne connecté... :lol:


---------------
Nikon D7000 + 18-105VR + 35mm 1.8
n°1533617
florianfg
Posté le 26-03-2007 à 12:48:01  profilanswer
 

oui mais c'est des modifs que j'ai faitent il y a un moins ou voir plus même., donc c'est meme qand les gens se reconnectent aprés que j'ai modifié.

n°1533887
Nederlands
Posté le 26-03-2007 à 19:40:09  profilanswer
 

Lol :)
 
Au lieu de faire F5, fait simplement CTRL+F5 ;)
 
 
Un problème de cache du navigateur sûrement :)

n°1533932
dartyduck
n00b AttitudE
Posté le 26-03-2007 à 22:34:51  profilanswer
 

tu nous parles de feedback ou de ton expérience perso? Je m'explique: les visiteurs se sont plaint ou c'est toi qui a vu ca de chez toi ?


---------------
Nikon D7000 + 18-105VR + 35mm 1.8
n°1535005
florianfg
Posté le 28-03-2007 à 13:39:30  profilanswer
 

non les visiteurs se sont plaind

n°1571600
Mitch2Pain
Posté le 07-06-2007 à 15:31:33  profilanswer
 

J'ai le même problème avec une appli en php/mysql que j'ai dev sur l'intranet de ma boite, le CSS ne passe pas toujours du 1er coup, il faut souvent faire F5 ou CTRL+F5 pour que le css soit pris en compte.
Mes users ont la liberté de choisie leur navigateur donc ça a été testé avec du firefox 1.5 et 2, du IE 6 et 7, du avant browser, du opera, du maxthon et ça fait la même chose pour tout le monde :(
 
J'ai cherché qq infos et selon certaines sources ça viendrai du cache du navigateur ... mouais, je me demande si ca viendrai pas plutôt du serveur...


---------------
Fichier Patrimoine V2 Disponible !
n°1571633
FlorentG
Unité de Masse
Posté le 07-06-2007 à 16:01:31  profilanswer
 

C'est effectivement souvent un problème de cache... Il faut envoyer les bons headers au navigateur pour l'obliger à recharger le fichier


---------------
last.fmflickr
n°1571637
dwogsi
Défaillance cérébrale...
Posté le 07-06-2007 à 16:05:00  profilanswer
 

http://fr.php.net/header
Voir les exemples si tu souhaite interdire la mise en cache.


---------------
-- Debian -- Le système d'exploitation universel | Le gras c'est la vie! | /(bb|[^b]{2})/
mood
Publicité
Posté le 07-06-2007 à 16:05:00  profilanswer
 

n°1574820
Mitch2Pain
Posté le 14-06-2007 à 11:48:10  profilanswer
 

J'ai fait qq tests et je suis désormais sur et certain que le problème de non prise en compte du CSS viens du fait que le cache du navigateur n'ets pas vidé à chaque rechargement de page. J'ai donc inséré le header suivant dans mon index.php:
 

Citation :

<head>
<TITLE> GUI Tempost </TITLE>
<META HTTP-EQUIV="REFRESH" CONTENT="5">
<LINK rel="stylesheet" href="style.css" TYPE="text/css">  
</head>


 
Toutes les 5 secondes ma page est rafraichie mais le CSS ne s'applique ttoujours qu'une seule fois.
EDIT: en fait ça marche mais comme j'ai plein de formulaire sur ma page et que ça les reset à chaque chargement ça rend l'appli inutilisable (mais plus jolie à l'oeuil c'est vrai)
 
J'ai aussi essayé ça:

Citation :


header("Cache-Control: no-cache, must-revalidate" ); // HTTP/1.1
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT" ); // Date du passé


 
sans succès :(

Message cité 1 fois
Message édité par Mitch2Pain le 19-06-2007 à 17:23:58

---------------
Fichier Patrimoine V2 Disponible !
n°1576698
Mitch2Pain
Posté le 19-06-2007 à 11:43:04  profilanswer
 
n°1576879
dwogsi
Défaillance cérébrale...
Posté le 19-06-2007 à 16:27:04  profilanswer
 

Mitch2Pain a écrit :

J'ai fait qq tests et je suis désormais sur et certain que le problème de non prise en compte du CSS viens du fait que le cache du navigateur n'ets pas vidé à chaque rechargement de page. J'ai donc inséré le header suivant dans mon index.php:
 

Citation :

<head>
<TITLE> GUI Tempost </TITLE>
<META HTTP-EQUIV="REFRESH" CONTENT="5">
<LINK rel="stylesheet" href="style.css" TYPE="text/css">  
</head>


 
Toutes les 5 secondes ma page est rafraichie mais le CSS ne s'applique ttoujours qu'une seule fois.
 
J'ai aussi essayé ça:

Citation :


header("Cache-Control: no-cache, must-revalidate" ); // HTTP/1.1
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT" ); // Date du passé


 
sans succès :(

Et tu l'as essayé sur quoi? Sur le fichier CSS et/ou sur la page Html?


---------------
-- Debian -- Le système d'exploitation universel | Le gras c'est la vie! | /(bb|[^b]{2})/
n°1576934
Mitch2Pain
Posté le 19-06-2007 à 17:18:05  profilanswer
 

sur la page html ...  
 
oulà pas con le Monsieur, je vais tester ça de suite !
 
j'ai rajouté ca:
 
header("Cache-Control: no-cache, must-revalidate" ); // HTTP/1.1  
header("Expires: Mon, 26 Jul 1997 05:00:00 GMT" ); // Date du passé  
 
en ahut de mon CSS et ca chie toujours autant.


Message édité par Mitch2Pain le 19-06-2007 à 17:20:18

---------------
Fichier Patrimoine V2 Disponible !
n°1576942
Mitch2Pain
Posté le 19-06-2007 à 17:22:36  profilanswer
 

en fait à chaque clic sur mon appli sa recrée le fichier css dans C:\Documents and Settings\...\Local Settings\Temporary Internet Files et une fois créé il n'est plus pris en compte. Je dois le supprimer alamano ou faire F5  ou ctrl+F5 dans le navigateur.


Message édité par Mitch2Pain le 19-06-2007 à 17:24:40

---------------
Fichier Patrimoine V2 Disponible !

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Programmation
  HTML/CSS

  Probleme d'actualisation

 

Sujets relatifs
Probleme de POST lors de l'actualisation de ma page ??[OpenGl] Problème actualisation du tampon de profondeur
Problème d'actualisationProblème d'actualisation et renvoi d'informations
[ASP] [Résolu] Problème d'actualisation[HTML] - Problème d'actualisation de mon site ?
Petit probleme de redirection apres actualisation de la page.problème d'actualisation
probleme d actualisation[VB] Probleme d'actualisation de combo box
Plus de sujets relatifs à : Probleme d'actualisation


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR