Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Aide | Shop Recherche
1454 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  resolv.conf sur Raspbian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

resolv.conf sur Raspbian

n°1394122
oes
Fan de Rastapopoulos
Posté le 30-08-2016 à 17:21:57  profilanswer
 

Chers tous [:greg2],

 

Ce fichier me rend dingue, il n'arrête pas de se réinitialiser à chaque démarrage avec pour seule ip DNS celle de ma passerelle LAN (qui est ma freebox).

 

Avec cette ip dns rien ne fonctionne, si j'ajoute l'ip du dns de google hop tout fonctionne à merveille. Reboot du raspberry et hop tout est à recommencer, je me retrouve de nouveau avec l'ip de ma freebox comme seule ip dns dans resolv.conf

 

J'ai trouvé plusieurs solutions de contournement mais rien ne me semble propre, pas tant que je comprenne qui détient l'autorité pour "nourrir" resolv.conf à chaque démarrage :fou:

 

Ma solution temporaire actuelle est de passer eth0 en dhcp et d'ajouter juste en dessous "dns-nameservers 8.8.8.8 xx.xx.xx.xx yy.yy.yy.yy etc."

 

A chaque reboot les ip apparaisent bien dans resolv.conf mais en première ligne réside l'ip de ma freebox, rien à faire.

 

Une info qui pourrait être intéressante, j'ai installé openvpn via pivpn (http://www.pivpn.io/), parce que j'aime bien me rendre la vie facile :o Je ne sais pas si ce script a pu mettre le boxon, mais à priori ça ne semble pas être de la merde.

 

Accessoirement, j'ai édité le fichier sshd_config récemment pour y mettre "UseDNS no" sur les recommandations de cette page pour accélérer mon login ssh. Mais je ne pense pas que ça ait un impact sur le fichier resolv.conf

 


Question supplémentaire qui n'a pas grand chose à voir mais je ne veux pas créer un deuxième topic pour cela : lorsque je suis connecté en ssh sur mon raspberry (99,999% du temps) je remarque que mes pings vers n'importe quelle ip publique comportent une importante perte (packet loss 30 à 40% en général). Est-ce que cela est dû au fait que je sois en ssh sur la même interface au moment du ping ? Ou bien est-ce que le problème est plus grave ? Je pourrais me connecter en direct sur le raspberry pour vérifier vous me direz sauf qu'il m'est un poil compliqué d'y accéder physiquement ces prochains jours.

 

Pas de problème pour ping une interface sur mon LAN en revanche donc ça n'a pas l'air d'être un problème de ressources hardware :/

 


:jap:


Message édité par oes le 30-08-2016 à 17:37:09
mood
Publicité
Posté le 30-08-2016 à 17:21:57  profilanswer
 

n°1394123
marounis
Posté le 30-08-2016 à 17:42:26  profilanswer
 

Proposal:
Tu édites resolv.conf avec ce dont tu es sûr à 100%, puis:

chattr +i /etc/resolv.conf

n°1394124
VisualC++
J'va y penser ...
Posté le 30-08-2016 à 17:47:27  profilanswer
 

C'est géré par resolvconf il me semble, j'ai eu la même mésaventure. Il faut éditer le /etc/resolvconf/???, mais de mémoire c'est marqué en première ligne du fichier resolv.conf

n°1394125
oes
Fan de Rastapopoulos
Posté le 30-08-2016 à 17:53:33  profilanswer
 

Ça devrait pas mal aider en effet, plutôt radical :o
 
Dans l'absolu j'aimerais bien comprendre la source du problème :D
 
Si c'est trop compliqué de trouver avec mes infos je sens que ça va être réinstall raspbian le weekend prochain et reconfiguration pas à pas en checkant les comportements jusqu'à ce que je trouve qui fout la merde :o

n°1394126
marounis
Posté le 30-08-2016 à 17:54:26  profilanswer
 

VisualC++ a écrit :

C'est géré par resolvconf il me semble

oes demande comment gérer lui-même, et non pas automatiquement.
La solution chattr est juste pour essayer (pas très élégant).
Ensuite, difficile de donner une réponse précise, selon comment le système est précisément installé (avec/sans network-manager , avec/sans systemd , avec/sans resolvconf installé etc etc....).
 
 

n°1394127
oes
Fan de Rastapopoulos
Posté le 30-08-2016 à 17:55:44  profilanswer
 

VisualC++ a écrit :

C'est géré par resolvconf il me semble, j'ai eu la même mésaventure. Il faut éditer le /etc/resolvconf/???, mais de mémoire c'est marqué en première ligne du fichier resolv.conf


C'est là que je bloque car je n'avais pas de package resolvconf installé... Je viens de l'installer pour avoir accès aux fichiers à éditer ("base" notamment mais il est vide [:jabbernaute] ).

n°1394128
hellohoora​y
Posté le 30-08-2016 à 18:03:35  profilanswer
 

dans base, rajoute la ligne "nameserver 8.8.8.8"

n°1394132
oes
Fan de Rastapopoulos
Posté le 30-08-2016 à 20:43:34  profilanswer
 

En installant resolvconf il semble que ça ait mis un peu d'ordre et que l'ip de la passerelle LAN n'apparaisse plus ...
 
En revanche j'ai toujours un problème avec les pertes de paquet. J'ai testé avec une autre carte SD et une installation "fraiche" de Raspbian et ça persiste (j'ai pas pu m'empêcher d'aller le chercher pour résoudre ces problèmes). Cela viendrait donc du Raspberry ? :??:
 
Il s'agit d'une v3 pour info, le tout dernier.
 

Code :
  1. pi@rasp3:~ $ ping www.google.fr
  2. PING www.google.fr (216.58.198.163) 56(84) bytes of data.
  3. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=4 ttl=52 time=113 ms
  4. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=6 ttl=52 time=116 ms
  5. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=7 ttl=52 time=120 ms
  6. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=9 ttl=52 time=115 ms
  7. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=11 ttl=52 time=121 ms
  8. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=12 ttl=52 time=119 ms
  9. 64 bytes from lhr25s10-in-f163.1e100.net (216.58.198.163): icmp_seq=14 ttl=52 time=118 ms
  10. ^C
  11. --- www.google.fr ping statistics ---
  12. 14 packets transmitted, 7 received, 50% packet loss, time 13047ms
  13. rtt min/avg/max/mdev = 113.716/118.023/121.615/2.651 ms


 
Notons que c'est 0% packet loss vers la passerelle (freebox).


Message édité par oes le 30-08-2016 à 20:49:23
n°1394133
o'gure
Modérateur
Multi grognon de B_L
Posté le 30-08-2016 à 21:53:29  profilanswer
 

VisualC++ a écrit :

C'est géré par resolvconf il me semble, j'ai eu la même mésaventure. Il faut éditer le /etc/resolvconf/???, mais de mémoire c'est marqué en première ligne du fichier resolv.conf


oui, c'est ça. Soit se débarrasser de resolvconf soit s'y adapté

marounis a écrit :

Proposal:
Tu édites resolv.conf avec ce dont tu es sûr à 100%, puis:

chattr +i /etc/resolv.conf



Et sinon essayer de comprendre le problème et le résoudre de manière propre, non ? [:opus dei]


---------------
Ton Antoine commence à me les briser menus !
n°1394139
oes
Fan de Rastapopoulos
Posté le 30-08-2016 à 23:02:52  profilanswer
 

Bon en fait je viens de tester le ping depuis un PC Windows de mon LAN et j'ai le même problème de perte de paquets quand je ping vers le web :??:
 
Ma freebox est donc en cause... je vais regarder de ce côté là.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  resolv.conf sur Raspbian

 

Sujets relatifs
Générer un fichier channels.conf pour VLC (TNT)Owncloud sur Raspbian --> impossible de se connecter
/etc/network/interfaces et /etc/resolv.confdéployer de la conf système avec un .deb
Pas de demande de mot de passe : RaspbianScript de sauvegarde raspbian
Comment sauvegarder et restaurer une conf depuis un Linux HS ?Icone RDP sous Raspbian
Conf Sendmail sur solaris 
Plus de sujets relatifs à : resolv.conf sur Raspbian


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite) / Groupe LDLC / Shop HFR