Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
1732 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Résolu] debian mount cifs

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] debian mount cifs

n°1141517
pouchat
Posté le 10-06-2009 à 11:25:43  profilanswer
 

Bonjour,
 
après une mise en place d'un serveur debian ltsp (+kerberos et winbind pour la liaison avec Active Directory), j'ai un problème de session. Après une petite recherche je me suis rendu compte d'un problème avec mount.
 
Si je fais simlpement en root :

Code :
  1. mount -t cifs //192.168.224.1/dupont$ /home/WIN2K3/dupont -o username=dupont,file_mode=0777,dir_mode=0777 --verbose


le montage est ok, mais le mask n'est appliqué qu'aux sous-dossiers de dupont et pas à dupont directement.

Code :
  1. ll /home/WIN2K/
  2. total 0
  3. dr-xr-x--x 1 dupont utilisa._du_domaine 0 jun 10 11:10 dupont


par contre mon masque (dir_mode) s'applique bien aux sous-dossiers :

Code :
  1. ll /home/WIN2K3/dupont/
  2. total 0
  3. drwxr-x--x 1 dupont utilisa._du_domaine 0 jun  9 08:33 Bureau
  4. drwxr-x--x 1 dupont utilisa._du_domaine 0 jun  5 16:28 System
  5. drwxr-x--x 1 dupont utilisa._du_domaine 0 oct 12  2007 web


 
Le problème de pas avoir de droit d'écriture sur dupont fait que la session gnome se lance pas (bah oui les fichiers de config .gnome... ne peuvent pas se créer).
 
Une solution ? Est-ce un bug ? Quelqu'un a déjà eu ce problème ?
merci.

Message cité 1 fois
Message édité par pouchat le 16-06-2009 à 14:17:24
mood
Publicité
Posté le 10-06-2009 à 11:25:43  profilanswer
 

n°1141524
boobaka
Posté le 10-06-2009 à 12:06:31  profilanswer
 

Tu as quoi en droit ntfs sur ton repertoire ?


---------------
www.google.fr  
n°1141640
e_esprit
Posté le 10-06-2009 à 19:45:48  profilanswer
 

pouchat a écrit :


par contre mon masque (dir_mode) s'applique bien aux sous-dossiers :

Code :
  1. ll /home/WIN2K3/dupont/
  2. total 0
  3. drwxr-x--x 1 dupont utilisa._du_domaine 0 jun  9 08:33 Bureau
  4. drwxr-x--x 1 dupont utilisa._du_domaine 0 jun  5 16:28 System
  5. drwxr-x--x 1 dupont utilisa._du_domaine 0 oct 12  2007 web




Heu... non :D
c'est du 751 ça, pas du 777 :D
 
Essaye de désactiver les extensions unix (unix extensions = no dans smb.conf)


---------------
Ce n'est point ma façon de penser qui a fait mon malheur, c'est celle des autres.
n°1141705
pouchat
Posté le 11-06-2009 à 08:16:38  profilanswer
 

unix extensions n'a pas marché mais je viens de débusquer le lièvre. Déjà, root lui avait bien les droits d'écriture sur le dossier de montage.
 
En fait je viens de m'aperçevoir que dans les droits ntfs sur le dossier dupont, il y a :  
- "afficher le dossier" pour l'utilisateur dupont
- le restes des accès pour dupont est situé dans "autorisations spéciales".
 
Ca explique tout. J'ai installé les acl, mais quand je monte avec l'option acl toujours pareil...

n°1141713
pouchat
Posté le 11-06-2009 à 08:43:03  profilanswer
 

rien à faire. En plus de ça même si je change les droits du partage dupont$ sur le serveur 2003 (en mettant bien modif, lecture,écriture) toujours pas les bonnes permissions sur mon dossier de montage...

n°1141774
pouchat
Posté le 11-06-2009 à 10:45:43  profilanswer
 

j'avais un client sous ubuntu. J'ai donc fait aussi un test avec : - intégration au domaine
- même fichier de conf
..et quand je lance la même commande, lui au moins m'applique bien mon masque sur le point de montage (donc dupont/ accessible en écriture).
 
Bug debian ?

n°1142698
pouchat
Posté le 16-06-2009 à 14:16:25  profilanswer
 

j'ai trouvé l'erreur et comme j'ai posté mon problème un peu partout je recopie-colle la réponse :  
 
En activant le mode debug de mount.cifs (echo 3 > /proc/fs/cifs/cifsFYI), des erreurs s'affichent dans la sortie dmesg :

Code :
  1. # dmesg
  2. [ 7845.389949]  fs/cifs/xattr.c: CIFS VFS: in cifs_getxattr as Xid: 50 with uid: 0
  3. [ 7845.389953]  fs/cifs/xattr.c: illegal xattr request security.selinux (only user namespace supported)
  4. [ 7845.389956]  fs/cifs/xattr.c: CIFS VFS: leaving cifs_getxattr (xid = 50) rc = -95
  5. [ 7845.389964]  fs/cifs/xattr.c: CIFS VFS: in cifs_getxattr as Xid: 51 with uid: 0
  6. [ 7845.389967]  fs/cifs/xattr.c: CIFS VFS: leaving cifs_getxattr (xid = 51) rc = -95


donc en utilisant l'option nouser_xattr ça règle le problème :

Code :
  1. mount -t cifs //192.168.224.1/MYSHARE$ TEST -o username=admin,uid=10066,gid=10000,dir_mode=0755,nouser_xattr --verbose
Code :
  1. ll .
  2. drwxr-xr-x 1 admin utilisa._du_domaine 0 jun 11 17:14 TEST


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  réseaux et sécurité

  [Résolu] debian mount cifs

 

Sujets relatifs
configuration d'un bridge sous debian avec deux cartes réseaux[Résolu] Transfert de fichiers avec 'Put' sous Linux
Stopper un RAID sous mdadm (debian lenny)Apache2/Lenny/ Installation impossible ! [RESOLU]
[RESOLU] Fedora sur PowerEdge 800 : pas de boot[RESOLU] Script PHP au démarrage d'Ubuntu
[Resolu] Nagios Hostgroup comment déclarer ?[Résolu] Installation de Ushare sous debian...
scanner Epson sous Debian 5.0 
Plus de sujets relatifs à : [Résolu] debian mount cifs


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR