Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
568 connectés 

 



 Mot :   Pseudo :  
 
 Page :   1  2
Page Précédente
Auteur Sujet :

Probléme+postfix

n°892992
wiame
Posté le 06-03-2007 à 11:02:31  profilanswer
 

Bonjour tout le monde,
j'ai un serveur postfix, il travaillait normalment et tt d'un coup ca marche pas le message est envoyé mais je n'arrive pas a le recevoir.
 
un postfix check me donne
 
postfix/postfix-script: warning: not owned by group postdrop: /var/spool/postfix/maildrop
postfix/postfix-script: warning: not owned by group postdrop: /usr/sbin/postqueue
postfix/postfix-script: warning: not owned by group postdrop: /usr/sbin/postdrop
 
Si qq peut m'aider mille merci

mood
Publicité
Posté le 06-03-2007 à 11:02:31  profilanswer
 

n°892993
fracolo
Posté le 06-03-2007 à 11:15:09  profilanswer
 

Bonjour,
 
Etonnant, cela signifie que les droits sur les fichiers /var/spool/postfix/maildrop ,  /usr/sbin/postqueue , et /usr/sbin/postdrop ont été modifiés.
Cela pourrait être la conséquence d'une mise à jour.
 
Pourrais-je avoir les droits se rapportant à ces fichiers ?

n°892994
wiame
Posté le 06-03-2007 à 11:46:07  profilanswer
 

/usr/sbin/postdrop -r-xr-sr-x
/usr/sbin/postqueue -r-xr-sr-x
/var/spool/postfix/maildrop
 
Comment je peux remedier a ce probléme??
 

n°892995
fracolo
Posté le 06-03-2007 à 12:00:23  profilanswer
 

wiame a écrit :

/usr/sbin/postdrop -r-xr-sr-x
/usr/sbin/postqueue -r-xr-sr-x
/var/spool/postfix/maildrop
 
Comment je peux remedier a ce probléme??


 
j'ai été imprécis, lorsque je demandais les droits, je pensais également avoir le propriétaire et le groupe associé aux fichiers.
Etant donnés les avertissements de postfix, il semble que ces fichiers ne sont associés au groupe postdrop
 
Les avertissements devraient disparaître après avoir fait :
S'assurer que le groupe demandé existe bien (> cat /etc/group | grep postdrop)
>chgrp postdrop  /var/spool/postfix/maildrop
>chgrp postdrop /usr/sbin/postqueue
>chgrp postdrop  /usr/sbin/postdrop

n°892996
wiame
Posté le 06-03-2007 à 15:37:02  profilanswer
 

fracolo a écrit :

j'ai été imprécis, lorsque je demandais les droits, je pensais également avoir le propriétaire et le groupe associé aux fichiers.
Etant donnés les avertissements de postfix, il semble que ces fichiers ne sont associés au groupe postdrop
 
Les avertissements devraient disparaître après avoir fait :
S'assurer que le groupe demandé existe bien (> cat /etc/group | grep postdrop)
>chgrp postdrop  /var/spool/postfix/maildrop
>chgrp postdrop /usr/sbin/postqueue
>chgrp postdrop  /usr/sbin/postdrop


 
Merci bcp mais  
quand je redemarre postfix me donne cette erreur:
 
/etc/init.d/postfix restart
Stopping mail transport agent: Postfix.
Starting mail transport agent: Postfixpostsuper: warning: bogus file name: incoming/281596.4396                                            

n°892997
fracolo
Posté le 06-03-2007 à 15:48:52  profilanswer
 

wiame a écrit :

Merci bcp mais  
quand je redemarre postfix me donne cette erreur:
 
/etc/init.d/postfix restart
Stopping mail transport agent: Postfix.
Starting mail transport agent: Postfixpostsuper: warning: bogus file name: incoming/281596.4396


 
Ce fichier doit être déplacé du repertoire dans lequel il se trouve.
Postfix devrait démarrer convenablement ensuite

n°892998
wiame
Posté le 06-03-2007 à 16:00:56  profilanswer
 

fracolo a écrit :

Ce fichier doit être déplacé du repertoire dans lequel il se trouve.
Postfix devrait démarrer convenablement ensuite


 
desolée jé pas bien compris ...
quel fichier qui doit etre deplacé??


Message édité par wiame le 06-03-2007 à 16:01:19
n°892999
fracolo
Posté le 06-03-2007 à 16:08:52  profilanswer
 

wiame a écrit :

desolée jé pas bien compris ...
quel fichier qui doit etre deplacé??


 
le fichier qui doit être déplacé est "incoming/281596.4396"
Il est vraisemblablement dans le repertoire /var/spool/mail ou un du genre.
Pour le trouver, deux options :
*  profiter de l'occasion pour mettre à jour la base pour locate en faisant un updatedb en ligne commande (sudo ou connecté en root), puis locate incoming/281596.4396
* faire un find -iname "*281596.4396*" depuis la racine (toujours avec les privilèges root)
 
Ensuite, faire un mv chemin/du/fichier/281596.4396  /chemin/sauvegarde

n°893000
wiame
Posté le 06-03-2007 à 18:10:18  profilanswer
 

fracolo a écrit :

le fichier qui doit être déplacé est "incoming/281596.4396"
Il est vraisemblablement dans le repertoire /var/spool/mail ou un du genre.
Pour le trouver, deux options :
*  profiter de l'occasion pour mettre à jour la base pour locate en faisant un updatedb en ligne commande (sudo ou connecté en root), puis locate incoming/281596.4396
* faire un find -iname "*281596.4396*" depuis la racine (toujours avec les privilèges root)
 
Ensuite, faire un mv chemin/du/fichier/281596.4396  /chemin/sauvegarde


 
Merci vraiment le pb de  incoming/281596.4396 est bien reglé avec ce que tu m a dit mille merci mais postfix chek me donne:
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postqueue
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
J'ai supprimé postdrop et rajouter mais ca ne marche pas

n°893001
fracolo
Posté le 06-03-2007 à 18:21:16  profilanswer
 

wiame a écrit :

Merci vraiment le pb de  incoming/281596.4396 est bien reglé avec ce que tu m a dit mille merci mais postfix chek me donne:
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postqueue
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
J'ai supprimé postdrop et rajouter mais ca ne marche pas


 
Ouille ouille ouille ! Comment ça supprimé postdrop et rajouté ??
Sur quelle distribution as-tu installé postfix, et comment ?

mood
Publicité
Posté le 06-03-2007 à 18:21:16  profilanswer
 

n°893002
wiame
Posté le 06-03-2007 à 20:23:34  profilanswer
 

fracolo a écrit :

Ouille ouille ouille ! Comment ça supprimé postdrop et rajouté ??
Sur quelle distribution as-tu installé postfix, et comment ?


 
C'est pas moi qu il l a installé.
 
postfix 2.13
 
voila mon fichier main.cf
++++++
# See /usr/share/postfix/main.cf.dist for a commented, more complete version
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no
setgid_group = postdrop
# appending .domain is the MUA's job.
append_dot_mydomain = no
# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
mydomain = xx.xx
myhostname = xx.xx.xx
myorigin = /etc/mailname
mydestination = xx.xx.xx, localhost.localdomain, localhost.localdomain, localhost
mynetworks = 127.0.0.0/8, xx.xx.xx.0/28
relay_domains=
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
# -- Added for MPP --
#content_filter = smtp:127.0.0.1:10025
# -- end --
 
+++
J'ajoute mes utilisateurs et groupes  avec webmin(interface web qui permet de configurer le serveur)
 Mercci bcp


Message édité par wiame le 06-03-2007 à 20:26:17
n°893003
fracolo
Posté le 06-03-2007 à 21:39:00  profilanswer
 

Lorsque tu disais avoir supprimé postdrop, c'était à propos de l'exécutable (/usr/sbin/postdrop) ou du groupe postdrop ?
Dans le fichier main.cf, je vois que postfix s'exécute en tant que membre du groupe postdrop (setgid_group = postdrop).
 
Est-ce que postfix a commencé à ne plus fonctionner à partir du moment où tu t'es servi de webmin pour l'administrer ?
J'y verrais bien ici l'explication des changements de propriétaire des fichiers /var/spool/postfix/maildrop ,  /usr/sbin/postqueue , et /usr/sbin/postdrop.
 
Si tu as supprimé le binaire postdrop, tu devras en installer un nouveau, et donc probablement réinstaller postfix (apt-get install --reinstall postfix).
 
Pour info, sur mon serveur les propriétaires et droits des fichiers qui t'ont posés des problèmes au départ sont :

Code :
  1. -r-xr-sr-x  1 root postdrop 8,3K 2005-03-01 02:05 /usr/sbin/postdrop
  2. -r-xr-sr-x  1 root postdrop 8,3K 2005-03-01 02:05 /usr/sbin/postqueue
  3. drwx-wx--T   2 postfix postdrop 4,0K 2007-03-06 14:24 maildrop

n°893004
wiame
Posté le 06-03-2007 à 22:19:54  profilanswer
 

fracolo a écrit :

Lorsque tu disais avoir supprimé postdrop, c'était à propos de l'exécutable (/usr/sbin/postdrop) ou du groupe postdrop ?
Dans le fichier main.cf, je vois que postfix s'exécute en tant que membre du groupe postdrop (setgid_group = postdrop).

 

Est-ce que postfix a commencé à ne plus fonctionner à partir du moment où tu t'es servi de webmin pour l'administrer ?
J'y verrais bien ici l'explication des changements de propriétaire des fichiers /var/spool/postfix/maildrop ,  /usr/sbin/postqueue , et /usr/sbin/postdrop.

 

Si tu as supprimé le binaire postdrop, tu devras en installer un nouveau, et donc probablement réinstaller postfix (apt-get install --reinstall postfix).

 

Pour info, sur mon serveur les propriétaires et droits des fichiers qui t'ont posés des problèmes au départ sont :

Code :
  1. -r-xr-sr-x  1 root postdrop 8,3K 2005-03-01 02:05 /usr/sbin/postdrop
  2. -r-xr-sr-x  1 root postdrop 8,3K 2005-03-01 02:05 /usr/sbin/postqueue
  3. drwx-wx--T   2 postfix postdrop 4,0K 2007-03-06 14:24 maildrop


 


" tu disais avoir supprimé postdrop," :le groupe postdrop
Est-ce que postfix a commencé à ne plus fonctionner à partir du moment où tu t'es servi de webmin pour l'administrer : non depuis qu'il a été installé on utlisé webmin.il marché bien ...

  



Message édité par wiame le 06-03-2007 à 22:56:37
n°893092
ami22
Posté le 07-03-2007 à 10:27:04  profilanswer
 

y a plus personne pour m'aider  :sweat:

n°893093
toniotonio
Posté le 07-03-2007 à 10:29:10  profilanswer
 

postfix 2.13 c'est vieux
faudrait peut etre en profiter pour installer une version plus recente
 
tu es sur quelle distrib ?

n°893101
ami22
Posté le 07-03-2007 à 10:41:15  profilanswer
 

toniotonio a écrit :

postfix 2.13 c'est vieux
faudrait peut etre en profiter pour installer une version plus recente
 
tu es sur quelle distrib ?


 
Postfix version 2.1.5
si je le reinstale je pers les messgaes des utlisateurs.???

n°893102
ami22
Posté le 07-03-2007 à 10:41:41  profilanswer
 

ami22 a écrit :

Postfix version 2.1.5
si je le reinstale je pers les messgaes des utlisateurs.???


Debian

n°893115
fracolo
Posté le 07-03-2007 à 11:15:21  profilanswer
 

Tu ne perdras ni les messages, ni les fichiers de conf si tu fais des sauvegardes.
 
Après avoir fait ces sauvegardes, tu peux sans risque reinstaller postfix avec la commande apt-get install --reinstall postfix
Sur une debian sarge, c'est sûr que tu n'auras pas la dernière version de postfix.
Dans l'immédiat, je te conseille d'en rester à cette méthode d'installation... et d'éviter d'avoir recours à Webmin pour la configuration.

n°893135
ami22
Posté le 07-03-2007 à 12:01:04  profilanswer
 

fracolo a écrit :

Tu ne perdras ni les messages, ni les fichiers de conf si tu fais des sauvegardes.

 

Après avoir fait ces sauvegardes, tu peux sans risque reinstaller postfix avec la commande apt-get install --reinstall postfix
Sur une debian sarge, c'est sûr que tu n'auras pas la dernière version de postfix.
Dans l'immédiat, je te conseille d'en rester à cette méthode d'installation... et d'éviter d'avoir recours à Webmin pour la configuration.

 

Y a pas autre methode pour resoudre le probélme???
pour le mail.err
me dit  
unnouknen group postdrop dans main.cf
 
pourtant il est crée

Message cité 1 fois
Message édité par ami22 le 07-03-2007 à 12:06:00
n°893144
fracolo
Posté le 07-03-2007 à 12:13:45  profilanswer
 

ami22 a écrit :

Y a pas autre methode pour resoudre le probélme???
pour le mail.err
me dit  
unnouknen group postdrop dans main.cf
 
pourtant il est crée


 
Etonnant...
La commande  

Citation :

grep postdrop /etc/group


retourne-t-elle une ligne du genre postdrop:x:1004:  ?
 
Si aucune ligne n'est retournée, c'est que le groupe n'est pas correctement créé.

n°893155
ami22
Posté le 07-03-2007 à 12:42:30  profilanswer
 

fracolo a écrit :

Etonnant...
La commande  

Citation :

grep postdrop /etc/group


retourne-t-elle une ligne du genre postdrop:x:1004:  ?
 
Si aucune ligne n'est retournée, c'est que le groupe n'est pas correctement créé.


 
 
il me retourne
 
postdrop:x:1008:
 
 :sweat:

n°893222
fracolo
Posté le 07-03-2007 à 15:40:34  profilanswer
 

ami22 a écrit :

il me retourne
 
postdrop:x:1008:
 
 :sweat:


 
Dans ce cas l'erreur signalée dans les logs de postfix date du moment où tu dis avoir supprimé le groupe.
 
Que donne la commande /etc/init.d/postfix check ?

n°893241
ami22
Posté le 07-03-2007 à 16:27:20  profilanswer
 

fracolo a écrit :

Dans ce cas l'erreur signalée dans les logs de postfix date du moment où tu dis avoir supprimé le groupe.
 
Que donne la commande /etc/init.d/postfix check ?


 
:~# /etc/init.d/postfix check
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postqueue
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop
 
 
 

n°893258
fracolo
Posté le 07-03-2007 à 16:52:41  profilanswer
 

ami22 a écrit :

:~# /etc/init.d/postfix check
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postqueue
postfix/postfix-script: warning: not set-gid or not owner+group+world executable: /usr/sbin/postdrop


 
les commandes suivantes devraient résoudre ce problème :
> chmod g+s /usr/sbin/postqueue
> chmod g+s /usr/sbin/postdrop
 

n°893302
ami22
Posté le 07-03-2007 à 18:52:36  profilanswer
 

fracolo a écrit :

les commandes suivantes devraient résoudre ce problème :
> chmod g+s /usr/sbin/postqueue
> chmod g+s /usr/sbin/postdrop


 
Merci bcp de m 'avoir aider oui t a raison l erreur ne s affiche plus
quand j envoi un message il n arrive pas immédiatement  :sleep:  
par exempele j'ai recu des messages que j'ai envoyé le matin
 
 

n°893305
fracolo
Posté le 07-03-2007 à 19:11:45  profilanswer
 

ami22 a écrit :

Merci bcp de m 'avoir aider oui t a raison l erreur ne s affiche plus
quand j envoi un message il n arrive pas immédiatement  :sleep:  
par exempele j'ai recu des messages que j'ai envoyé le matin


 
Comme jusqu'à maintenant, il y avait des erreurs, c'est normal que l'acheminement ne se soit pas fait "normalement".
Dorénavant, tout devrait être rentré dans l'ordre.
 
Bonne continuation

n°893320
wiame
Posté le 07-03-2007 à 20:15:28  profilanswer
 

fracolo a écrit :

Comme jusqu'à maintenant, il y avait des erreurs, c'est normal que l'acheminement ne se soit pas fait "normalement".
Dorénavant, tout devrait être rentré dans l'ordre.
 
Bonne continuation


 
Derniére question si je veus supprimer les messages qui sont en file d'attente??
je supprime dans quel dossier???
 
Je suis desolée pour le derangement

n°893332
fracolo
Posté le 07-03-2007 à 20:50:10  profilanswer
 

wiame a écrit :

Derniére question si je veus supprimer les messages qui sont en file d'attente??
je supprime dans quel dossier???
 
Je suis desolée pour le derangement


 
>postfix flush
permet d'envoyer les messages en files d'attente
 
Sinon, pour les supprimer purement et simplement,
>  du -h /var/spool/postfix/active
pour vérifier qu'il y a bien des messages à supprimer.
 
Sur mon serveur, il n'y en a pas, j'ai donc le résultat suivant :
serveur:~# du -h /var/spool/postfix/active
4,0K    /var/spool/postfix/active/8
4,0K    /var/spool/postfix/active/4
4,0K    /var/spool/postfix/active/C
4,0K    /var/spool/postfix/active/B
4,0K    /var/spool/postfix/active/D
4,0K    /var/spool/postfix/active/5
4,0K    /var/spool/postfix/active/6
4,0K    /var/spool/postfix/active/1
4,0K    /var/spool/postfix/active/A
4,0K    /var/spool/postfix/active/E
4,0K    /var/spool/postfix/active/7
4,0K    /var/spool/postfix/active/2
4,0K    /var/spool/postfix/active/3
4,0K    /var/spool/postfix/active/0
4,0K    /var/spool/postfix/active/9
4,0K    /var/spool/postfix/active/F
68K     /var/spool/postfix/active
 
S'il y en a à effacer, supprimer le contenu des répertoires dans lesquels ils sont.

n°893439
ami22
Posté le 08-03-2007 à 09:48:29  profilanswer
 

fracolo a écrit :

>postfix flush
permet d'envoyer les messages en files d'attente

 

Sinon, pour les supprimer purement et simplement,
>  du -h /var/spool/postfix/active
pour vérifier qu'il y a bien des messages à supprimer.

 

Sur mon serveur, il n'y en a pas, j'ai donc le résultat suivant :
serveur:~# du -h /var/spool/postfix/active
4,0K    /var/spool/postfix/active/8
4,0K    /var/spool/postfix/active/4
4,0K    /var/spool/postfix/active/C
4,0K    /var/spool/postfix/active/B
4,0K    /var/spool/postfix/active/D
4,0K    /var/spool/postfix/active/5
4,0K    /var/spool/postfix/active/6
4,0K    /var/spool/postfix/active/1
4,0K    /var/spool/postfix/active/A
4,0K    /var/spool/postfix/active/E
4,0K    /var/spool/postfix/active/7
4,0K    /var/spool/postfix/active/2
4,0K    /var/spool/postfix/active/3
4,0K    /var/spool/postfix/active/0
4,0K    /var/spool/postfix/active/9
4,0K    /var/spool/postfix/active/F
68K     /var/spool/postfix/active

 

S'il y en a à effacer, supprimer le contenu des répertoires dans lesquels ils sont.


qd je fait le ceck cé bon y a pas de probléme
Il fait plusque 15 minutes pour envoyer un message et qq messags n'arrive pas

Message cité 1 fois
Message édité par ami22 le 08-03-2007 à 09:58:58
n°893448
fracolo
Posté le 08-03-2007 à 10:26:37  profilanswer
 

ami22 a écrit :

qd je fait le ceck cé bon y a pas de probléme  
Il fait plusque 15 minutes pour envoyer un message et qq messags n'arrive pas


 
Dans quel environnement tourne ton serveur (où est-il physiquement, dans quel réseau) ? et quel type de serveur est-ce (mutualisé, dédié virtuel, dédié) ?
A-t-il suffisamment de mémoire ? N'est-il pas surchargé (quel est l'average load) ?
 

n°893482
ami22
Posté le 08-03-2007 à 11:36:31  profilanswer
 

fracolo a écrit :

Dans quel environnement tourne ton serveur (où est-il physiquement, dans quel réseau) ? et quel type de serveur est-ce (mutualisé, dédié virtuel, dédié) ?
A-t-il suffisamment de mémoire ? N'est-il pas surchargé (quel est l'average load) ?


 
 
La memoire est de 256
C'est un serveur dedié >400 utlisateurs
ca a marché avant je ne sais ce qu'il ai arrivé

n°893537
fracolo
Posté le 08-03-2007 à 14:09:53  profilanswer
 

ami22 a écrit :

La memoire est de 256
C'est un serveur dedié >400 utlisateurs
ca a marché avant je ne sais ce qu'il ai arrivé


Y-a-t'il un antispam installé avec Postfix (comme spamassassin) ? Un antivirus ?
 
Avec la commande :
> top
 
Quelles sont les valeurs de load average (première ligne) ?

n°893567
ami22
Posté le 08-03-2007 à 15:35:46  profilanswer
 

fracolo a écrit :

Y-a-t'il un antispam installé avec Postfix (comme spamassassin) ? Un antivirus ?
 
Avec la commande :
> top
 
Quelles sont les valeurs de load average (première ligne) ?


 
Oui y a sur serveur sapmasssin
 
 top me done  
 
top - 14:52:35 up  4:26,  1 user,  load average: 2.29, 2.65, 2.48
Mem:    257036k total,   251760k used,     5276k free,    56680k buffers
Swap:   755012k total,    64996k used,   690016k free,    51644k cached

n°893573
fracolo
Posté le 08-03-2007 à 15:50:25  profilanswer
 

ami22 a écrit :

Oui y a sur serveur sapmasssin
 
 top me done  
 
top - 14:52:35 up  4:26,  1 user,  load average: 2.29, 2.65, 2.48
Mem:    257036k total,   251760k used,     5276k free,    56680k buffers
Swap:   755012k total,    64996k used,   690016k free,    51644k cached


 
Ces valeurs de load average sont importantes.
Reste maintenant à savoir si c'est passagé ou permanent.
Par défaut, avec top, tu as les processus classés par ordre de charge CPU.
Regarde si tu n'as pas un processus qui squatte le CPU.
 
Pour spamassin, l'as-tu configuré pour qu'il tourne en daemon ?
Sinon, il doit être lancé pour chaque message traité.

Message cité 1 fois
Message édité par fracolo le 08-03-2007 à 15:51:11
n°893576
ami22
Posté le 08-03-2007 à 15:58:22  profilanswer
 

fracolo a écrit :

Ces valeurs de load average sont importantes.
Reste maintenant à savoir si c'est passagé ou permanent.
Par défaut, avec top, tu as les processus classés par ordre de charge CPU.
Regarde si tu n'as pas un processus qui squatte le CPU.
 
Pour spamassin, l'as-tu configuré pour qu'il tourne en daemon ?
Sinon, il doit être lancé pour chaque message traité.


voila
/**
10212 postfix   11   0  1216 1216 1036 D  0.7  0.5   0:00.17 cleanup
11002 root      18   0  1116 1116  852 R  0.7  0.4   0:00.69 top
   48 root      13   0     0    0    0 D  0.3  0.0   0:41.02 kjournald
10166 postfix   10   0  1216 1216 1036 S  0.3  0.5   0:00.16 cleanup
10522 postfix   10   0  1216 1216 1036 S  0.3  0.5   0:00.09 cleanup
10917 postfix   12   0  1708 1708 1028 S  0.3  0.7   0:02.13 qmgr
10981 postfix   10   0  1320 1316 1116 S  0.3  0.5   0:00.01 smtp
    1 root       8   0   496  468  444 S  0.0  0.2   0:00.08 init
    2 root       9   0     0    0    0 S  0.0  0.0   0:00.01 keventd
    3 root      19  19     0    0    0 S  0.0  0.0   0:00.02 ksoftirqd_CPU0
    4 root       9   0     0    0    0 S  0.0  0.0   0:01.91 kswapd
    5 root       9   0     0    0    0 S  0.0  0.0   0:00.00 bdflush
    6 root       9   0     0    0    0 S  0.0  0.0   0:00.00 kupdated
   18 root       9   0     0    0    0 S  0.0  0.0   0:00.00 scsi_eh_0
  335 root       7  -4   432  384  384 S  0.0  0.1   0:00.01 udevd
  452 root       9   0     0    0    0 S  0.0  0.0   0:00.00 khubd
  768 daemon     9   0   444  416  416 S  0.0  0.2   0:00.00 portmap
  936 root      10   0   772  744  668 S  0.0  0.3   0:37.47 syslogd
  939 root       9   0  1256  524  524 S  0.0  0.2   0:00.08 klogd
  947 bind       9   0  1764 1352 1136 S  0.0  0.5   0:00.00 named
  948 bind       9   0  1764 1352 1136 S  0.0  0.5   0:00.00 named
  949 bind       9   0  1764 1352 1136 S  0.0  0.5   0:00.00 named
  950 bind       9   0  1764 1352 1136 S  0.0  0.5   0:00.00 named
  951 bind       9   0  1764 1352 1136 S  0.0  0.5   0:00.00 named
  958 root       9   0  1716 1224 1028 S  0.0  0.5   0:00.01 lwresd
  959 root       9   0  1716 1224 1028 S  0.0  0.5   0:00.00 lwresd
  960 root       9   0  1716 1224 1028 S  0.0  0.5   0:00.00 lwresd
  961 root       9   0  1716 1224 1028 S  0.0  0.5   0:00.00 lwresd
  962 root       9   0  1716 1224 1028 S  0.0  0.5   0:00.00 lwresd
  971 root       9   0 21276 2292 2292 S  0.0  0.9   0:00.77 spamd
  979 root       9   0 22032  15m 6656 S  0.0  6.2   0:00.67 spamd
  980 root       9   0 22580  14m 6288 S  0.0  6.0   0:00.58 spamd
  981 root       9   0 23044  16m 6288 S  0.0  6.6   0:00.76 spamd
  982 root       9   0 22132 8644 5980 S  0.0  3.4   0:00.63 spamd
  983 root       9   0 21976  14m 6188 S  0.0  5.9   0:00.58 spamd
  984 clamav     9   0 20112  19m  19m S  0.0  7.8   0:10.18 clamd
 1025 clamav     9   0  1408 1264 1164 S  0.0  0.5   0:00.05 freshclam
 1030 root       9   0   452  400  400 S  0.0  0.2   0:00.00 courierlogger
/**
spam asssin ca a été installé avec webmin  
j'ai mis juste que les si cé un spam ca se rejte avec(webmin)
/*******
dsl vrément

n°893584
fracolo
Posté le 08-03-2007 à 16:18:28  profilanswer
 

Pour savoir si spamassassin est en mode daemon :
Dans le fichier de conf /etc/default/spamassassin, il doit y avoir
ENABLED=1
 
Sinon, le copier-coller de la liste des processus affichée par top ne montre pas de processus qui monopolise le processeur.
 
A surveiller
 

n°893597
ami22
Posté le 08-03-2007 à 16:38:14  profilanswer
 

fracolo a écrit :

Pour savoir si spamassassin est en mode daemon :
Dans le fichier de conf /etc/default/spamassassin, il doit y avoir
ENABLED=1
 
Sinon, le copier-coller de la liste des processus affichée par top ne montre pas de processus qui monopolise le processeur.
 
A surveiller


 
OUi enabled=1
je ne sais vraiment pas quoi faire
 

n°893612
fracolo
Posté le 08-03-2007 à 17:48:49  profilanswer
 

Ca vaut le coup de regarder dans les logs postfix pour s'assurer que le serveur ne soit pas utilisé par des spammeurs.
Si j'étais toi, j'analyserais ces mêmes logs pour estimer le nombre de messages traités par postfix.

n°893675
wiame
Posté le 08-03-2007 à 21:29:11  profilanswer
 

fracolo a écrit :

Ca vaut le coup de regarder dans les logs postfix pour s'assurer que le serveur ne soit pas utilisé par des spammeurs.
Si j'étais toi, j'analyserais ces mêmes logs pour estimer le nombre de messages traités par postfix.

 


le mail.err me donne derné rement ca

 

Mar 8 17:37:17 postfix/qmgr[3139]: fatal:watching tiemout
Mar 8 20:29:31 postfix/qmgr[5433]: fatal:watching tiemout

 

mail.info contient bcp d'adresse yahoo a quii on envoi des messages de mon serveur.

 

:sweat:
est ce que cé foutu ou ya un moyen de réparer  :sweat:
Merci bcp

 

les messages qui vont  a l exterieur yahoo ou hotmail n arrive meme pas

 

Message cité 1 fois
Message édité par wiame le 08-03-2007 à 22:04:36
n°893726
fracolo
Posté le 09-03-2007 à 08:13:54  profilanswer
 

wiame a écrit :

le mail.err me donne derné rement ca  
 
Mar 8 17:37:17 postfix/qmgr[3139]: fatal:watching tiemout
Mar 8 20:29:31 postfix/qmgr[5433]: fatal:watching tiemout
 
mail.info contient bcp d'adresse yahoo a quii on envoi des messages de mon serveur.
 
 :sweat:  
est ce que cé foutu ou ya un moyen de réparer  :sweat:  
Merci bcp
 
les messages qui vont  a l exterieur yahoo ou hotmail n arrive meme pas


 
Le gestionnaire de la file d'attente (qmgr) est visiblement dans l'impossibilité de la traiter correctement. Dans la chaîne d'acheminement des messages, un processus joue le rôle de goulot d'étranglement en ne traitant pas assez rapidement les messages. Y a t-il trop de messages à traiter pour les capacités physiques du serveur (RAM, processeur) ? Le(s) programme(s) en cause sont-ils bien paramétrés ?
 
Par ailleurs, je suis étonné de lire des fautes de frappe dans les logs mail :

Citation :


Mar 8 17:37:17 postfix/qmgr[3139]: fatal:watching tiemout
Mar 8 20:29:31 postfix/qmgr[5433]: fatal:watching tiemout


 
On y lit "tiemout" au lieu de "timeout".
 
Remettre ton serveur sur pied est certainement possible.  
Pour cela, il faut au minimum que tu fournisses des logs "verbeux" (notamment smtpd).
Edite le fichier master.cf et ajoute l'option " -v" à la suite de smtpd :
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd -v
 
> /etc/init.d/postfix reload
pour intégrer le changement de configuration
 
Ensuite, si tu ne découvres pas ce qui coince en les analysant les logs, pour des raisons de confidentialité, je te propose de me les fournir en privé.


Message édité par fracolo le 09-03-2007 à 08:16:18
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2
Page Précédente

Aller à :
Ajouter une réponse
 

Sujets relatifs
probleme mails en double Postfix+MysqlProblème avec serveur mail (sous postfix)
Serveur de messagerie - SME7 - Nouveau probleme \o/Problème Postfix : connexion refusée 127.0.01
Probleme avec Postfix, amavisd-new et spamassassin : ca marche pas[Résolu] Postfix+postfixadmin+mysql problème d'authentification
[postfix] probleme nom domaine d'expediteur[résolu] problème config postfix mail ver extérieur blockés
POstfix + SASL le retour : probleme[problème] serveur postfix
Plus de sujets relatifs à : Probléme+postfix


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR