Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
2964 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs

  Probleme: Installation Gd-2.0.4 avec php-4.2.3

 


 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme: Installation Gd-2.0.4 avec php-4.2.3

n°187759
Nicoolem
Posté le 12-11-2002 à 13:42:21  profilanswer
 

Salut a tous,  
 
depuis plusieurs jours j'essaye d'installer php avec la librairie GD 2  
Voila ce ke j'obtiens au configure de GD :
------
Found OS with linux-like shared library link command
Shared library link command: ld -shared
png library found.
zlib library found.
jpeg library found.
freetype 2.x library found.
Xpm library found.
Optional libraries found: png z jpeg freetype Xpm X11
------
donc apres make et make install j'ai bien libgd.a et libgd.so ds le rep /usr/local/lib
ensuite je configure php avec cette ligne la:
./configure  
--enable-calendar  
--with-mysql  
--with-apxs=/usr/local/apache/bin/apxs  
--with-config-file-path=/usr/local/apache/conf  
--enable-versioning  
--enable-ftp  
--enable-track-vars  
--with-jpeg-dir=/tmp/download/jpeg-6b  
--with-png-dir=/tmp/download/libpng-1.2.5  
--with-libz-dir=/tmp/download/zlib-1.1.4  
--with-gd=/usr/local  
--with-freetype=/usr  
--with-xpm=/usr  
(normalement j'ai tout sur la meme ligne mais la c pour la presentation)
et voila un extrait du configure
----------
checking for GD support... yes
checking whether to enable truetype string function in GD... no
checking for the location of libjpeg... yes
checking for jpeg_read_header in -ljpeg... (cached) yes
checking for the location of libpng... yes
checking for png_write_image in -lpng... (cached) yes
checking for the location of libXpm... no
If configure fails try --with-xpm-dir=<DIR>
checking for freetype(2)... no
If configure fails try --with-freetype-dir=<DIR>
checking for FreeType 1.x support... no
checking for T1lib support... no
checking for gdImageString16 in -lgd... (cached) no
checking for gdImagePaletteCopy in -lgd... (cached) no
checking for gdImageCreateFromPng in -lgd... (cached) no
checking for gdImageCreateFromGif in -lgd... (cached) no
checking for gdImageGif in -lgd... (cached) no
checking for gdImageWBMP in -lgd... (cached) no
checking for gdImageCreateFromJpeg in -lgd... (cached) no
checking for gdImageCreateFromXpm in -lgd... (cached) no
checking for gdImageCreateFromGd2 in -lgd... (cached) no
checking for gdImageCreateTrueColor in -lgd... (cached) no
checking for gdImageSetTile in -lgd... (cached) no
checking for gdImageSetBrush in -lgd... (cached) no
checking for gdImageStringTTF in -lgd... (cached) no
checking for gdImageStringFT in -lgd... (cached) no
checking for gdImageStringFTEx in -lgd... (cached) no
checking for gdImageColorClosestHWB in -lgd... (cached) no
checking for gdImageColorResolve in -lgd... (cached) no
checking for gdImageGifCtx in -lgd... (cached) no
-------------
 
Est ce que quelqu'un a deja réussi cette install ? parce que la moi je pige plus ca fais 50 fois que je refais mon configure et la c ma version avec le moins d'erreurs.
 
Si quelqu'un peut m'aider ce serait sympa !!!  :jap:  


---------------
Nicoolem - nicoolem.online.fr
mood
Publicité
Posté le 12-11-2002 à 13:42:21  profilanswer
 

n°187761
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 13:45:20  profilanswer
 

et en mettant /usr/local/lib ds le path de gd au nivo du configure, c pas mieux?


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."
n°187771
Nicoolem
Posté le 12-11-2002 à 13:59:42  profilanswer
 

nan ca change rien g testé


---------------
Nicoolem - nicoolem.online.fr
n°187774
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 14:06:18  profilanswer
 

kestion con: tu lui met le path des libs, mais peutr etre a t il besoin des headers, come pour jpg png etc


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."
n°187794
Nicoolem
Posté le 12-11-2002 à 14:24:14  profilanswer
 

j'ai installé Gd ds /usr donc g libgd.a  et libgd.so dans /usr/lib et gd.h et les autres dans /usr/include
 
si je mets --with-gd=/usr j'ai ce ki est note ds le 1er post
 
si je mets --with-gd=/usr/lib ou --with-gd-dir=/usr/lib j'obtiens ceci :
checking for GD support... no
 


---------------
Nicoolem - nicoolem.online.fr
n°187796
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 14:27:15  profilanswer
 

nicoolem a écrit a écrit :

j'ai installé Gd ds /usr donc g libgd.a  et libgd.so dans /usr/lib et gd.h et les autres dans /usr/include
 
si je mets --with-gd=/usr j'ai ce ki est note ds le 1er post
 
si je mets --with-gd=/usr/lib ou --with-gd-dir=/usr/lib j'obtiens ceci :
checking for GD support... no
 
 




 
ds le premier post, ya /usr/local, pas /usr...
 
ta installer gd correctemetn? ca vient peut etre de lui
 
sinon t sur kel distrib?


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."
n°187803
Nicoolem
Posté le 12-11-2002 à 14:40:07  profilanswer
 

oui j'ai vu je me suis gouré sur le 1er post je suis bien ds /usr
 
je suis sur une redhat 7.3
 
pour installer gd  
j'installe d'abord jpeg-6b, libpng et zlib
puis
g fais tar xvfz gd-2.0.4.tar
cd gd-2.0.4  
./configure --prefix /usr
make
make install
 
voila mais la je pige plus rien  :??:  :(  


---------------
Nicoolem - nicoolem.online.fr
n°187804
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 14:41:57  profilanswer
 

nicoolem a écrit a écrit :

oui j'ai vu je me suis gouré sur le 1er post je suis bien ds /usr
 
je suis sur une redhat 7.3
 
pour installer gd  
j'installe d'abord jpeg-6b, libpng et zlib
puis
g fais tar xvfz gd-2.0.4.tar
cd gd-2.0.4  
./configure --prefix /usr
make
make install
 
voila mais la je pige plus rien  :??:  :(  
 




 
yavait pas une ou deux otres options sympa ds ./configure de gd? ta fait un ./configure --help pour voir?
 
tu utilise koi kom man pour essayer de l'installer?


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."
n°187819
Nicoolem
Posté le 12-11-2002 à 14:49:56  profilanswer
 

Nan c la seule option :
 ./configure --help
Usage: ./configure [--prefix /usr|/usr/local|et cetera]
 
ben le probleme ce que j'ai rien trouvé comme manuel d'install de php + gd2, pour gd y a le site meme de gd mais pour php partout je vois "Sous Linux, pas de problème, il suffit de télécharger la librairie, puis de compiler PHP avec le support de cette librairie (--with-gd)." Et crois moi c bien la premiere chose ke k'ai fais !!! mais bien sur ca ne marche pas


---------------
Nicoolem - nicoolem.online.fr
n°187823
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 14:53:06  profilanswer
 

nicoolem a écrit a écrit :

Nan c la seule option :
 ./configure --help
Usage: ./configure [--prefix /usr|/usr/local|et cetera]
 
ben le probleme ce que j'ai rien trouvé comme manuel d'install de php + gd2, pour gd y a le site meme de gd mais pour php partout je vois "Sous Linux, pas de problème, il suffit de télécharger la librairie, puis de compiler PHP avec le support de cette librairie (--with-gd)." Et crois moi c bien la premiere chose ke k'ai fais !!! mais bien sur ca ne marche pas  




 
et le INSTALL de gd et de php y dit rien?


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."
mood
Publicité
Posté le 12-11-2002 à 14:53:06  profilanswer
 

n°187833
Nicoolem
Posté le 12-11-2002 à 15:02:48  profilanswer
 

bon alors voila je viens d'ouvrir le fichier install de php et voila ce ke je vois des le debut  
2:  If you are recompiling PHP to add new extensions or upgrading
    something like GD, remove the config.cache file before you re-run  
    configure.
 
donc je supprime le fichier et je relance mon configure et la g bien les fonctions gd ki se mettent en yes dont celles ke j'avais besoin:
checking for gdImageCreateFromJpeg in -lgd... yes
checking for gdImageCreateTrueColor in -lgd... yes
 
je fais mon make et make install de php et je teste ca mais ca m'a l'air tres bien parti !!
 
 :jap:  Merci bcp de tes conseils et now je lirais les fichiers install avant de chercher sur des sites ki m'embrouillent ;)


---------------
Nicoolem - nicoolem.online.fr
n°187837
leirn
A.D.I.D.A.S.
Posté le 12-11-2002 à 15:06:14  profilanswer
 

nicoolem a écrit a écrit :

bon alors voila je viens d'ouvrir le fichier install de php et voila ce ke je vois des le debut  
2:  If you are recompiling PHP to add new extensions or upgrading
    something like GD, remove the config.cache file before you re-run  
    configure.
 
donc je supprime le fichier et je relance mon configure et la g bien les fonctions gd ki se mettent en yes dont celles ke j'avais besoin:
checking for gdImageCreateFromJpeg in -lgd... yes
checking for gdImageCreateTrueColor in -lgd... yes
 
je fais mon make et make install de php et je teste ca mais ca m'a l'air tres bien parti !!
 
 :jap:  Merci bcp de tes conseils et now je lirais les fichiers install avant de chercher sur des sites ki m'embrouillent ;)  




 
tjs faire README + INSTALL + ./configure --help avant de tenter koi ke ca soit d'autre
si ca merde tjs,alors on commence a chercher plus loin ;) (la doc fourni ailleurs ds le tar par exmeple ;)


---------------
"Je brandirai une épée d'orichalque, je m'assouvirai sur des Templiers." | "Avec dans son sillage l'Ombre du Diable, Leirn appelait les morts pour une danse macabre et déchainaît les horreurs de la nuit..."

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs

  Probleme: Installation Gd-2.0.4 avec php-4.2.3

 

Sujets relatifs
[DEBIAN] Installation depuis D7 + reseau/internet[XFree86] problème au delà de 640*480
[deb] probleme install de carte réseau !![linux] MODEM : PROBLEME DE NUMEROS BLACKLISTED (résolu)
Problème de paramètrage i810 avec Xfree86 4[debian] installation des driver Kyro II
Probleme avec gmplayer ss mdk 9 (résolu)installation raid 1 et pertes de données
installation de serveur d'impressionLéger Problème smbmount
Plus de sujets relatifs à : Probleme: Installation Gd-2.0.4 avec php-4.2.3


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR