Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
3285 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Compiler Digikam sous Mandrake

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Compiler Digikam sous Mandrake

n°454040
leneveu
Posté le 12-04-2004 à 22:23:14  profilanswer
 

J'essaye d'installer Digikam3 sous Linux
 
Pour ça j'utilise cela :
 

Citation :

Dependencies :
-----------------------------------------------------------------------
 
AutoConf >= 2.5
AutoMake >= 1.7.0
KDE 3.x
gphoto2 2.x
imlib1 >= 1.90
libexif >= 0.5.7
 
Installation :
------------------------------------------------------------------------
In the source directory do :
 
1) export WANT_AUTOCONF_2_5=1
2) export KDEDIR=KDE_installation_dir_on_your_system
3) make -f Makefile.cvs
4) ./configure
5) make
6) su
7) make install


 
Tout ce passe bien jusqu'au 4/ où le ./configure échoue...  :(  
Apparemment cela vient de l'absence de lien vers un compiler C dans $PATH :

Citation :

$ ./configure
checking build system type... i686-pc-linux-gnuoldld
checking host system type... i686-pc-linux-gnuoldld
checking target system type... i686-pc-linux-gnuoldld
checking for a BSD-compatible install... /usr//bin/install -c
checking for -p flag to install... yes
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.


 
Débutant qq peu sous Linux, je me trouve coincé car je ne sais pas comment résoudre ce problème de lien...
 
Si qq peut m'aider ?
 
Merci d'avance
 
@+

mood
Publicité
Posté le 12-04-2004 à 22:23:14  profilanswer
 

n°454042
j_c_p
Linux user
Posté le 12-04-2004 à 22:23:46  profilanswer
 

:D urpmi gcc :)

n°454071
leneveu
Posté le 12-04-2004 à 22:34:33  profilanswer
 

j_c_p a écrit :

:D urpmi gcc :)

A y est c'est fait ! Merci !
 
Mais j'ai un autre souci maintenant...  :(  
 
Ca compile jusqu'à cette erreur :

Citation :

checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!


 
Que faire ?


Message édité par leneveu le 12-04-2004 à 22:35:04
n°454073
Mjules
Modérateur
Parle dans le vide
Posté le 12-04-2004 à 22:37:14  profilanswer
 

urpmi XFree86-devel


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454078
leneveu
Posté le 12-04-2004 à 22:39:33  profilanswer
 

Mjules a écrit :

urpmi XFree86-devel

Merci  :jap:  
Mais vous aller rire mais j'ai une nouvelle erreur ! Ouin !  :(  
Je vais pas lacher !
 

Citation :

checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


 
?  :(

n°454084
Mjules
Modérateur
Parle dans le vide
Posté le 12-04-2004 à 22:40:34  profilanswer
 

et puis pour simplifier,  
urpmi digikam  (source contrib)


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454086
Mjules
Modérateur
Parle dans le vide
Posté le 12-04-2004 à 22:41:40  profilanswer
 

leneveu a écrit :

Merci  :jap:  
Mais vous aller rire mais j'ai une nouvelle erreur ! Ouin !  :(  
Je vais pas lacher !
 

Citation :

checking for libjpeg... no
configure: WARNING: libjpeg not found. disable JPEG support.
checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


 
?  :(  


urpmi libqt3-devel  
 
pour faire simple, quand tu veux compiler, il te faut les -devel qui vont bien


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454094
leneveu
Posté le 12-04-2004 à 22:44:55  profilanswer
 

Mjules a écrit :

et puis pour simplifier,  
urpmi digikam  (source contrib)

Merci Mjules mais ma source Contrib ne semble pas à jour...
 

Citation :

# urpmi digikam
Le medium « contrib » utilise un fichier de liste invalide :
  le site mirroir n'est probablement pas à jour. Essai d'une méthode alternative en cours...
 
    ftp://ftp.univ-savoie.fr/pub/Linu [...] k.i586.rpm
L'installation a échoué, il manque des fichiers :
    ftp://ftp.univ-savoie.fr/pub/Linu [...] k.i586.rpm
Vous devriez mettre à jour votre base de données urpmi


 
Je n'arrive plus à accéder à EasyURPMI pour reconfigurer contrib....

n°454102
Mjules
Modérateur
Parle dans le vide
Posté le 12-04-2004 à 22:46:53  profilanswer
 

les mirroirs ont changés de structure, un des rares déjà à jour est proxad
ça devrait s'améliorer d'ici quelques jours et il faudra refaire tes sources.
 
en attendant, tu trouveras les paquets ici :
 
ftp://ftp.proxad.net/pub/Distribu [...] trib/i586/


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454112
leneveu
Posté le 12-04-2004 à 22:55:48  profilanswer
 

Merci MJules pour les infos mais j'essaye de persévérer dans la compilation pour "apprendre"...
 
./configure est terminé maintenant
MAIS le 5/ Make ne fonctionne pas  :??:  
 

Citation :

# make
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.

mood
Publicité
Posté le 12-04-2004 à 22:55:48  profilanswer
 

n°454117
Mjules
Modérateur
Parle dans le vide
Posté le 12-04-2004 à 22:59:29  profilanswer
 

ok, si tu veux vraiment compiler, alors au moins, utilise checkinstall ; il faut l'installer et il s'utilise en lieu et place de la commande make install ; ça va permettre de créer un paquet RPM à partir de ton install et ainsi de pouvoir le désinstaller par la suite (parce que sinon, c'est beaucoup plus difficile)
 
pour ton pb de make, le configure n'a pas du passer correctement


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454118
leneveu
Posté le 12-04-2004 à 23:02:09  profilanswer
 

Mjules a écrit :


pour ton pb de make, le configure n'a pas du passer correctement

Oui tu as raison (je n'avais pas besoin de préciser d'ailleurs !)
 

Citation :

./configure: line 25325: syntax error near unexpected token `LIBEXIF,'
./configure: line 25325: `PKG_CHECK_MODULES(LIBEXIF, libexif >= 0.5.7)'


 
?
 
Ps : Merci pour ton aide  :jap:

n°454123
leneveu
Posté le 12-04-2004 à 23:08:31  profilanswer
 

Apparemment c'est mon package libexif qui devrait être >= à 0.5.7
Or la dernière version téléchargeable de libexif est la 0.5.12 !
Comprends rien !  :??:

n°454198
leneveu
Posté le 13-04-2004 à 06:55:39  profilanswer
 

Quelqu'un aurait une idée ?  :??:

n°454202
Taz
bisounours-codeur
Posté le 13-04-2004 à 08:01:47  profilanswer
 

oui : laisse tomber ... comment tu veux compiler si t'es pas si tu sais pas qu'il te faut un compilateur ?

n°454252
leneveu
Posté le 13-04-2004 à 10:33:47  profilanswer
 

Taz a écrit :

oui : laisse tomber ... comment tu veux compiler si t'es pas si tu sais pas qu'il te faut un compilateur ?

Euh c'est un trait d'humour ?  :heink:  
Merci mais je sais qu'il faut un compilateur pour compiler...  :pt1cable:  
Maintenant tout le monde ne reconnait pas les messages d'erreur de la console...
Tu trouves ça encourageant comme réponse ?
"Va y laisse tomber t'es un gros boulet..."
Je suis là pour apprendre et je le revendique !  :kaola:  
Ce genre de réflexion est vraiment trop présent sur les forums, c'est regrettable...

n°454261
Mjules
Modérateur
Parle dans le vide
Posté le 13-04-2004 à 10:42:14  profilanswer
 

tu as bien installé libexif9-devel ?
 
vu le message, je pense que c'est une erreur dans le fichier configure. et là, à part essayer un autre paquet ou modifier ce fichier (mais comment ?) je vois pas de solutions


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454270
leneveu
Posté le 13-04-2004 à 10:54:46  profilanswer
 

Mjules a écrit :

tu as bien installé libexif9-devel ?
 
vu le message, je pense que c'est une erreur dans le fichier configure. et là, à part essayer un autre paquet ou modifier ce fichier (mais comment ?) je vois pas de solutions
 

Merci MJules pour ton aide précieuse !  :jap:  :jap:  
libexif9-devel est installé...
 
Bon je vais installer en utilisant les rpm alors...
J'essayerai de comprendre le processus une autre fois...
Effectivement s'il y a un soucis dans le configur !
 
J'ai trouvé ce lien pour la dernière version 0.6.1 en rpm

n°454275
Mjules
Modérateur
Parle dans le vide
Posté le 13-04-2004 à 11:08:40  profilanswer
 

ça a l'air d'être bon


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454276
leneveu
Posté le 13-04-2004 à 11:09:23  profilanswer
 

Bon avec les rpm ça prend 10 secondes...
Ca marche impec maintenant !
Génial à ce propos ce soft ! Je le recommande à tous les possesseurs d'APN  :D  
Pour info reconnait sans pb un CANON Powershot Pro 90 IS
 
Merci à ceux qui m'ont aidés !  :jap:  
 
@+

n°454278
Mjules
Modérateur
Parle dans le vide
Posté le 13-04-2004 à 11:14:32  profilanswer
 

leneveu a écrit :

Bon avec les rpm ça prend 10 secondes...
Ca marche impec maintenant !
Génial à ce propos ce soft ! Je le recommande à tous les possesseurs d'APN  :D  
Pour info reconnait sans pb un CANON Powershot Pro 90 IS
 
Merci à ceux qui m'ont aidés !  :jap:  
 
@+


tu vois ;)
 
en fait digikam est une interface graphique à un soft + généraliste qui s'appelle Gphoto2 ; c'est Gphoto2 qui s'occupe de la reco des APN.


---------------
Celui qui pose une question est idiot 5 minutes. Celui qui n'en pose pas le reste toute sa vie. |  Membre du grand complot pharmaceutico-médico-scientifico-judéo-maçonnique.
n°454279
leneveu
Posté le 13-04-2004 à 11:16:02  profilanswer
 

Mjules > Merci pour la précision !

mood
Publicité
Posté le   profilanswer
 


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Compiler Digikam sous Mandrake

 

Sujets relatifs
Mandrake 10.0 qui ne s'arrète pas !....Et pas de son non plus :(Cherche lien pour Mandrake 9.2 ;)
URGENT: Gros pb de boot de Windows apres install mandrake 10.0Mandrake 10 et Xp ... sujet usé ?
pb install mandrake 10 sur nouvelle machine ...[Mandrake] Logiciel pour discuter oralement sur internet
[Mandrake 9.2] Mozilla (encore ...)[Mandrake 9.2] Erreurs bizzares [Résolu]
[Mandrake 9.2] Rajouter des alias [Résolu]kdbg et mandrake 10: ca marceh chez vous?
Plus de sujets relatifs à : Compiler Digikam sous Mandrake


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR