Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1014 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [ubuntu 16.04 LTS] apt-get update erreur 404

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[ubuntu 16.04 LTS] apt-get update erreur 404

n°1430100
xilebo
noone
Posté le 18-02-2019 à 09:38:21  profilanswer
 

Bonjour,
 
Je recontre une difficulté avec un portable sur lequel j'avais installé une ubuntu 16.04. Je ne me sers pas souvent de ce portable, donc il n'est pas souvent à jour, mais je n'ai pas installé de package exotique ou quoi que ce soit, je me suis contenté d'installer des logiciels provenant des dépots standard ( hormis atom que je viens d'installer directement depuis le .deb ).
 
Lorsque je fais un apt-get update, j'ai quelques erreurs, dont des liens 404
 


root@fmr-be:/etc/apt# apt-get update
Réception de:1 file:/var/cuda-repo-8-0-local  InRelease
Ign:1 file:/var/cuda-repo-8-0-local  InRelease
Réception de:2 file:/var/libopencv4tegra-repo  InRelease
Ign:2 file:/var/libopencv4tegra-repo  InRelease
Réception de:3 file:/var/visionworks-repo  InRelease
Ign:3 file:/var/visionworks-repo  InRelease
Réception de:4 file:/var/visionworks-sfm-repo  InRelease
Ign:4 file:/var/visionworks-sfm-repo  InRelease
Réception de:5 file:/var/visionworks-tracking-repo  InRelease
Ign:5 file:/var/visionworks-tracking-repo  InRelease
Réception de:6 file:/var/cuda-repo-8-0-local  Release [574 B]
Réception de:7 file:/var/libopencv4tegra-repo  Release [347 B]
Réception de:8 file:/var/visionworks-repo  Release [1 999 B]                                                                                  
Réception de:9 file:/var/visionworks-sfm-repo  Release [2 003 B]                                                                              
Réception de:6 file:/var/cuda-repo-8-0-local  Release [574 B]                                                                                  
Réception de:10 file:/var/visionworks-tracking-repo  Release [2 008 B]                                                                        
Réception de:7 file:/var/libopencv4tegra-repo  Release [347 B]                                                                                
Réception de:8 file:/var/visionworks-repo  Release [1 999 B]                                                                                  
Réception de:9 file:/var/visionworks-sfm-repo  Release [2 003 B]                                                                              
Réception de:10 file:/var/visionworks-tracking-repo  Release [2 008 B]                                                                        
Réception de:11 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]                                                          
Atteint:12 http://fr.archive.ubuntu.com/ubuntu xenial InRelease                                                                                
Ign:13 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                  
Atteint:15 http://linux.teamviewer.com/deb stable InRelease                                                                                    
Atteint:18 http://dl.google.com/linux/chrome/deb stable Release                                                                  
Réception de:14 http://fr.archive.ubuntu.com/ubuntu xenial-updates InRelease [109 kB]          
Réception de:17 http://fr.archive.ubuntu.com/ubuntu xenial-backports InRelease [107 kB]          
Ign:24 http://fr.archive.ubuntu.com/ubuntu xenial/main arm64 Packages                            
Ign:25 http://fr.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages
Ign:26 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages
Réception de:27 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [614 kB]
Ign:24 http://fr.archive.ubuntu.com/ubuntu xenial/main arm64 Packages                                                    
Ign:25 http://fr.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages                                                
Ign:26 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages                                              
Ign:24 http://fr.archive.ubuntu.com/ubuntu xenial/main arm64 Packages                                                    
Ign:25 http://fr.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages                                                
Réception de:28 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [517 kB]
Ign:29 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages            
Réception de:30 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [254 kB]                            
Réception de:31 http://security.ubuntu.com/ubuntu xenial-security/main amd64 DEP-11 Metadata [67,8 kB]                        
Réception de:32 http://security.ubuntu.com/ubuntu xenial-security/main DEP-11 64x64 Icons [67,1 kB]                                
Réception de:33 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [7 204 B]                        
Réception de:34 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [7 224 B]                      
Réception de:35 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2 152 B]                    
Réception de:36 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [425 kB]                        
Réception de:37 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [370 kB]                        
Réception de:38 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [912 kB]                          
Réception de:39 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [800 kB]                            
Ign:40 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages                  
Ign:41 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages                
Réception de:42 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main Translation-en [368 kB]
Réception de:43 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [170 kB]  
Réception de:44 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 DEP-11 Metadata [116 kB]
Réception de:45 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main amd64 DEP-11 Metadata [318 kB]
Réception de:46 http://security.ubuntu.com/ubuntu xenial-security/universe DEP-11 64x64 Icons [173 kB]
Réception de:47 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [5 600 B]
Réception de:48 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [5 764 B]
Ign:49 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages              
Réception de:50 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [2 676 B]
Réception de:51 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 DEP-11 Metadata [2 464 B]
Réception de:52 http://security.ubuntu.com/ubuntu xenial-security/multiverse DEP-11 64x64 Icons [2 638 B]
Réception de:53 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main DEP-11 64x64 Icons [228 kB]
Réception de:54 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 Packages [7 556 B]
Réception de:55 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted i386 Packages [7 524 B]
Réception de:56 http://fr.archive.ubuntu.com/ubuntu xenial-updates/restricted Translation-en [2 272 B]
Ign:29 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages                    
Réception de:57 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages [728 kB]
Ign:41 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages                
Ign:49 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages              
Réception de:58 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages [666 kB]
Ign:59 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages              
Réception de:60 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe Translation-en [301 kB]
Réception de:61 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 DEP-11 Metadata [252 kB]
Ign:29 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages                          
Ign:41 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages                
Réception de:62 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe DEP-11 64x64 Icons [350 kB]
Réception de:63 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 Packages [16,6 kB]
Réception de:64 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse i386 Packages [15,8 kB]
Ign:65 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages              
Réception de:66 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse Translation-en [8 440 B]
Ign:49 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages                    
Err:29 http://security.ubuntu.com/ubuntu xenial-security/main arm64 Packages                    
  404  Not Found [IP : 91.189.88.152 80]
Réception de:67 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse amd64 DEP-11 Metadata [5 964 B]
Réception de:68 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse DEP-11 64x64 Icons [14,3 kB]
Ign:26 http://fr.archive.ubuntu.com/ubuntu xenial/multiverse arm64 Packages                        
Err:24 http://fr.archive.ubuntu.com/ubuntu xenial/main arm64 Packages
  404  Not Found [IP : 194.158.119.186 80]
Ign:25 http://fr.archive.ubuntu.com/ubuntu xenial/universe arm64 Packages                      
Réception de:69 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 Packages [7 280 B]
Réception de:70 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main i386 Packages [7 288 B]
Ign:71 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages                
Réception de:72 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main Translation-en [4 456 B]
Réception de:73 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main amd64 DEP-11 Metadata [3 328 B]
Réception de:74 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 Packages [7 804 B]  
Réception de:75 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe i386 Packages [7 488 B]
Ign:76 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages              
Réception de:77 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe Translation-en [4 184 B]
Réception de:78 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe amd64 DEP-11 Metadata [5 104 B]
Réception de:79 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe DEP-11 64x64 Icons [1 789 B]
Ign:40 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages                      
Ign:59 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages              
Ign:65 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages            
Ign:41 http://security.ubuntu.com/ubuntu xenial-security/universe arm64 Packages                
Ign:49 http://security.ubuntu.com/ubuntu xenial-security/multiverse arm64 Packages
Ign:71 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:76 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Ign:40 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
Ign:59 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:65 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Ign:71 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
Ign:76 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
Err:40 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main arm64 Packages
  404  Not Found [IP : 194.158.119.186 80]
Ign:59 http://fr.archive.ubuntu.com/ubuntu xenial-updates/universe arm64 Packages
Ign:65 http://fr.archive.ubuntu.com/ubuntu xenial-updates/multiverse arm64 Packages
Err:71 http://fr.archive.ubuntu.com/ubuntu xenial-backports/main arm64 Packages
  404  Not Found [IP : 194.158.119.186 80]
Ign:76 http://fr.archive.ubuntu.com/ubuntu xenial-backports/universe arm64 Packages
325 ko réceptionnés en 1s (264 ko/s)                          
Lecture des listes de paquets... Fait
W: Entrée « Date » non valable dans le fichier Release /var/lib/apt/lists/_var_libopencv4tegra-repo_Release
N: Skipping acquire of configured file 'main/binary-arm64/Packages' as repository 'http://linux.teamviewer.com/deb stable InRelease' doesn't support architecture 'arm64'
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://security.ubuntu.com/ubuntu/dists/xenial-security/main/binary-arm64/Packages  404  Not Found [IP : 91.189.88.152 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/xenial-updates/main/binary-arm64/Packages  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/xenial-backports/main/binary-arm64/Packages  404  Not Found [IP : 194.158.119.186 80]
E: Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.
root@fmr-be:/etc/apt#  


 
Donc forcément quand je veux installer apache2 , j'ai le message d'erreur suivant, puisque le système utile une version précédente du package, pointant vers une vieille version du package apache qui n'existe plus :
 


root@fmr-be:/etc/apt# apt-get install apache2
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances        
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-4.8.0-36 linux-headers-4.8.0-36-generic linux-image-4.8.0-36-generic linux-image-extra-4.8.0-36-generic
Veuillez utiliser « apt autoremove » pour les supprimer.
The following additional packages will be installed:
  apache2-bin apache2-data apache2-utils libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.1-0
Paquets suggérés :
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom
Les NOUVEAUX paquets suivants seront installés :
  apache2 apache2-bin apache2-data apache2-utils libaprutil1-dbd-sqlite3 libaprutil1-ldap liblua5.1-0
0 mis à jour, 7 nouvellement installés, 0 à enlever et 83 non mis à jour.
Il est nécessaire de prendre 1 256 ko/1 378 ko dans les archives.
Après cette opération, 5 881 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2-bin amd64 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
Ign:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2-utils amd64 2.4.18-2ubuntu3.2
Ign:3 http://fr.archive.ubuntu.com/ubuntu xenial-updates/main i386 apache2-data all 2.4.18-2ubuntu3.2
Ign:4 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2 amd64 2.4.18-2ubuntu3.2
Ign:3 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2-data all 2.4.18-2ubuntu3.2
Err:1 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2-bin amd64 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
Err:2 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2-utils amd64 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
Err:4 http://security.ubuntu.com/ubuntu xenial-security/main amd64 apache2 amd64 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
Err:3 http://security.ubuntu.com/ubuntu xenial-security/main i386 apache2-data all 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
Err:3 http://security.ubuntu.com/ubuntu xenial-security/main i386 apache2-data all 2.4.18-2ubuntu3.2
  404  Not Found [IP : 194.158.119.186 80]
E: Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-bin_2.4.18-2ubuntu3.2_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
 
E: Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-utils_2.4.18-2ubuntu3.2_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
 
E: Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/a/apache2/apache2-data_2.4.18-2ubuntu3.2_all.deb  404  Not Found [IP : 194.158.119.186 80]
 
E: Impossible de récupérer http://security.ubuntu.com/ubuntu/pool/main/a/apache2/apache2_2.4.18-2ubuntu3.2_amd64.deb  404  Not Found [IP : 194.158.119.186 80]
 
E: Impossible de récupérer certaines archives, peut-être devrez-vous lancer apt-get update ou essayer avec --fix-missing ?
root@fmr-be:/etc/apt#  


 
Sachant que si je vais sur le lien : http://security.ubuntu.com/ubuntu/pool/main/a/apache2/
 
je n'ai que la version apache2 2.4.18 ... .3.8. ou 3.9 et non plus 3.2 ce qui explique pourquoi j'ai une erreur 404.
 
Sauf que je n'arrive pas à résoudre ce problème d'apt-get update qui échoue. Je ne sais pas si le fichier sources.list est correct ou pas ( je ne sais pas où se trouve la source officielle d'un fichier valide et à jour ), et le répertoire sources.list.d contient quelques dépots spécifiques de logiciels qui se sont ajoutés automatiquement lors d'installations précédentes :  
 

root@fmr-be:/etc/apt/sources.list.d# ls
cuda-8-0-local.list  libopencv4tegra-repo.list  visionworks-repo.list      visionworks-tracking-repo.list
google-chrome.list   teamviewer.list            visionworks-sfm-repo.list


 
Savez-vous comment je peux résoudre le problème ?
 
Merci de votre aide  :jap:  

mood
Publicité
Posté le 18-02-2019 à 09:38:21  profilanswer
 

n°1430107
Trit'
Posté le 18-02-2019 à 11:12:58  profilanswer
 

Faudrait peut-être penser à mettre à jour, non ? Ça a beau être une version LTS prise en charge pendant 5 ans avec encore deux ans devant lui, Ubuntu 16.04, c’est un peu vieux, maintenant…
 
De plus, as-tu vérifié l’état des miroirs que tu utilises ? Ils sont peut-être simplement morts, depuis…
 
Enfin, « apt-get » est déprécié : il faut juste utiliser « apt » tout court, maintenant.

n°1430108
majax2011
Posté le 18-02-2019 à 11:21:04  profilanswer
 

Bonjour,
dans synaptic: Configuration->Dépôts
doit permettre de résoudre le problème (j'ai une Mint, mais ça doit être pareil . . .)

n°1430109
xilebo
noone
Posté le 18-02-2019 à 11:37:12  profilanswer
 

Trit' a écrit :

Faudrait peut-être penser à mettre à jour, non ? Ça a beau être une version LTS prise en charge pendant 5 ans avec encore deux ans devant lui, Ubuntu 16.04, c’est un peu vieux, maintenant…
 
De plus, as-tu vérifié l’état des miroirs que tu utilises ? Ils sont peut-être simplement morts, depuis…
 
Enfin, « apt-get » est déprécié : il faut juste utiliser « apt » tout court, maintenant.


 
donc tu me conseilles de mettre à jour une machine dont je ne me sers pas souvent, qui est censée être encore valable point de vue support OS pendant encore au moins 2 ans ? Je ne comprends pas trop la logique. JE ne vais pas me retaper une install juste parce que je ne peux pas installer apache2 sur ma machine ( apt-get dist-upgrade je préfère éviter vu les déboires que j'ai eu par le passé ).
 
edit : merci pour le apt-get déprécié, j'utiliserai désormais apt.
 
L'état des miroirs, je n'en sais rien mais quand je lis cette ligne :
 

E: Impossible de récupérer http://fr.archive.ubuntu.com/ubuntu/dists/xenial/main/binary-arm64/Packages  404  Not Found [IP : 194.158.119.186 80]


 
que signifie-t-elle concrètement car l'url http://fr.archive.ubuntu.com/ubunt [...] ary-arm64/ répond bien, et j'ai bien une liste de paquets, mais le suffixe Packages n'existe pas ...
 
 
blablabla , en fait non ca répond pas, en copiant le lien, je m'apercois que ce n'est pas du amd64 mais arm64, qu'est ce que arm vient foutre là ? je suis sur une machine intel.
 
Comment ca a pu changer en arm64, je ne me rappelle pas avoir changé quoi que ce soit ?
 
Edit : bon, je m'apercois qu'en fait, lorsqu'on fait un apt-get update ( ou apt update ) il met à jour plusieurs architectures, amd64 ( normal ), x86 ( pourquoi pas ), et arm64 ( je ne sais pas d'où ça vient ).  
Par contre, lorsque je demande à installer apache2, c'est bien dans l'architecture amd64 qu'il tente d'aller chercher le dépôt, sauf que ça échoue.
 
Je veux bien changer mes "sources" mais je ne sais pas où aller chercher l'information officielle pour avoir les liens à jour, je ne comprends pas pourquoi cette info est automatique, j'ai aucun moyen d'être prévenu, sauf à faire un apt update 6 mois plus tard qui échoue.


Message édité par xilebo le 18-02-2019 à 11:51:37
n°1430110
xilebo
noone
Posté le 18-02-2019 à 11:38:46  profilanswer
 

majax2011 a écrit :

Bonjour,
dans synaptic: Configuration->Dépôts
doit permettre de résoudre le problème (j'ai une Mint, mais ça doit être pareil . . .)


 
je n'ai pas synaptic, enfin je ne crois pas ( je travaille habituellement en console, je ne suis pas habitué à l'interface graphique ). J'ai "Logiciel et mise à jour" dans paramètres système, et tout a l'air correct. D'ailleurs je n'ai pas de notion de plateforme /architecture ( amd64 / arm64 / x86 / autre ) dans cette fenêtre.

n°1430114
majax2011
Posté le 18-02-2019 à 11:56:38  profilanswer
 

As-tu essayé sudo apt upgrade avant update.
(upgrade n'est pas dist-upgrade)

n°1430115
xilebo
noone
Posté le 18-02-2019 à 12:08:34  profilanswer
 

majax2011 a écrit :

As-tu essayé sudo apt upgrade avant update.
(upgrade n'est pas dist-upgrade)


 
non je n'ai pas essayé. Pour moi upgrade met à jour les paquets installés.  
 
Je vais essayer.

n°1430116
xilebo
noone
Posté le 18-02-2019 à 12:35:05  profilanswer
 

Bon, sans surprise, cela n'a rien donné.
 
Pour moi :  
 - apt upgrade met à jour les paquets déjà installés en fonction de la base apt actuellement sur la machine. Si un paquet est plus récent ( par rapport à la base locale et non par rapport au réel ), il le met à jour.
 - apt update met à jour la base de paquets en fonction des liens contenus dans /etc/apt/sources.list et sources.list.d/* .
 - mais que fait-on pour mettre à jour les liens ? Y a-t-il une procédure officielle ? Car si les liens sont morts, je ne sais pas où chercher pour avoir des nouveaux liens valides. Peut être via les outils graphiques ? je vais chercher de ce côté.

n°1430117
xilebo
noone
Posté le 18-02-2019 à 12:46:46  profilanswer
 

je viens de tenter le dist-upgrade ( via l'interface graphique ) suite à vos conseils, mais celle-ci échoue également, avec des messages d'erreur similaires :
 

E:Impossible de récupérer http://archive.ubuntu.com/ubuntu/dists/bionic/main/binary-arm64/Packages  404  Not Found [IP : 91.189.88.149 80], E:Impossible de récupérer http://archive.ubuntu.com/ubuntu/dists/bionic-updates/main/binary-arm64/Packages  404  Not Found [IP : 91.189.88.149 80], E:Impossible de récupérer http://archive.ubuntu.com/ubuntu/dists/bionic-backports/universe/binary-arm64/Packages  404  Not Found [IP : 91.189.88.149 80], E:Impossible de récupérer http://archive.ubuntu.com/ubuntu/dists/bionic-security/main/binary-arm64/Packages  404  Not Found [IP : 91.189.88.149 80], E:Le téléchargement de quelques fichiers d'index a échoué, ils ont été ignorés, ou les anciens ont été utilisés à la place.


 
on voit bien "bionic" et non plus "xenial", mais le système cherche toujours à accéder à des paquets ( arm en l'occurrence alors que je m'en fous ) et qui echouent.
 
Résultat, même l'upgrade de distribution est vérolée, pour une raison que j'ignore ( et c'est pas parce que j'ai bidouillé, je me sers de ce portable juste pour flasher des clés de firmware à base de dd, je voulais juste installer apache pour faire des tests ).
 
Je vais être obligé de réinstaller de 0, ce qui ne m'arrange pas :(
 
edit ( je suis accusé de flood , pfff ) :
 
quelques infos supplémentaires intéressantes ici : https://askubuntu.com/questions/917 [...] m64-in-apt
 
je vais désinstaller toutes les dépendances arm64 ( ca doit être le cross compiler que j'avais installé à l'origine de l'installation de cette machine pour étudier le tegra TX2 , mais abandonné depuis ).  
 
Je ne comprends cependant pas comment ça peut tout bloquer.
 
edit2 : j'avais raison :
 
Faced same issue while working with jetson-tx2 arm64. This manual refers the solution in advanced setup scenario It turns out you can't remove architecture without removing packages.
 
This is useful when a foreign architecture has been added, causing "404 Not Found" errors to appear when the repository meta-data is updated. For example, if you wanted to restrict a repository to only the amd64 and i386 architectures, it would look like:
 


Message édité par xilebo le 18-02-2019 à 12:52:08
n°1430120
xilebo
noone
Posté le 18-02-2019 à 14:56:45  profilanswer
 

Tout est rentré dans l'ordre à partir du moment où j'ai désinstallé les paquets arm64 du jetson tx2. J'ai enlevé l'architecture arm64, et j'ai pu faire un apt update, suivi d'un dist-upgrade.
 
Il est cependant dommage que le système de paquet ne remonte pas une erreur plus claire, notamment le fait d'ajouter une architecture supplémentaire foute la merde dans les différentes lignes du source.list pour lesquelles il essayait de récupérer chaque architecture.

mood
Publicité
Posté le 18-02-2019 à 14:56:45  profilanswer
 

n°1430128
majax2011
Posté le 18-02-2019 à 17:11:39  profilanswer
 

Merci pour le retour, ça peut toujours servir.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [ubuntu 16.04 LTS] apt-get update erreur 404

 

Sujets relatifs
Problème démarrage Ubuntu suite MàJ ZentyalServeur Ubuntu KVM + Kimchi VPS innaccessible en SSH de l'exterieur
probleme apres instalation de ubuntu 14.04Différence entre un ubuntow LTS et non
[Ubuntu] Comment installer quelque choseUbuntu sur x230, LID problem
[CentOS 7] Erreur de partage sambaCentos 7 - Erreur Grub suite virtu
[résolu] securité server web ubuntuMAJ de Ubuntu server 18.04TLS vers 18.04.1TLS
Plus de sujets relatifs à : [ubuntu 16.04 LTS] apt-get update erreur 404


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR