Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1162 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Ubuntu sur x230, LID problem

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Ubuntu sur x230, LID problem

n°1424639
tachion
Posté le 17-10-2018 à 12:13:56  profilanswer
 

Bonjour à tous.  
 
Je vous soumet mon problème du moment :
 
J'utilise un X230 sous linux ubuntu 18.04.1 LTS avec les dernières mises a jour.  
 
Tout fonctionne parfaitement bien, excepté le LID button. Lorsque je ferme l'écran, rien ne se passe.  
 
J'ai déjà été voir dans les stats de l'acpi, ce celui-ci donne le status "Open" tout le temps.
 

Code :
  1. cat /proc/acpi/button/lid/LID/state
  2. state:      open


 
J'ai été voir dans les paramètrs de systemd et décommenté les variables suivantes:
 

Code :
  1. HandleLidSwitch=suspend
  2. HandleLidSwitchDocked=suspend
  3. LidSwitchIgnoreInhibited=yes


 
le Lid Switch n'est pas dans la listes des inibit de systemd  
 

Code :
  1. systemd-inhibit --list         
  2.      Who: tachikomas (UID 1000/tachikomas, PID 2472/gsd-media-keys)
  3.     What: handle-power-key:handle-suspend-key:handle-hibernate-key
  4.      Why: GNOME handling keypresses
  5.     Mode: block
  6.      Who: tachikomas (UID 1000/tachikomas, PID 2472/gsd-media-keys)
  7.     What: sleep
  8.      Why: GNOME handling keypresses
  9.     Mode: delay
  10.      Who: gdm (UID 124/gdm, PID 1808/gsd-media-keys)
  11.     What: sleep
  12.      Why: GNOME handling keypresses
  13.     Mode: delay
  14.      Who: gdm (UID 124/gdm, PID 1813/gsd-power)
  15.     What: sleep
  16.      Why: GNOME needs to lock the screen
  17.     Mode: delay
  18.      Who: tachikomas (UID 1000/tachikomas, PID 2419/gsd-power)
  19.     What: sleep
  20.      Why: GNOME needs to lock the screen
  21.     Mode: delay
  22.      Who: UPower (UID 0/root, PID 1414/upowerd)
  23.     What: sleep
  24.      Why: Pause device polling
  25.     Mode: delay
  26.      Who: ModemManager (UID 0/root, PID 986/ModemManager)
  27.     What: sleep
  28.      Why: ModemManager needs to reset devices
  29.     Mode: delay
  30.      Who: GNOME Shell (UID 1000/tachikomas, PID 2323/gnome-shell)
  31.     What: sleep
  32.      Why: GNOME needs to lock the screen
  33.     Mode: delay
  34.      Who: gdm (UID 124/gdm, PID 1808/gsd-media-keys)
  35.     What: handle-power-key:handle-suspend-key:handle-hibernate-key
  36.      Why: GNOME handling keypresses
  37.     Mode: block
  38.      Who: NetworkManager (UID 0/root, PID 1223/NetworkManager)
  39.     What: sleep
  40.      Why: NetworkManager needs to turn off networks
  41.     Mode: delay
  42. 10 inhibitors listed.


 
J'ai testé avec W10, et ça fonctionne bien, donc j'ai écarté un problème hardware... mais pour le coup c'est un peu relou de toujours devoir le suspend a la main... une idée ?  
 
 
 
 

mood
Publicité
Posté le 17-10-2018 à 12:13:56  profilanswer
 

n°1449174
gunsman
La bonne affaire...
Posté le 15-05-2020 à 22:30:22  profilanswer
 

Dans gestionnaire d'alimentation tu as "couvercle du portable", il faut mettre "mettre en veille".
 
Par contre le pc se met en veille mais ne s'eteind pas comme sur windows 10.
 
Donc au bout de plusieurs heures tu n'as plus de batterrie.


---------------
La route n'est longue que si l'on regarde loin...
n°1449177
Trit'
Posté le 16-05-2020 à 00:24:31  profilanswer
 

Il a dû avoir sa réponse ou passer à autre chose, depuis un an et demi… :o


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  Ubuntu sur x230, LID problem

 

Sujets relatifs
[résolu] securité server web ubuntuMAJ de Ubuntu server 18.04TLS vers 18.04.1TLS
Dual boot Ubuntu/Win10 sur HP ElitebookPC neuf avec 1 SSD + 2 HDD ; W10 + Ubuntu
Installation Ubuntu : Asus hybride t100 transformerProblème décalage horloge Dual Boot Ubuntu/Windows 10
Tester Ubuntu en Live USB sur PC du boulotinstallation Ubuntu avec CM x470 et ryzen 5 2600
Installation Ubuntu : secure bootProblèm Ubuntu sur second HHD interne et Win 10 sur premier HDD intern
Plus de sujets relatifs à : Ubuntu sur x230, LID problem


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR