Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1805 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [résolu] probleme eth* debian : help svp

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[résolu] probleme eth* debian : help svp

n°1009254
Rocks
HTTP 418
Posté le 08-02-2008 à 08:11:14  profilanswer
 

Hello,
 
J'ai une machine sous debian etch. J'ai voulu lui ajouter une deuxième carte réseau pour des tests et je crois que j'ai fait une bêtise  :sweat:  
Juste après le boot, si je fais dmesg|grep eth, il me parle de eth0 et eth1 :


e100: eth0: e100_probe: addr 0xff100000, irq 10, MAC addr 00:D0:B7:23:51:6C
eth1: Digital DS21140 Tulip rev 18 at 0001dc00, 00:00:F8:30:16:79, IRQ 11.


 eth0 est une intel et eth1 une digital (je fais dans l'archéologie informatique  :D ).
Dans /etc/network/interfaces j'ai :


auto eth0
allow-hotplug eth0
iface eth0 inet static
 address 192.168.31.28
 netmask 255.255.255.0
 network 192.168.31.0
 broadcast 192.168.31.255
 gateway 192.168.31.254
 
auto eth1
allow-hotplug eth1
iface eth1 inet static
 address 192.168.35.245
 netmask 255.255.255.0
 network 192.168.35.0
 broadcast 192.168.35.255


La eth0 est reliée au routeur mais pas la eth1 qui est reliée directement via un câble croisé à une autre machine.
Si je fais /etc/init.d/networking restart, il me dit qu'il ne trouve pas eth0 (No such device) et il monte seulement eth1  :heink:  
Pire encore, si je refais un dmesg|grep eth, cette fois-ci j'ai :


e100: eth0: e100_probe: addr 0xff100000, irq 10, MAC addr 00:D0:B7:23:40:5B
eth1: Digital DS21140 Tulip rev 18 at 0001dc00, 00:00:F8:30:05:68, IRQ 11.
e100: eth1: e100_watchdog: link up, 100Mbps, full-duplex


La eth0 est devenue la eth1?  :heink:  
Je peux même faire un ifconfig eth2 up et là il me monte la Digital...
Bien évidemment, si après ça je fais un ifconfig, j'ai bien eth1 qui à les paramètres de eth0 dans /etc/network/interfaces et eth2 qui a ceux de eth1 du même fichier...
Alors je me suis dit qu'il suffisait de changer eth0 en eth1 et eth1 en eth2 dans /etc/network/interfaces. Certes, dans ce cas là /etc/init.d/networking restart est ok et la table de routage semble ok mais je n'ai pas de réseau... Je ping les cartes elles mêmes sans problème mais aucun ping à destination du routeur ne passe...
Alors là, je comprends plus rien et je sais vraiment pas quoi faire pour me dépatouiller  :(  donc toute aide sur le sujet serait vivement appréciée  ;)  
Merci.
 
a+


Message édité par Rocks le 08-02-2008 à 08:33:18
mood
Publicité
Posté le 08-02-2008 à 08:11:14  profilanswer
 

n°1009256
fighting_f​alcon
Posté le 08-02-2008 à 08:13:40  profilanswer
 

va jetter un oeil dans le fichier
/etc/udev/rules.d/z25_persistent-net.rules
 
;)
 
(c'est de la conf de udev, le fichier précise d'associer tel nom symbolique [ethX] à telle adresse MAC ...)

n°1009262
Rocks
HTTP 418
Posté le 08-02-2008 à 08:32:42  profilanswer
 

Yessssss, ça marche :wahoo:  
Merci fighting_falcon :jap:  Tu me sauves :)
J'y connais strictement rien à udev (noob inside  :whistle: ), tu aurais uns source d'information à consulter à me conseiller sur le sujet?
Merci, encore mille fois merci.
 
a+


---------------
J'ai cherché à chercher mais je n'ai rien pu trouver et pourtant, j'avais trouvé.
n°1033900
fighting_f​alcon
Posté le 16-04-2008 à 20:22:37  profilanswer
 

dsl pour le déterrage de topic, espérant que ma réponse sera considérée comme intéressante ...
 
a 1ère vue comme ça, je dirais GETA (google est ton ami, http://www.google.com/linux même) mais j'ai quand même ça dans mes bookmarks :
http://reactivated.net/writing_udev_rules.html


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Installation

  [résolu] probleme eth* debian : help svp

 

Sujets relatifs
[Résolu] [Apache 2] Délai d'attente dépasséhelp ecran noir mandriva apres commande numlockx
[OpenSuse] Problème de DNS[RESOLU][Dell] 5 partitions préinstallée , dual boot impossible ?
probleme connexion wifi mandriva[Debian] Carte réseau intégrée
Mon micro ne fonctionne pas dans Skype [Résolu]Debian Installation de Pilotes Propriétaire
[Résolu] pb partage nfsprobleme lancement mandriva one 2008
Plus de sujets relatifs à : [résolu] probleme eth* debian : help svp


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR