Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1768 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Résolu] [Apache 2] Délai d'attente dépassé

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] [Apache 2] Délai d'attente dépassé

n°1008944
Jotunheim
A.K.A. FenrirDarkWolf
Posté le 06-02-2008 à 20:10:11  profilanswer
 

Petit soucis de configuration Apache (du moins je pense) :
http://monserveur/joomla marche, puis, après une légère navigation, "délai d'attente dépassé" pour toutes les pages, même le bête phpinfo de test à la racine (qui marchait avant)
 
Par contre, sans rien toucher, mon https://monserveur/phpmyadmin marche parfaitement.
 
Pourquoi ?  :sweat:  
De plus, quand j'utilise l'IP plutot que le nom de domaine, rien ne marche correctement, même le phpmyadmin...
Donc je pense à un pb de config, mais je vois pas bien quoi...
 
EDIT : Après un certain temps d'inactivité, c'est reviendu pendant... 2 pages... puis rebelote...
Par contre, avec lynx ca passe si je fais http://localhost/monrep


Message édité par Jotunheim le 12-02-2008 à 09:49:37

---------------
Gestionnaire de persos (v4.3.1 du 31/01/21) pour Dark Heresy / Rogue Trader / DeathWatch / Black Crusade (JDR) + critique des romans Warhammer 40K
mood
Publicité
Posté le 06-02-2008 à 20:10:11  profilanswer
 

n°1009259
fighting_f​alcon
Posté le 08-02-2008 à 08:16:16  profilanswer
 

je vais aller voir o'gure et sa boule de cristal et je reviens te donner la solution ....  :fou:  :fou:  :fou:  :fou:  
 
 
 
poste nous ta conf, dis nous ta distrib, la version d'apache ....

n°1009303
Jotunheim
A.K.A. FenrirDarkWolf
Posté le 08-02-2008 à 10:46:00  profilanswer
 

Après vérification des logs, quand je demande les pages qui bloquent, j'ai tout un tas d'erreurs du type

 
Code :
  1. [Fri Feb 08 10:11:08 2008] [error] [client 193.55.xxx.xxx] File does not exist: /var/www/IntegraPlus, referer: http://monserveur/integra/index.ph [...] &Itemid=94
  2. [Fri Feb 08 10:11:08 2008] [error] [client 193.55.xxx.xxx] File does not exist: /var/www/IntegraPlus, referer: http://monserveur/integra/index.ph [...] &Itemid=94
 

Sachant que le repertoire /var/www/IntegraPlus n'existe effectivement pas (c'est un template modifié de Joomla effectué par quelqu'un d'autre, mais le problème n'est pas là). Que ca produise des erreurs, c'est pas le plus grave (la personne concernée corrigera), ce qui est genant c'est que ca bloque le site. J'ai testé de bouger le site sur un autre serveur, j'ai les mêmes erreurs dans les logs mais le site tourne nickel.

 

J'ai comparé les php.ini, rien de très intéressant, ainsi que les apache2.conf, rien de notable. Quand au fichier de conf des VirtualHosts, il est identique sur les 2 serveurs.

 

Aucun blocage quand je passe le repertoire dans la partie https !

 

Les serveurs sont tous les deux des debians avec apache2 (dernière version de la distro), php 4.4.4-8


Message édité par Jotunheim le 08-02-2008 à 10:47:41

---------------
Gestionnaire de persos (v4.3.1 du 31/01/21) pour Dark Heresy / Rogue Trader / DeathWatch / Black Crusade (JDR) + critique des romans Warhammer 40K
n°1009313
fighting_f​alcon
Posté le 08-02-2008 à 11:21:15  profilanswer
 

t'aurais pas une différence entre tes deux serveurs ?
-matériel
-un firewall sur l'un mais pas sur l'autre
-...

n°1009321
Jotunheim
A.K.A. FenrirDarkWolf
Posté le 08-02-2008 à 11:36:11  profilanswer
 

C'est pas exactement la même génération de Dell, mais je ne pense pas que ca vienne de là.
Pas de firewall.


---------------
Gestionnaire de persos (v4.3.1 du 31/01/21) pour Dark Heresy / Rogue Trader / DeathWatch / Black Crusade (JDR) + critique des romans Warhammer 40K
n°1009360
fighting_f​alcon
Posté le 08-02-2008 à 14:07:42  profilanswer
 

bah à ta place, j'irai carrément faire quelques captures réseau avec wireshark pour voir ce qu'il se passe, pourquoi des fois ton serveur ne répond pas ...

n°1009391
Jotunheim
A.K.A. FenrirDarkWolf
Posté le 08-02-2008 à 15:59:34  profilanswer
 

En faisant un filtrage sur l'IP et sur le port (80), je n'ai rien : la dernière trame est de ma machine vers le serveur avec www [FIN, ACK]
Pourtant, ma page affiche toujours "délai d'attente dépassé"

 

Ce qui me fait penser à un problème de config est que sur un autre site, les pages s'affichent mais le css est absolument pas pris en compte (et c'est pas un problème de droits). Je rajouterais que ce même site marche parfaitement sur un autre serveur.


Message édité par Jotunheim le 08-02-2008 à 16:07:19

---------------
Gestionnaire de persos (v4.3.1 du 31/01/21) pour Dark Heresy / Rogue Trader / DeathWatch / Black Crusade (JDR) + critique des romans Warhammer 40K
n°1010399
Jotunheim
A.K.A. FenrirDarkWolf
Posté le 12-02-2008 à 09:49:19  profilanswer
 

Après quelques recherches, j'ai trouvé d'où ca vient : c'est mon fail2ban qui banne mon IP car l'appli web génère trop d'erreurs... Si je le désactive, tout va bien...
 
Je vais donc immédiatement faire corriger l'appli (chose qui me parait essentielle de toute façon).
 
Merci de ton aide.


---------------
Gestionnaire de persos (v4.3.1 du 31/01/21) pour Dark Heresy / Rogue Trader / DeathWatch / Black Crusade (JDR) + critique des romans Warhammer 40K

Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Résolu] [Apache 2] Délai d'attente dépassé

 

Sujets relatifs
[RESOLU][Dell] 5 partitions préinstallée , dual boot impossible ?Mon micro ne fonctionne pas dans Skype [Résolu]
[Résolu] pb partage nfs[RESOLU] tunnel ssh et pare feu
[RESOLU] capacités serveur et charge dnsRecompilation Apache
[RESOLU]espace disque supérieur à 2to[Résolu] pb config reseau local
zabbix_serverproblème emerge qt-4.3.3 [Résolu] proc trop chaud instable
Plus de sujets relatifs à : [Résolu] [Apache 2] Délai d'attente dépassé


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR