Forum |  HardWare.fr | News | Articles | PC | Prix | S'identifier | S'inscrire | Shop Recherche
2020 connectés 

 


 

 Mot :   Pseudo :  
  Aller à la page :
 
 Page :   1  2  3  4  5  6  7  ..  98  99  100  101  102  103
Auteur Sujet :

[Topic Unique] Seagate Dockstar, le plug computer pas cher !

n°1230603
mirtouf
Light is right !
Posté le 31-07-2010 à 16:16:35  profilanswer
 

Reprise du message précédent :

./blparam
baudrate=115200
loads_echo=0
ipaddr=169.254.254.253
serverip=169.254.254.254
rootpath=/mnt/ARM_FS/
netmask=255.255.0.0
run_diag=yes
console=console=ttyS0,115200
CASset=min
MALLOC_len=1
ethprime=egiga0
bootargs_root=root=/dev/mtdblock2 ro
ethmtu=1500
usb0Mode=host
nandEcc=1bit
ethact=egiga0
ethaddr=00:10:75:1A:1E:5A
cesvcid=8ETEUA9H97NGHXJJXS9NESJKQ6
ceserialno=2GEP084F
ceboardver=REDSTONE:1.0
bootcmd_usb=nand read.e 0xc00000 0x2500000 0x40000; go 0xc00000
bootcmd1=setenv bootcmd run bootcmd2; saveenv; run bootcmd_usb
bootcmd2=setenv bootcmd run bootcmd1; saveenv; run bootcmd_original
bootcmd_original=nand read.e 0x800000 0x100000 0x300000; setenv bootargs $(console) $(bootargs_root); bootm 0x800000
stdin=serial
stdout=serial
stderr=serial
mainlineLinux=no
enaMonExt=no
enaCpuStream=no
enaWrAllo=no
pexMode=RC
disL2Cache=no
setL2CacheWT=yes
disL2Prefetch=yes
enaICPref=yes
enaDCPref=yes
sata_dma_mode=yes
netbsd_en=no
vxworks_en=no
bootdelay=3
disaMvPnp=no
bootcmd=run bootcmd2

 

uBoot modifié et Debian Lenny


Message édité par mirtouf le 31-07-2010 à 16:19:59

---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE
mood
Publicité
Posté le 31-07-2010 à 16:16:35  profilanswer
 

n°1230605
deK
watching for beerz on the wing
Posté le 31-07-2010 à 16:21:55  profilanswer
 

Et donc tu arrives à accéder à ton OS sur le dur après l'avoir débranché électriquement, c'est ça ?
 
Si oui, ça donne quoi un
 

# ./blparam 'bootcmd=run bootcmd1'
# reboot


 
?
 
Tes paramètres blparam sont identiques aux miens.


---------------
Feed HA/V          
n°1230610
deK
watching for beerz on the wing
Posté le 31-07-2010 à 19:13:05  profilanswer
 

[feature]
 
Le CPU du DS (Marvell Kirkwood) intègre des instructions visant à accélerer matériellement les algos de chiffrement (Marvell CESA).
Et c'est supporté par le kernel :  
 
 

cortex:~# cat /proc/crypto  
name         : cbc(aes)
driver       : mv-cbc-aes
module       : mv_cesa
priority     : 300
refcnt       : 1
selftest     : passed
type         : ablkcipher
async        : yes
blocksize    : 16
min keysize  : 16
max keysize  : 32
ivsize       : 16
geniv        : <default>
 
name         : ecb(aes)
driver       : mv-ecb-aes
module       : mv_cesa
priority     : 300
refcnt       : 1
selftest     : passed
type         : ablkcipher
async        : yes
blocksize    : 16
min keysize  : 16
max keysize  : 32
ivsize       : 0
geniv        : <default>
 
[...]


 
(par défaut sur Lenny)
 
Potentiellement bien sympa pour faire du VPN, du SSH intensif, etc.
 
Bon par contre je n'arrive pas à utiliser mv_cesa sur OpenSSL pour faire des benchs comparatifs (comme j'avais fait sur mon VIA avec PadLock)


---------------
Feed HA/V          
n°1230612
bohwaz
$bwz++
Posté le 31-07-2010 à 19:22:56  profilanswer
 

Ça existe les écrans LCD en USB auto-alimenté ? (petit évidemment, genre 5 ou 7" )


---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230613
deK
watching for beerz on the wing
Posté le 31-07-2010 à 19:24:33  profilanswer
 

Auto-alimenté pas sûr, mais oui il me semble que ça existe :jap:


---------------
Feed HA/V          
n°1230614
pixeye3300​0
Posté le 31-07-2010 à 19:31:17  profilanswer
 

bohwaz a écrit :

Ça existe les écrans LCD en USB auto-alimenté ? (petit évidemment, genre 5 ou 7" )

 

Oui j'en ai un d'ailleurs  :D (mais je suis trop une *** pour être foutu de m'en servir je pense)

 

voici celui que je possède : lilliput um-70 :)

 

et piste pour le faire fonctionner : http://ubuntuforums.org/showthread.php?t=1364207

 

et un "bon" prix : http://www.thinkgeek.com/computing/usb-gadgets/c609/


Message édité par pixeye33000 le 31-07-2010 à 19:34:19
n°1230615
bohwaz
$bwz++
Posté le 31-07-2010 à 19:31:33  profilanswer
 

Ah oui j'ai trouvé mais le moins cher est à 120$ quand même : http://www.mimomonitors.com/


---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230616
bohwaz
$bwz++
Posté le 31-07-2010 à 19:33:28  profilanswer
 

Ah ouais dans les même prix, enfin ça existe mais ça fait trop cher pour mon dockstar ^^


---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230618
pixeye3300​0
Posté le 31-07-2010 à 20:01:48  profilanswer
 

une bonne idée à creuser, pour nous tous plus tard : on finira tous plus ou moins à bricker nos dockstar
 
Il serait tip top que certains trouvent les méthodes pour revenir en config "originale".
 
ou ne serait-ce que par anticipation, genre pouvoir "cleaner" la bête avant de se lancer dans quelque chose d'autre.

n°1230621
ktalog
Posté le 31-07-2010 à 20:15:20  profilanswer
 

j'ai commandés 2 DockStar chez topachat et les 2 défectueux (la led qui clignote orange) ...
pour ceux qui ont fait la demande, il faut payer les frais de retour?

mood
Publicité
Posté le 31-07-2010 à 20:15:20  profilanswer
 

n°1230622
pixeye3300​0
Posté le 31-07-2010 à 20:16:54  profilanswer
 

ktalog a écrit :

j'ai commandés 2 DockStar chez topachat et les 2 défectueux (la led qui clignote orange) ...
pour ceux qui ont fait la demande, il faut payer les frais de retour?


 
non, on est censés recevoir un bon prépayé d'affranchissement  :D  
 
(censés : car j'attends toujours)

n°1230625
ktalog
Posté le 31-07-2010 à 20:25:07  profilanswer
 

ok merci, j'appellerait donc topachat dès lundi
en attendant j'ai quand même acheté un cable usb > serie pour 2$
ca pourra toujours servir

n°1230626
bohwaz
$bwz++
Posté le 31-07-2010 à 20:36:22  profilanswer
 

Perso elle clignotait orange la LED (topachat aussi) mais ça m'a pas empêché d'y accéder en SSH et de mettre debian...

Message cité 1 fois
Message édité par bohwaz le 31-07-2010 à 21:42:55

---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230627
azrael24
PàN, dans les dents !
Posté le 31-07-2010 à 20:38:51  profilanswer
 

bohwaz a écrit :

Perso elle clignotait orange la LED (topachat aussi) mais ça m'a empêché d'y accéder en SSH et de mettre debian...


 
Il manquerai pas une négation ?  [:urd] La mienne aussi clignotait orange au début et j'ai pu m'y connecter en ssh, apparemment c'est l'indication de boot sur pogoplug.

n°1230629
pixeye3300​0
Posté le 31-07-2010 à 20:42:26  profilanswer
 

perso, elle obtient pas d'ip donc à partir de ce moment là je vois pas comment m'en sortir :D

 

(et puis c'est l'exemplaire que je ne vais pas bidouiller, du moins dans un premier temps :D)

Message cité 1 fois
Message édité par pixeye33000 le 31-07-2010 à 20:45:03
n°1230631
mirtouf
Light is right !
Posté le 31-07-2010 à 20:59:43  profilanswer
 

Au fait on a une liste des noyaux disponibles pour ces plugs ?
Voir un lien pour les compiler ?


---------------
-~- Libérez Datoune ! -~- Camarade, toi aussi rejoins le FLD pour que la flamme de la Révolution ne s'éteigne pas ! -~- A VENDRE
n°1230634
pixeye3300​0
Posté le 31-07-2010 à 21:27:10  profilanswer
 

deK a écrit :

Et OpenWRT n'est pas qu'une distro pour routeur, elle est adaptée à l'embarqué de manière générale ;)

 

Sinon, pure awesomeness  [:cerveau sol]

 

http://ledek.free.fr/photos/hardwa [...] _4410s.JPG

 

Dockstar / Debian / MPD / Sound Blaster Live 24Bit External / MPDroid sous Android

 

La carte son est plus grosse que la machine [:ddr555]

 

Avec du recul je réalise qu'en fait ce que tu as fait m'intéresse GRANDEMENT :D
pourrais-tu nous linker toutes ressources utiles afin d'arriver au même résultat,
et si au passage tu as une carte son à conseiller un peu plus cheap et qui fonctionnerait (genre dealextreme), je suis preneur :D

 

merci d'avance !

 

edit: en fait ça a pas l'air si sorcier, mais si tu as rencontré des "difficultés" précises fais moi signe ! :)

 

en atendant j'ai trouvé une carte son USB apacher : http://www.dealextreme.com/details.dx/sku.5831 qui fonctionne avec les paquets "snd-usb-audio" donc c'est tout bon :)

Message cité 2 fois
Message édité par pixeye33000 le 31-07-2010 à 21:34:16
n°1230636
bohwaz
$bwz++
Posté le 31-07-2010 à 21:43:55  profilanswer
 

azrael24 a écrit :


 
Il manquerai pas une négation ?  [:urd] La mienne aussi clignotait orange au début et j'ai pu m'y connecter en ssh, apparemment c'est l'indication de boot sur pogoplug.


 
Oui, +pas :)
 
En corrigé ça donne : "Perso elle clignotait orange la LED (topachat aussi) mais ça m'a pas empêché d'y accéder en SSH et de mettre debian..."
 

pixeye33000 a écrit :

en atendant j'ai trouvé une carte son USB apacher : http://www.dealextreme.com/details.dx/sku.5831 qui fonctionne avec les paquets "snd-usb-audio" donc c'est tout bon :)


 
ARG ! Fuis comme la peste ces pauvres trucs, en général basés sur un chipset Tenx, c'est la catastrophe niveau qualité. J'en ai une comme ça qui vient de chez Pearl (LogiLink UA0053), c'est bien reconnu c'est sûr mais voilà la merde que c'est. Le truc sort le son à un niveau absolument incroyable c'est quasiment un ampli USB ! Même à 1 sur 100, le son est méga fort (j'ai grillé un casque avec le volume à 50), et complètement pourrave. Epargne tes oreilles, prends un truc un peu mieux. Pour info le chipset de ces machins est un chip conçu pour aller dans des microcasques de VoIP, donc c'est pas vraiment fait pour écouter de la musique...

Message cité 2 fois
Message édité par bohwaz le 31-07-2010 à 21:47:52

---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230637
azrael24
PàN, dans les dents !
Posté le 31-07-2010 à 21:53:46  profilanswer
 

bohwaz a écrit :

 

Oui, +pas :)

 

[...]

 

ARG ! Fuis comme la peste ces pauvres trucs, en général basés sur un chipset Tenx, c'est la catastrophe niveau qualité. J'en ai une comme ça qui vient de chez Pearl (LogiLink UA0053), c'est bien reconnu c'est sûr mais voilà la merde que c'est. Le truc sort le son à un niveau absolument incroyable c'est quasiment un ampli USB ! Même à 1 sur 100, le son est méga fort (j'ai grillé un casque avec le volume à 50), et complètement pourrave. Epargne tes oreilles, prends un truc un peu mieux. Pour info le chipset de ces machins est un chip conçu pour aller dans des microcasques de VoIP, donc c'est pas vraiment fait pour écouter de la musique...

 

J'avais eu la version encore moins chère et ce n'était pas si horrible que ça dans mes souvenirs.

  

Concernant openWRT le tuto à suivre est ici. Pour le moment il faut utiliser les images pré-compilées que le type tiens à jour.
/!\ les packages standards ne marcheront pas, ils faut les patcher soit même... Eric Cooper pense à faire une version avec les modules de bases pré-intégrés ce qui reste assez chiant au niveau du suivi mais mieux que rien. En attendant que le DS soit supporté par la version officielle de wrt du moins...

 


Message édité par azrael24 le 31-07-2010 à 21:58:53
n°1230639
pixeye3300​0
Posté le 31-07-2010 à 21:59:03  profilanswer
 

bohwaz a écrit :


 
ARG ! Fuis comme la peste ces pauvres trucs, en général basés sur un chipset Tenx, c'est la catastrophe niveau qualité. J'en ai une comme ça qui vient de chez Pearl (LogiLink UA0053), c'est bien reconnu c'est sûr mais voilà la merde que c'est. Le truc sort le son à un niveau absolument incroyable c'est quasiment un ampli USB ! Même à 1 sur 100, le son est méga fort (j'ai grillé un casque avec le volume à 50), et complètement pourrave. Epargne tes oreilles, prends un truc un peu mieux. Pour info le chipset de ces machins est un chip conçu pour aller dans des microcasques de VoIP, donc c'est pas vraiment fait pour écouter de la musique...


 
merci pour l'information, je m'attendais à un truc pas excellent mais là du coup tu m'as complètement motivé pour fuir ce produit :D
du coup j'ai annulé ma commande. Mais bon je ne suis pas sûr que ça vaille le coup que "j'investise" dans une carte son, étant même pas sûr d'arriver à quelque chose :/
 
du coup j'hésite à quand même commander juste pour tester, et si ça marche trouver une bonne occase  :D  

n°1230641
thana54
made in concept
Posté le 31-07-2010 à 22:04:29  profilanswer
 

En parlant d'openwrt, est-il au même niveau qu'un NAS ou est-ce seulement une distrib (embarquée) dédiée au routage/parefeu ?
 
Faudra-t-il bidouiller ou installer des paquets pour gérer ce que l'on peut brancher au dock ?

n°1230642
bohwaz
$bwz++
Posté le 31-07-2010 à 22:08:55  profilanswer
 

D'après ce que je comprends, les chipsets ont changé dans le temps, si tu as acheté le tiens il y a assez longtemps tu as eu un chip C-Media (bonne qualité), mais pour baisser le prix/coût ils ont remplacé ensuite par Tenx et maintenant par un Solid State System. Maintenant à voir si le SSS est mieux que le Tenx. Si quelqu'un tente d'en prendre un faites un rapport ici, mais je pense que ça vaudra pas grand chose...


---------------
Suivi et archivage des offres LIDL, Aldi et Norma
n°1230643
azrael24
PàN, dans les dents !
Posté le 31-07-2010 à 22:17:35  profilanswer
 

thana54 a écrit :

En parlant d'openwrt, est-il au même niveau qu'un NAS ou est-ce seulement une distrib (embarquée) dédiée au routage/parefeu ?

 

Faudra-t-il bidouiller ou installer des paquets pour gérer ce que l'on peut brancher au dock ?

 

Il y'a un module vfat dans l'image pré-compilée, tu peux monter des périphériques fat32 avec. Sinon de ce que j'en ai vu il y'a pas mal de modules dispo (mais pas forcement compilés).
Ce qui m'intéresse c'est l'interface web pour coller un gestionnaire de chose dont on ne doit pas parler ici  [:cupra] couplé à un petit serveur ftp-http.

 

D'ailleurs ca existe sur debian ce genre de fonction utilisable à partir d'une interface web ?

Message cité 1 fois
Message édité par azrael24 le 31-07-2010 à 22:19:34
n°1230649
deK
watching for beerz on the wing
Posté le 01-08-2010 à 00:24:37  profilanswer
 

pixeye33000 a écrit :


 
Avec du recul je réalise qu'en fait ce que tu as fait m'intéresse GRANDEMENT :D
pourrais-tu nous linker toutes ressources utiles afin d'arriver au même résultat,
et si au passage tu as une carte son à conseiller un peu plus cheap et qui fonctionnerait (genre dealextreme), je suis preneur :D
 
merci d'avance !
 
edit: en fait ça a pas l'air si sorcier, mais si tu as rencontré des "difficultés" précises fais moi signe ! :)


 
Non pas difficile du tout, c'est idem que sur une Debian classique : la carte son est détectée en hotplug par le kernel et Alsa, montage de mon répertoire de musique par NFS, installation et configuration de MPD, du très classique ;)
 

thana54 a écrit :

En parlant d'openwrt, est-il au même niveau qu'un NAS ou est-ce seulement une distrib (embarquée) dédiée au routage/parefeu ?
 
Faudra-t-il bidouiller ou installer des paquets pour gérer ce que l'on peut brancher au dock ?


 
À la base c'était dédié routeur, mais depuis c'est devenu assez généraliste pour l'embarqué.
Pour avoir une idée, les paquets dispo pour Kirkwood (donc logiquement pour le DS) : http://downloads.openwrt.org/backf [...] /packages/
Pour faire un NAS, pas grand chose à faire je pense :o


---------------
Feed HA/V          
n°1230653
thana54
made in concept
Posté le 01-08-2010 à 09:19:14  profilanswer
 

azrael24 a écrit :


 
Il y'a un module vfat dans l'image pré-compilée, tu peux monter des périphériques fat32 avec. Sinon de ce que j'en ai vu il y'a pas mal de modules dispo (mais pas forcement compilés).  
Ce qui m'intéresse c'est l'interface web pour coller un gestionnaire de chose dont on ne doit pas parler ici  [:cupra] couplé à un petit serveur ftp-http.
 
D'ailleurs ca existe sur debian ce genre de fonction utilisable à partir d'une interface web ?


M'enfin le fat32 maintenant, c'est un peu juste :whistle:  
 

deK a écrit :


À la base c'était dédié routeur, mais depuis c'est devenu assez généraliste pour l'embarqué.
Pour avoir une idée, les paquets dispo pour Kirkwood (donc logiquement pour le DS) : http://downloads.openwrt.org/backf [...] /packages/
Pour faire un NAS, pas grand chose à faire je pense :o


J'ai vu qu'il y avait pas mal de paquets "classiques" (ntfs-3g, openssh, pure-ftpd) donc ca me va bien. Mais ces paquets fournissent-ils une interface web qui se marrie avec l'interface globale d'openwrt ?

n°1230657
deK
watching for beerz on the wing
Posté le 01-08-2010 à 10:51:35  profilanswer
 

Nop, l'interface web LuCi, c'est principalement pour gérer les fonctions réseau.
Pour ces paquets-là, ça s'utilise comme pour une distrib classique.
D'ailleurs sur mes OpenWRT, je désactive LuCi, je gère tout par les fichiers de conf.


---------------
Feed HA/V          
n°1230659
azrael24
PàN, dans les dents !
Posté le 01-08-2010 à 11:04:23  profilanswer
 

C'est beaucoup moins intéressant alors  [:cerveau totoz]

 

Moi qui attendais une version stable pour utiliser mon DS sous openWRT, autant passer directement sur une Debian avec WebMin qui marche plutôt bien si on ne tiens pas compte du problème de boot.


Message édité par azrael24 le 01-08-2010 à 11:08:48
n°1230660
deK
watching for beerz on the wing
Posté le 01-08-2010 à 11:08:54  profilanswer
 

Ben tu peux aussi mettre webmin sur OpenWRT ;)


---------------
Feed HA/V          
n°1230662
deK
watching for beerz on the wing
Posté le 01-08-2010 à 11:18:35  profilanswer
 

Je vais attaquer ça dans les prochains jours : http://www.plugcomputer.org/plugwi [...] TP_and_NFS [:clooney15]  
À mon avis, pas grand chose à faire pour adapter ça sur le DS, mais gaffe au brick [:clooney23]


---------------
Feed HA/V          
n°1230677
monsieur
Posté le 01-08-2010 à 15:41:37  profilanswer
 

pixeye33000 a écrit :

perso, elle obtient pas d'ip donc à partir de ce moment là je vois pas comment m'en sortir :D
 
(et puis c'est l'exemplaire que je ne vais pas bidouiller, du moins dans un premier temps :D)


 
Si elle n'obtient pas d'IP en DHCP, elle se met automatiquement en configuration réseau suivante:
ipaddr=169.254.254.253
serverip=169.254.254.254
netmask=255.255.0.0
 
Donc si tu la branches en direct sur ton ordi dont tu auras fixer les paramètres réseau à la main avec netmask=255.255.0.0 et une classe d'adresse similaire 169.254.254.xx il est fort probable que tu puisses accèder quand même à la Dockstar.
 
Quand il a fallu que je reflash en tftp ma Fonera semi-bricked et un autre routeur Linksys (qui après une mauvaise manip ne répondait plus), il a bien fallu que je force le destin de l'adressage IP... quitte à mettre mon ordi au même niveau de réseau que la bestiole en face qui refuse de se laisser dompter.

Message cité 2 fois
Message édité par monsieur le 01-08-2010 à 15:48:35

---------------
mon feedback H/V
n°1230684
dami3n
Posté le 01-08-2010 à 21:07:42  profilanswer
 

monsieur a écrit :

 

Si elle n'obtient pas d'IP en DHCP, elle se met automatiquement en configuration réseau suivante:
ipaddr=169.254.254.253
serverip=169.254.254.254
netmask=255.255.0.0

 

Donc si tu la branches en direct sur ton ordi dont tu auras fixer les paramètres réseau à la main avec netmask=255.255.0.0 et une classe d'adresse similaire 169.254.254.xx il est fort probable que tu puisses accèder quand même à la Dockstar.

 

Quand il a fallu que je reflash en tftp ma Fonera semi-bricked et un autre routeur Linksys (qui après une mauvaise manip ne répondait plus), il a bien fallu que je force le destin de l'adressage IP... quitte à mettre mon ordi au même niveau de réseau que la bestiole en face qui refuse de se laisser dompter.

 

bestiole avec led orange clignotante branchée en direct à mon pc ss passer par 1 routeur
carte réseau configurée à la main selon tes recommandations
ping 169.254.254.253 ne donne rien

 

ps :serverip, c'est la passerelle par défaut ?

Message cité 1 fois
Message édité par dami3n le 01-08-2010 à 21:09:08
n°1230691
pixeye3300​0
Posté le 01-08-2010 à 22:18:35  profilanswer
 

monsieur a écrit :


 
Si elle n'obtient pas d'IP en DHCP, elle se met automatiquement en configuration réseau suivante:
ipaddr=169.254.254.253
serverip=169.254.254.254
netmask=255.255.0.0
 
Donc si tu la branches en direct sur ton ordi dont tu auras fixer les paramètres réseau à la main avec netmask=255.255.0.0 et une classe d'adresse similaire 169.254.254.xx il est fort probable que tu puisses accèder quand même à la Dockstar.
 
Quand il a fallu que je reflash en tftp ma Fonera semi-bricked et un autre routeur Linksys (qui après une mauvaise manip ne répondait plus), il a bien fallu que je force le destin de l'adressage IP... quitte à mettre mon ordi au même niveau de réseau que la bestiole en face qui refuse de se laisser dompter.


 
ah et bien c'est bon à savoir...
je me doutais bien qu'il y avait un truc dans le genre mais j'avais pas trouvé l'info : merci !

n°1230695
deK
watching for beerz on the wing
Posté le 01-08-2010 à 22:54:01  profilanswer
 

dami3n a écrit :


 
bestiole avec led orange clignotante branchée en direct à mon pc ss passer par 1 routeur
carte réseau configurée à la main selon tes recommandations
ping 169.254.254.253 ne donne rien
 
ps :serverip, c'est la passerelle par défaut ?


 
Chez moi ce n'était pas 169.254.254.253, j'ai du passer par un scan pour trouver la bonne IP, même méthode que là :
 

root@host ~ # ifconfig eth0 169.254.1.0
root@host ~ # nmap -e eth0 -sP 169.254.0.0/16


http://ahsoftware.de/dockstar/#dockstar


---------------
Feed HA/V          
n°1230701
monsieur
Posté le 02-08-2010 à 02:16:55  profilanswer
 

En effet ce n'est pas 169.254.254.253 dans tous les cas (j'avais repris l'exemple du "uBoot modifié" ), mais c'est même la classe d'IP mais en un peu plus dynamique: elle se donne elle-même une IP entre 169.254.1.0 et 169.254.254.255
 

Citation :

Because the device won't get an IP from an DHCP server, it will use an automatic generated IP between 169.254.1.0 and 169.254.254.255 (see RFC 3927).
 
To find out the IP the device uses we are scanning this range. You might have luck and this quick scan may find the IP:
root@host ~ # ifconfig eth0 169.254.1.0 root@host ~ # nmap -e eth0 -sP 169.254.185.0/24
 
If this won't find the device, you have to take the long route:
root@host ~ # ifconfig eth0 169.254.1.0 root@host ~ # nmap -e eth0 -sP 169.254.0.0/16


 
---------------------------------------------------------------------
 
Bon sinon côté musique c'est cool: MPD installé et le son part en bluetooth sur la chaine hifi.
J'ai branché sur la Dockstar ma "clef musicale" Logitech: http://www.erenumerique.fr/images/ [...] gitech.jpg
rien de spécial à faire c'est reconnu immédiatement, un extrait de dmesg:
 

Citation :

usb 1-1.4: new full speed USB device using orion-ehci and address 4
input: Logitech Logitech Music Anywhere USB Transmitter as /devices/platform/orion-ehci.0/usb1/1-1/1-1.4/1-1.4:1.2/input/input0
generic-usb 0003:0B7A:0100.0001: input,hiddev96: USB HID v1.10 Device [Logitech Logitech Music Anywhere USB Transmitter] on usb-orion-ehci.0-1.4/input2
usbcore: registered new interface driver snd-usb-audio


 
puis j'ai fait un simple:
aptitude install mpd mpc
 
une toute petite modif de rien du tout dans /etc/mpd.conf:
 
j'ai juste eu à commenter la ligne:
bind_to_address                 "127.0.0.1"
en:
#bind_to_address                 "127.0.0.1"
 
et décommenter la ligne:
#port                            "6600"
en:
port                            "6600"
 
puis j'ai lancé mpd avec la commande:
/etc/init.d/mpd start
 
et zouh! MPD disponible et connecté et le son marche immédiatement (je lui ai demandé de lire une webradio en streaming depuis Sonata) sans avoir eu à configurer le moindre truc pour la partie audio.
Nan mais c'est trop simple maintenant, sur mon autre box Debian à l'époque j'avais du configurer plusieurs trucs pour le son dans le fichier de conf, ainsi que d'adapter un peu la conf d'Alsa... là quasi rien à faire (à part l'adresse IP et le port) c'est magique!
Ça fait maintenant 2h que ma Dockstar envoie la musique de Sub.fm sur ma hifi :D
 
Bon, dans htop je vois que MPD me bouffe entre 23 et 30% du CPU, c'était prévisible et attendu étant donné que le décodage de mp3 et autres joyeuseté du son doivent faire appel à des instructions en virgule flottante que le CPU ne gère pas. On avait eu cette discussion sur le topic des plug computer.
 
-------------------------------------------------------
 
Roohh, mais heu: http://plugcomputer.org/plugforum/ [...] pic=1961.0
Android for Sheevaplug

Message cité 2 fois
Message édité par monsieur le 02-08-2010 à 03:02:49

---------------
mon feedback H/V
n°1230707
darkpengui​n
Posté le 02-08-2010 à 08:57:57  profilanswer
 

j'ai le mien [:arcueid brunestud]


---------------
Counting all the assh*les in the room, well I'm definitely not alone...
n°1230709
deK
watching for beerz on the wing
Posté le 02-08-2010 à 09:18:05  profilanswer
 

monsieur a écrit :


Bon sinon côté musique c'est cool: MPD installé et le son part en bluetooth sur la chaine hifi.
J'ai branché sur la Dockstar ma "clef musicale" Logitech: http://www.erenumerique.fr/images/ [...] gitech.jpg

 

[...]

 

[:bien]

  

Si on a une sortie écran, je vois bien l'utilité, mais sinon bof  :o


Message édité par deK le 02-08-2010 à 09:18:16

---------------
Feed HA/V          
n°1230716
ktalog
Posté le 02-08-2010 à 10:37:16  profilanswer
 

J'ai essayé la manipulation :

Citation :

ifconfig eth0 169.254.1.0
nmap -e eth0 -sP 169.254.0.0/16


et sur mes 2 boitiers aucune adresse ip de trouvé.

 

Si je branche une clé usb sur mon boitier, au démarrage la clé usb n'est jamais allumé.
La lumière orange clignote au bout de environ 14 sec.

 

c'est pareil sur vos dockstar ?

 

edit : j'ai fait une demande d'échange des dockstar chez topachat  

Message cité 2 fois
Message édité par ktalog le 02-08-2010 à 11:08:04
n°1230726
ktalog
Posté le 02-08-2010 à 11:06:08  profilanswer
 

oups


Message édité par ktalog le 02-08-2010 à 11:06:49
n°1230727
Plam
:o
Posté le 02-08-2010 à 11:06:29  profilanswer
 

Ça clignote environ 15 sec, ça s'éteint 2 ou 3 sec, puis orange fixe.


---------------
Ossifié, comme fusionné dans son cockpit
n°1230756
monsieur
Posté le 02-08-2010 à 13:01:49  profilanswer
 

J'ai un truc dans /var/logs/messages qui me fait un peu peur:
 

Citation :

NAND device: Manufacturer ID: 0x2c, Chip ID: 0xda (Micron NAND 256MiB 3,3V 8-bit)
Scanning device for bad blocks
Creating 3 MTD partitions on "orion_nand":
0x000000000000-0x000000100000 : "u-boot"
0x000000100000-0x000000500000 : "uImage"
0x000000500000-0x000010000000 : "root"
 
....
 
uncorrectable error :  
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :  
end_request: I/O error, dev mtdblock1, sector 8
Buffer I/O error on device mtdblock1, logical block 1
uncorrectable error :  
end_request: I/O error, dev mtdblock1, sector 16
Buffer I/O error on device mtdblock1, logical block 2
uncorrectable error :  
end_request: I/O error, dev mtdblock1, sector 24
Buffer I/O error on device mtdblock1, logical block 3
uncorrectable error :  
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :  
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :  
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :  
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254
uncorrectable error :  
end_request: I/O error, dev mtdblock0, sector 2040
Buffer I/O error on device mtdblock0, logical block 255
uncorrectable error :  
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254


 
C'est Debian qui n'arrive pas à accéder à la NAND ou bien c'est la mémoire Flash qui a un sérieux problème?


---------------
mon feedback H/V
n°1230761
deK
watching for beerz on the wing
Posté le 02-08-2010 à 13:19:42  profilanswer
 

J'ai pareil, et a priori c'est normal ;)

 

uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 8
Buffer I/O error on device mtdblock1, logical block 1
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 16
Buffer I/O error on device mtdblock1, logical block 2
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 24
Buffer I/O error on device mtdblock1, logical block 3
uncorrectable error :
end_request: I/O error, dev mtdblock1, sector 0
Buffer I/O error on device mtdblock1, logical block 0
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 1920
Buffer I/O error on device mtdblock0, logical block 240
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2040
Buffer I/O error on device mtdblock0, logical block 255
uncorrectable error :
end_request: I/O error, dev mtdblock0, sector 2032
Buffer I/O error on device mtdblock0, logical block 254

 

De ce que j'ai lu, la mémoire NAND a un taux habituellement élevé de secteurs défectueux, et les constructeurs en tiennent compte en faisant de la correction d'erreur, a priori le message est purement cosmétique, derrière tout fonctionne bien.

 

Edit : pile-poil les mêmes, si ça se trouve c'est même pas des vraies erreurs :o


Message édité par deK le 02-08-2010 à 13:21:09

---------------
Feed HA/V          
mood
Publicité
Posté le   profilanswer
 

 Page :   1  2  3  4  5  6  7  ..  98  99  100  101  102  103

Aller à :
Ajouter une réponse
 

Sujets relatifs
Le topic vert - gestion d'énergie sous LinuxTopic netbook originaux pour barbu
[ Topic Unique ] Problème de connexion à InternetSquid par authentification unique
[Topic Unique] Google Chrome OSUbuntu 9.04 sur portable : forcer l'utilisation unique du second écran
Plus de sujets relatifs à : [Topic Unique] Seagate Dockstar, le plug computer pas cher !


Copyright © 1997-2018 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR