Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1281 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Probleme d'affichage sous Debian

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

Probleme d'affichage sous Debian

n°871419
geozzz75
Posté le 16-12-2006 à 00:35:35  profilanswer
 

Bonjour a tous,
J'ai reussi a installer debian tant bien que mal (j'ai du taper linux26 au début au lieu de me contenter d'appuyer sur entre)
Bref maintenant sa marche un peu pres et je suis tres content :)
 
Seulement j'ai un petit probleme ! Linux Debian (GNOME et KDE) ne m'affiche que en 800*600 pas moye de changer car rien d'autre ne m'est proposé (mise a part du 480* je sais plus quoi enfin plus petit) ! Ce qui rend l'interface peu agréable et moche !
 
j'ai une ATI RADEON X300 au début lors de la configuration du serveur X j'avais un choix sur je ne sais pas trop quoi et j'ai choisi VGA, j'ai reinstallé Debian il n'y a pas longtemps et la j'ai mis ATI mais la grosse Erreur le serveur X n'arrive pas a se lancer ! donc pas d'interface graphique ! Je ne sais pas comment faire pour avoir du 1600*1200 enfin meme un peu moins ! mais si je peux quiter le 800*600 sa serait cool !
 
Comment faire ?
 
Merci beaucoup :)

mood
Publicité
Posté le 16-12-2006 à 00:35:35  profilanswer
 

n°871423
Fork Bomb
Obsédé textuel
Posté le 16-12-2006 à 01:11:02  profilanswer
 

dpkg-reconfigure xserver-xfree86
ou
dpkg-reconfigure xserver-xorg


---------------
Décentralisons Internet-Bépo-Troll Bingo - "Pour adoucir le mélange, pressez trois quartiers d’orange !"
n°871427
FCKGW
◥▶◀◤
Posté le 16-12-2006 à 08:56:22  profilanswer
 

Tu dois choisir le module 'radeon' dans la liste après avoir fait 'dpkg-reconfigure xserver-x***' et cocher les cases des résolutions que ton écran supporte. Puis tu pourras configurer dans KDE ou Gnome.
 
Je suppose que tu as installé sarge. Si c'est le cas, je te conseille de l'upgrader en 'etch' en modifiant le fichier /etc/apt/sources.list puis en faisant 'apt-get update' puis 'apt-get dist-upgrade'.
La X300 est maintenant supportée par le driver libre. Tu n'auras donc pas besoin d'installer le (vilain) driver (propriétaire et pas open source) ATI pour avoir l'accélération 2D et 3D de base.  
Puis la plupart des packages sont plus récents ;)


Message édité par FCKGW le 16-12-2006 à 08:56:53
n°871445
geozzz75
Posté le 16-12-2006 à 11:01:07  profilanswer
 

Ok je vais essayer ca :) je vous tiens au courrant : J'ai Xfree86 et un apt-get install xorg-driver-fglrx ne marche pas.
 
Par contre je n'ai pas bien compris ce que je devais modifier dans le fichier pour mettre en etch

n°871446
geozzz75
Posté le 16-12-2006 à 11:16:28  profilanswer
 

Bon ba j'ai essayé un peu :) Et voila ce qui en ressort:
 
Apres avoir taper dpkg-reconfigure xserver-xfree86 j'ai essayer de choisir Radeon parmi la liste mais il n'etait pas proposé ! j'ai mis ATI et j'ai continué a appuyé sur entré. et apres j'ai edité le fichier /etc/X11/XF864-xfree86 ou un truc comme ca bref un fichier de config, et a la place de ATI j'ai mis radeon
 
Bref maintenant quand j'allume Debian je n'ai pas de graphique j'ai juste une console et le server X me dit:
 
No Matching Device section for instance Radeon
No Devices detected
 
Fatal error server
No Screens detected
 
voila je dois ptete pas avoir les truc necessaires ? :s

n°871463
Koybe
Posté le 16-12-2006 à 13:18:04  profilanswer
 

Lors de ton dpkg-reconfigure, il faut que tu spécifie les résolutions que ton écran est capable de supporter. Lors de l'avant dernier menu de config, il te propose les résolution à utiliser, choisis celles que tu désires avec la barre d'espace.
 
Pour ton problème Radeon, il cherche une définition qui n'existe pas... Si tu fais correctement le reocnfigure ca devrrait passer.
 
Sinon poste ton fichier /etc/X11/XF86Config-4 ici ;-)

n°871470
FCKGW
◥▶◀◤
Posté le 16-12-2006 à 14:15:21  profilanswer
 

geozzz75 a écrit :

Bon ba j'ai essayé un peu :) Et voila ce qui en ressort:
 
Apres avoir taper dpkg-reconfigure xserver-xfree86 j'ai essayer de choisir Radeon parmi la liste mais il n'etait pas proposé ! j'ai mis ATI et j'ai continué a appuyé sur entré. et apres j'ai edité le fichier /etc/X11/XF864-xfree86 ou un truc comme ca bref un fichier de config, et a la place de ATI j'ai mis radeon
 
Bref maintenant quand j'allume Debian je n'ai pas de graphique j'ai juste une console et le server X me dit:
 
No Matching Device section for instance Radeon
No Devices detected
 
Fatal error server
No Screens detected
 
voila je dois ptete pas avoir les truc necessaires ? :s


 
Tu n'as pas le module radeon dans xfree86, il est trop vieux. Le pilote fglrx, c'est le pilote proprio ATI. Tu n'en as pas besoin.  
 
Ouvre le fichier /etc/apt/sources.list  
A chaque ligne, tu dois avoir stable ou sarge ecrit quelque-part. Change chacun des stable/sarge par 'etch'.
Puis tu fais update&&dist-upgrade et il mettra à jour ta distrib. Il devrait automatiquement upgrader toute ta distrib, et migrer de xfree à xorg. Si pour une raison ou une autre ca foire, il suffit d'installer le package xorg. Tu pourras allors faire dpkg-reconfigure xserver-xorg, choisir le module radeon et les résolutions.


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Hardware

  Probleme d'affichage sous Debian

 

Sujets relatifs
[Résolu] [Debian] Problème d'affichage[Debian/Etch] Problème d'affichage
[debian]probleme d'affichage[DEBIAN] Probleme affichage sur un ordinateur portable
[KDE][Firefox][Debian] probleme d'affichage[debian sarge] problème d'affichage dans un (x)term de screen|aptitude
[Debian Unstable] Problème affichage accentDebian sur portable : Problème d'affichage
[Debian]Probleme affichage console aprés upgrade du noyau[Resolu]Probleme d'affichage sur portable GeForce FX 4200 Debian
Plus de sujets relatifs à : Probleme d'affichage sous Debian


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR