Forum |  HardWare.fr | News | Articles | PC | S'identifier | S'inscrire | Shop Recherche
1510 connectés 

  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Résolu] [Debian] Problème d'affichage

 



 Mot :   Pseudo :  
 
Bas de page
Auteur Sujet :

[Résolu] [Debian] Problème d'affichage

n°864345
sluke
Posté le 19-11-2006 à 13:36:22  profilanswer
 

Bonjour,
 
Je suis actuellement sous Debian SID et depuis une mise à jour (il a maintenant au moins un mois ...), j'ai de très gros problèmes d'affichages pour quasiment tous les logiciels :
 
http://aprovin.linux62.org/others/ [...] screen.png
 
J'ai bien pensé qu'après une mise à jour le problème serait résolu, mais comme ça fait un petit moment que ça dure, j'aimerai résoudre ce problème.
En fait si un bouton est mal affiché, il suffit de faire glisser la souris dessus pour qu'il s'affiche. Par contre pour firefox, il faut sélectionner tout le contenu ce qui l'affiche correctement mais dès que je désélectionne, une partie du texte se "brouille" à nouveau. Bref c'est assez aléatoire. La capture d'écran ne montre que firefox mais c'est valable pour les menus, boutons ...
 
Quelqu'un a une idée ?


Message édité par sluke le 20-11-2006 à 13:25:35
mood
Publicité
Posté le 19-11-2006 à 13:36:22  profilanswer
 

n°864376
THRAK
- THR4K -
Posté le 19-11-2006 à 14:44:35  profilanswer
 

J'ai déjà vu des cartes vidéo avoir ce genre de problème d'affichage, ça ressemble à une corruption de la mémoire vidéo.

 

Cela pourrait peut-être coïncider avec la mise à jour de Xorg et son passage en version 7.1.0-6 il y a quelques temps ; peut-être que celle-ci a simplement induit un bogue dans le driver qui gère ta carte vidéo et du coup tu te retrouves avec ce problème d'affichage. Je n'ai pas d'idée plus précise, il faudrait regarder au niveau de la version du serveur X (de quand date la dernière mise à jour que tu as effectuée) et au niveau de ta carte vidéo (quel chipset / driver est concerné).

 

Cela pourrait aussi venir de la mise à jour du noyau au niveau du module gérant le DRI pour ta carte vidéo (si elle l'utilise toutefois) ou encore éventuellement d'un module pour le framebuffer.

 

Dernière possibilité à ne pas exclure, cela pourrait provenir directement d'un problème matériel avec ta carte, on ne sait jamais.


Message édité par THRAK le 19-11-2006 à 14:45:11

---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°864503
Combi_A_Ve​ndre
Posté le 19-11-2006 à 20:21:58  profilanswer
 

J'ai aussi eu ce problème, il a maintenant disparu suite à une mise à jour. Je suis aussi sous SID.
Le problème venait de libcairo. Tu fais régulièrement les update?
Essaye de passer la variable MOZ_DISABLE_PANGO à 1 et lance firefox pour voir si ça change quelque chose.

 

vw

Message cité 1 fois
Message édité par Combi_A_Vendre le 20-11-2006 à 09:51:18
n°864541
THRAK
- THR4K -
Posté le 19-11-2006 à 21:54:06  profilanswer
 

Combi_A_Vendre a écrit :

J'ai aussi eu ce problème, il a maintenant disparu suite à une mise à jour. Je suis aussi sous SID.
Le problème venait de pango. Tu fais régulièrement les update?
Essaye de passer la variable MOZ_DISABLE_PANGO à 1 et lance firefox pour voir si ça change quelque chose.
 
vw


Apparement le problème concerne tous les logiciels et pas uniquement Firefox.
 
Ensuite perso j'ai une machine de test sous Sid qui est régulièrement mis à jour et pour ma part je n'ai pas eu de problème de ce type, ni sous Firefox, ni dans aucun autre logiciel.


---------------
THRAK (def.) : 1) A sudden and precise impact moving from intention, direction and commitment, in service of an aim. 2) 117 guitars almost striking the same chord simultaneously.
n°864604
Combi_A_Ve​ndre
Posté le 20-11-2006 à 09:46:56  profilanswer
 

THRAK a écrit :

Apparement le problème concerne tous les logiciels et pas uniquement Firefox.

 

Ensuite perso j'ai une machine de test sous Sid qui est régulièrement mis à jour et pour ma part je n'ai pas eu de problème de ce type, ni sous Firefox, ni dans aucun autre logiciel.

 

J'ai bien vu que ça concernait toutes les applications, mais je donne juste une méthode pour voir si le problème peut se régler pour Firefox.
Si ça marche, comme ce fut le cas pour moi, ce serait dommage de changer sa carte vidéo alors que le problème est logiciel.
J'ai eu exactement le même problème.

 

D'ailleurs, pas mal de personnes ont eu ce problème sous Debian. Voir les bugs debian #377147, #379482, #377879, ...
http://bugs.debian.org/cgi-bin/bug [...] bug=377147
http://bugs.debian.org/cgi-bin/bug [...] bug=379482
http://bugs.debian.org/cgi-bin/bug [...] bug=377879

 

vw.


Message édité par Combi_A_Vendre le 20-11-2006 à 09:48:57

---------------
The best way to accelerate a computer running windows is at 9.8m.s-2
n°864666
sluke
Posté le 20-11-2006 à 13:24:23  profilanswer
 

J'ai mis à jour le kernel, et le driver graphique et ça marche ! J'aurai plutôt pensé que ça venait d'un problème de librairie, mais enfin le principal c'est que ce soit réglé !
 
Merci à tous !
 
 :hello:


Aller à :
Ajouter une réponse
  FORUM HardWare.fr
  Linux et OS Alternatifs
  Logiciels

  [Résolu] [Debian] Problème d'affichage

 

Sujets relatifs
monter un HDD sous debian[Ubuntu Serveur] Problème config sudo!!
[resolu] j'entend pas le sonProblème mineur speedtouch {Résolu}
Pb de démarrage drak3d mandriva 2007 [resolu][Debian] Stable vers Testing : ssh ne marche plus
[debian]pas de modules apres compilation kerneljukebox sur tablet pc ecran tactile ? Debian inside
[Réglé] Problème conflit réseau WiFi & ethernet sur ma machine[Debian]Probleme affichage console aprés upgrade du noyau[Resolu]
Plus de sujets relatifs à : [Résolu] [Debian] Problème d'affichage


Copyright © 1997-2022 Hardware.fr SARL (Signaler un contenu illicite / Données personnelles) / Groupe LDLC / Shop HFR